Observer Suite 18.2.0.0
Analyzer and Expert Probe User Guide
21 Jan 2021
Notice
Every effort was made to ensure that the information in this manual was accurate at the time of printing. However, information is subject to change without notice, and VIAVI reserves the right to provide an addendum to this manual with information not available at the time that this manual was created.

Copyright
© Copyright 2020 VIAVI Solutions Inc. All rights reserved. VIAVI and the VIAVI logo are trademarks of VIAVI Solutions Inc. (“VIAVI”). All other trademarks and registered trademarks are the property of their respective owners. No part of this guide may be reproduced or transmitted, electronically or otherwise, without written permission of the publisher.

Copyright release
Reproduction and distribution of this guide is authorized for Government purposes only.

Terms and conditions
Specifications, terms, and conditions are subject to change without notice. The provision of hardware, services, and/or software are subject to VIAVI standard terms and conditions, available at www.viavisolutions.com/terms.

Specifications, terms, and conditions are subject to change without notice. All trademarks and registered trademarks are the property of their respective companies.

Federal Communications Commission (FCC) Notice
This product was tested and found to comply with the limits for a Class A digital device, pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful interference when the equipment is operated in a commercial environment. This product generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the instruction manual, may cause harmful interference to radio communications. Operation of this product in a residential area is likely to cause harmful interference, in which case you will be required to correct the interference at your own expense.

The authority to operate this product is conditioned by the requirements that no modifications be made to the equipment unless the changes or modifications are expressly approved by VIAVI.

Laser compliance
This device is a class 1 laser product.

Industry Canada Requirements
This Class A digital apparatus complies with Canadian ICES-003.

Cet appareil numérique de la classe A est conforme à la norme NMB-003 du Canada.

WEEE and Battery Directive Compliance

This product, and the batteries used to power the product, should not be disposed of as unsorted municipal waste and should be collected separately and disposed of according to your national regulations. In the European Union, all equipment and batteries purchased from VIAVI after 2005-08-13 can be returned for disposal at the end of its useful life. VIAVI will ensure that all waste equipment and batteries returned are reused, recycled, or disposed of in an environmentally friendly manner, and in compliance with all applicable national and international waste legislation.

It is the responsibility of the equipment owner to return equipment and batteries to VIAVI for appropriate disposal. If the equipment or battery was imported by a reseller whose name or logo is marked on the equipment or battery, then the owner should return the equipment or battery directly to the reseller.

Instructions for returning waste equipment and batteries to VIAVI can be found in the Environmental section of VIAVI web site at . If you have questions concerning disposal of your equipment or batteries, contact VIAVI WEEE Program Management team at WEEE.EMEA@viavisolutions.com.

Technical Support

<table>
<thead>
<tr>
<th>Region</th>
<th>Contact Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America</td>
<td>1.844.GO VIAVI / 1.844.468.4284</td>
</tr>
<tr>
<td>Latin America</td>
<td>+52 55 5543 6644</td>
</tr>
<tr>
<td>EMEA</td>
<td>+49 7121 862273</td>
</tr>
<tr>
<td>APAC</td>
<td>+1 512 201 6534</td>
</tr>
<tr>
<td>All Other Regions</td>
<td>viavisolutions.com/contacts</td>
</tr>
<tr>
<td>email</td>
<td><a href="mailto:customer.care@viavisolutions.com">customer.care@viavisolutions.com</a></td>
</tr>
</tbody>
</table>

Support hours are 7:00 A.M to 7:00 P.M. (local time for each office).
**Table of Contents**

**Chapter 1: Getting started**.............................................................. 13

Which version of Observer is right for you?.................................................. 13
Observer Standard.............................................................................................. 13
Observer Expert................................................................................................... 13
Observer Suite.................................................................................................... 13
Comparing Observer versions............................................................................. 14

How to install or upgrade the software............................................................ 17
Minimum and recommended system specifications......................................... 18
How to upgrade to Windows 10.......................................................................... 19
How to install all versions.................................................................................. 20
How to upgrade version 17 and later................................................................. 20
How to upgrade version 16 and earlier............................................................... 21
FAQ: Licensing and updating............................................................................ 21
Capture card driver requirements.................................................................... 23
Installing Windows updates and updating virus protection............................ 24

Virtual machine troubleshooting...................................................................... 24
Cannot capture traffic using VMware ESX VM.................................................. 24
Experiencing BSOD when packet capture starts.............................................. 25

Overview of Observer..................................................................................... 26
User interface..................................................................................................... 27
Ports used by Observer Platform v17 and later............................................... 28

Configuring Observer’s general settings......................................................... 29
General tab........................................................................................................ 29
Security tab....................................................................................................... 30
Folders tab........................................................................................................ 32
SNMP tab.......................................................................................................... 32
IPv6 tab............................................................................................................ 33
Chapter 2: Real-Time Statistics

- Monitoring connection statistics.................................................. 39
- Discovering conversations between local devices and the Internet........................................... 39
- Configuring the IP application list....................................................... 41
- Discovering conversations between local devices.................................................. 41
- Viewing real-time statistics per device................................................ 41
- Viewing a list of protocols seen on the network........................................ 42
- Viewing wireless access point statistics................................................. 42
- Monitoring network load........................................................................ 43
- Viewing router utilization statistics........................................................ 43
- Viewing bandwidth utilization................................................................. 44
- Viewing bandwidth utilization with a filter............................................... 45
- Wireless Access Point Load Monitor...................................................... 45
- Viewing the distribution of packet sizes by station.................................. 46
- Discovering current top talkers on the network........................................ 46
- Load testing the network........................................................................ 47
- Configuring your load test settings........................................................ 47
- Viewing utilization history...................................................................... 48
- Viewing a summary of network activity.................................................. 48
- Checking the health of your network..................................................... 49
- Viewing network errors.......................................................................... 49
- Viewing network errors by device........................................................... 50
- Searching for wireless interference........................................................ 50
- Ethernet errors tracked by Observer........................................................ 52
- Watching for packet storms.................................................................... 54
- Understanding Real-time Statistics........................................................ 55
- Monitoring your VLAN........................................................................... 56
- Viewing optional VLAN statistics............................................................ 56

Chapter 3: Network and Application Discovery

- Building and saving an address book.................................................... 58
- Configuring a discovery method (optional)................................................ 58
- Building an address book automatically.................................................. 59
- Adding entries to the address book manually.......................................... 59
- Resolving DNS names............................................................................ 60
- Saving the address book......................................................................... 61
Editing address book entries................................................................................................. 61
Importing a previously saved address book......................................................................... 61
Using multiple address books................................................................................................ 62
Discovery........................................................................................................................................ 62
Discovering server applications on the network................................................................. 62
Discovering SNMP devices........................................................................................................ 63
Discovering which devices are connected to a switch........................................................... 65
Calculating subnet masks.......................................................................................................... 67
Performing ping and trace route............................................................................................. 67
How to add application definitions.......................................................................................... 68
How to associate non-standard ports with an application.................................................... 69
Sharing application definitions with others............................................................................... 70
How to import application definitions.................................................................................... 70
How to export application definitions.................................................................................... 71
Adding derived application definitions................................................................................... 71
Enabling or disabling applications that use dynamic ports.................................................... 72
Defining applications differently per IP address..................................................................... 72
Restoring the default application list....................................................................................... 73
How to restore TCP application definitions........................................................................... 73
How to restore UDP application definitions........................................................................... 74
Chapter 4: Packet Captures................................................................................................. 75
How to configure the capture buffer settings........................................................................ 75
How to adjust the statistical buffer......................................................................................... 77
Configuring the packet capture options................................................................................ 78
Excluding non-native packets from capture........................................................................... 79
Configuring a circular capture buffer................................................................................... 80
Configuring Observer to capture partial packets................................................................... 81
Packet Captures.......................................................................................................................... 81
Saving packet captures............................................................................................................ 82
Merging packet captures.......................................................................................................... 83
Capturing network traffic......................................................................................................... 84
Capturing from multiple probe instances............................................................................... 84
Scheduling packet captures..................................................................................................... 85
Transferring a packet capture to another probe instance....................................................... 85
Tell me more about the Packet Capture tool......................................................................... 86
Why am I missing packets?...................................................................................................... 86
Understanding duplicate packets............................................................................................ 87
Understanding packet deduplication....................................................................................... 87
Chapter 5: Filtering............................................................................................................... 89
Pre-filtering your packet captures........................................................................................... 89
Tell me how to filter by protocol............................................................................................. 90
Tell me how to filter by pattern............................................................................................... 91
Tell me more about choosing a VLAN protocol...................................................................... 93
Tell me more about regular expressions................................................................................ 94
Tell me more about modifiers................................................................................................. 95
Activating and deactivating filters ................................................................................. 96
How to chain filter rules using logical operators ................................................................. 96
Post-filtering your packet captures ..................................................................................... 97
Enabling command-line filtering ...................................................................................... 98
Post-filtering via command line ...................................................................................... 99

Chapter 6: Decodes ........................................................................................................... 103

Decoding network traffic.................................................................................................. 103
I have a packet capture to analyze. What file formats can Observer load?...................... 104
Opening files from unknown locations .............................................................................. 104
Private key locations per server ...................................................................................... 105
Decoding encrypted network traffic .................................................................................. 106
Decoding NetFlow or sFlow streams .................................................................................. 109
Registering custom decode DLLs ...................................................................................... 110
Replaying a packet capture ............................................................................................... 111
Working with packets ....................................................................................................... 112
Using the Decode pane ..................................................................................................... 114
Saving a packet capture ..................................................................................................... 116
Searching for a specific packet ......................................................................................... 117
Filtering your saved packet capture .................................................................................. 118
Processing NetFlow or sFlow data .................................................................................... 118
Packet View Settings ....................................................................................................... 118
Configure SNMP MIBs ...................................................................................................... 119
General ............................................................................................................................... 119
Protocol Colors .................................................................................................................. 121
Protocol Forcing ................................................................................................................ 121
Summary ............................................................................................................................. 121
TCP/UDP/SCTP Application Colors .................................................................................. 121

Chapter 7: Expert Analysis ............................................................................................... 122

Preparing expert decoding techniques .............................................................................. 122
Configuring global settings ............................................................................................... 123
What is goodput? ............................................................................................................... 124
Network delay calculation ................................................................................................. 124
Response time calculation ................................................................................................. 125
Using Expert Summary .................................................................................................... 125
Using Time Interval Analysis ............................................................................................ 126
Using Server Analysis ....................................................................................................... 127
Using End-to-End Analysis ............................................................................................... 127
Using "What-if" modeling ................................................................................................ 128
Reconstructing TCP data streams ..................................................................................... 130
Tell me more about stream reconstruction ..................................................................... 131
Using Connection Dynamics ......................................................................................... 131
Tell me more about the Connection Dynamics tool ......................................................... 132
What are skipped packets, and why are they appearing? ............................................... 133
Configuring expert thresholds .......................................................................................... 134
Tell me more about expert thresholds ............................................................................. 135
<table>
<thead>
<tr>
<th>Chapter 8: Alarms</th>
<th>142</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuring and using alarms</td>
<td>142</td>
</tr>
<tr>
<td>Enabling probe instance alarms</td>
<td>142</td>
</tr>
<tr>
<td>Enabling individual alarms</td>
<td>143</td>
</tr>
<tr>
<td>Creating filter-based alarms</td>
<td>144</td>
</tr>
<tr>
<td>Resetting statistical alarms</td>
<td>145</td>
</tr>
<tr>
<td>Customizing triggers and actions</td>
<td>146</td>
</tr>
<tr>
<td>Customizing alarm triggers</td>
<td>146</td>
</tr>
<tr>
<td>Customizing alarm actions</td>
<td>146</td>
</tr>
<tr>
<td>Sharing alarms with others</td>
<td>147</td>
</tr>
<tr>
<td>How to export alarms</td>
<td>147</td>
</tr>
<tr>
<td>How to import alarms</td>
<td>148</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 9: Security and Privacy</th>
<th>149</th>
</tr>
</thead>
<tbody>
<tr>
<td>Security, privacy, and regulatory compliance</td>
<td>149</td>
</tr>
<tr>
<td>Configuring user accounts for secure access</td>
<td>150</td>
</tr>
<tr>
<td>Sharing packet captures with third-parties</td>
<td>150</td>
</tr>
<tr>
<td>Password protecting the ability to change partial packet capture size</td>
<td>151</td>
</tr>
<tr>
<td>Trimming data from your captures</td>
<td>151</td>
</tr>
<tr>
<td>How to encrypt captured data at rest</td>
<td>152</td>
</tr>
<tr>
<td>Understanding the certificate trust model</td>
<td>155</td>
</tr>
<tr>
<td>How to view certificates</td>
<td>156</td>
</tr>
<tr>
<td>How to change the trust of a certificate</td>
<td>156</td>
</tr>
<tr>
<td>Certificates and how they are used</td>
<td>156</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 10: Network Trending</th>
<th>158</th>
</tr>
</thead>
<tbody>
<tr>
<td>Understanding the Network Trending tool</td>
<td>158</td>
</tr>
<tr>
<td>Does network trending have any limitations?</td>
<td>159</td>
</tr>
<tr>
<td>Understanding Application Performance Analysis</td>
<td>159</td>
</tr>
<tr>
<td>How to configure Application Performance Analysis</td>
<td>160</td>
</tr>
<tr>
<td>Understanding Application Transaction Analysis</td>
<td>163</td>
</tr>
<tr>
<td>Analyzing servers and applications using ATA</td>
<td>164</td>
</tr>
<tr>
<td>Importing or exporting a server profile</td>
<td>165</td>
</tr>
<tr>
<td>Global Settings</td>
<td>166</td>
</tr>
<tr>
<td>ATA is reporting inaccurate values</td>
<td>167</td>
</tr>
<tr>
<td>Collecting network trending data</td>
<td>168</td>
</tr>
<tr>
<td>Viewing network trending data</td>
<td>168</td>
</tr>
<tr>
<td>Deleting your network trending data files</td>
<td>168</td>
</tr>
<tr>
<td>Configuring your network trending settings</td>
<td>169</td>
</tr>
<tr>
<td>Scheduling your network trending data collection</td>
<td>170</td>
</tr>
<tr>
<td>How to determine disk space requirements for network trending</td>
<td>170</td>
</tr>
</tbody>
</table>
Chapter 11: VoIP and Teleconferencing ................................................................. 175
Collecting VoIP or video conferencing trending data........................................... 175
Importing and exporting VoIP or video conferencing settings............................. 176
Analyzing VoIP or video conferencing traffic......................................................... 177
How to extract VoIP and video calls from your GigaStor....................................... 178
VoIP MOS.............................................................................................................. 179
VoIP R-Factor........................................................................................................ 179
Configuring network trending settings for VoIP or video conferencing............... 180
  General tab........................................................................................................... 181
  MOS tab............................................................................................................... 181
  Device IP Addresses tab...................................................................................... 183
  Caller ID Determination tab................................................................................ 184
  IP Range Filters tab............................................................................................ 184
Enabling VoIP alarms........................................................................................... 185
VoIP Top 10 best practices.................................................................................... 186
  Network Jitter and Delay..................................................................................... 187
  Packet Loss......................................................................................................... 188
  Managing VoIP Quality....................................................................................... 188
  VoIP terminology............................................................................................... 189

Chapter 12: Reports.................................................................................................. 192
Setting up email notifications................................................................................ 192
Setting up text message notifications.................................................................. 192
Setting up pager notifications............................................................................... 193
  Sending a page...................................................................................................... 194
  Viewing the Paging Server logs.......................................................................... 194

Chapter 13: SNMP Management Console............................................................ 195
Introduction to SNMP............................................................................................ 195
  Configuring Observer Suite for SNMP devices.................................................. 197
  What can Observer’s SNMP console tell me about a problem switch?............. 198
  Resetting SNMP device alarm counters............................................................. 198
  About MIBs........................................................................................................ 198
Configuring SNMP agents.................................................................................... 200
  OIDs.................................................................................................................... 200
  SNMP Management Station............................................................................... 201
Using SNMP Management Console...................................................................... 201
Using the MIB editor.............................................................................................. 202
  Adding triggers based on SNMP chart values.................................................... 203
  Adding, modifying, and deleting SNMP agents............................................... 204
Using agent information windows....................................................................... 205
Collecting SNMP agent information.................................................................... 206
Collecting chart information................................................................................. 206
Collecting list information.................................................................207
Collecting forms information.............................................................208
Collecting table information...............................................................208
Traps.................................................................................................209
The MIB Editor..................................................................................210
Understanding a MIB file.................................................................210
Understanding a Request file.........................................................211
Compiled MIBs..................................................................................211
Compiling MIBs...............................................................................211
Building Expressions........................................................................212
Adding new MIB objects and traps to request files..........................213
    Adding a new MIB object............................................................214
    Adding a Trap.............................................................................214
Using the MIB Walker........................................................................214
    Viewing the MIB tree.................................................................215
    Setting values...........................................................................215
SNMP MIB Walker............................................................................216
SNMP technical overview...............................................................216
    General principles.....................................................................217
    SNMP MIB objects, groups, and addresses..............................218
Types of SNMP MIB objects............................................................219

Chapter 14: Integrating Observer with HP OpenView or Tivoli........220
Integrating with IBM Tivoli NetView.................................................220
Integrating with HP OpenView.......................................................220

Chapter 15: Observer Suite Custom Decode Kit..............................222
Using the Custom Decode Kit.........................................................222
    Introduction..............................................................................222
    Warranty..................................................................................223
    Installation...............................................................................223
    How the Custom Decode API Works.........................................223
    Files Included..........................................................................223

Chapter 16: Probes and Probe Instances.................................225
About Probes and Instances............................................................225
    What is a probe instance?.........................................................226
    Which software probe is right for you?.................................228
    How probes work with switches............................................230
Allocating RAM............................................................................231
    How a probe uses RAM............................................................231
    How to allocate the reserved RAM........................................231
Troubleshooting common issues....................................................238
    Troubleshooting a slow probe system.................................240
    A probe is not connecting to the analyzer or vice versa........241
No network adapter available.......................................................241
Integrated adapters report all sent packets with bad TCP checksum...242
“No VLAN” shown while using a Gigabit NIC.................................242
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>17</td>
<td><strong>Expert Probe Software</strong></td>
<td>249</td>
</tr>
<tr>
<td></td>
<td>How to install or upgrade the software</td>
<td>249</td>
</tr>
<tr>
<td></td>
<td>Comparing software probe features</td>
<td>250</td>
</tr>
<tr>
<td></td>
<td>Minimum and recommended system specifications</td>
<td>252</td>
</tr>
<tr>
<td></td>
<td>How to upgrade to Windows 10</td>
<td>253</td>
</tr>
<tr>
<td></td>
<td>How to install all versions</td>
<td>254</td>
</tr>
<tr>
<td></td>
<td>How to upgrade version 17 and later</td>
<td>254</td>
</tr>
<tr>
<td></td>
<td>How to upgrade version 16 and earlier</td>
<td>254</td>
</tr>
<tr>
<td></td>
<td>Capture card driver requirements</td>
<td>255</td>
</tr>
<tr>
<td></td>
<td>Installing the wireless NIC driver on Windows 7/Vista</td>
<td>256</td>
</tr>
<tr>
<td></td>
<td>Installing a third-party USB wireless adapter</td>
<td>256</td>
</tr>
<tr>
<td></td>
<td>Installing Windows updates and updating virus protection</td>
<td>257</td>
</tr>
<tr>
<td></td>
<td>Upgrading the probe software</td>
<td>258</td>
</tr>
<tr>
<td></td>
<td>Creating a probe instance</td>
<td>262</td>
</tr>
<tr>
<td></td>
<td>Creating GigaStor active and passive probe instances</td>
<td>263</td>
</tr>
<tr>
<td></td>
<td>Creating and configuring an MPLS probe instance</td>
<td>264</td>
</tr>
<tr>
<td></td>
<td>How to use additional storage volumes on the GigaStor active instance</td>
<td>264</td>
</tr>
<tr>
<td></td>
<td>Connecting to a Probe</td>
<td>265</td>
</tr>
<tr>
<td></td>
<td>How to change the monitored network adapter</td>
<td>265</td>
</tr>
<tr>
<td></td>
<td>Connecting to a probe for the first time from Observer</td>
<td>265</td>
</tr>
<tr>
<td></td>
<td>Connecting the Multi Probe or Expert Probe to an Observer</td>
<td>266</td>
</tr>
<tr>
<td></td>
<td>Connecting to a probe instance from an Observer</td>
<td>266</td>
</tr>
<tr>
<td></td>
<td>Connecting the probe to an Observer</td>
<td>267</td>
</tr>
<tr>
<td></td>
<td>Redirecting a probe instance</td>
<td>267</td>
</tr>
<tr>
<td></td>
<td><strong>Probe Properties</strong></td>
<td>269</td>
</tr>
<tr>
<td></td>
<td>Configuring a probe's name and other probe options</td>
<td>269</td>
</tr>
<tr>
<td></td>
<td>Understanding the Packet Broker Integration tab</td>
<td>277</td>
</tr>
<tr>
<td></td>
<td><strong>Security and Encryption</strong></td>
<td>282</td>
</tr>
<tr>
<td></td>
<td>How to encrypt captured data at rest</td>
<td>282</td>
</tr>
<tr>
<td></td>
<td><strong>Using the Probe</strong></td>
<td>285</td>
</tr>
<tr>
<td></td>
<td>Using the Expert Probe software</td>
<td>285</td>
</tr>
<tr>
<td></td>
<td>VoIP Expert, Application Performance Analysis, and Application Transaction Analysis</td>
<td>286</td>
</tr>
<tr>
<td></td>
<td>Switching between the probe and analyzer user interfaces</td>
<td>286</td>
</tr>
<tr>
<td></td>
<td>Enabling Network Trending and setting which statistics are collected</td>
<td>287</td>
</tr>
<tr>
<td></td>
<td>Monitoring a wireless access point</td>
<td>287</td>
</tr>
</tbody>
</table>
Using the Microburst Analysis tab in the GigaStor Control Panel............................ 340
Using the Detail Chart only.................................................................................................340
Reconstructing streams of HTTP, VoIP, and more.......................................................... 343
   Defining what can be recreated in Stream Reconstruction........................................344
   How to extract VoIP and video calls from your GigaStor...........................................344
Using Observer in financial firms.................................................................................... 345
   Analyzing FIX transactions..............................................................................................347
   Configuring a FIX profile..................................................................................................347
Troubleshooting the GigaStor Control Panel.................................................................. 348
   GigaStor Control Panel option is grayed out.................................................................348
   GigaStor is full or does not have the history you expect..............................................349
   TCP applications are not appearing in the GigaStor Control Panel.......................... 349
   Loading decodes in Observer is slow............................................................................349

Chapter 19: Backups and Restoring.........................................................................350
   Configuring a FIX profile..................................................................................................350
   Sharing alarms with others............................................................................................... 351
      How to import alarms.................................................................................................351
      How to export alarms.................................................................................................351
   Sharing application definitions with others.................................................................352
      How to export application definitions.........................................................................352
      How to import application definitions.........................................................................352
   Private key locations per server.....................................................................................353
      Microsoft Lync Server.................................................................................................353
      Apache Web Server.......................................................................................................353
      Windows IIS Web Server..............................................................................................354
      Non-encrypted private key file....................................................................................354
      Encrypted private key file............................................................................................354
   Importing and exporting VoIP or video conferencing settings......................................355
   Restoring the default application list..............................................................................355
      How to restore TCP application definitions...............................................................355
      How to restore UDP application definitions..............................................................355
   Importing or exporting a server profile..........................................................................356
   Creating a Forensic Settings profile...............................................................................356
   Importing Snort rules........................................................................................................361

Index..................................................................................................................................363
Chapter 1: Getting started

Read about Observer and its system requirements. Plus, learn how to perform software upgrades and change general settings.

Which version of Observer is right for you?

Observer is available in three versions: Standard, Expert, and Suite. This section lists what features are available in each one.

**Note:** Because the functionality of Observer versions is additive, all features of Observer Standard are in Observer Expert. Similarly, Observer Suite includes the features of both Observer Standard and Observer Expert.

**Observer Standard**

Observer Standard allows you to discover your network, capture and decode network traffic, and use real-time statistics to solve problems within networks and network applications.

**Observer Expert**

Observer Expert allows you to discover your network, capture and decode network traffic, and use real-time statistics to solve network problems. Observer Expert is also the first offering of Observer to include advanced analysis tools for graphically viewing network conversations, analyzing server response time, VoIP, and much more.

**Observer Suite**

Observer Suite allows you to discover your network, capture and decode network traffic, and use real-time statistics to solve network problems. Observer Suite also includes advanced analysis tools for graphically viewing network conversations, analyzing server response time, VoIP, and much more.
conversations, analyzing server response time, and VoIP. Observer Suite is also the first offering of Observer to include SNMP device management, support for RMON, and advanced reporting options.

### Comparing Observer versions

Table 1. Comparing Observer versions

<table>
<thead>
<tr>
<th></th>
<th>Standard</th>
<th>Expert</th>
<th>Suite</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Packet Capture (page 84)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Packet Decode (page 103)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Real-Time Packet Captures &amp; Decode (page 112)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Automated Packet Captures (page 85)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Nanosecond Resolution (page 82)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Financial Protocol Support</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Filters (page 89)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Find Virus and Hack Signatures</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Statistical Drill Down</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Alarms (page 142)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Custom Alarm Triggers (page 146)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Error Tracking (page 52)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Real-Time Statistics (page 39)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Top Talkers (page 46)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Bandwidth Utilization (page 44)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>VLAN Analysis (page 56)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Internet Activity (page 39)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Wireless Analysis (page 42)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>IP Pair Statistics (page 41)</strong></td>
<td>X</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Which version of Observer is right for you?

#### Chapter 1: Getting started

<table>
<thead>
<tr>
<th>Feature</th>
<th>X</th>
<th>X</th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Protocol Distribution</strong> (page 42)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>64 &amp; 32-bit applications (page 17)</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Network Trending/Reporting (page 158)</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Comparison Reports</strong></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Ready-Made Reports</strong></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Custom Reports</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Report Scheduler</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>IPv6 Support</strong> (page 33)</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Trace File Aggregation (page 83)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>SRTP Support</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Integrated reporting with Apex</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td><strong>Application Analysis Trending</strong> (page 159)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Stream Reconstruction (page 130)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td><strong>Web pages</strong></td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Email</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td><strong>Instant messages</strong></td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>VoIP</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>HTTP-transferred files</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td><strong>Expert Analysis</strong></td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Over 600 Experts</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td><strong>Expert Summary</strong></td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td><strong>Network Delay</strong> (page 124)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td><strong>Connection Dynamics</strong> (page 131)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td><strong>MultiHop Analysis</strong> (page 135)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>&quot;What-If&quot; Analysis (page 128)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Application Analysis (page 164)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>----------------------------------</td>
<td>---</td>
<td>---</td>
<td></td>
</tr>
<tr>
<td>Citrix</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>DHCP</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>DNS</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>FIX</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>FTP</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>HTTP</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>LDAP</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>MS Exchange</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>MS Networking (SMB)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Oracle</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>POP3</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>SMTP</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>SNMP</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>SQL</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Telnet</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>VoIP</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>URL-Based Tracking (page 164)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>VoIP Analysis (page 175)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Call Detail Records</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Aggregate Call Summaries</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Over 70 VoIP metrics</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Over 50 VoIP Experts</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>QoS Metrics</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>MOS, R-Factor</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>SRTP support</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>VoIP Systems Supported</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Avaya</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Cisco</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Mitel</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Nortel</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Siemens</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>ShoreTel</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>MPLS Monitoring</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>SSL decryption (page 106)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>NetFlow Collector</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Video monitoring</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>
How to install or upgrade the software

This section describes the installation process and minimum requirements if you are installing Observer or probe on your system. This applies to physical and virtualized servers. If you virtualize the server, each server must meet these specifications.

Prerequisite(s):

♦ An administrator account is required to install and run any version of Observer or probe software except Observer Expert Console Only (ECO). Observer ECO requires an administrator account just for installation; a standard user account can be used for running Observer ECO.

♦ Standard network cards do not support “raw” wireless packets, nor do they enable “promiscuous” mode by default. Promiscuous mode captures all packets for the analyzer, not just those addressed to the network card. Both “raw” wireless packets and promiscuous mode are required by Observer. ErrorTrak drivers were needed in earlier versions of Observer. They are no longer necessary.

♦ If you do not meet the minimum requirements, the system may seem to operate in the short term, but be aware that even if a sub-minimum installation works momentarily, a later, heavier load on the system can cause it to fail. VIAVI sells hardware probes that are guaranteed to keep up with heavy loads. See the Observer Platform website for details.

♦ You may install the probe software on a virtual machine so long as it meets the system requirements. The installation process is the same. You may also want to consider using a virtual TAP. See Using the probe as a virtual TAP (page 288).

Caution: See the important information in How to upgrade to Windows 10 (page 19) if you want to upgrade the operating system!

1. Ensure your system meets the minimum requirements.
   See Minimum and recommended system specifications (page 18).
2. Choose one of the following:
   • How to install all versions (page 20)
- How to upgrade version 17 and later (page 20)
- How to upgrade version 16 and earlier (page 21)

After completing this task:
- License your software. See FAQ: Licensing and updating (page 21).
- If you are using a wireless network adapter to capture traffic, see Installing the wireless NIC driver on Windows 7/Vista (page 256).
- If you are using a USB wireless network adapter to capture traffic, see Installing a third-party USB wireless adapter (page 256).
- If you use Observer on a virtual machine and network traffic cannot be captured or BSODs (bluescreens) are occurring, see Virtual machine troubleshooting (page 24).

Minimum and recommended system specifications

If you are installing the software on your own hardware or a virtual machine, these are the minimum and recommended specifications for a production environment.

Table 2. Observer Expert Console Only (ECO)

<table>
<thead>
<tr>
<th>Processor / CPU</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Dual core Pentium class processor</td>
<td>Quad core Pentium class processor</td>
</tr>
<tr>
<td>RAM</td>
<td>2 GB RAM</td>
<td>8 GB RAM</td>
</tr>
<tr>
<td>Operating system</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
</tr>
<tr>
<td>Network Card</td>
<td>Server-class</td>
<td>Intel server-class</td>
</tr>
</tbody>
</table>

1. If your system has 4 GB of RAM, you cannot reserve any memory for Observer. This is a limitation of Windows known as the BIOS memory hole. Either add more RAM or take some out.
2. See Supported Operating Systems (page 19) for a full list of supported operating systems.

Table 3. Observer or GigaStor Software Edition in a virtual server

<table>
<thead>
<tr>
<th>Processor / CPU</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Four core</td>
<td>Six core Intel</td>
</tr>
<tr>
<td>RAM</td>
<td>Minimum 16 GB (8 GB for Observer and 8 GB for the operating system)</td>
<td>64 GB</td>
</tr>
<tr>
<td>Storage</td>
<td>Packet capture - Hardware: Determined by your product</td>
<td>Same</td>
</tr>
<tr>
<td>Operating system</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
</tr>
<tr>
<td>Network Card</td>
<td>Virtualized network adapter</td>
<td>Intel server-class</td>
</tr>
</tbody>
</table>
Minimum | Recommended
--- | ---
Capture Card ³ | Virtualized network adapter | Server-class onboard network adapter

1. If your system has 4 GB of RAM, you cannot reserve any memory for Observer. This is a limitation of Windows known as the BIOS memory hole. Either add more RAM or take some out.
2. See Supported Operating Systems (page 19) for a full list of supported operating systems.
3. A second network card that acts solely as a capture card is required (and must be in “promiscuous mode”). Alternatively, a dual-port NIC can be used. For further details, see Capture card driver requirements (page 23).

Current compatibility and incompatibly of virtual machines with the GigaStor Software Edition (GSE) is described in this list:

- VMWare ESXi Server
  - ESXi 5.0 and higher is compatible with GSE.
- VMWare Workstation Pro is not supported with GSE
- Microsoft Hyper-V may function but is not supported with GSE

**Supported Operating Systems**

Your product must be installed on one of these operating systems to receive assistance from Technical Support.

**Table 4. Supported Operating Systems**

<table>
<thead>
<tr>
<th>Product Name</th>
<th>64-bit Windows</th>
<th>32-bit Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>GigaStor Software Edition</td>
<td>Windows 7 (SP1 or higher) to Windows Server 2012 R2</td>
<td>Not supported</td>
</tr>
<tr>
<td>Observer Apex</td>
<td>Windows Server 2008 R2 Enterprise, Standard, Web (SP1 or higher) to Windows Server 2012 R2</td>
<td></td>
</tr>
<tr>
<td>Observer Management Server (OMS)</td>
<td>Windows 7 (SP1 or higher) to Windows Server 2012 R2</td>
<td></td>
</tr>
<tr>
<td>Observer Expert</td>
<td>Windows 7 (SP1 or higher) to Windows Server 2012 R2</td>
<td></td>
</tr>
<tr>
<td>Observer Standard</td>
<td>Windows Server 2008 R2 Enterprise, Standard, Web (SP1 or higher) to Windows Server 2012 R2</td>
<td></td>
</tr>
<tr>
<td>Observer Suite</td>
<td>Windows 7 (SP1 or higher) to Windows Server 2012 R2</td>
<td></td>
</tr>
<tr>
<td>Observer Expert Console Only (ECO)</td>
<td>Windows 7 (SP1 or higher) to Windows Server 2012 R2</td>
<td>Windows 7 (SP1 or higher) to Windows Server 2012 R2</td>
</tr>
<tr>
<td></td>
<td>Windows Server 2008 R2 Enterprise, Standard, Web (SP1 or higher) to Windows Server 2012 R2</td>
<td>Windows Server 2008 R2 Enterprise, Standard, Web (SP1 or higher) to Windows Server 2012 R2</td>
</tr>
</tbody>
</table>

**How to upgrade to Windows 10**

Due to the way Microsoft has designed its Windows® 10 operating system upgrade feature, Observer will not function if you upgrade your operating system from Windows 7, Vista or Windows 8 to Windows 10 without first uninstalling Observer.

This information does not apply if you:

- Already uninstalled Observer.
- Are installing Windows 10 rather than upgrading to it.
Are already using Windows 10.

Are upgrading using the **Observer Platform OS Upgrade** product because it replaces the operating system rather than upgrading it. Additionally, it uses Windows Server 2012 R2.

**Note:** Unfortunately, if you have already upgraded the operating system and Observer was not uninstalled prior to upgrading to Windows 10, the only path to recovery is to reinstall the operating system. *Back up (page 260)* any Observer files on the operating system, reinstall the operating system, then install Observer and restore its files.

To upgrade a system with Observer to Windows 10:

1. **Back up your settings (page 260).**
2. **Uninstall Observer using Control Panel > Program and Features.**
3. **Upgrade your operating system.**
4. **Install the Observer (page 20) software (page 20).**
5. **Restore your settings from step 1 using whatever method is best for you.**

Observer is now available to use on Windows 10.

### How to install all versions

Use this procedure to install all versions of the software.

**Prerequisite(s):**

An administrator account is required to install and run any version of Observer or probe software except Observer ECO. Observer ECO requires an administrator account just for installation; a standard user account can be used for running Observer ECO.

1. **Insert the installation CD in your CD drive or use the latest installation image from our update site.** If you copied the installation files from our web site, start the installation program.

   ![Image Link](http://update.viavisolutions.com/latest/ObserverSetupx64.exe)

2. **When the setup program runs, follow the onscreen instructions.**
3. **Choose to install:**
   - Observer.
   - Advanced Probe. Choose this for Single Probe or Multi Probe. Your license determines whether it is a Single Probe or Multi Probe.
   - Expert Probe
4. **After the files have been installed on your system you must restart Windows. You will not be able to run the software until you restart your computer.**

### How to upgrade version 17 and later

Version 17 allows you to upgrade directly from within Observer or from OMS (if used).

If OMS is *not* controlling Observer, then do the following in Observer:
♦ Click the File tab, and click **Info > Update Observer**.

If OMS is controlling Observer:
♦ See **How to manage software versions using OMS**.

The software is updated to the latest version.

**How to upgrade version 16 and earlier**

Upgrading version 16 uses the same procedure as installing the software. The process is different for version 17 and later.

1. Insert the installation CD in your CD drive or use the latest installation image from our update site. If you copied the installation files from our web site, start the installation program.
   
   http://update.viavisolutions.com/latest/ObserverSetupx64.exe

2. When the setup program runs, follow the onscreen instructions.

3. Choose to install:
   ▪ Observer.
   ▪ Advanced Probe. Choose this for Single Probe or Multi Probe. Your license determines whether it is a Single Probe or Multi Probe.
   ▪ Expert Probe

4. After the files have been installed on your system you must restart Windows. You will not be able to run the software until you restart your computer.

**FAQ: Licensing and updating**

Some customer concerns deal with licensing and updating issues. Explore this good resource for licensing and updating help, or call the Technical Support department for further assistance.

**How to license Observer and GigaStor**

To license and activate a compatible GigaStor, Observer, or Probe:

1. Install and launch the application.

2. After launching the application in DEMO mode, click the **Help** menu and select **License Observer**.

3. Click the **Enter Name** button in the lower left corner.

4. Type into the **Contact/Department** and **Company** boxes exactly what is listed in your license document.

5. Click **OK**, and then click **Accept** on the confirmation dialog.

6. Ensure the **Identification Number** matches the number on your license document. If they do not match, click **Re-Type Name?** to correct any mistakes.

7. Type the license number, from your license document, into the **License Number** box.

8. Click **OK**.

You successfully licensed and activated your product.

If licensing and activating your product remains unsuccessful, please contact Technical Support.
How to update your license

If Observer or GigaStor is already licensed and you need to modify, update, or change that license, you can do so.

Prerequisite(s):

This task requires you have already licensed (page 21) your Observer or GigaStor.

This task cannot be completed if the license to your Observer or GigaStor is managed by OMS. Instead, refer to How to edit an asset license.

Upgrading your license refers to changing, editing, or updating the license that is already applied to your product. Some reasons for needing to do this can include:

- Activating a new license. The new license might provide different or increased functionality over your existing license, like increased data storage for a GigaStor Software Edition (GSE).
- Changing a license. Perhaps you accidentally applied the wrong license to your product and need to change it.

To update a license:

1. Click the File tab, and click Info > License Observer.
2. Click OK to confirm you want to re-license.
3. Type the license number, from your license document, into the License Number box.
4. Click the Re-Type Name? button in the lower left corner.
5. Type into the Contact/Department and Company boxes exactly what is listed in your license document.
6. Click OK, and then click OK on the confirmation dialog.

You successfully updated your license. Observer begins using the license the next time Observer is launched.

Close and restart Observer for the new license to take effect. You may need to coordinate a suitable time to do so if restarting would affect many users or significantly interrupt your data collection.

Why is my license number not working?

Each license number is case-sensitive, so be sure to type it in exactly the way it was given to you. Also, if you copy-pasted the license number into the activation prompt, be sure you did not introduce a leading or trailing space character—those are not part of your license number.

Ensure you are licensing the correct version of Observer. License numbers are version-specific. License numbers work within equal major version numbers of the product only. For example, an 17.0 license can be used to activate 17.x versions but not 16.1, 16.0, 15.1, 15.0, etc.

Could I have my license re-sent to me?

Yes. If you lost the original information containing your license number, please contact us so we can resend your license document(s).
What type of license do I have?

The type of license you have is described in your license document. Each license document contains a license number, and the document describes which software version the license number applies to. If it does not, or you notice any other error, please call our support team for assistance.

Should I uninstall Observer before updating it?

If you wish to update your existing Observer software to a newly released version within the same major release number, you do not need to uninstall your existing version for the update process to succeed. Simply install the new version over the old.

Capture card driver requirements

If you are going to use a third-party capture card in your probe, the capture card must meet certain requirements so that Observer can report statistics and errors. The network card used to monitor or capture network traffic must have all of the mandatory and optional NDIS functions. The VIAVI capture card has all of the necessary features.

Most NIC vendors provide solid, functional NDIS drivers for all cards available within the Ethernet, Token Ring, and FDDI marketplace.

Accessing a standard network with a “normal” network device is somewhat different from what a protocol analyzer requires. While both share a number of driver functions, a protocol analyzer requires a set of features and functions that the average network device will never need. Examples of these optional functions are promiscuous mode, error tracking, and network speed reporting. (Examples of mandatory functions would include functions to determine the maximum packet size, functions to verify the number of sent packets, and functions to specify or determine a packets’ protocol.)

Microsoft made a number of the less used (by “normal” network users) functions “optional”, as opposed to “mandatory” regarding driver requirements. The result has been that most vendors support all (or most) mandatory functions with the first release of the driver. As time passes, and the initial chaos of the first release of the card and driver passes, most manufacturers add some or all of the optional functions, as well as fix or complete all of the mandatory functions.

As part of the optional section of defined NDIS functions, Microsoft specified a number of counters that can be kept for Ethernet frame errors. These counters include CRC errors, Alignment errors, Packets Too Big (Jabbers), and Packets Too Small (Runts). Collisions are counted, but there are limitations of NDIS collision statistics. Four important points should be considered:

- These optional counts only provide a numerical value to the total number of errors on the segment (i.e. the number of CRC errors found), they do not specify where (which station) the error originated from.

- After the error packet is identified and the proper error counter is incremented, the packet is discarded, and not sent to Windows (this is the reason it is impossible to determine the source of an Ethernet error packet with standard NDIS drivers).
♦ A number of vendor’s NDIS drivers return a positive acknowledgment when the NDIS error function is queried for existence, but the error statistic is not actually kept.

♦ A few vendors (3COM, for example) do not keep any error statistics whatsoever.

If a NIC driver both reports that the optional Ethernet error statistics are being kept, and actually keeps data on these errors, Observer reports these statistics in the Network Vital Sign Display.

Installing Windows updates and updating virus protection

From time to time Microsoft releases updates for the operating system used for your probe or your virus protection software vendor updates their virus definitions. You should apply those updates as soon as feasible, however, you should always apply the updates manually.

We do not recommend that you allow Windows to automatically install the updates and restart the system. By manually applying the updates you ensure that the system restarts properly and that the probe starts correctly whether running as a Windows service or as an application.

For your anti-virus software, follow these guidelines:

♦ Ensure TCP ports 25901 and 25903 are open. All Observer Platform products communicate on these ports.

♦ Ensure UDP ports 25901 and 25903 are open if you use OMS.

♦ For all probes, disable any scanning of the Observer installation directory (typically C:\Program Files\Observer) and of D: (RAID) drive as scanning greatly diminishes the performance of writing data to disk.

♦ The performance of the operating system may be greatly diminished when using anti-virus software.

Virtual machine troubleshooting

The hardware abstraction granted by virtual machines can interact with Observer Platform products in ways bare-metal systems cannot. This can sometimes lead to oddities, but these problems can be resolved.

Cannot capture traffic using VMware ESX VM

When using GigaStor Software Edition in a virtual machine, Observer cannot capture network traffic when Memory Hot Add is enabled.

When Memory Hot Add is enabled, Observer can see traffic as a blue line, but Observer cannot capture any traffic by manually starting packet capture or being set to always capture data. You can still reserve memory in Observer (for example: 12 GB of 16 GB), and Observer states that it has reserved 12 gigabytes of memory; however, Windows does not actually reserve the memory. Windows views all 16 GB of memory, from our example, as available to the operating system. The result of this behavior is that Observer cannot capture data.

A solution for this issue is to Disable memory hot add for this virtual machine in your virtual machine settings. The process for disabling memory hot add is described in How to disable memory hot add (page 25).
How to disable memory hot add

Memory hot add lets you add memory resources for a virtual machine while the machine is powered on.

Prerequisite(s):

♦ VMware Tools must be installed.
♦ The guest operating system supports memory hot add.
♦ The virtual machine uses hardware version 7 or later.
♦ Follow the steps outlined in the vSphere Documentation.
♦ Ensure Disable memory hot add for this virtual machine is selected in the VM properties.

This means the feature is disabled.

Figure 1: Disable memory hot add

Memory hot add is now disabled. You should now be able to capture traffic.

Experiencing BSOD when packet capture starts

A blue screen of death (BSOD) can occur when Observer is installed on a virtual machine and packet capture begins.

In this case, the issue is specifically related to the Virtual Machine (VM) itself. The VM has been configured in a way that prevents Observer from using memory correctly, and this leads to a system BSOD when packet capture begins.

There are some options in the configuration details of your VM that have been found to resolve this issue. These include disabling hotplug options in your
virtual machine settings. The process for disabling memory hot add and CPU hot plug is described in How to disable hot plug VM features (page 26).

**How to disable hot plug VM features**

Hot plug features can interfere with Observer running inside a virtual machine. Disable them to avoid blue screen errors and crashes.

**Prerequisite(s):**
- VMware Tools must be installed.
- The guest operating system supports Memory/CPU Hotplug.
- The virtual machine uses hardware version 7 or later.
- Follow the steps outlined in the vSphere Documentation.
- Select both **Disable memory hot add for this virtual machine** and **Disable CPU hot plug for this virtual machine** in the VM properties.

This means the features will be disabled on this virtual machine.

![Figure 2: Disable hot plug options](image)

Memory hot add and CPU hot plug features are now disabled. You should now be able to capture network traffic without experiencing a BSOD.

**Overview of Observer**

Observer is the network administrator's ultimate toolbox. Deep packet inspection, network analysis, and network management tools are included at various depths.
Note: All Observer versions use the same set of TCP ports to communicate with Observer Platform probes. For more details, see Ports used by Observer Platform v17 and later (page 28).

Observer Standard allows you to discover your network, capture and decode network traffic, and use real-time statistics to solve network problems. For more details, see Comparing Observer versions (page 14).

Observer Expert allows you to discover your network, capture and decode network traffic, and use real-time statistics to solve network problems. Expert is also the first offering of Observer to include advanced analysis tools for graphically viewing network conversations, analyzing server response time, VoIP, and much more. For more details, see Comparing Observer versions (page 14).

Observer Suite allows you to discover your network, capture and decode network traffic, and use real-time statistics to solve network problems. Suite also includes advanced analysis tools for graphically viewing network conversations, analyzing server response time, and VoIP. Suite is also the first offering of Observer to include SNMP device management, support for RMON, and advanced reporting options. For more details, see Comparing Observer versions (page 14).

The depth of features in Observer depends on which product license you purchased. For information about Observer licenses, see FAQ: Licensing and updating (page 21).

User interface

Observer, the software and its user interface, is described as the analyzer. The engine that makes traffic collection possible is the probe.

Observer (i.e., the Observer software) is the key to viewing, manipulating and controlling all of the data that a probe captures or sees flow through it. The analyzer communicates with remote probes throughout your network using TCP/IP, or the analyzer uses the local probe built into it.

The leftmost portion of the Observer user interface is the probe window where local and remote probes, NetFlow, sFlow, and SNMP devices are listed.

The main portion of the interface is the tools window. It is here where statistics, trending, decode, expert, and all other tools are displayed. Most tools have their own Settings button used to configure it. Within the tool window you can select and drag separator lines between windows (for instance, you may want to reduce the size of the probes list or log window or even hide it), and you can customize which tools are shown from the View menu.

To use Observer select the desired probe, then pick the desired tool from the main toolbar or from the main menu. You may have multiple tools running simultaneously for each probe. Each tool is in its own tab at the bottom of the tool window. Some tools have additional tabs along the top or bottom that provide even more functionality and display options.
Ports used by Observer Platform v17 and later

Open inbound and outbound TCP 80, 443, and 25901 on your firewalls for Observer Platform products version 17 and later.

Table 5. Supported Operating Systems

<table>
<thead>
<tr>
<th>Port</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>TCP 80</td>
<td>Requests from product to VIAVI to see if a new version or update exists.</td>
</tr>
<tr>
<td>TCP 443</td>
<td>Secure web server traffic, including Understanding GigaStor trace extraction</td>
</tr>
<tr>
<td>TCP 8008</td>
<td>between Apex and GigaStor.</td>
</tr>
<tr>
<td>TCP 25901</td>
<td>Default port for transfer of software upgrades.</td>
</tr>
<tr>
<td></td>
<td>All intra-Observer Platform communication.</td>
</tr>
</tbody>
</table>
Configuring Observer's general settings

The Observer General Options window allows you to configure the general settings for Observer. These include general configuration options, e-mail and pager options, folder settings, and more.

To configure Observer's general settings:

♦ Click the File tab, and click **Options > General Options**.

General tab

This tab allows you to set how the analyzer functions. Preferences you can set on this tab include:

♦ Whether Observer asks for confirmation before doing certain things
♦ What application certain file extensions are association with
♦ Whether any features are disabled
♦ Several display and formatting options
♦ Several start and runtime options

The **Remember expert post-capture statistic data when switching tabs** field is only available when the product is installed on 64-bit systems because of memory limitations of 32-bit systems.

One option of note is: Enable port control via command line on capture card (xxxGig2010) capture cards. This option is only available for 1 Gb, 10 Gb, or capture cards released with version 15 or later. It will not work for any capture cards in probes purchased prior to version 15 and later upgraded to version 15. The command line usage and options are:

```
NiDecodeApi.exe -VIRTADAPTER=C:;V:;P:
```

**Purpose**
Sets the ports for the capture card to be on or off from a command line using NiDecodeApi.exe -VIRTADAPTER. Parameters must be separated by a semi-colon (;).

**Parameters**

- **C:** Specifies that the capture card is a either a 1, 10, or 40 Gb capture card. The options are:
  - C:oneGig2010
  - C:tenGig2010
  - C:fortyGig2010
- **V:** Specifies the virtual port adapter number. The capture card supports up to four virtual adapters. You may only specify one virtual adapter at a time.
  - V:1
  - V:2
  - V:3
  - V:4
- **P:** Specifies whether a port is on or off for a given virtual adapter. The capture card has up to 12 ports.
  - 0=off
  - 1=on

Ports can be partially filled. For instance:
P; means all ports are off.
P:1; means port 1 is on and all others are off.
P:0001; means ports 1, 2, and 3 are off and port 4 is on. If the capture card has more than four ports, any ports beyond 4 are also off.

Use
NiDecodeApi.exe -VIRTADAPTER=C:oneGig2010;V:1;P:1111
NiDecodeApi.exe -VIRTADAPTER=C:tenGig2010;V:3;P:01010101
NiDecodeApi.exe -VIRTADAPTER=C:fortyGig2010;V:2;P:11110101

Security tab

There are several options available to you to tighten access to Observer. Many of the options are used in conjunction with OMS, but some can be used by Observer by itself.

To view and change the security settings for an Observer, in Observer choose Options > Observer General Options > Security tab. Use the information in Table 6 (page 30) to configure the analyzer's security and OMS options.

Table 6. Security options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Require Observer Login</td>
<td>When enabled, this option forces a user to provide a user name and password to open Observer. The user name can be stored locally if you are not using OMS, or maintained by OMS if the &quot;Authenticate Observer login with OMS&quot; option is enabled. This option is not visible unless you have a special license enabling it. Caution: Do not lose this password! There is no way to recover a lost administrative password. Observer Login Credentials—Type a user name and password. This information is encrypted and stored locally. Only one user account is allowed per system. If you want numerous people to have access to Observer with different user accounts, you must use OMS. Administrative Credentials—A local administrative user account that allows you to create a non-administrator account and to set security options for OMS.</td>
</tr>
<tr>
<td>Use Observer Encryption Key file for secure connections</td>
<td>Strong encryption is available for Observer Expert and Suite users. Observer Encryption Key (.OEK) files let you use private encryption keys to ensure that unauthorized persons do not have access to the data flowing between Observer and probes. To use Observer Encryption Key files, you must copy the encryption key file into the installation directory (usually C:\Program Files\Observer) of each probe or analyzer that you want to authorize. To generate a key file, click the “Launch Encryption Key Generator” button. Its online help explains its use and how to set up the keys it generates. Each analyzer and each probe must have the .oek file. Observer encryption keys are required if you want to use OMS.</td>
</tr>
<tr>
<td>Authenticate users (for redirected Probe instances)</td>
<td>Forces users to authenticate with OMS before using remote probes. User accounts belong to user groups in OMS and through the user group’s access to probe instances can be granted or restricted. Only probe instances to which the user has access will be visible in the analyzer. This option does not control whether users can open Observer. That is done through the &quot;Authenticate Observer login with OMS&quot; option.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Manage Observer / Probe license with</td>
<td>An Observer or probe license can be stored and managed locally at each analyzer or probe, or it can be managed centrally by OMS. If unchecked, it is managed locally and you must provide a license for each analyzer/probe. If selected, then you can provide a pool of licenses in OMS and the analyzer or probe will take an available license when the analyzer or probe starts.</td>
</tr>
<tr>
<td>OMS</td>
<td></td>
</tr>
<tr>
<td>Get list of Probe instances available</td>
<td>When selected all probe instances to which you the user has access to through group permissions set in OMS are available when connecting to a probe. When unchecked only the local probe instances are available and no probe instances are listed when connecting to a remote probe.</td>
</tr>
<tr>
<td>for redirection from OMS</td>
<td></td>
</tr>
<tr>
<td>Share filters with OMS</td>
<td>When selected you may create filters and share them with others. You may also get any filters created by others. Whenever a filter is updated, other users can be informed and update their local version. The list is maintained by OMS.</td>
</tr>
<tr>
<td>Synchronize user protocol definitions</td>
<td>When selected you synchronize protocol definitions, including any derived applications definitions, automatically through OMS. If any protocol definitions are updated in another analyzer, you automatically receive those. If a protocol definition is updated in one analyzer, it is published to OMS and OMS pushes that new definition to all analyzers that choose to synchronize their protocol definitions. Extra caution should be used with this setting because definitions are automatically propagated to all analyzers (assuming the setting is selected in Observer). If two users are updating the same protocol definition, the last user to save and close the window is whose definition is used. Only one user (or a small select group of users) should be responsible for maintaining the list of protocol definitions. This ensures that no inadvertent changes are made.</td>
</tr>
<tr>
<td>through OMS</td>
<td></td>
</tr>
<tr>
<td>Primary/Secondary server</td>
<td>Provide the IP address of the primary OMS server. If you are also using a failover OMS server, type its IP address in the Secondary server box.</td>
</tr>
<tr>
<td>Allowed to modify shared filters</td>
<td>When selected, you can get a shared filter from someone else, modify it locally, then upload your modified version to OMS thereby making your new version available to everyone else. When disabled, you can only get filters from OMS and upload your own. You cannot modify any filters you get from OMS. This option requires that you have the ability to share filters with OMS.</td>
</tr>
<tr>
<td>Authenticate Observer login with OMS</td>
<td>This option works in conjunction with the &quot;Require Observer Login&quot; option. This forces Observer to use OMS to authenticate users rather than Observer's local user list. A user list is maintained in OMS.</td>
</tr>
<tr>
<td>Require a password to change partial</td>
<td>Select this option if you want to require someone to provide a password before they may change the partial packet capture size. This is a central password and all users must use the same password.</td>
</tr>
<tr>
<td>packet capture size</td>
<td></td>
</tr>
<tr>
<td>Launch Encryption Key Generator</td>
<td>Click this button to open the VIAVI encryption key generator. If you want the GigaStor payload to be encrypted using 256-bit AES encryption before it is stored, select the &quot;Encrypt GigaStor network traffic...&quot; option. An encryption key is needed on the GigaStor (or a location accessible by the GigaStor) to encrypt and decrypt the data.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>The AES key is not needed on workstations, probes, or other collection points. A special license is required for this feature. Contact VIAVI for this license.</td>
</tr>
</tbody>
</table>

### Folders tab

This tab allows you set the directories that hold Observer data. In most cases, the defaults are fine. We do not recommend pointing to networked directories or mapped drives.

<table>
<thead>
<tr>
<th>Network Trending Folder</th>
<th>The location for Observer to store Network Trending data.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Trending Viewer data size (in MB)</td>
<td>The maximum amount of memory to use when loading trending data in the network trending viewer. If the data exceeds the specified memory limit, an error message is displayed.</td>
</tr>
<tr>
<td>Folder for GigaStor and saving packets to disk</td>
<td>The default save location for packet captures. Automatically generated files are also stored here, like packet capture data collected by GigaStor. The default directory for a GigaStor appliance is D:\DATA.</td>
</tr>
<tr>
<td>SNMP Trending Folder</td>
<td>The location for Observer Suite to store SNMP Trending data.</td>
</tr>
<tr>
<td>Write SNMP Trending data to disk every N-minutes</td>
<td>Allows you to set the number of minutes the system will wait before writing trended SNMP data to disk.</td>
</tr>
<tr>
<td>Compiled SNMP MIB folder</td>
<td>The location for Observer to store and access compiled SNMP Management Information Base (MIB) files. The default is C:\Program Files\Observer\SNMP. We do not recommend changing this unless you have a specific reason to do so. When you change the MIBs or requests directory, any currently installed MIBs (or requests) will become inaccessible to the SNMP Management Console and its supporting utilities. If you change these directories, you will need to move the files in the existing directories to the new location. All executable files in the SNMP Management Console package use these definitions to find installed MIBs and requests.</td>
</tr>
<tr>
<td>SNMP Requests folder</td>
<td>Allows you to define the path to the directory where SNMP Management Console should look for compiled request files. The default is C:\Program Files\Observer\SNMP.</td>
</tr>
</tbody>
</table>

### SNMP tab

This tab will not be active unless you have purchased a licensed copy of Observer Suite. After installation, the SNMP Management Console will generally require little, if any, configuration before it can be used.

<table>
<thead>
<tr>
<th>Stop MIB compilation upon error in MIB source file</th>
<th>If you want Observer to complete the compilation even though the source file contains errors, leave the box unchecked.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use as MIB source editor</td>
<td>Allows you to enter the program you wish to use to edit MIB source files. The default is Microsoft Windows Notepad, although any editor capable of saving a plain text file will do.</td>
</tr>
</tbody>
</table>
### Default SNMP version
Allows you to select the default version of SNMP to use for new agents. You may also override this in the Agent Properties dialog.

### Request time-out period (sec)
Allows you to set the number of seconds that SNMP Management Console will wait for an agent to respond before resending a request.

### Request retry count
Allows you to define how many times SNMP Management Console will re-send a request to an agent before timing out.

### Max data buffer (x100K) for running charts
Allows you to define how much memory will be made available for SNMP Management Console’s chart display. The more memory made available, the more data points the chart display will be able to show. Memory saved for the SNMP Management Console’s chart display; however, will not be available for other programs or purposes.

### Max allowed RMON objects in MIB Walk
Allows you to set the maximum number of RMON objects to appear and/or be processed during a MIB Walk. The default value is 9999.

### Repeat alarm notifications
Allows you to select the number of times that Observer should send out SNMP-related alarms when the alarm has been triggered.

### Repeat trap notifications
Allows you to select how many times to repeat trap notifications. While, in practice, the vast majority of notifications sent via UDP will reach their destination, the UDP protocol, which is specified by the SNMP RFC for trap notification, does not require or permit packets being acknowledged by the receiving station. It is simply a matter of sound practice to repeat trap notifications several times.

## IPv6 tab

IPv6 is fully and natively supported in Observer.

This tab configures Observer to display actual IPv6 addresses when sensed, rather than their IPv4-compatible representation. This affects all statistical displays that show IP addresses in an IPv6 environment. You can also choose how to represent these addresses.

- **Compressed hexadecimal** represents the address as native IPv6 (i.e. each of the eight 16-bit portions of the address are specified), but with the 0000 portions of the address replaced by double colons (::). For example: FE80::254E:F35D:7DB4:11

- **Not compressed hexadecimal** represents the address as native IPv6 (i.e. each of the eight 16-bit portions of the address are specified), including the 0000 portions. For example: FE80:0000:0000:0000:254E:F35D:7DB4:0011

- **The IPv4 compatible formats** represent the address as x:x:x:x:x:d.d.d.d, where the x’s are the 16-bit left-most portions of the IPv6 address, and the d’s are four 8-bit (IPv4-style) decimal values derived from the last two portions of the 16-bit IPv6 address. An example of the compressed form is FE80::254E:F35D:125.180.0.17. In uncompressed format, it would be FE80:0000:0000:0000:254E:F35D:125.180.0.17

- **Decimal separated** represents the address as 16 decimal octets, for example: 254.128.0.0.0.0.0.0.37.78.243.93.125.180.0.17
Third Party Decoder tab

**Prerequisite:** Observer Expert or Observer Suite

This tab allows you to specify a third party decoder, which can be installed anywhere on the same system as Observer, to use when loading saved packet captures. By enabling this option, a new menu option is available: File > Decode Capture File using Wireshark. Some third party packet analyzers can decode some things that Observer cannot. You can use Observer to capture the traffic and use the third party decoder to analyze it. Additionally, if you want to use a third party decoder to look at the same packet capture and compare the results side-by-side, you can now launch the decoder from within Observer.

<table>
<thead>
<tr>
<th><strong>Assign menu name</strong></th>
<th>Defines the menu option that appears under the File menu. It defaults to &quot;Decode Capture File using Wireshark,&quot; but this menu item can be anything you want.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Executable name</strong></td>
<td>Provide the full path to the third party application you want to use to decode capture files. The decoder must be installed on the same system as Observer, not the probe.</td>
</tr>
<tr>
<td><strong>Command line</strong></td>
<td>Provide any command line options you want to pass to the third party decoder when you are opening the application.</td>
</tr>
<tr>
<td><strong>Capture buffer format</strong></td>
<td>Choose which file format to export your capture to: Observer’s native BFR format or PCAP. See Saving packet captures (page 82).</td>
</tr>
</tbody>
</table>

GeoIP Settings

There may be times when you want to know more about an IP address you are seeing in Observer. Using an external geolocation service, you can more easily find out information such as the IP’s carrier or service provider and the city, state, and country where the IP address is located in the world. This information could be valuable in identifying the source of a security threat, malicious communication, or a simply an incorrectly configured system somewhere in the world impacting your organization.

This tab allows you to define a URL that is called and opened in a web browser. By default the geolocation service of the GeoIP website is used, but you may change this to any geolocation service you wish.

You can look up the geolocation information for an IP address when you are on the Decode and Analysis tab in Observer or when you are on the IP Stations tab in the GigaStor Control Panel. For instance, click the Top Talkers tab, select an IP address, right-click and choose Connect to the Selected Station via GeoIP Lookup.

How to have Observer managed by OMS

If your organization uses OMS and wants Observer to be a managed asset, you must integrate Observer into OMS. Doing so allows functionality like user authentication and authorization, plus software version control.

**Caution:** By following these steps, Observer will be managed by OMS. After the connection is made, you will be unable to disable the management within Observer. Therefore, the only way to remove Observer from being managed is to remove the asset from within OMS.
To change Observer to be managed by OMS:

1. Click the File tab, and click Info > Manage by OMS.
2. In the System Settings pane, click Manage by OMS.
3. Select Manage Asset with OMS.
4. In the OMS Server box, type the IP address or DNS name of the OMS server.
5. Choose the type of license to redeem using the License Type list.
6. Type OMS administrator credentials into the User Name and Password boxes.
   The credentials must have permission to add new assets and/or licenses to OMS (depending on which is needed), or the asset must already be defined and the user must have access to the asset and a license number must be present.
7. Click Manage.

If successful, Observer should now be managed by OMS.

How to show and use older features (Classic Mode)

Starting in version 17.3.0.0, some older features are hidden from view by default. You must turn on Classic Mode to show and use these older Observer features.

Prerequisite(s):
- 17.3.0.0 or higher
- Windows user account that can restart the Observer application
- Preparation for up to one minute of Observer downtime

Tip! Classic Mode is turned off by default.

An updated user interface was introduced in version 17.3.0.0 of Observer. The updated user interface places the most popular features in one area—the Home tab on the ribbon. Some of the older or less popular features were relocated to Classic Mode because of this change.

Turning on Classic Mode reveals a new tab on the ribbon: Classic. This tab provides access to older features.

1. Click the File tab, and click Options > General Options.
2. Ensure you are viewing the General tab, and then scroll down until you see the Startup and runtime settings list.
3. Select Enable Classic Mode in the Startup and runtime settings list.
   A confirmation message appears that says Classic Mode activates after the next restart of the Observer.
4. Restart the Observer application.

You turned on Classic Mode, so the Classic tab now shows on the ribbon.
How to upgrade Observer

New and past versions of Observer software are made available to you directly from VIAVI. Use the Observer upgrade tool to check for, download, or install a version of Observer.

Prerequisite(s):

- Internet access to update.viavisolutions.com (port 80) is required on the system interacting with the VIAVI upgrade repository. This includes checking for upgrades and downloading upgrades.
- Only if your application or appliance is managed by OMS, LAN access to the OMS system over port 8008 (default) is required for downloading upgrades.
- Proxy settings (page 37) can be used if direct Internet access is unavailable.

The Observer upgrade tool allows you to:

- Check the VIAVI upgrade repository for old and new versions of Observer.
- Download any available version of Observer for offline installation.
- Install any available version of Observer without needing to leave the Observer interface.

How to retrieve a list of available Observer versions

A listing of Observer software versions to upgrade or downgrade to is available directly in Observer. Connect to the VIAVI upgrade repository to retrieve the latest listing of available versions.

Note: Interacting with the upgrade repository requires web connectivity over TCP port 80 or 8008 (by default) on the Observer system. This can be achieved with direct connectivity from OMS to the web or by configuring a proxy in the proxy configuration settings of OMS for downloads. The upgrade repository is hosted by VIAVI and no public mirrors are used.

To ensure your product is using the latest code available, always check the in-product update capability even if you have recently installed. It is strongly recommended that all product updates and upgrade are performed using the in-product update methods instead of installing the executable using Windows File Explorer.

To retrieve a list of available versions, click System > Update.

To retrieve a list of available versions:

1. Click the File tab, and click Info > Update Observer.

Observer connects to the upgrade repository and displays the versions available for download. Release notes for each version are available for viewing.

How to download a version of Observer

New or old versions of Observer can be downloaded from the upgrade repository. Observer is not automatically installed after downloading a version.
using this method. Instead, this method is suitable for scheduled installation or installation from Windows Explorer.

**Tip!** It is strongly recommended that you perform product updates using the in-product update method instead of installing with Windows File Explorer.

To download an available version of software for later installation, visit the repository and download any self-extracting setup executable:

1. Click the File tab, and click **Info > Update Observer**.
2. (Optional) Click the check for updates icon.
   - **Example:** (Optional) Doing this ensures all available versions are shown.
3. Select an item by clicking it.
4. Click the download icon.
   - If not previously downloaded, the download begins, and you can view its transfer progress.

You successfully downloaded a software upgrade.

### How to install a version of Observer

Installing a software upgrade downloads the self-extracting setup executable and immediately installs the upgrade.

**Note:** Firmware updates to the capture card are bundled with Observer software upgrades. During installation of an Observer software upgrade, any firmware updates available to your capture card will be applied.

To install a software upgrade:

1. Click the File tab, and click **Info > Update Observer**.
2. Select an item by clicking it.
3. Click the install icon.
   - The download begins, and you can view its transfer progress.
4. After the download completes, the software upgrade begins installing.

You successfully installed the selected software upgrade. A notification appears if any errors occur during the upgrade.

### Upgrade settings

There are several settings that change the behavior of version upgrades.

<table>
<thead>
<tr>
<th>Automatically check for upgrades</th>
<th>If selected, Observer periodically checks for upgrades. Scheduled transfers and installs rely on knowing if new versions exist. If cleared, users must manually check for available upgrades before any scheduled transfers or installs can occur.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show downgrade options</td>
<td>If selected, any available downgrade versions are displayed in the available versions list. It is recommended to leave this cleared (disabled) if downgrading to previous versions is not desirable.</td>
</tr>
</tbody>
</table>
Preferred speed (Kbps)
Sets the preferred maximum transfer speed in kilobits per second.
Use the value '0' to disable this bandwidth restriction.

Use proxy server
If selected, a proxy server is used for downloading upgrade versions.

Type
Sets which type of proxy server to connect to.

Address
The IP address or DNS name of the proxy server.

Port
The port number accepting connections to the proxy server.

Username
Sets the user name expected by the proxy server for authentication.
Leave this box empty if authentication is not required.

Password
Sets the password used to authenticate with the proxy server.
Leave this box empty if authentication is not required.

Edit Download Schedule
Schedules the download of available upgrade versions.
Downloaded versions will not automatically install unless an installation schedule or upgrade policy allows it.

Edit Install Schedule
Schedules the installation of downloaded version upgrades.
This setting affects version upgrades that are downloaded both automatically or manually.

Version numbering
Observer Platform products use a four-field decimal scheme for product versions.

Table 7. Supported Operating Systems

<table>
<thead>
<tr>
<th>Portion of version number</th>
<th>Some defining characteristics ¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>(17.1.3.2) — Major</td>
<td>Requests from product to VIAVI to see if a new version or update exists.</td>
</tr>
<tr>
<td>(17.1.3.2) — Minor</td>
<td>Secure web server traffic, including Understanding GigaStor trace extraction between Apex and GigaStor.</td>
</tr>
<tr>
<td>(17.1.3.2) — Build</td>
<td>Default port for transfer of software upgrades.</td>
</tr>
<tr>
<td>(17.1.3.2) — R&amp;D Use Only</td>
<td>All intra-Observer Platform communication.</td>
</tr>
</tbody>
</table>

¹. These are representative examples only. No development efforts are restricted to just the examples shown.
Chapter 2: Real-Time Statistics

Real-time statistics help you discover network load, utilization rates, and other connection statistics on your network. Real-time statistics tools can be used at any time; a packet capture is not needed.

Monitoring connection statistics

Real-time statistics can aid you in more ways than just determining network health—they can provide information about the connections seen on the network. This section describes several Observer tools to help you oversee how devices are communicating over the network.

Discovering conversations between local devices and the Internet

The Internet Observer tool has three distinct tabs:

- Internet Patrol—Internet Patrol permits you to examine established connections between local devices (e.g. stations) and the greater Internet.
- IP Pairs (Matrix)—Similar to Internet Patrol, the IP Pairs (Matrix) permits you to examine established connections between local devices (e.g. stations) and the greater Internet.
- IP Subprotocols—IP Subprotocols displays network traffic flow categorized by subprotocol, such as HTTP or SMTP.

Each tab of the Internet Observer tool can be customized. Specifically, you can change the layout of the in-focus tab by clicking View and selecting another. To make further customizations to each view, click the Settings button and a window appears.
The Statistics Settings tab of the Internet Observer Settings window is its most important tab. Notably, you can specify a specific TCP or UDP port to observe if desirable, and you can also configure which subprotocols are recognized by clicking Configure IP Application List.

**Note:** Changes made to the Statistics Settings tab are saved and shared by all modes (tabs) of the Internet Observer tool; however, changes made to any layout view (list, pair circle, etc.) are saved and used independently.

**Internet Patrol tab**

Internet Patrol displays MAC address to layer 3 IP address traffic. If the MAC address has an alias assigned, this text will be displayed instead of the true MAC address. Additionally, the IP addresses of the destination sites will be resolved using DNS. This view of your Internet traffic is most appropriate for local network traffic to and from the Internet, and for sites that use DHCP. Since DHCP changes IP addresses frequently, source IP addresses are not useful on DHCP sites for identification.

**IP Subprotocols tab**

IP Subprotocols display layer 3 IP addresses traffic flow broken-down by subprotocol. Subprotocols are defined in the setup dialog. Twenty-four (24) user-defined subprotocols can be created. Other indicates a protocol that did not match the criteria of the twenty-four user-defined protocols.

- To discover conversations between local network devices and the Internet, use the Internet Observer tool.
- On the Home tab, in the Statistics group, click **Internet Observer**.
Configuring the IP application list

Clicking the Configure IP Application List buttons displays the subprotocols and allows you to add a new one, change an existing one, or remove an existing one.

1. To edit or add a protocol, click the **Edit or New** button.
2. The Configure IP Application Ports dialog is displayed.
3. If you are editing a protocol, the protocol you selected on the List of IP SubProtocols will be displayed in the IP Application box. The information in this box is editable.
4. If you are adding a protocol, enter the desired name of the SubProtocol in the box. You can have a total of 24 subprotocols in your list of IP SubProtocols.
5. Choose either Add TCP or Add UDP, and another dialog is displayed that lets you define a port or range of ports for the IP application. The maximum is five ports. A range of ports counts as two ports. In other words, you can define one range and three ports, or two ranges and one port. You cannot assign three ranges.
6. Click **OK** to display the List of IP SubProtocols dialog.

Discovering conversations between local devices

The Pair Statistics tool tracks established connection between local devices. Observer recognizes each of these conversations to be a *station pair*.

Many statistics are kept for each pair, including the packets and bytes in each direction, and the latency for each direction. Latency can further be configured to be ignored after a certain number of milliseconds. Latency configuration will make Observer only track packets that are part of a true conversation flow.

Over a few hours, you will find that almost every station on your segment will have some sort of conversation with every other station. This is why Observer provides the ability to zoom in on a specific conversation on the top of your display. This will make watching one conversation amongst many hundreds much easier. To zoom in, highlight the pair you are interested in and it will be displayed on the top of the Pair dialog.

In Pair Circle view, the thickness of each line represents the amount of data flowing between the stations, and the thickness grows in a logarithmic pattern.

To discover conversations between local network devices:

1. On the Home tab, in the Statistics group, click **Pair Statistics**.
2. Click the **Start** button to activate the tool.
3. (Optional) Click **Settings** for more configuration options.
4. (Optional) To view a different layout, click the **View** button and select another.

Results can be saved in a comma delimited file using **File > Save > Save Data**.

Viewing real-time statistics per device

To view real-time statistics of individual stations, use the Web Observer tool, which focuses on HTTP traffic (port 80)—or all traffic if desired—to and from an individual station.
Prerequisite(s):

Classic mode (page 35) must be enabled.

1. On the Home tab, in the Analysis group, click Web Observer.

2. At least one station must be configured before Web Observer can be activated. To configure a station, click the Settings button and select an address to monitor.

3. Click OK, and click Start to activate.

Web Observer can be configured to show additional individual stations—you are not limited to viewing one station at a time. To view the real-time statistics of individual stations in bulk, simply configure more stations in Web Observer.

To do this, right-click the row of empty tabs near the lower, leftmost portion of the Web Observer window, and select Create Web Window.

Results can be saved in a comma delimited file using File > Save > Save Data.

Viewing a list of protocols seen on the network

The Protocol Distribution tool tracks how data is being distributed across the network. Viewing protocols can give you an idea of which servers and applications are being used and if there are any unknown or misconfigured protocols on your network.

Note: You can have a maximum number of the following for each: 512 for UDP and TCP subprotocols, and 512 for major protocols.

To view a list of protocols seen on the network:


2. Click the Start button to activate the tool.

3. To view a different layout, click the View button and select another or click Settings for more configuration options.

4. Right-click results to navigate to a list of stations using a particular protocol.

Results can be saved in a comma delimited file using File > Save > Save Data.

Viewing wireless access point statistics

The Wireless Access Point Statistics tool shows network traffic passing through any access points visible to the Observer wireless NIC.

Note: Wireless Access Point Statistics is only available using a supported VIAVI wireless driver.

The Access Point Statistics mode shows traffic passing through any Access Points (APs) visible to the Observer wireless NIC.

This mode is an all-purpose tool for maintaining performance and security on a WLAN that uses APs, showing you:

♦ Wireless stations that are connected to an AP
♦ Non-wired stations that they communicate with
Levels of signal strength, quality, data/non-data transfer rates for each station on the access point

AP traffic totals

For example, you can immediately see if there is a station connected to the wrong AP, or if an unauthorized AP has been installed. AP statistics will display whether a station has a problem with quality or range of connection based on the number of reassociations and retransmissions, or whether a station is configured incorrectly based on station poll totals.

There are two Access Point Statistics tabs. The Cumulative tab shows running totals of statistics collected since the mode was started; the Latest/Min/Max tab shows the most recent, the minimum, and the maximum values for access point statistics.

2. Click the **Settings** button.

After completing this task:

Click the tab that you want to use to configure how the pair circle or list appears.

**Monitoring network load**

Network congestion can be caused by numerous factors, and many can affect the network simultaneously. The greatest contributing factor of network congestion is sustained high network load—times when bandwidth is fully allotted.

This section describes several Observer tools for monitoring network load, which may help you find bottlenecks in your network.

**Viewing router utilization statistics**

Router Observer is suitable for searching for failing or over-stressed routers, and it can determine whether the source of demanding packets is incoming or outgoing (or both).

**Prerequisite(s):**

**Classic mode (page 35)** must be enabled.

The Router Observer tool, which allows you to monitor one or more routers’ utilization rates. Observation is done passively; the router is not performing extra work.

1. On the Classic tab, in the Statistics group, click **Router Observer**.

**Figure 5: Setting the known speed of a router**

The top status bar shows router speed and IP address. In Graph view, dials show packets per second, bytes per second, and the current utilization. When you
receive user complaints that the network is slow, check the 1 minute, 1 hour, and total bandwidth utilization averages. You can tell whether a bandwidth problem is temporary or persistent. Each listing also shows values by direction (in or out of the router).

Router Observer can be configured to show additional routers—you are not limited to viewing just one router. So, to view the real-time statistics of routers in bulk, simply configure more routers in Router Observer.

To do this, right-click the row of empty tabs near the lower, leftmost portion of the Router Observer window, and click Create Router Observer Window.

At least one router must be configured before Router Observer can be activated. To configure a router, click the Settings button and select an address to monitor.

Note: Be sure to select the address of a port, on your router, that is visible to Observer. For example, no results are seen by selecting an outside interface, as the MAC address is not visible.

You must specify the router speed before continuing. Type the speed and click OK. Now click Start to activate. As always, you can change your layout by clicking View and selecting something else.

Results can be saved in a comma delimited file using File > Save > Save Data.

Viewing bandwidth utilization

To view real-time bandwidth utilization as seen by a probe instance, choose Utilization > Bandwidth Utilization. This reveals the Bandwidth Utilization tool, which calculates utilization by how many bytes are seen over a one-second interval. If you are monitoring multiple ports (which the tool displays if true), the results are averaged.

The Bandwidth Utilization tool automatically activates. Click the View button to choose a different layout, or click Settings to further customize said layouts.

Note: The Bandwidth Utilization tool is only accurate when the network adapter speed is set correctly in Observer. To do this, choose Options > Selected Probe or SNMP Device Properties, and click the Adapter Speed tab.

Adapter speed is automatically determined by Observer. If necessary, you can manually set the network adapter speed—choose Options > Selected Probe or SNMP Device Properties, and click the Adapter Speed tab.

Changing the network adapter speed only affects Observer’s understanding of the adapter on that probe instance; no actual changes are made to the speed of your network adapter.

Bandwidth utilization is calculated by recording the number of bytes seen by the Observer (or probe) station. By running the mode at different times under typical network load, you can get an idea of what “normal” utilization is for your network. Knowing what is normal for your network is key to understanding any analyzer statistical modes and putting them in context. After you understand and recognize what is normal for your network, you can easily spot the anomalies if and when they occur.
Viewing bandwidth utilization with a filter

Bandwidth Utilization with Filter offers the same features and functionality as the Bandwidth Utilization tool; however, only filtered data appears. If you have multiple filters applied, they are applied with a logical OR expression.

Bandwidth utilization is calculated by recording the number of bytes seen by the Observer (or probe) station. By running the mode at different times under typical network load, you can get an idea of what “normal” utilization is for your network. Knowing what is normal for your network is key to understanding any analyzer statistical modes and putting them in context. After you understand and recognize what is normal for your network, you can easily spot the anomalies if and when they occur.

To view real-time bandwidth utilization as seen by a probe instance and with one or more filters applied:


Wireless Access Point Load Monitor

Shows wireless Access Points utilization rates. Available only when the current probe (or probe instance) is capturing packets from a wireless network interface. Note that for Observer to accurately assess utilization rates, you must enter the correct bandwidth speed in the Settings dialog.

The Wireless Access Points Load Monitor lets you look at an access point in real-time to see its utilization rate. You can create a tab for each access point, allowing you to easily click between them. You can quickly find out if an access point is acting as a bottleneck and, if so, whether the source of the packets clogging the AP are incoming or outgoing (or both). By examining historical information you can tell whether this is a chronic problem, which might indicate the need for a faster connection, or an acute problem, which might indicate a failure of some sort. Observer does this passively; therefore, the Access Point is not affected.

Tip! Right-click any tab at the bottom of the Load Monitor window to select an access point to set up and monitor. You can then view any access point by simply clicking on its tab.

2. Click the Settings button to configure the wireless access point.
3. Select an AP from the list. This list is read from your address/alias list. If no routers are displayed, use Discover Network Names to scan your network and populate the list. See Building an address book automatically (page 59) for more details.
4. In the Access Point speed (Bits/second), type the throughput speed for the wireless device. Typically, assuming theoretical maximums, this will be 300000000 for 802.11n (two-streams), 54000000 for 802.11a/g access points or 11000000 for 802.11b access points.

Dials provide a heads-up immediate display of packets/second, bits/second, and interface utilization.
Viewing the distribution of packet sizes by station

Observer makes it easy to see what protocols are being used on your network, and what devices are using them. The Size Distribution Statistics tool shows stations’ traffic patterns (subject to filter criteria) sortable by packet size.

For example, you can see if printers are sending packets out to non-existent devices or routers are broadcasting in protocols that no other devices understand; these are just two examples of incorrectly configured devices that could be wasting bandwidth on your network.

♦ On the Classic tab, in the Statistics group, click **Size Distribution Statistics**.

You can collapse or expand the tree’s subprotocol branches. The statistics are derived from the raw bytes and utilization percentages for each protocol and subprotocol. Search for any protocols that should not be running on your network, or discover if an expected protocol is generating an unexpected amount of traffic, which may indicate a hardware or configuration problem.

By right-clicking the display, you can jump immediately to a list of stations generating the selected protocol.

Discovering current top talkers on the network

The Top Talkers tool lets you see who is using the most network bandwidth, which can show whether a particular user, station, or application is consuming excessive network bandwidth. View LAN use patterns, detect faulty network hardware, and determine what percentage of the network’s bandwidth potential each system is using, all from one comprehensive window.

Tip! If you are considering implementing a switch, the information gathered by the Top Talkers tool can help divide stations effectively for your switch.

In Observer **top talkers** are defined as stations or devices that process more packets per second than others during an observed period of time.

**Note:** Top talker statistics are relative; for example, an active station may appear especially “chatty” during times when other stations are idle.

To immediately identify the stations using the most bandwidth, sort by %Bytes, which is done by clicking that column heading. You can determine whether systems generating the most traffic are servers (which probably means everything is OK) or user workstations (which could indicate a hardware problem or unauthorized use of a computer).

You can start a packet capture on any of the listed addresses by right-clicking that entry. The right-click menu also allows you to list the protocols generated by the selected station.

To discover current top talkers on the network:

1. On the Home tab, in the Statistics group, click **Top Talkers**.
2. Click **Start** to begin the tool.

Observer displays a tree of protocols and subprotocols seen on your network.
Load testing the network

Sometimes network problems only appear under peak load conditions. Instead of waiting for those conditions to occur naturally, create them yourself by using the Traffic Generator tool. Doing so helps reveal problems in your network.

**Prerequisite(s):**

Classic mode (page 35) must be enabled.

- To use the Traffic Generator tool, you must be using a local probe instance. The probe instance on which you want to generate traffic from cannot be on a remote system.
- The network adapter must be capable of generating sufficient traffic to heavily load the network. For example, a 100 megabit NIC cannot use more than 10% of a 1 Gb network’s bandwidth.

The Traffic Generator tool allows you to load test (stress) your network by generating packets of a certain type and size, at the frequency you specify, sent toward a specific device or device group.

**Caution:** Be careful when generating traffic. Generating too much traffic can slow down the network. This is especially true using the broadcast destination (default), as packets are sent to every switch port of every switch in the broadcast domain. Be aware of what you are doing, and perhaps notify your users of possible downtime.

To use the Traffic Generator tool:

- On the Classic tab, in the Tools group, click **Traffic Generator**.

When generating traffic it is best to view the generated traffic, including results, from a station separate from the Observer station generating the traffic.

**Configuring your load test settings**

The Traffic Generator tool has several options that can be set.

The traffic generator tool is located at **Tools > Traffic Generator**. Several noteworthy settings can be configured directly in the tool, and they are described in Table 8 (page 48).

**Note:** The VIAVI capture cards do not allow the generation of network traffic using this tool.

You can also right-click anywhere in the Generated Packet Header area to reveal the following options:

- Load Packet From File—displays the Load Packet dialog, letting you load a particular packet number from a particular buffer file.
- Save Packet to File—lets you save the currently configured packet to a standard Observer capture file.
- Open Packet in Decode—shows currently formed packet in Observer’s packet capture decode window.
Table 8. Traffic generator settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Packet size</td>
<td>Allows you to define the size of the packets to be generated.</td>
</tr>
<tr>
<td>Allow jumbo frames</td>
<td>Allows packet sizes to be set greater than the conventional maximum of your network type. This change is reflected in the packet size setting. Ensure the network card driver generating the traffic is also configured to support jumbo frames.</td>
</tr>
<tr>
<td>Requested utilization</td>
<td>If selected, the traffic generator attempts to generate packets at a fast enough rate to meet the requested bandwidth utilization. An error is displayed if the requested utilization cannot be fulfilled.</td>
</tr>
<tr>
<td>Generate sequential source MACs</td>
<td>If selected, the tool generates packets with MAC source addresses in a sequence, up to the number of addresses specified. If generating more packets than the number of addresses in the sequence, the traffic generator restarts the address sequence from the beginning. The start of the sequence is defined in the Edit Header dialog’s Source MAC Address field.</td>
</tr>
<tr>
<td>Generate sequential destination MACs</td>
<td>If selected, the tool generates packets with MAC destination addresses in a sequence, up to the number of addresses specified. If generating more packets than the number of addresses in the sequence, the traffic generator restarts the address sequence from the beginning. The start of the sequence is defined in the Edit Header dialog’s Destination MAC Address field.</td>
</tr>
</tbody>
</table>

Viewing utilization history

**Note:** The Utilization History tool ignores any filters applied to the probe instance. This means the utilization shown is not affected by filters, which ensures the utilization history you see is always accurate. Bandwidth Utilization—a separate Observer tool—may serve as a substitute if you need to see utilization that adheres to your probe instance’s filters. For details, see Viewing bandwidth utilization with a filter (page 45).

Results can be saved in a comma delimited file using **File > Save > Save Data**.

To view short-term utilization history of the network, follow the steps. For viewing utilization history over a longer period, we recommend using network trending features instead; see Understanding the Network Trending tool (page 158).

- On the Home tab, in the Statistics group, click **Utilization > Utilization History**.

Click the **View** button to choose a different layout, or click **Settings** to further customize said layouts. Most importantly, changes can be made to the update interval of the graph view. Regardless of the graph view’s update interval, sampling is done each second.

Viewing a summary of network activity

To view a simple summary of current network activity:

- On the Home tab, in the Statistics group, click **Network Summary**.
Checking the health of your network

Network health is difficult to measure and usually relies on your judgment as a network administrator. This section describes several Observer tools to help you make meaningful measurements.

Viewing network errors

The Vital Signs tool gives you a complete snapshot of errors witnessed during current network activity.

The Network Vital Signs tool informs you at a glance as to network error conditions and their severity, with respect to traffic conditions, by combining graphical shapes with specific color codes.

To view network vital signs, like error occurrences:

♦ On the Classic tab, in the Statistics group, click Vital Signs.

Click the View button to choose a different layout, or click Settings to further customize said layouts. Most importantly, changes can be made to the update interval of the graph view and to thresholds of the plot view.

Results can be saved in a comma delimited file using File > Save > Save Data.

If you are using an Ethernet network and are worried that errors may be traversing the network, yet this tool has not detected any, ensure that your NIC’s NDIS driver can indeed recognize errors. To check driver error support, choose Options > Selected Probe or SNMP Device Properties, and click the Parameters tab.

After you are familiar with your network’s “signature,” you will be able to immediately notice spikes in utilization and error activity as they occur. If you see an unusual divergence from the typical Vital Signs signature for your network, you can then use Network Errors by Station to pinpoint the source of the anomaly.

Color codes

♦ Yellow lines anywhere in the display represent an idle condition. In other words, no matter what your display is telling you, activity is so low that the errors are not statistically important.

♦ Green lines show normal network activity and error counts.

♦ Red lines indicate error counts out of normal range.

♦ Red lines are displayed when the following default error counts are encountered. Whenever a red line (i.e. a critical condition) is displayed, all of the formerly green lines turn blue to highlight the network state.

♦ Utilization goes over 35%.
• CRC & packets too small represent more than 25% of the total traffic.
• Packets too big represent over 1% of total traffic.
♦ Gray “shadows” show you an image of the reading taken immediately before the current reading.

About Vital Signs’ broadcasting LLC Exploratory packets
Vital Signs sends exploratory LLC packets when running the collision test. When the collision test option is on, Observer bursts 100 exploratory LLC packets per second, addressed to 00:00:FF:FF:FF, and listens for packet collisions. On a 1 Gb network this uses 0.004% of the network’s bandwidth and significantly less on a 10 Gb network. Collision testing is generally only run when a collision problem is suspected, although it can be run routinely at your discretion. If you turn off Vital Signs, then Observer will be completely passive and not send any LLC packets.

Viewing network errors by device
Network errors can be caused by many factors; hardware failure, slightly incompatible drivers, and even poorly shielded cables may be the culprit.

**Prerequisite(s):**
Classic mode (page 35) must be enabled.

To discover network errors and their originating source:
1. On the Classic tab, in the Statistics group, click **Errors By Station**.
2. Click the **Start** button to activate the tool.
3. Click Settings for more configuration options.
4. Click **View** to select a different layout.

Results can be saved in a comma delimited file using **File > Save > Save Data**.

Searching for wireless interference
The Wireless Site Survey tool displays activity by channels on your wireless network, detailed activity on the WLAN by channel, and allows you to search for wireless (Wi-Fi) interference, including its potential sources.

**Note:** Wireless Site Survey is only available using a supported VIAVI wireless driver.

To use the Wireless Site Survey tool and search for wireless interference:
♦ On the Classic tab, in the Statistics group, click **Wireless Site Survey**.

If you want to scan multiple channels:
♦ You must set the channels to scan in the Probe or Device Properties dialog, 802.11a/b/g/n Settings.
♦ When Observer is scanning wireless channels, the other modes (such as Top Talkers, Access Point Statistics) will no longer be able to present a complete view of the network, as Observer’s data sample is limited to the current channel being scanned. Therefore, you should only use the Site Survey by itself.

See Table 9 (page 51) for a list of noteworthy settings.
Table 9. Wireless interference

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Information Tab</td>
<td>This table summarizes essential information about what access points and stations are currently visible to wireless Observer. The status line at the bottom of the display shows all channels currently being scanned, highlighting each channel as it is looked at. Click Scan Setup to change the list of channels to scan.</td>
</tr>
<tr>
<td>Frame Type Tab</td>
<td>This table summarizes frame type totals for wireless data, management, and control packets.</td>
</tr>
<tr>
<td>Control Frames Tab</td>
<td>This table details control frames analyzed, including Power Save Polls, Requests to Send (RTS), Clear to Send (CTS), acknowledge (ACK), and CF (Contention Free) End packets.</td>
</tr>
<tr>
<td>Management Frames Tab</td>
<td>Displays detailed information about wireless management frames, including association requests and responses, reassociation requests and responses, ATIMs (Announcement Traffic Indication Message), and authentication/de-authentications.</td>
</tr>
<tr>
<td>Data Frames Tab</td>
<td>Displays detailed information about data frames on the wireless network.</td>
</tr>
<tr>
<td>Speeds Tab</td>
<td>Shows what stations are either transmitting (or receiving) wireless data at the various supported rates. To switch between transmitting and receiving speeds, click the down arrow next to the Tx (or Rx) and select the desired setting.</td>
</tr>
<tr>
<td>Signal Tab</td>
<td>Displays detailed statistics on wireless signal strength, quality, and data rates being used by stations and APs.</td>
</tr>
<tr>
<td>Channel Scan Tab</td>
<td>Shows the channel being tracked along with many statistics.</td>
</tr>
</tbody>
</table>

How Observer calculates wireless signal strength

A few of Observer’s wireless analysis modes display a metric labeled “signal strength,” expressed as percentage of the optimum signal strength. Table 10 (page 51) shows how dB measurements are calculated into signal strength percentage.

Table 10. Wireless signal strength

<table>
<thead>
<tr>
<th>Sensed (dB)</th>
<th>Reported (%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1-3 dB</td>
<td>0%</td>
</tr>
<tr>
<td>4-22 dB</td>
<td>1%</td>
</tr>
<tr>
<td>23 dB</td>
<td>5%</td>
</tr>
<tr>
<td>24 dB</td>
<td>10%</td>
</tr>
<tr>
<td>25 dB</td>
<td>12%</td>
</tr>
<tr>
<td>26 dB</td>
<td>14%</td>
</tr>
<tr>
<td>27 dB</td>
<td>16%</td>
</tr>
<tr>
<td>28 dB</td>
<td>18%</td>
</tr>
<tr>
<td>29 dB</td>
<td>20%</td>
</tr>
<tr>
<td>30 dB</td>
<td>22%</td>
</tr>
<tr>
<td>31 dB</td>
<td>24%</td>
</tr>
<tr>
<td>32 dB</td>
<td>26%</td>
</tr>
<tr>
<td>33 dB</td>
<td>28%</td>
</tr>
<tr>
<td>34 dB</td>
<td>30%</td>
</tr>
<tr>
<td>35 dB</td>
<td>34%</td>
</tr>
<tr>
<td>Sensed (dB)</td>
<td>Reported (%)</td>
</tr>
<tr>
<td>------------</td>
<td>--------------</td>
</tr>
<tr>
<td>36 dB</td>
<td>38%</td>
</tr>
<tr>
<td>37 dB</td>
<td>42%</td>
</tr>
<tr>
<td>38 dB</td>
<td>46%</td>
</tr>
<tr>
<td>39 dB</td>
<td>50%</td>
</tr>
<tr>
<td>40 dB</td>
<td>52%</td>
</tr>
<tr>
<td>41 dB</td>
<td>54%</td>
</tr>
<tr>
<td>42 dB</td>
<td>56%</td>
</tr>
<tr>
<td>43 dB</td>
<td>58%</td>
</tr>
<tr>
<td>44 dB</td>
<td>60%</td>
</tr>
<tr>
<td>45 dB</td>
<td>62%</td>
</tr>
<tr>
<td>46 dB</td>
<td>64%</td>
</tr>
<tr>
<td>47 dB</td>
<td>66%</td>
</tr>
<tr>
<td>48 dB</td>
<td>68%</td>
</tr>
<tr>
<td>49 dB</td>
<td>70%</td>
</tr>
<tr>
<td>50 dB</td>
<td>73%</td>
</tr>
<tr>
<td>51 dB</td>
<td>75%</td>
</tr>
<tr>
<td>52 dB</td>
<td>78%</td>
</tr>
<tr>
<td>53 dB</td>
<td>80%</td>
</tr>
<tr>
<td>54 dB</td>
<td>83%</td>
</tr>
<tr>
<td>55 dB</td>
<td>85%</td>
</tr>
<tr>
<td>56 dB</td>
<td>88%</td>
</tr>
<tr>
<td>57 dB</td>
<td>90%</td>
</tr>
<tr>
<td>58 dB</td>
<td>92%</td>
</tr>
<tr>
<td>59 dB</td>
<td>93%</td>
</tr>
<tr>
<td>60 dB</td>
<td>95%</td>
</tr>
<tr>
<td>61 dB</td>
<td>97%</td>
</tr>
<tr>
<td>62 dB</td>
<td>98%</td>
</tr>
<tr>
<td>63 dB</td>
<td>99%</td>
</tr>
<tr>
<td>64-257 dB</td>
<td>100%</td>
</tr>
</tbody>
</table>

**Ethernet errors tracked by Observer**

Observer tracks many Ethernet errors, including alignment errors, CRC errors, collisions, runts, and jabbers.

**Alignment Errors**

Ethernet Alignment errors are detected when a packet is not "aligned" on a phase boundary.

For timing purposes, the network adapter card assembles and sends a "preamble" for Ethernet packets. Then timers on both Ethernet adapters (sending and receiving) synchronize (agree) on phase timing, and calculate a phase position to begin the actual packet. This phase position is used so that the receiving adapter can know when the packet begins, and how the packet should correspond to the actual signal wave.
Alignment errors can be caused by a number of factors. Typically, they are caused by a previous collision. When a collision occurs, either a CRC error or an Alignment error almost always results. In the case of an Alignment error, if the collision occurs during a transmission after the preamble, the position of the resulting signal with respect to the phase of the wave is incorrect. The receiving adapter acknowledges this, and the packet is discarded.

MAC Frame CRC Errors

These CRC errors are the most common, and are what most devices and analyzers are referring to when they claim a CRC error has occurred.

Ethernet packets are encapsulated in a MAC frame that contains a preamble, and a post-envelope CRC check. The Ethernet adapter on the sending station is responsible for creation of the preamble, the insertion of the packet data (addressing, protocol, data, etc.) and then calculating a CRC checksum and inserting this at the end of the packet. The receiving station uses the checksum to make a quick judgment if the packet was received intact. If the checksum is not correct, the packet is assumed to be bogus and is discarded.

MAC frame CRC errors can be caused by a number of factors. Typically they are caused by either faulty cabling, or as the result of a collision. If the cabling connecting an Ethernet Adapter or hub is faulty the electric connection may be on and off many times during a transmission. This “on and off” state can interrupt parts of a transmission, and “damage” the signal.

If a collision happens during packet transmission, the signal for the specific packet will be interrupted, and the resulting received packet will be damaged.

If the signal is interrupted partially during transmission, the CRC checksum that was calculated by the network adapter will no longer be valid and the packet will be flagged as a CRC error and discarded.

CRC errors are common on a busy network, and a small percentage does not reflect a network problem. When the percentage is large, or when a single station shows a larger percent CRC errors there is probably a problem that needs to be addressed.

Protocol CRC Checksums

Some protocols (TCP/IP for example), have a second (in addition to the MAC frame CRC checksum) checksum for data integrity purposes. This checksum is calculated on only a portion of the internal data of each packet, and can give a second and independent check for the validity of the packet’s contents.

Observer calculates this checksum independent of the MAC layer CRC and displays the results in the decode display. These CRC errors are very rare and can be caused by malfunctioning software or protocol drivers.

Collisions

Collisions happen when two Ethernet adapters send a signal on the Ethernet simultaneously. Ethernet networks operate under a principle known as Carrier Sense, Multiple Access with Collision Detection (CSMA/CD).

In a nutshell, this means that a station (prior to sending a packet) listens to the wire for any other traffic (it senses the wire for a carrier), if no other stations are sending, the station may proceed with sending the packet. Otherwise it must wait and repeat the carrier sensing later. During periods of heavy traffic, several stations may be waiting to send data. If two (or more) of these stations
carrier sense at the same time, they may each decide that it is O.K. to send. If this occurs, a collision will result. Depending on the timing this may also cause an Alignment error, a CRC error, both or neither. Collisions also become self-perpetuating. As they begin to occur, bandwidth is wasted, and more stations must wait to use the wire, thus causing more collisions.

Collisions are a natural (at reasonable levels) and acceptable part of any Ethernet network and the busier the network, the more collisions you may see. Collisions are acceptable to a point, but after that collisions can bring your network to a virtual standstill.

Collisions are caused by either a faulty network adapter (the “sensor” is failing), or a congested network segment. If the adapter is faulty, replacement is the only option. For a congested network, segmentation is usually the best option.

**Packets Too Small (Runts)**

The Ethernet specification requires that all packets be at least 64 bytes long. 64 bytes is the total length, including checksum. Any packet on the wire that is less than 64 bytes is considered a “Packet Too Small”. Unfortunately, not all vendors adhere to this rule, and many send valid packets smaller than 64 bytes.

**Packets Too Big (Jabbers)**

The Ethernet specification requires that no packets be larger than 1518 bytes (including checksum). Any packet that is larger than this is flagged as an error and discarded. These packets are also sometimes referred to as “Jabbers”.

Packets too big are almost always caused by faulty hardware. The network adapter card in a station showing a high rate of packets too big should be replaced.

**Watching for packet storms**

Broadcast and multicast storms can greatly slow the network. To watch for impending broadcast or multicast storms, use the Activity Display tool. The Activity Display tool tracks occurrences of broadcast/multicast packets.

**Prerequisite(s):**

Classic mode (page 35) must be enabled.

- On the Classic tab, in the Statistics group, click Activity Display.
- (Optional) Click the View button to choose a different layout.
- (Optional) Click Settings to further customize said layouts.

(Optional) Most importantly, changes can be made to the update interval of the graph view and to thresholds of the plot view.

Results can be saved in a comma delimited file using File > Save > Save Data.

The indicator lines change color for easy viewing of specific network conditions. If an indicator line is yellow, the Activity Display is showing a network condition that is essentially idle (total net utilization is under 5%). Here, the percentage of broadcast or multicast packets may be high compared to actual traffic. However, because the traffic is so low, this condition is not statistically important.

If an indicator line segment is green, the Activity Display is displaying a normal network condition. If an indicator line segment displays red, the Activity Display
is letting you know that a load condition exists. This is not necessarily a problem, but indicates that you should be aware of this condition.

Load conditions can mean different things depending on where the red, blue, or green lines appear. Typically, a red line means that a threshold has been overcome. Blue lines display on the side where the threshold may be an indication of trouble. By default, red lines are displayed if broadcast or multicast packets are representing more than 10% of total network utilization or if utilization goes over 35%.

Understanding Real-time Statistics

In Observer, real-time statistics are gathered by viewing—not capturing or trending—network traffic and incrementing a statistic counter. Statistics are particularly useful for determining network health.

Real-time statistics are fundamentally different from packet captures and network trending. For example, real-time statistics can display the number of errors occurring on your network, the number of established connections, and the bandwidth utilization across the network.

Tip! If you are connected to a Observer GigaStor, you can view statistics in the GigaStor Control Panel

2. Click Start to start the tool.

The tool begins to show the relevant statistics. For Top Talkers, it is a tree of protocols and subprotocols seen on your network.

There are Start, Stop, and Settings buttons for the statistics tool (top). Notice that there are three separate statistics tools running, each with its own tab in the tool tray (bottom). Select the tab of the desired tool to display that statistics window. Recall that by dragging the vertical line between the probe and tool window, the window sizes can be adjusted. Right-click a row to show even more options, like filters or start a packet capture on that station.

Figure 6: Statistics tools

VLAN Statistics  Shows the VLANs operating on your network.
Top Talkers Statistics | Lets you see who is using the most network bandwidth.
---|---
Protocol Distribution Statistics | Displays all protocols running on the network.

Internet Observer | Show what websites users are visiting and how much time was spent on a website.
Internet Patrol | Allows you to view MAC to IP communication as a list, pairs circle, or charts.
Wireless environments | There are several statistics tailored to provide information that is characteristic or unique to wireless networks. Wireless Site Survey and Wireless Access Point Statistics are available only for wireless interfaces and common statistics such as Top Talkers and Vital Signs contain wireless tabs that are only available when monitoring a wireless interface.

**Monitoring your VLAN**

VLANs can be used to contain broadcast traffic, act as a load balancing tool, and enhance data security, but there are some maintenance and troubleshooting challenges. Observer makes it easy to see a breakdown of total traffic (or each station's traffic) by VLANs.

Being able to see VLAN information within the context of other metrics makes it much easier to separate VLAN configuration problems from general network problems, and thus keep your network running smoothly.

The **VLAN Summary** tab lets you focus on VLAN-level statistics by omitting station-level statistics. For example, you can quickly determine if traffic levels on your VLAN have become extraordinarily high and it allows you to assess your overall network performance health.

**VLAN Stations** shows what stations comprise each VLAN, what VLAN(s) a station belongs to, and traffic totals by station or by VLAN. You can think of it as a "top talkers" for VLANs.

If you want to limit packet captures to particular VLANs (or to exclude particular VLANs), you may filter by VLAN header fields for 802.1Q and ISL VLANs when troubleshooting a network on which VLANs are implemented.

Knowing which VLAN has been assigned to a switch port can be indispensable in troubleshooting connection problems. Although you could theoretically keep up-to-date records of VLAN port assignments, in the real world no one ever has time for this housekeeping task. You could also look up the information through the switch’s administrative interface when necessary, but it is much more convenient to have this information available directly from your analyzer. Using an SNMP form query, you can query your switch for VLAN port assignments.

**Viewing optional VLAN statistics**

Depending on your network infrastructure, virtual LANs (VLANs) may exist on your network. If VLANs exist, the VLAN Statistics tool is useful to you.
To view optional VLAN statistics, including a list of seen VLANs and the traffic passing through them:

1. On the Home tab, in the Statistics group, click VLAN.
2. Click the Start button to activate the tool.

Results can be saved in a comma delimited file using File > Save > Save Data.
Chapter 3: Network and Application Discovery

Observer uses application definitions to identify applications and services. Learn the best ways of identifying your network’s servers, clients, and the applications they use, by using discovery tools and the address book.

Building and saving an address book

After your probe instance has adequate visibility of the network, you should take time to discover the devices on your network. Start by building an address book or importing a previously saved one.

To build and save an address book in Observer Analyzer, choose Tools > Discover Network Names. This reveals the Discover Network Names tool, which records all seen network addresses on the segment, stores them in the table, and assigns them names (aliases).

Configuring a discovery method (optional)

Observer discovers network names using two separate methods—IP or Microsoft Network Discovery. Both of these methods have specific configuration options, which can be set by clicking Settings.

The default discovery method, IP, places some additional load on your network during the discovery process. If you want to passively discover the names instead, click the Settings button and choose "Passively discover IP addresses." Passive discovery may take longer than active, but it requires the least amount of network resources.
Building an address book automatically

Typically, you can use the Discover Network Names tool successfully without additional setup. The default method of discovery is IP. In this method, Observer attempts to use ARP to discover all of the addresses in the IP address range given in the IP configuration, and listens for any additional addresses that may show up over time.

Tip! We recommend running the discovery process long enough to ensure the resulting address book is complete—this process can take several hours on larger networks; you may consider running the discovery process overnight when network load is typically lowest.

To build an address book automatically, complete the following steps:

2. Click Start to begin the discovery process.
3. Click Stop to end the discovery process.
4. Click Save Aliases to save your results.

You successfully built an address book, which will help you throughout numerous portions of Observer in the future because other modes and tools rely on it.

Adding entries to the address book manually

If necessary, you can manually add entries to your address book. Here are some common reasons for doing so, followed by instructions:

To build an address book to only contain specific network addresses:
- May help you stay organized (smaller list)
- Only solicits the stations you specify (good neighbor)

To add stations to an existing address book:
- Add network addresses without running another discovery

If the automatic discovery process is prohibited:
- Due to security policies, applicable laws, etc.
- Avoid introducing potential interference to devices within a mission critical environment

To manually add entries to the address book:

2. Click Add Entry. The Add Alias dialog box appears.
3. Select the network address type of the station, and type information into the fields; the first field is always required.

4. Click OK to save your entry in the address book.

You successfully added an address book entry without having to run a full discovery. Remember, you can manually add more entries by repeating this process.

After completing this task:

Typically, DNS names are more meaningful to end-users than IP addresses, so you should resolve them. To do this, click the Resolve IP button. Observer then attempts to resolve the DNS name of each entry in the address book.

Resolving DNS names

After building an address book, consider resolving the DNS names of the collected IP addresses. Typically, DNS names are more meaningful to end-users than IP addresses, so you should resolve them.

To do this, click the Resolve IP button. Observer then attempts to resolve the DNS name of each entry in the address book.

Having trouble resolving DNS names in other portions of the Observer software? Check any of the following:

- Save your address book after resolving DNS names as described above, and see if this resolves your problem.
- Ensure the option for resolving DNS names is enabled. Choose Options > General Options. Then, in the General tab, ensure Disable IP Address DNS Resolution is not selected.
- Remember that DNS names in the decode views are resolved by the Observer analyzer viewing the decode. Loading a saved packet capture might return different DNS names than originally seen, but this occurs because the IP addresses have changed since that time.
Saving the address book

To save the address book:

1. On the Home tab, in the Tools group, click **Discover Names**.
2. Run the tool, and click **Save Aliases**.

This saves all address book entries in an internal file, which Observer references frequently in the application.

Because the address book is used internally by Observer, you cannot specify a custom file name from this location. Instead, click the **File** tab, and select **Options > Address Table** to create a new, empty address book that you can name and switch between at any time (local Observer only).

Editing address book entries

**Prerequisite(s):**

You have completed Building and saving an address book (page 58).

To edit address book entries in Observer:

1. On the Home tab, in the Tools group, click **Discover Names**.
2. Select an entry from the list, and click **Edit Entry**.
3. Edit the address book entry.
4. Click **Save Aliases** to save your changes.

Importing a previously saved address book

If you have access to a previously saved address book (file extensions *.ADR; *.ADR11; *.ALI) and would like to import it as your address book, complete the following steps:

1. On the Home tab, in the Tools group, click **Discover Names**.
2. Click the **Import Aliases** button.
3. Follow the on-screen instructions that appear.

After completing this task:

If you own multiple Observer licenses/installations, consider building an address book on one machine and then securely distribute it to other machines for importing. This can save you time and effort.

Tell me more about importing a previously saved address book

The format of address entries in an .ali file is:

```
MACaddress, IP, alias
```

where **MACaddress** is the MAC address, **IP** is the Internet Protocol dot address, and **alias** is the alias by which you want the system to be known. Note that entries are separated by commas. If you want to specify a MAC Address/Alias pair without an IP, the format is:

```
MACaddress, , alias
```
Note the two commas separated by a space. You can specify the MAC address with or without colons, as long as the format is consistent within the .ali file. Leading zeros are allowed but not required. For example

00:00:C0:87:49:45, 168.0.0.1, router1 00:00:C0:13:4B:33, 223.188.11.3, Sue’s Accounting PC
-or-
00:00:C0:13:4B:33, 223.188.11.3, Sue’s Accounting PC

The alias can be no longer than 17 characters.
The Replace aliases with newly discovered name option will replace any existing MAC address/alias pairs in the Address Table with the entry found in the .ali file. If this option is left unchecked, any pair of existing MAC address/alias entries are not overwritten. Existing IP address and comment fields are never overwritten by the Import Aliases action.

Using multiple address books
Multiple address books are supported to allow the saving and reuse of different address/alias lists (e.g., for multiple sites). The default address table, LocalAddressTable.adr, is stored in the LocalAddressTable directory under the Observer installation directory.

To switch to a different address book, complete the following steps:

1. Click the File tab, and click Options > Address Table.
2. Select the address book you want to use, and click OK.

You are now using the selected address book, and you can repeat the process to switch again.

Discovery
Mapping your network is important, and it should be completed as thoroughly as possible to ensure Observer has visibility of the full network (or your chosen portion of it). This section describes discovery tools for mapping your network.

Discovering server applications on the network

Tip! Typically, the Server Application Discovery tool is used only when needed; running the discovery continuously provides little benefit over running it on demand. For example, many users run the Server Application Discovery tool only long enough to discover a set of applications that they want to interact with using the right-click menu.

To fully understand Observer’s application discovery method, and how to modify it, we recommend you review this entire section.

Using the Server Application Discovery tool, Observer can automatically analyze network traffic and identify servers and applications, along with the ports being used. Observer then reports how confident it feels each discovery is using a color legend seen along the bottom of the window.

To discover server applications running on the network, complete the following steps:
Tip! To save time, you can import and export your protocol definitions. Choose Options > Protocol Definitions and Server Application Discovery > Tools and select the option you want. If you use Observer Management Server (OMS), you can have OMS collect and publish your protocol definitions. The setting to enable is at Options > Observer General Options > Security > Synchronize user protocol definitions through OMS.

1. Click the File tab, and click Options > Protocol Definitions.

2. (Optional) If you have applications that use non-standard ports or you want to specify a range of IP addresses, click Settings to modify the settings before starting the server discovery process.

3. Click the Server Application Discovery tab. This screen is where the discovery occurs.

4. Click the Start button to begin discovering applications. Clicking any of the Protocol or Application Definitions tabs cause the search to automatically stop. You will need to restart the search.

Wait patiently for the discovery process to begin showing results; this may take some time because the tool acts passively—results are collected and not "grabbed". Results appear in the manner shown in Figure 8 (page 63).

You successfully discovered server applications seen on the network. Right-click any result to perform additional functions such as adding the server directly to the Network Trending tool. Remember, you can repeat the server application discovery process at any time for any reason.

Discovering SNMP devices

Note: Some SNMP devices on your network may not adhere to RFC1213, causing them to remain undiscoverable even when your other settings are configured correctly. If you suspect this is occurring—or you want to discover SNMP devices that react to a very specific MIB—change the assigned device type to something more fitting (option seen in the lower-right of Figure 9 (page 64)). You may need to experiment with this setting if you are unsure of what to choose. Remember that RFC1213 is default.

We highly recommend allowing Observer to communicate with Simple Network Management Protocol (SNMP) enabled devices on your network. To do so, you
must attempt to discover those devices automatically or add them manually. Observer SNMP functionality is only available with an Observer Suite license.

**Note:** This section only describes the process for automatic SNMP device discovery; to add SNMP devices manually (and perhaps with greater success than automatically) see Introduction to SNMP (page 195).

Before SNMP devices can be discovered, the IP discovery ranges must be configured. An error message is shown if you try discovering before the discovery ranges are configured.

Set the IP address discovery ranges by completing the following:

1. On the Home tab, in the Tools group, click **SNMP > Device Discovery**.
2. Click the **Settings** button. The SNMP Device Discovery window appears.

![Figure 9: Configure SNMP IP discovery ranges](image)

3. In the IP Ranges area, click Add to specify the IP discovery range. Repeat as necessary until all your IP discovery ranges are set.
4. In the SNMP Credentials area, click Add to configure an SNMP credential. Repeat as necessary until all of your possible SNMP credentials are listed.

The purpose of step 4 is to ensure the SNMP devices return a discovery handshake. Without providing credentials, SNMP devices may not react to your discovery attempts—overlooking devices that might otherwise have been discovered.

5. Click **OK** to save your changes. SNMP device discovery is now configured and discovery can be attempted.
6. Click **Start** to begin the discovery process.
7. As SNMP devices are discovered, select one from the list and click Add to SNMP Devices.

The SNMP devices you add are now recognized by Observer.
Discovering which devices are connected to a switch

Use the Switch Station Locator tool to show the MAC addresses of devices connected to switches on the network; in this way, you can determine which stations are connected to a network switch.

**Prerequisite(s):**

Classic mode (page 35) must be enabled.

**Prerequisite:** Observer Suite

This tool strictly uses SNMP queries to function, and requires an Observer Suite license.

This tool is well-suited for responding to complaints about network slowdowns, as you can use the Switch Station Locator to immediately narrow down the problem to a particular switch. You can then query the switch to find out if a particular port is generating a lot of errors. This in turn might cause you to be suspicious of a server connected to that port, in which case you can retrieve the server's SNMP statistics to see if there is a problem with that system.

**Note:** During step 3, you can optionally associate your new switch with a probe instance, allowing the Switch Station Locator tool to use its corresponding address book. Do this by choosing a probe instance from the list. See Building and saving an address book (page 58) for more information about address books in general.
1. On the Classic tab, in the Tools group, click **Switch Station Locator**.

2. Do one of the following:
   - If your switch station list is empty—click New Switch, and proceed directly to step 3 of these instructions.
   - If your switch station list is populated—proceed directly to step 5 of these instructions.

3. Type the details of your switch, or choose an existing SNMP device.

4. Click **OK** to save your new switch.

5. Double-click the switch you want to query.
   
   The tool polls the switch and populates the list with connected stations.

6. (Optional) Click the **Settings** button. If you want all seen stations to be indefinitely remembered, choose that option.
   
   Otherwise, if you only want currently connected stations to appear in the list (default behavior) keep that option enabled.

7. (Optional) Save your populated list by click **File** and **Save > Save Data**.
Calculating subnet masks

The IP Subnet Mask Calculator tool calculates the network address, the host address and the broadcast address for a given TCP/IP address and subnet mask. It will also tell you the number of available addresses in the network, displaying the first, last, and next addresses given the parameters entered.

Prerequisite(s):
Classic mode (page 35) must be enabled.

To use the IP Subnet Mask Calculator tool:

♦ On the Classic tab, in the Tools group, click **IP Calculator**.

Only the top of the dialog is editable; the rest of the fields are determined by what you select in the first three controls. After making any changes, click Calculate to see the results. Click close when you are done.

♦ IP Address: Enter the IP address for which you want to calculate subnet parameters.

♦ Subnet Mask: Select the subnet mask for the network you are calculating parameters for. Depending on whether you have selected Show all masks or Show class-specific masks, the number of masks available on the drop-down menu will change.

♦ Show class-specific masks: This choice lets you limit the mask selection drop-down menu to show only those masks valid for the current class of address. The first octet of the IP address defines the address class.

♦ Show all masks: This choice expands the mask selection drop-down menu to include all subnet masks, including those masks that are not compatible with the current class. Address class is defined by the first octet of the IP address.

Performing ping and trace route

Observer’s Ping/Trace Route tool permits the user to see if specific stations on an IP network are active and to trace a route from the Observer (or probe) PC to a selected station.

Prerequisite(s):
Classic mode (page 35) must be enabled.

To use the Ping/Trace Route tool:

♦ On the Classic tab, in the Tools group, click **Ping/Trace Route**.

See Table 11 (page 67) for more information.

Table 11. Ping/Trace Route options

<table>
<thead>
<tr>
<th>Internet Address</th>
<th>Allows you to specify the Internet address to ping, or the address to which the route will be traced.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save button</td>
<td>Allows you to save the present Internet address.</td>
</tr>
<tr>
<td>Delete button</td>
<td>Selecting an address in the saved addresses box and clicking this button allows you to delete the address from the saved addresses.</td>
</tr>
</tbody>
</table>
How to add application definitions

The Server Application Discovery tool is pre-loaded with popular application definitions, ensuring most of the server applications you discover are recognized by Observer. There are cases, however, when adding more application definitions to the stock set is desirable.

To add more application definitions for the Server Application Discovery tool to use, complete the following steps or see Adding derived application definitions (page 71) for details about creating definitions for applications that are subsets of another application:

1. Click the File tab, and click Options > Protocol Definitions.
2. Click the applications definitions tab you want to add to (below the Start and Stop buttons).
3. Click Add Application. The Add Application window appears.

Figure 11: Add an application from the list or define a custom application.
4. Select an application from the list, and click **Add**. If your application is not in the list, click **Custom** to create your own.

5. In the **Add Application Definition** dialog that appears, ensure these details are correct, (or type application details if you chose Custom), and click **OK**.

6. Click **Apply Changes**.

   Choices are displayed that allow you to set the scope of your changes.

7. Choose one of the following:
   - Apply changes to this Probe Instance only
   - Apply changes across all Probe Instances

   **Apply changes across all Probe Instances** only applies changes to currently connected probes instances. The changes cannot apply to disconnected probe instances.

Your new application now appears in the list of application definitions.

### How to associate non-standard ports with an application

Some applications running on the network may be using a non-standard port. If you are aware of these exceptions and want to add the port to an application’s definition, you can do so.

The benefit of is that you do not need to wait for the Server Application Discovery tool to see something that you already know exists.

For example, the standard server port for MySQL is 3306. But you configured your MySQL server to use 63245 instead—a non-standard port. You must therefore associate port 63245 with the MySQL application definition so that it can be reported with greater ease in Server Application Discovery.

To associate non-standard ports with an application definition, complete the following steps:

1. Click the File tab, and click **Options > Protocol Definitions**.
2. Click an applications definitions tab that interests you (seen below the Start and Stop buttons).
3. Scroll through the list of application definitions, and find one that you want to associate non-standard ports with.
4. Click the application definition to select it.
5. Click **Add Ports**.

   The **Add Application Definition** dialog appears.

6. Type the port number, or port range, to associate with the selected application.
7. Click **OK** to confirm your changes.
8. Click **Apply Changes**.

You successfully associated a non-standard port with an application. You can repeat this process for any application definition at any time.

Observer is intelligent enough to not require you to complete these steps—it will discover items regardless—but your manual entry adds meaningful intelligence to your tool set and may aid you in the future.
Using the MySQL example, you would select the TCP Application Definitions tab, scroll down the list, select MySQL, click Add Ports, type 63245, click OK, and finally click **Apply Changes**. The software now recognizes activity on port 63245 as potentially being MySQL.

### Sharing application definitions with others

Application definitions can be shared using the included import and export functions. Sharing is useful for making your application definitions uniform across multiple installations, and it can even be used as a backup tool.

### How to import application definitions

<table>
<thead>
<tr>
<th>Prerequisite(s):</th>
</tr>
</thead>
<tbody>
<tr>
<td>To import application definitions, you need access to an exported *.protodefs file. See [How to export application definitions](page 71) for details.</td>
</tr>
</tbody>
</table>

To import application definitions, follow the import process:

1. Click the File tab, and click **Options > Protocol Definitions**.
2. Click any one of the applications definitions tabs (not the Server Application Discovery tab itself) to ensure one of these tabs has focus.
3. Click **Tools**, and click **Import Application Definitions**.
   
   The **Open file** dialog appears.
4. Locate and select the *.protodefs file that you want to import, and click **Open**.

   Figure 12: The final importing dialog

   ![Import Application Definitions dialog](image)

   The **Import Application Definitions** dialog appears.

5. Select the protocols to import and the importing behavior.

You successfully imported application definitions. The definitions you import are now part of your local collection.
How to export application definitions

To share application definitions with other users, you must first save them to a file.

Create your file by following this export process:

1. Click the File tab, and click **Options > Protocol Definitions**.
2. Click any one of the applications definitions tabs (not the Server Application Discovery tab itself) to ensure one of these tabs has focus.
3. Click **Tools**, and click **Export Current Application Definitions**.
   The **Export Application Definitions** dialog appears.
4. Select the groups of definitions you want to export, and click **Export**.
5. Type a name for your file, and click **Save**.
   You successfully exported your application definitions to a *.protodefs file.

You can now share this file with other users and installations, or keep it as a backup copy.

Adding derived application definitions

Creating a derived application definition allows Observer to take one large application that may have many sub-applications within it and identify each of the sub-applications.

For instance, Java traffic can be identified within HTTP. After Observer identifies the derived application, it appears on your reports and elsewhere within Observer as its own application. The Decode tab is unaffected though. The derived application decodes as part of its parent’s application type. In our Java example, all Java traffic is viewable on the Decode tab as part of HTTP.

To add a derived application definition for the Server Application Discovery tool to use, complete the following steps:

1. Click the File tab, and click **Options > Protocol Definitions**.
2. Click the applications definitions tab you want to add to (below the Start and Stop buttons).
3. Click **Add Derived Application**.
   The **Add Derived Application** window appears.
4. Type a name for the derived application (this name will appear in reports and throughout Observer) and choose from which application it stems.
   The **Add Application Definition** window appears.
5. Specify the port or port range and optional IP address on which the application is found, and click **OK**.

Your new derived application now appears in the list of application definitions. Most importantly, the new application is discoverable using the Server Application Discovery tool and, if the application is seen, it is recognized correctly by Observer.
Enabling or disabling applications that use dynamic ports

When run, the Server Application Discovery tool automatically recognizes applications (if any are seen) that are known to use dynamic ports; they appear light blue in your discovery results. These applications are flagged by the Observer software as being dynamic, and this designation cannot be changed.

You can, however, enable or disable dynamic port discovery for each application known by Observer to use dynamic ports by completing the following steps:

1. Click the File tab, and click Options > Protocol Definitions.
2. Click a protocol/applications definitions tab that interests you (seen below the Start and Stop buttons).
3. Scroll through the list of application definitions, and find a dynamic port application.
   Dynamic port applications always display the string (dynamic - enabled) or (dynamic - disabled) in the ports column of the table.
4. Right-click a dynamic port application, and click Enable/Disable Dynamic Discovery.

![Figure 13: Enabling or disabling a dynamic port application](image)

Defining applications differently per IP address

Sometimes, you may want to treat server application definitions differently depending on the IP address that is discovered in tandem with the port(s).

For example, if you know an FTP server is hosted on 192.168.0.90 on port 63245 (a non-standard port), you could force Server Application Discovery to report all server application discoveries that use port 63245 as FTP—but only if it is destined to 192.168.0.90. This specific rule does not apply to other IP addresses; meaning, the standard port of 21 is recognized as FTP for all other IP addresses.

To define application definitions differently depending on the IP address seen, complete the following steps:

1. Click the File tab, and click Options > Protocol Definitions.
2. Click an applications definitions tab that interests you.
   Application definition tabs are located below Start and Stop.
3. Scroll through the list of application definitions, and find one that you want to associate non-standard ports with per IP address.
4. Click an application definition to select it.
5. Click Add Ports.
6. Type the port number or port range to be associated with the selected application.
7. Select **Use Specific IP Address**, and type the IP address you want to treat differently.
8. Click **OK**.
9. Click **Apply Changes**.

Now, as server applications are discovered, those matching an IP address and port combination are correctly recognized by the Server Application Discovery tool.

Figure 14: A completed example of FTP ports being recognized differently per IP address

---

### Restoring the default application list

Under certain circumstances, it may be beneficial for you to restore the default application list. Doing so removes *all* of your custom or modified application definitions and returns your applications to default—exactly how the default installation would behave.

### How to restore TCP application definitions

To restore the default TCP applications, complete the following steps:

1. Click the File tab, and click **Options > Protocol Definitions**.
2. Click the **TCP Application Definitions** tab to ensure it has focus.
3. Click the **Tools** button, and click **Restore Predefined TCP Applications**. A confirmation prompt appears.
4. Click **OK** to confirm.
5. (Optional) Select **Apply Changes Across All Probe Instances** if you want to apply these changes to all probe instances.

**Apply changes across all Probe Instances** only applies changes to currently connected probes instances. The changes cannot apply to disconnected probe instances.

6. Click **OK** to apply and save your changes.

Your TCP application definitions list is now restored.
How to restore UDP application definitions

To restore the default UDP applications, complete the following steps:

1. Click the File tab, and click Options > Protocol Definitions.
2. Click the UDP Application Definitions tab to ensure it has focus.
3. Click the Tools button, and click Restore Predefined UDP Applications. A confirmation prompt appears. Click OK to confirm.
4. (Optional) Select Apply Changes Across All Probe Instances if you want to apply these changes to all probe instances.

   **Apply changes across all Probe Instances** only applies changes to currently connected probes instances. The changes cannot apply to disconnected probe instances.
5. Click OK to apply and save your changes.

Your list is restored.
Chapter 4: Packet Captures

Capturing network traffic is the primary purpose of Observer. Network packets can be captured, merged, and saved to several file formats, plus the buffer settings can be tweaked for performance.

How to configure the capture buffer settings

Observer can perform packet captures without additional setup. However, to maximize Observer performance, you should consider configuring your capture settings manually.

During the creation of your probe instance(s), you set the size of your buffers. The capture buffer is used to store raw data captured from the network before it is written to disk, and the statistical buffer stores statistical data entries (example buffer change shown in Figure 15 (page 76)).

Note: All packets seen by the capture card interface are time-stamped immediately, then are passed to the capture buffer. This ensures the most accurate time stamp.

Experimenting with buffer sizes is encouraged; it may take some time to find a balance between how large or small your buffer sizes should be for a probe instance, and it depends greatly on how the probe instance is used. Try finding the best balance between what the probe instance needs to operate efficiently and how much RAM a fully-maxed buffer would leave for other services to use.

The default settings for the statistical buffer work perfectly well for most installations—change them if they do not. The packet capture buffer, however, typically needs increasing or decreasing to best reflect your system.
To change the buffer sizes of probe instances, complete the following:

1. On the Home tab, in the Probe group, click **Setup > Memory and Security Administration**.

2. Double-click the probe instance you want to configure.

3. Change the buffer sizes to better match the needs of your chosen probe instance.

4. (Optional) Select a statistics memory configuration from the list. (Optional) These choices affect the maximum number of entries per statistic tracked in real-time statistic modes. A larger choice allows more statistical entries to be held in non-reserved system memory (RAM available to Windows) than its preceding, smaller choice. The size shown is the maximum memory allowed to be used for this purpose—the memory footprint can grow up to this size but never greater. The memory used here follows FIFO rules (first-in, first-out), meaning if the limit is reached, the oldest data is discarded as the newest data arrives. Remember, this setting only affects real-time statistics modes only, and any statistics modes running will continue to fill up to your chosen limit for however long your real-time statistics tools are running. This is because the memory is not flushed until all statistical mode windows are closed.

5. (Optional) Select a trending memory configuration from the list. (Optional) These choices affect the maximum number of entries per statistic tracked in network trending during a 1-minute collection interval. One IP pair would be an example of one entry. The size shown is the maximum memory allowed to be used for this purpose—the memory footprint can grow up to
How to configure the capture buffer settings

this size but never greater. The memory used here follows FIFO rules (first-in, first-out), meaning if the limit is reached, the oldest data is discarded as the newest data arrives.

6. Click OK twice to confirm and save your changes.

You successfully changed the buffer sizes of a chosen probe instance. In the future, you may need to re-evaluate your buffer sizes using the same process; this is especially true after adding or removing memory from your system or after adding new probe instances.

How to adjust the statistical buffer

There are two kinds of buffers that a probe instance uses to store data in real-time: a capture buffer and a statistical buffer. The capture buffer stores raw data captured from the network; the statistical buffer stores statistical entries and nothing more. This section is only concerned with statistical buffers.

The default statistics memory configuration Medium - (default) is sufficient for most users and does not need to be changed. The memory settings are preconfigured based on network size. Each individual statistic is collected as a table entry in non-reserved system RAM, where the processed data is stored. Choose the relative size of the network you are monitoring with this probe instance.

1. To view and manage memory allocation for probe instances, click the Memory Management tab to display the list of instances and their buffer sizes.

   Note: When allocating memory for a probe instance with a capture card as the chosen adapter, at least 80 MB of memory must be allocated to both the capture buffer and statistics queue buffers. Failure to do so will result in the inability to capture data.

2. Right click any instance and select Configure Memory to access the memory allocation dialog.
3. Choose the size of network you are monitoring with this probe instance.
4. Click **OK**.

**Configuring the packet capture options**

There are many ways to configure how your network traffic is captured. To alter the most basic of these settings, first choose one of the following tasks you want to complete:

- Excluding non-native packets from capture
- Configuring a circular capture buffer
- Configuring Observer to capture partial packets
Excluding non-native packets from capture

By default, non-native packets—called expert information packets—are automatically added to your captures by Observer. These packets serve as reference points, time-stamping important network events and utilization rates in your captures. These packets help network administrators understand the context of the captures they share.

If you do not find expert information packets useful, disable them by completing the following steps:

1. On the Home tab, in the Capture group, click Configuration > Packet Capture.
2. Click the Settings button. The Packet Capture Settings window appears.
3. Ensure the Capture Options tab is selected.
4. Disable any or all settings in the Include Expert Information Packets area.

The disabled settings exclude the corresponding expert information packets from entering your future captures.

What are Expert Information Packets? Can I disable them? Do I need them?

When viewing a decode captured from an Expert Observer or Observer Suite, the capture contains Expert Information Packets.

What are Expert Information Packets?

Expert Information Packets are packets inserted into a capture to assist the Expert engine within Observer while processing packets. There are three types of Expert Information Packets:

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Load</td>
<td>These packets are inserted every second into the capture. They include information about the number of packets and bytes seen during the previous second, along with the utilization seen. These figures are used while drawing the graph seen on the Network Load tab within the Expert screen.</td>
</tr>
<tr>
<td>Start/Stop Packet Capture</td>
<td>These packets are inserted whenever you click Start or Stop from either the Packet Capture or Decode Screen. They are used to help expert know that there are gaps of time between packets.</td>
</tr>
<tr>
<td>Wireless Channel Change</td>
<td>These packets are inserted when monitoring a wireless network adapter. They are inserted only if you are using the Channel Scan option. Each time Observer begins monitoring a new channel while in the Channel Scan mode, a new packet is inserted with the current channel being monitored.</td>
</tr>
</tbody>
</table>

Can I disable them?

Yes. These packets can each be disabled from within Packet Capture. From the Packet Capture screen, click **Settings**. (GigaStor users, can modify these settings...
from GigaStor). Clear those boxes beside the Expert Information Packets you do not want to have generated.

**Do I need them?**

Expert Information packets are not required for the Expert to work. The following describes the behavior you will see if these packets are disabled.

(Disabling Expert Load Packets) – Disabling these packets will cause Expert to draw the Summary graph based solely on those packets within the capture buffer. As an example assume 20,000 packets were seen during a one second period, also that there was 10,240,000 bytes and 10% utilization. With these packets enabled Expert would graph 20,000 packets and 10% utilization.

Now assume during this one second you used a filter and captured only five packets during that second, with these packets Observer would graph 20,000 packets and 10% utilization. If you had disabled the Network Load Packets, Observer would graph five packets and 0% utilization.

(Disabling Start/Stop Packet Capture) – Disabling these packets can cause Observer to produce invalid response times to packets seen as Observer does not know that the capture was stopped. It only sees gaps within a sequence of the data stream and assumes that the data was not sent or dropped and will, in the case of VoIP packet loss within calls, register calls that have not actually occurred.

(Disabling Wireless Channel Change) – When Expert is processing Wireless data, we need to understand when the adapter is looking at a different channel then when a packet in a conversation was originally seen. This allows Observer to know that though Expert was looking at a conversation on Channel 5, that the next set of packets is now looking at channel 6 or 7 and so on. This prevents Observer from believing data is missing from a conversation due to packets not being captured. If you disable these packets while using the Channel Scan option, your response times and other calculations within the Expert System may not be accurate.

**Configuring a circular capture buffer**

Circular buffer is an optional buffer type that, as the packet capture buffer fills, writes new packets to the end of the buffer and discards packets from the start of the buffer (i.e. first in, first out). This allows you to continually run a packet capture, as the buffer recycles itself.

To configure a circular capture buffer, complete the following steps:

1. On the Home tab, in the Capture group, click **Configuration > Packet Capture**.
2. Click the **Settings** button. The Packet Capture Settings window appears.
3. Ensure the Capture Options tab is selected.
4. Enable the Use Circular Packet Buffer setting.
   
   A circular buffer also allows you to save the packet capture buffer to multiple, sequentially labeled files instead of overwriting a circular capture file. Some of the next steps describe how to enable that functionality.

5. (Optional) Enable the Save Captured Packets to a File setting; type the maximum amount of disk space to be used for this purpose.

By design, as a circular capture buffer is filled/capped, the oldest packets are discarded to make room for the new, incoming packets. If, however, you want
to save those oldest packets from being discarded, this option allows you to do so.

6. (Optional) Enable the Create Multiple Sequential Files setting; type the maximum number of files to create this way.

This option causes Observer to write out a sequence of files rather than overwriting the file each time the buffer fills up.

7. Click OK to confirm and save your changes.

**Configuring Observer to capture partial packets**

By default, Observer captures each packet in its entirety. Under certain circumstances, however, you may want to configure Observer to capture a smaller portion of each packet. Such circumstances may include, but are not limited to:

- If you have trouble capturing or processing bandwidth spikes
- If you are interested in capturing packet headers only
- To extend the length of capture time before the buffer is full

To configure Observer to capture partial packets, instead of full packets, complete the following steps:

> Note: The partial packet capture setting affects all Observer consoles that connect to this probe instance. You cannot change this setting unless you have administrative privileges to do so. See Configuring user accounts for secure access (page 150).

1. On the Home tab, in the Capture group, click **Configuration > Packet Capture**.
2. Click the **Settings** button. The Packet Capture Settings window appears.
3. Ensure the Capture Options tab is selected.
4. Enable the Capture Partial Packets setting. For now, leave the default number of bytes unchanged.
5. (Optional) Click Change Size to increase or decrease the number of bytes to be captured per packet—starting at the beginning of the header. Also, to password protect this field, see Password protecting the ability to change partial packet capture size (page 151).
6. Click **OK** to confirm and save your changes.

**Packet Captures**

The ability to capture network traffic as it flows through the network is invaluable. This section describes how to perform packet captures, including advanced pre-filtering techniques and other settings.

Packet captures are fundamentally different from real-time statistics and network trending.
Saving packet captures

A packet capture is most useful after saving it to disk. This is because a saved packet capture can be re-opened, shared, or even converted to other file formats for analysis in third-party applications.

The available file formats you can save to depend on the network topology of the captured traffic—although Observer’s native BFR format can be saved to regardless of topology. Observer can save packet captures to any of the formats listed in Table 12 (page 82).

Except for XML, Observer can load all of the files formats that it can save to, plus the DMP format. To load packet captures, see Decoding network traffic (page 103) and the loadable file formats (page 104) of Observer.

After starting a packet capture—described in Capturing network traffic (page 84)—save the packet capture:

♦ Click the File tab, and click **Save > Save Capture**.

**Tip!** You can also press **CTRL+S** on the keyboard to save.

You can now choose which packets to save (all packets since the capture began are chosen by default) and in which file format.

Table 12. Save Capture Buffer options

<table>
<thead>
<tr>
<th>File format</th>
<th>Supported topologies</th>
<th>Limitations and other information</th>
</tr>
</thead>
<tbody>
<tr>
<td>BFR</td>
<td>Ethernet and Wireless</td>
<td>BFR can only be read in Observer and Wireshark. Retains both nanosecond resolution and expert information packets. Only BFR captures can be merged directly in Observer.</td>
</tr>
<tr>
<td>PCAPNG</td>
<td>Ethernet and Wireless</td>
<td>PCAPNG retains both nanosecond resolution and expert information packets.</td>
</tr>
<tr>
<td>PCAP</td>
<td>Ethernet and Wireless</td>
<td>PCAP retains nanosecond resolution, but loses expert information packets.</td>
</tr>
<tr>
<td>CAP</td>
<td>Ethernet</td>
<td>CAP loses nanosecond resolution and expert information packets.</td>
</tr>
<tr>
<td>ENC</td>
<td>Ethernet</td>
<td>ENC loses nanosecond resolution and expert information packets.</td>
</tr>
<tr>
<td>XML¹</td>
<td>Ethernet</td>
<td>XML loses nanosecond resolution, but retains expert information packets. Limited in usefulness.</td>
</tr>
</tbody>
</table>

¹. XML formatted packet captures cannot be re-opened by Observer.

♦ Saving to any format other than Observer’s native BFR format or PCAPNG removes all expert information packets from the resulting saved packet
capture. For more information about expert information packets, see Excluding non-native packets from capture (page 79).

- Saving to any format other than Observer's native BFR format, or the PCAPNG or PCAP formats, removes all nanosecond resolution from the resulting saved packet capture. If you need to retain nanosecond resolution, ensure you save a packet capture to BFR, PCAPNG, or PCAP format. See the table for a full list of limitations per format.

Merging packet captures

If you have packet capture files that captured the same data, but from different viewpoints, you can merge them to create a more comprehensive packet capture.

**Note:** Only *.BFR format captures can be merged in Observer.

To merge packet captures, complete the following steps:

1. Click the File tab, and click **Open > Local Packet Captures > Merge**.
2. Type a file name for the resulting capture.
3. Click **Add**, and navigate to and open a saved *.BFR capture.
   Repeat this step as necessary to add more captures. Also, when adding a capture you can also create a time adjustment for the other buffers (relative to the first buffer added).
4. (Optional) Select your criteria for how duplicate packets are handled.
   - **Skip duplicate packets only when packet time difference is less than**
     During evaluation, packets are only compared against packets that arrived at nearly the same time, or specifically during a time difference less than N-milliseconds. Setting this can help avoid some false-positive results, but you may need to experiment with the value.
   - **Data link layer**
     If selected, layer 2 of the OSI Model is ignored when determining duplicate packets. For example, MAC addresses would not be examined when determining if a packet is a duplicate. They are ignored, but the rest of the packet is not.
   - **IP time to live (TTL)**
     If selected, the time to live (TTL) value in packets would not be examined when determining if a packet is a duplicate. This is useful to select when the same packets makes multiple hops through routers.
   - **IPv4 type of service or IPv6 traffic class**
     If selected, type of service (ToS) and traffic class (for IPv6) would not be examined when determining if a packet is a duplicate. The option is most useful when network hardware or software is changing these quality of service fields.
   - **TCP sequence and acknowledgement numbers, and TCP options**
     If selected, TCP sequence and acknowledgement numbers, and also TCP options, are not would not be examined when determining if a packet is a duplicate. Overall, this ignores the ordering of the packets and the values of optional packet fields.
5. Click **Start Merge**.

Depending on the size of the captures, this process may take a few minutes.

You successfully merged packet captures. If you have additional capture files to merge with your new capture, do so by simply repeating the process indefinitely.
Capturing network traffic

Capture packets so you can use Expert analysis to identify network problems and to help determine the best course of action.

Tip! Are you seeing duplicate packets collected during your capture? Do you want to ignore them? See .

Using Observer, network traffic can be captured in real-time and examined immediately or later. This section describes several methods for capturing network traffic using Observer.

Observer makes capturing network traffic easy. The very simplest way to capture packets (i.e. create a packet capture) is to use the Packet Capture tool as described below:

1. On the Home tab, in the Capture group, click Configuration > Packet Capture.
2. Click the Start button to begin your packet capture. If desired, filters can be defined before the capture from Filters > Configure Software Filter. Capture options like buffer size and where to save packets is configured in Settings. At any time during the capture, click Decode to open the Decode tool and display the Expert Analysis.
3. Click Stop to complete the packet capture.

After completing this task:

After capturing is complete, you may want to:

- Save your capture—select Save > Save Capture to keep a shareable buffer file. For information about saving packet captures, see Saving packet captures (page 82).
- Analyze the capture—click Decode to examine the captured packets and how they interact over the network.

Capturing from multiple probe instances

Capturing from multiple probes allows you to collect multiple, synchronized packet captures from multiple points of visibility, which can be especially useful in Multi-Hop Analysis. Complete the following steps:

1. On the Home tab, in the Capture group, click Configuration > Capture Multiple.
2. Select the probe instances you want to capture from, and, if desired, set filters for any of the instances enabled for capture.
3. Click Start to begin the synchronized packet captures. Meanwhile, the Multiple Instance Packet Capture dialog appears.
4. (Optional) If you want any remote packet captures transferred and saved locally (and you should if you intend to run Multi-Hop Analysis), ensure the Transfer and Save Packet Captures setting is enabled.
5. (Optional) You can also choose to load Multi-Hop Analysis immediately upon completing the packet capture. To do this, ensure the Start MultiHop Analysis setting is enabled.

6. Click the Stop button after Observer collects enough packets for your purpose.

**Scheduling packet captures**

One way to ensure you always have timely packet captures is to schedule them. For example, you may want to automatically start a packet capture at the beginning of business hours each day; you can accomplish this by scheduling your packet captures accordingly.

**Note:** Scheduled packet captures only tell Observer when to automatically begin and end a packet capture. The true length of capture time still depends on the size of your capture buffer; after it fills, you are no longer capturing packets. In effect, all scheduled packet captures automatically end in one of two ways: the capture buffer becomes full or the capture ends at the scheduled time. One way to prevent a premature end to scheduled captures is to use a circular capture buffer that writes to disk. See Configuring a circular capture buffer (page 80).

To schedule packet captures to begin at preset times, complete the following steps:

1. On the Home tab, in the Capture group, click Configuration > Packet Capture.

2. Click the Settings button. The Packet Capture Settings window appears.

3. Click the Schedule tab.

4. Select one of the following scheduling types:
   - No scheduling—captures are never scheduled
   - Always—capture runs continuously unless explicitly stopped
   - Daily at specified times—capture runs at same time each day
   - By day of week at specified times—capture runs at specific times on specific days

   For Daily at specified times, you must specify a capture begin and end time by clicking the Add button. Multiple time intervals are configurable if the times do not conflict.

   For by day of week at specified times, you must specify a capture begin and end time by clicking the Add button for each day you select. Multiple time intervals are configurable, per day, if the times do not conflict.

5. Click OK to confirm and save your changes

**Transferring a packet capture to another probe instance**

If for any reason you want to transfer and view a packet capture from one probe instance to another, you can do that. The packet capture must be saved on
the remote probe instance. By default the file is saved in C:\Program Files \Observer\Data.

1. Select the remote probe instance from which you want to transfer the packet capture.
2. Choose File and Open > Remote Packet Captures.
   The Probe Packet Capture Files window opens. This option is disabled if you selected a local probe instance.
3. Select the files you want to transfer.
4. Choose whether you want to transfer the files or view them, and whether Expert Analysis should be included.
5. If you want to transfer the files to a different probe instance, select the probe instance to which to transfer the files. By choosing a probe-to-probe transfer you do not need to use an intermediary location. It is a direct transfer.
6. Choose whether to apply a filter to the data before the transfer is made.
7. (Optional) Choose whether to delete the files after the transfer is complete.

Tell me more about the Packet Capture tool

In Graph view, the cyan line shows the total number of packets; yellow shows the number of packets being captured. Unless there are filters in effect, the yellow line should cover the cyan line. This can be used to verify that you are capturing the percentage of traffic that you intend to capture.

The graph also shows any dropped packets as a red line (which is usually zero). Dropped packets mean that something is wrong with the system running Observer; either it is not fast enough to keep up with traffic, or it is incorrectly configured in some way. If you see dropped packets you should check your hardware for conflicts and make sure that system processing power meets the minimum requirements for Observer.

Why am I missing packets?

Assuming your Observer has the network visibility it needs— and packets are not being dropped due to hardware or driver issues—there are a few reasons Observer may not “see” packets that you, yourself, were expecting to see. Fortunately, this problem can typically be fixed by changing a simple setting in Observer, which is outlined in this section.

By default, Observer's packet capture tool is configured to see (i.e. follow) only newly opened TCP connections. A newly opened TCP connection is any connection established after Expert Analysis was started. To change this behavior, complete the following steps:

1. On the Home tab, in the Capture group, click Configuration > Packet Capture.
2. Click the Decode button. The Decode and Analysis tool opens.
3. Click Settings. The Expert Global Settings window appears.
4. Ensure the TCP/IP tab is selected.
5. Clear the “Follow only newly opened TCP connections” check box; this changes Observer’s default behavior. A newly opened TCP connection is any connection established after Expert Analysis was started. If the conversation started before Expert Analysis was started, Observer cannot see it.

6. Click OK to confirm and save your changes. You may need to restart the Observer application for these changes to take effect.

This change should allow you to see connections that were established prior to opening the packet capture tool, along with the packets they contain. If you are still not seeing all packets, ensure you have all pre-filters deactivated. See Activating and deactivating filters (page 96).

Understanding duplicate packets

Duplicate packets lower the statistical accuracy of analysis, increase network link saturation, and can interfere with tools. Packet deduplication removes duplicate packets and helps you avoid those situations.

A duplicate packet is any packet that is identical to another packet. The packet header is inspected and all fields must be identical for it to be a duplicate. However, there are some situations where the header has been modified slightly during the packet’s journey. These situations require some fine-tuning of the deduplication settings to ignore those fields that were modified before the duplicate packet is received.

Understanding packet deduplication

Deduplication is useful when multiple copies of the same packet are received, but only a single copy should be seen.

Duplicate traffic is part of any network environment and is unavoidable. However, reducing duplicate packets as much as possible helps ensure your
network is more efficient. It also allows your tools to be more accurate. Duplicate packets reduce statistical accuracy, which leads to higher perceived levels of traffic or network connections. If you experience duplicate packets, consider your analytical needs and network topology when deciding whether deduplication should be used. You most often encounter them when packets are traversing multiple routers and those routers are copying their traffic to the SPAN/mirror port.

Removing duplicates from a saved packet capture can be more accurate than deduplication with the capture card. Observer has several more options than the capture card for ignoring packet header fields. These are header fields you choose to not examine (ignore) when determining if a packet is a duplicate. When all packet header fields are used as criteria (none are ignored) the capture card-based deduplication and Observer deduplication produce nearly the same results.

In some cases you may want to retain the duplicate packets. For example, when packets are being looped or when multiple VLANs are used with your hardware, you may want to keep the packets. Retaining a copy of duplicate packets and their traversal through both VLANs may be necessary when verifying whether the traffic was routed properly.

If you are attempting to find the source of duplicate packets in real time, do not deduplicate packets. Removing duplicate packets before they reach Observer or the GigaStor system lessens your ability to find the source of duplicates—if that is your goal. Instead, you can allow all duplicate packets and make changes to you monitored switches or SPANs and see if that resolves the duplicates coming in or helps locate the source.
Chapter 5: Filtering

Filtering narrows the scope and size of your packet captures so you get only what you want. This filtering can take place before (pre-filter) and after (post-filter) the packet capture is saved to disk.

Pre-filtering your packet captures

By filtering your packet captures, you can extract and examine only network packets that meet certain criteria. You can introduce such a filter either before (pre-filter) or after (post-filter) you perform a packet capture.

When you pre-filter your packet captures, you have two choices. You can choose to use a software pre-filter or a hardware pre-filter.

Some countries or locales have laws regarding data privacy and strictly regulate what information may be captured. Failure to abide by these laws could result in fines or jail time. This means that if you are troubleshooting an issue for a specific user you may not be able to create a generic filter. Instead, you must create a filter that captures only traffic for that individual. If you need to be very specific about what you capture, we recommend a hardware filter with a pattern filter (page 91).

Caution: Failing to click OK in step 8 causes Observer Analyzer to discard any and all changes made since the Active Filters window first appeared in step 1, including all filters you may have created during that period of time.

This section describes pre-filters only; these filters affect what your future packet captures record. If you have an existing capture file and would like to post-filter it instead, see Post-filtering your packet captures (page 97).

To create and apply a pre-filter, complete the following steps:

1. Choose one of the following to create your filter.
- On the **Home** tab, in the **Probe** group, click **Filters > Configure Software Filter**.
- On the **Home** tab, in the **Probe** group, click **Filters > Configure Hardware Filter**.

2. Click **New Filter**.
   The **New Filter** dialog appears.

3. Type a name for your new filter, and click **OK**.
   The **Edit Filter** window appears.

4. Use the editor to create a filter.
   The maximum number of elements a filter expression may have is 256.
   See [Tell me more about modifiers](page 95) for a list of rules, types, and their usage.

5. Click **OK** to confirm your changes.
   Your new filter appears in the **Active Filters** window.

6. (Optional) To exclude, negate, or do the inverse of what you just defined, select the rule, right-click and choose **Toggle Include/Exclude on rule**.
   (Optional) When you exclude a rule, a diagonal red line crosses through it.

7. (Optional) Activate your new filter by enabling it from the list.

8. Click **OK** to save your changes.
   Your newly created filter is available to use when capturing packets.

### Tell me how to filter by protocol

Observer’s Protocol Data Field filter rule lets you search for specific values in selected protocol header fields. For example, you can filter for ICMP destination unreachable packets and wireless control, data, and management packets. You can also define your own custom protocol filter, either by port or search pattern.

![Figure 18: Protocol Filters](image)

Click Add and give the protocol filter a descriptive name and choose whether you want to define the protocol by a pattern filter or a port filter. After you click **OK**, the appropriate filter dialog is displayed allowing you to enter the pattern or port that defines the protocol.
Tell me how to filter by pattern

**Tip!** For hexadecimal patterns, you must enter the two-character representation of each byte in the hex pattern, with a SPACE between. For the example above, telnet is on port 23, which is represented as 00 17 in hex. Note the SPACE between the 00 and the 17. For binary patterns, you must enter each byte as two 8-position bit strings separated by a space (for example, 10011101 11001100).

When defining a Pattern rule, you can enter a specific offset from the beginning of a packet header (or from the beginning of a protocol’s header), and a specific pattern or data sequence to search for after that offset.

The offset is the decimal position to start looking for the sequence, in the byte order you specify (Big Endian or Little Endian, or most significant bit first or last, respectively). Enter the offset as a decimal value. If you select Search Using Range you can enter an ending offset beyond which the filter will not search for the pattern. You can also make the search case sensitive or insensitive.

The pattern itself is the actual ASCII, Regular Expression, Hex or Binary string that you are filtering for.

**Figure 19: Pattern Filter**

For example, to define an offset-sequencing filter to look for telnet packets (i.e., looking for TCP port 23) in one direction, the offset would be 34 (14 bytes of Ethernet header + 20 more bytes of IP header) and the hex pattern would be 00 17 (23 in hex).

To create a Hex Pattern rule for telnet in both directions, you could first tell Observer you want to start the offset at the IP-TCP protocol portion of the header (specify IP-TCP in the Protocol dialog), then tell Observer that you want the first offset to start immediately (port number is the first field after the TCP header) by entering 0 in the first offset field and 00 17 in the first Offset Filter area. This will filter for telnet packets in the direction of source to destination. To see the telnet response packets, you should enter a second offset (in the same dialog) for offset 2 and with a value of 00 17. The second offset specifies the destination port (this is the reason for the offset of 2).

**Table 13. Rules types**

<table>
<thead>
<tr>
<th>Rule Type</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address - IP Range/ IP</td>
<td>Specify a hardware or IP address or range of addresses for source and destination. You can also limit the rule to apply only to packets from particular source or destination ports. For IPv4 packets, you can specify a subnet mask for inclusion/exclusion.</td>
</tr>
<tr>
<td>Rule Type</td>
<td>Usage</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Packets with Comments</td>
<td>Filter for packets that have been commented by an Observer user and saved with a capture file. Comments are useful for annotating packets when two analysts are working on a problem together, perhaps sending each other captures from remote sites on a corporate network. There are no setup options. Available for post-filter only.</td>
</tr>
<tr>
<td>Error</td>
<td>Specify the categories of errors you want to filter for: CRC, Alignment, packet to small, and packet too large are available for all network types. You can also filter for Wireless WEP errors if you are analyzing a wireless network. If you are analyzing a WAN link, you can filter for WAN abort and RBIT errors. Observer also lets you filter for Token Ring error notifications when analyzing Token Ring networks.</td>
</tr>
<tr>
<td>Ethernet Physical Port</td>
<td>Allows you to filter on the physical port or link of the Ethernet capture card. When choosing to filter by link, you can also choose the direction (DCE or DTE).</td>
</tr>
<tr>
<td>Expert Packets</td>
<td>This rule lets you filter for Observer-generated Expert packets. These packets will only be generated if the Include Expert Load information packets box has been checked in Mode Commands Setup for Packet Capture. There are no setup options. Available for post-filter only.</td>
</tr>
<tr>
<td>Full Duplex Ethernet Port</td>
<td>Lets you filter for direction (DCE or DTE) on a selected full-duplex port.</td>
</tr>
<tr>
<td>Length (Bytes)</td>
<td>Specify a packet length, and whether you want to filter for packets that are less than, equal to, or greater than that length. You can also filter for packets that fall within a range of length values.</td>
</tr>
<tr>
<td>MPLS</td>
<td>The MPLS filter allows you to filter on any level of the MultiProtocol Label Switching protocol.</td>
</tr>
<tr>
<td>Numeric Value</td>
<td>This rule is useful when you need to filter for a numeric value (or range of values) that is embedded within a byte, word or double word.</td>
</tr>
<tr>
<td>Packet Time</td>
<td>Allows you to create a capture file with packets only before, after, or during a specific time. This filter is only available for pre- and post-filtering.</td>
</tr>
<tr>
<td>Partial Packet Payload for TCP/UDP</td>
<td>Allows you to capture (or not capture) specific payload data based on how the rule is configured. This is especially useful if you need to share packet captures. See Sharing packet captures with third-parties (page 150)</td>
</tr>
<tr>
<td>Pattern</td>
<td>Use this rule to filter an ASCII, Regular Expression, hexadecimal, or binary string starting at specified offset or within a specified range. Hexadecimal and binary strings allow you to filter for values embedded within a particular byte, word, or double word if you know the offset, either from the beginning of the packet, or from the beginning of a particular protocol header. If you want to filter for numeric value or range of values within a byte or word, consider using the numeric value filter. Regular Expression filters allow you to use Unix/Perl-style regular expressions, which let you wildcard for single characters, groups of characters, ranges of characters and numeric values, and more.</td>
</tr>
<tr>
<td>Port</td>
<td>Specify a port or range of ports for inclusion or exclusion.</td>
</tr>
</tbody>
</table>
Pre-filtering your packet captures
Chapter 5: Filtering
93

<table>
<thead>
<tr>
<th>Rule Type</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Protocol</td>
<td>Select a protocol and field to filter on. For example, you can filter for ICMP Destination unreachable messages, or the presence of a VLAN tag.</td>
</tr>
<tr>
<td>VLAN 802.1Q or VLAN 802.1ad (QinQ)</td>
<td>The 802.1Q protocol allows you to filter on the outermost or innermost Virtual Local Area Network (VLAN) packet. The 802.1ad, or QinQ, protocol allows you to filter on any or all of the multiple VLANs in a packet. See Tell me more about choosing a VLAN protocol (page 93) to learn how to use VLAN filtering.</td>
</tr>
<tr>
<td>VLAN ISL</td>
<td>VLAN ISL (Cisco proprietary VLAN). Beyond the VLAN ID, you can filter by user-defined bits.</td>
</tr>
<tr>
<td>VNTag</td>
<td>Allows you to define the direction, loop, DVIF, and SVIF for tags created by the vNIC in your virtual network.</td>
</tr>
<tr>
<td>WAN - DLCI Address</td>
<td>Specify a WAN DLCI by number.</td>
</tr>
<tr>
<td>WAN Port</td>
<td>Specify a WAN Port by number.</td>
</tr>
<tr>
<td>WAN Conditions</td>
<td>Lets you filter for direction (DCE or DTE or both), and logically chain tests for forward congestion packets, backward congestion packets, and discard eligibility.</td>
</tr>
<tr>
<td>Wireless Access Point</td>
<td>Enter or select a hardware address that corresponds to the wireless access point you want to capture traffic from.</td>
</tr>
<tr>
<td>Wireless Data Rate</td>
<td>Select a wireless data rate, and whether you want to filter for packets traveling at, under, or over that rate.</td>
</tr>
<tr>
<td>Wireless Channel</td>
<td>Select a wireless channel, and whether you want to filter for packets received from channels less than, greater than, or equal to that channel.</td>
</tr>
<tr>
<td>Wireless Channel Strength</td>
<td>Select a wireless signal strength, and whether you want to filter for packets received at, under, or over that signal strength.</td>
</tr>
</tbody>
</table>

Tell me more about choosing a VLAN protocol

The filter string tells Observer which VLAN protocol to use.

- To use 801.Q for the outermost data, follow the setup in this example.

Figure 20: Outermost configuration and resulting filter

- To use 801.Q for the innermost data, follow the setup in this example.
Tell me more about regular expressions

Regular expressions provide a powerful method of building sophisticated search filters in which you can wildcard single characters, groups of characters, ranges of characters and numbers, and more. If you are familiar with Snort pattern-matching, you probably already have some familiarity with regular expressions.

The power of regular expressions comes from the ability to interpret meta-characters, which are a kind of programming code to specify search patterns. For example, in a regular expression, a period by itself means match any single character in this position. Suppose you want to find all references of the phone number 555-5155 in a large buffer filled with email traffic, for purposes of SOX audit. Depending on who typed the email, the number could be separated with the dash, a space, or even a period. You could search separately for all these versions of the phone number, or you could use the regular expression (the forward slashes enclosing the string identify it as a regular expression; these are optional unless you use modifiers).

Rather than providing a comprehensive definition or tutorial, this section gives a few short examples which are intended to give you an idea of the kinds of things you can do with regular expressions.

/555.5155/

Which would match 555-5155, 555 5155, 555.5155, etc. But it would also match 555X5155, 555B5155 etc. A more precise regular expression would be:

/555[ -|\.]5155/

which demonstrates how to use the bracket and pipe ([x|y|z]) construct to search for any of a class of characters. This regular expression would only match 555-5155, 555 5155, and 555.5155. Note the slash in front of the period, which tells the filter to look for a literal period rather than interpreting the period as a meta-character. This use of the slash (interpret a meta-character as a literal character) is called slash-quoting.

Be careful with meta-characters. Consider the following regular expression:

/210.43.165.90/
This would match not only the IP address 210.43.165.90, but also any other string of digits that included the literal elements (i.e., non-meta-characters) in the string:

```
2105433165490
2107435165190
210x43165890
2103437165a90
```

would all match. As noted before, to specify a literal period match, you must slash-quote the meta-character: To match only the IP address 210.43.165.90, use the regular expression

```
/210\..3\..5\..90/
```

**Tell me more about modifiers**

The backslash not only turns meta-characters into literal characters, it is also used to give otherwise literal characters special meaning. In the Perl-compatible regular expressions supported by Observer, this includes modifiers or controls that affect the way the entire expression is interpreted. For example, regular expressions are case-sensitive unless you use the /i modifier:

```
/network instruments/i
```

Would match:

Network Instruments and NETWORK INSTRUMENTS and Network instruments

Table 14 (page 95) lists the modifiers supported by Observer’s regular expression filters. For more comprehensive definitions of all the meta-characters supported by Perl-compatible regular expressions, see [http://perldoc.perl.org/perlre.html](http://perldoc.perl.org/perlre.html).

**Table 14. Modifiers**

<table>
<thead>
<tr>
<th>Modifier</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>i</td>
<td>Make the search case insensitive.</td>
</tr>
<tr>
<td>s</td>
<td>Interpret the period (.) meta-character to include newlines.</td>
</tr>
<tr>
<td>m</td>
<td>By default, the string is treated as one big line of characters. \ and $ (two other meta-characters) match at the beginning and ending of the string. When \m is set, \ and $ match immediately following or immediately before any newline in the buffer, as well as the very start and very end of the buffer.</td>
</tr>
<tr>
<td>x</td>
<td>Whitespace data characters in the pattern are ignored unless escaped or inside a character class. This is useful for making long regular expressions more readable.</td>
</tr>
<tr>
<td>A</td>
<td>The pattern must match only at the start of the buffer (same as ^)</td>
</tr>
<tr>
<td>E</td>
<td>Set $ to match only after the subject string. Without E, $ also matches immediately before the final character if it is a newline (but not before any other newlines).</td>
</tr>
<tr>
<td>G</td>
<td>Inverts the greediness of the quantifiers so that they are not greedy by default, but become greedy if followed by a question mark (?). Greediness refers to how many characters it will consider when trying to match strings of variable length.</td>
</tr>
</tbody>
</table>
Activating and deactivating filters

Typically, an active (activated) filter narrows the scope of your packet captures according to that filters’ rules. For example, a filter that filters LDAP traffic—if active—causes only LDAP packets to be captured to the capture buffer. Furthermore, this effect is additive, meaning if you activate an additional filter, both filters’ rules apply to future captures using a logical OR expression.

**Tip!** While enabling filters narrows the scope of your future packet captures, you can broaden that scope by enabling more filters. Alternatively, consider creating a “negative” filter to ignore packets you do not want to capture, and use that instead.

**Note:** By activating more than one filter (if desired), all activated filters are linked together with a logical OR statement.

Also, if you apply a rule that is not relevant to your pre-filter or post-filter scenario, that rule is ignored.

1. On the Home tab, in the Probe group, click **Filters > Configure Software Filter**.
2. Browse the list of filters, and activate any filter by enabling it.
3. (Optional) Edit any filter by selecting it and clicking **Edit Filter**.
4. (Optional) If you want to deactivate all filters, activate the “Empty Filter” filter.
5. Click **OK** to save your changes.

All future packet captures now adhere to the rules of all active filters. When necessary, you can deactivate filters by disabling them during step 2. To deactivate all active filters simultaneously, activate the Empty Filter filter.

How to chain filter rules using logical operators

Sometimes you need more sophisticated rules to capture packets from several addresses that meet complex criteria.

For these kinds of situations, you can chain multiple rules together into a single filter using the logical operators AND, OR, and BRANCH. The filter rule editor arranges the rules according to where they fall logically in the decision tree that you are building when using multiple rules. Each rule is represented by a rectangle, ANDs are represented by horizontal connecting lines, ORs and BRANCHes are represented by vertical lines.

AND and OR mean exactly what you would think. For example, the following rule would cause Observer to include only CRC error packets that originate from IP 255.0.0.1 (in other words, both the address rule AND the error rule must return positive for the packet to be captured).
If you want to capture traffic from 255.0.0.1 along with any error packets regardless of originating station, you would chain the rules with OR:

Figure 24: OR filter example

BRANCH is somewhat like an OR, but if the packet matches the first rule in the branch, it is matched only against the rules that follow on that branch.

When you chain multiple rules in a filter, packets are processed using the first match wins method: If a packet matches an exclude in the filter, further processing through that particular string stops. However, the packet is still processed through any subsequent OR or BRANCH rules in the filter.

**Post-filtering your packet captures**

By filtering your packet captures, you can extract and examine only network packets that meet certain criteria. You can introduce such a filter either before (pre-filter) or after (post-filter) you perform a packet capture.

This section describes post-filters only; these filters affect what you see in a loaded capture file. If you have an existing capture file and would like to pre-filter it instead, see Pre-filtering your packet captures (page 89).

To apply a post-filter, complete the following steps:

1. Click the File tab, and click **Options > Fallback Instance**.
2. Choose the probe instance with the settings you want to use to decode the buffer file. For more details about why this is important, see Opening files from unknown locations (page 104).
3. Click the File tab, and click **Open > Local Packet Captures > PreFilter and Analyze**.
4. Navigate to the capture file you want to load, and select it.
5. Click Open. The Pre-Filtering window appears.
6. Enable the filters you want to apply to the capture file.
   If you do not see any pre-installed filters worth using, create your own. The maximum number of elements a filter expression may have is 256.

7. Click OK. The capture file loads into Observer and you arrive at the Decode tab.

The Decode tab, of the Decode and Analysis window, displays each captured packet stored in the file matching the filter criteria. See Using the Decode pane (page 114) for more details.

**Enabling command-line filtering**

Command-line filtering is a method for post-filtering your packet captures via command line.

To enable command-line filtering:

1. On the Home tab, in the Capture group, click Configuration > Packet Capture.
2. Click the Start button to begin your packet capture.
3. Click the Decode button.
4. Ensure the Decode tab is selected, and then click Settings.
5. Select Enable type script filters in the General tab.
After command-line filtering is enabled, you can post-filter via command line as described in Post-filtering via command line (page 99).

**Post-filtering via command line**

Post-filtering via command line can save you time if you are comfortable building a filter using text.

**Prerequisite(s):**

You have enabled command-line filtering (page 98).

As an alternative to traditional set-up of filters, it is possible to post-filter your packet captures via command line.

**Note:** Command-line filtering must be enabled before continuing. See Enabling command-line filtering (page 98).
Some benefits of creating a command-line filter include:

- Ability to create a custom filters without losing focus of your capture window
- Ability to automatically convert to a traditional filter that is...
  - persistent, exportable, and shareable using Observer Management Server (OMS) or the network
  - suitable for more complex rules or later reconfiguration
- Familiarity with command-line interfaces may save you time

You can either type the text manually or use text building blocks to aid your syntax. To use this tool most efficiently, we highly recommend using saved packet captures.

This filtering process also works with an unsaved, real-time packet capture, but realize the data that appears after the filter is applied is static and unchanging. Your packet capture is still running, but new packets are not shown in the filtered view. Simply re-run your query from the active packet capture window to refresh your filtered data.

To post-filter via command line:

1. Click the File tab, and click **Open > Local Packet Captures > Load and Analyze**.
2. Navigate to the capture file you want to load, and select it.
3. Click Open. The capture file loads into Observer and you arrive at the Decode and Analysis tool.
4. Click the **Type Script Filter** button.
   
   If you do not see the **Type Script Filter** button, verify you have enabled command-line filtering (page 98).
5. Build your filter, using the building blocks list as your guide.

   Descriptions of each building block, including example usage, can be found in Table 15 (page 101).

   Figure 26: Use building blocks as your guide
6. Click **Apply** when finished.

The packet capture is filtered according to the rules. If you encounter an error, or provide improper syntax, Observer alerts you that the filter must be fixed.

7. (Optional) To automatically convert your command-line filter to a traditional Observer filter, which can be kept forever, click **Save Filter**.

**Table 15. Building blocks**

<table>
<thead>
<tr>
<th>Building block</th>
<th>Examples</th>
<th>Description</th>
</tr>
</thead>
</table>
| -ip=           | -ip=10.0.36.139  
                | -ip=74.125.224.72 | IPv4 Address—use this to filter for a single IP address (IPv4). |
| -ip_pair=      | -ip_pair=10.0.36.139/10.0.36.154  
                | -ip_pair=10.0.36.139/74.125.224.72/  | IPv4 Pair—use this to filter for two IP addresses (IPv4) that have conversed with each other. |
| -ip_range=     | -ip_range=10.0.36.1/10.0.36.255  
                | -ip_range=192.168.0.20/192.168.0.100 | IPv4 Range—use this to filter for any IP address (IPv4) within a set range. The IP addresses that form the beginning and the end of the range are included in the filter. |
| -ipv6=         | -ipv6=FE80::F544:9E0:9C81:9FB1  
                | -ipv6=ff00::7f00:1 | IPv6 Address—use this to filter for a single IP address (IPv6). |
| -ipv6_pair=    | -ipv6_pair=FE80::F544:9E0:9C81:9FB1/2002::4A7D:E048 | IPv6 Pair—use this to filter for two IP addresses (IPv6) that have conversed with each other. |
| -ipv6_range=   | -ipv6_range=FE80::A00:2401/FE80::A00:24FF | IPv6 Range—use this to filter for any IP address (IPv6) within a set range. The IP addresses that form the beginning and the end of the range are included in the filter. |
| -mac=          | -mac=00:0C:85:BD:08:80  
                | -mac=00:50:56:2E:AB:A0 | MAC Address—use this to filter for a single MAC (hardware) address. |
| -mac_pair=     | -mac_pair=00:50:56:2E:AB:A0/00:0C:85:BD:08:80 | MAC Address Pair—use this to filter for two MAC addresses that have conversed with each other. |
| -mac_range=    | -mac_range=01:00:5E:00:00:00/01:00:5E:7F:FF:FF | MAC Address Range—use this to filter within a set range. The IP addresses that form the beginning and the end of the range are included in the filter. |
| -regex=        | -tcp=22  
                | -tcp=80  
                | -tcp=25901 -and -tcp=25903  
                | -tcp=63268 | TCP Port—use this to filter for a single TCP port number. As with other building blocks, you can add more using an 
                | -tcp_pair=63268/25901  
                | -tcp_pair=25901/25903  
                | -tcp_pair=3389/3391 | TCP Port Pair—use this to filter for any pair of TCP ports that have conversed with each other. Direction is a non-factor for this building block; the filter looks for a pair of ports regardless of source or destination. |
| -tcp_range=    | -tcp_range=0/5000  
                | -tcp_range=35/1023  
                | -tcp_range=60000/63500 | TCP Port Range—use this to filter for communication on any TCP port between the specified range. The port numbers that form the beginning and the end of the range are included in the filter. Direction is a
<table>
<thead>
<tr>
<th>Building block</th>
<th>Examples</th>
<th>Description</th>
</tr>
</thead>
</table>
| -udp= | -udp=53  
-udp=88  
-udp=26000 -and -udp=61001 | UDP Port—use this to filter for a single UDP port number. As with other building blocks, you can add more using an –and building block. |
| -udp_pair= | -udp_pair=63240/27015  
-udp_pair=49501/42 | UDP Port Pair—use this to filter for any pair of UDP ports that have conversed with each other. Direction is a non-factor for this building block; the filter looks for a pair of ports regardless of source or destination. |
| -udp_range= | -udp_range=27901/27910  
-udp_range=27030/27000  
-udp_range=0/1023 | UDP Port Range—use this to filter for communication on any UDP port between the specified range. The port numbers that form the beginning and the end of the range are included in the filter. Direction is a non-factor for this building block; the filter looks for a pair of ports regardless of source or destination. |
| -vlan= | -vlan=101  
-vlan=101 -and -vlan=102 | VLAN ID—use this to filter for a single VLAN ID. As with other building blocks, you can add more using an –and building block. |
| (space character) | -tcp=80 -tcp=8080  
(TCP port 80 -OR- TCP port 8080) | Use this to denote a logical OR statement. Use this to include more items and broaden the scope of your filter. |
| / (forward slash) | -ip_range=10.0.36.1/10.0.36.255  
(Any IPv4 address between 10.0.36.1 and 10.0.36.255) | Use this to denote a value range or any pairs. Do not add a leading or trailing space character to the forward slash. |
Chapter 6: Decodes

When you are working with packets or need to open a packet capture, the decoding tools are what you use. Customize your packet view settings and be able to search packet payload, process NetFlow data, or even replay a packet capture.

Decoding network traffic

The ability to decode and analyze network traffic is equally as important as the ability to collect it. This section describes how to decode and analyze packet captures, including advanced post-filtering techniques and other settings.

Observer can easily decode and analyze packet capture files, including multiple file formats. Even captures made using third-party tools can be analyzed in Observer, as long as they are based on Ethernet, Token Ring, or FDDI traffic. This section describes several methods for decoding network traffic using Observer.

The simplest method for decoding network traffic is to load a capture file—a saved file that is a complete, self-contained packet capture collected during an earlier time. If you do not have access to a capture file and need help creating one, see Capturing network traffic (page 84) before continuing. Also, that section describes how to decode a real-time packet capture, while this section does not.

Note: If you are already comfortable loading capture files and decoding their contents, this section may not be useful to you. Advanced decoding methods are described in Preparing expert decoding techniques (page 122).

To decode network traffic stored in a capture file, complete the following steps:

1. Click the File tab, and click Open > Local Packet Captures > Load and Analyze.
2. Navigate to the capture file you want to load, and select it.
3. Click Open.

The capture file loads into Observer and you arrive at the Decode and Analysis tool. The Decode tab displays each captured packet that is stored in the file.

**Tip!** Are you seeing duplicate packets? See .

After completing this task:
See Using the Decode pane (page 114) for more details.

**I have a packet capture to analyze. What file formats can Observer load?**

Except for XML, Observer can load all of the files formats that it can save to, plus the DMP format.

Simply, Observer can load any packet capture of these formats:
- BFR
- CAP
- DMP
- ENC
- FDC
- PCAP
- PCAPNG
- TRC

For information about the formats Observer can save packet captures to, see Saving packet captures (page 82).

**Opening files from unknown locations**

You may not know where or how a packet capture was taken. This can cause some confusion when decoding a foreign buffer file, because probe instance settings that may be unique to that probe instance may be saved in the buffer file. When opening a capture buffer, Observer uses the probe instance settings of the first probe instance in its list unless you specify which probe instance to use.

You may want to use this option if you are:
- Unsure of the header, MPLS analysis, or ToS/QoS settings
- Decrypting wireless data
- Decoding protocols on non-standard ports (although user-defined protocols are not decoded for a NetFlow instance)

**Note:** This option is not intended to allow you to open a capture from a different topology. For instance, it will not make sense to use an Ethernet Probe instance to open a WAN capture or a Wireless probe instance to open a Fibre Channel capture.

**Tip!** Create a probe instance just for analyzing packet captures that you load into Observer. By using a dedicated probe instance, you can easily and temporarily change the probe instance settings. This allows you to view the buffer files using settings for the type of probe instance used to capture the file, and more importantly, you do not need to change any probe instance you use for monitoring.
Do the following:
1. Click the File tab, and click **Options > Fallback Instance**.
2. Select a probe instance with settings you think are similar to the capture adapter used to capture the buffer.

### Private key locations per server

Private key locations differ from application to application.

#### Microsoft Lync Server

Microsoft Lync Server encrypts all of its VoIP traffic, including the call set up process. To decrypt a Microsoft Lync server conversation, you must have the security certificate and Observer must see the telephone’s power up.

By default, the Lync Server key is not exportable. You must create an exportable key for Observer to use. Getting the Lync Server key is similar to that for the IIS Web Server. See [Windows IIS Web Server (page 105)](#).

#### Apache Web Server

Perform a search for the file with the name “server.key”. Check the format of the server.key file to ensure it is **not** an encrypted private key file. See [Encrypted private key file (page 106)](#).

However, if the private key file is encrypted, the private key file must be decrypted using the openSSL command line tool and the password that was used to encrypt it. This utility can be obtained by following an appropriate link as follows:

- [http://www.openssl.org](http://www.openssl.org)
- For Windows compatible versions, use a search engine to search for the terms “Download,” “Win32,” and “OpenSSL”.

After obtaining the openSSL command line utility, the private key file can be decrypted using the following command (choose the appropriate locations for the input and output files):

```
openssl rsa -in server.key -out UnencryptedKey.key [enter passphrase]
```

You can now use the newly created output key, in Observer, to successfully decrypt and analyze encrypted network traffic.

#### Windows IIS Web Server

Windows does not contain a searchable private key file. The key file must be extracted from the website server certificate, and the server certificate must contain the private key file.

Use the following Microsoft Support document to export your server certificate and private key to a single .pfx file: [http://support.microsoft.com/kb/232136](http://support.microsoft.com/kb/232136) (How to back up a server certificate in Internet Information Services).
After you successfully export the .pfx file (PKCS #12), you must obtain the OpenSSL utility. This utility can be obtained by following an appropriate link as follows:

- http://www.openssl.org
- For Windows compatible versions, use a search engine to search for the terms “Download,” “Win32,” and “OpenSSL.”

With a valid .pfx server certificate backup file and the openssl utility, the following command should be used (choose the appropriate locations for the input and output files):

openssl pkcs12 -nodes -in c:\mycertificate.pfx -out c:\server.key

You can now use the newly created output key, in Observer, to successfully decrypt and analyze encrypted network traffic.

Non-encrypted private key file

A normal, non-encrypted private key file should contain text of the following format. Notice the absence of a “Proc-Type: ENCRYPTED” header.

A file of this format is usable by Observer.

```
-----BEGIN RSA PRIVATE KEY-----
MIICXgIBAAKBgQD7uhNymd6WCORqH0rpd5zs4FEwCW2JrKtm0dmTf44SVaGvFLF1
vakeOFy/sFs4aa2UnOFcbs432w31ZWWmun4acCtqtv821ll+13VcdyR+2SRx9GmBu
SnoL/6FI68tmGCHq6g0IoItAJoN+MOEC2bwmYmksJjPVU0XcE91EG0A0Q1DAQAB
AoGAFQOyWeUmqmRspW2NW6XKXvVGBGzcRpiDrWfgCO/ITXhYUlt2147QL+d
-----END RSA PRIVATE KEY-----
```

Encrypted private key file

An encrypted private key file may have the following format, which indicates that the private key file obtained contains an RSA Private Key, where the text for the key itself is encrypted.

A file in this format will generate an error dialog stating “Error Loading the Private Key File!” You must decrypt this key file before it will function.

```
-----BEGIN RSA PRIVATE KEY-----
Proc-Type: 4,ENCRYPTED
DEK-Info:
DES-EDE3-CBC,7BC....
JHQ800pDbeFM9h2jZSmuiugxdq0a2q/MiX43Xa4Es6nKmu9oI/ZfIdAHx18gwsD
mZ5bQR1X9AXeIRy+0tG2ibUasphQEsv1995FWUsh8N9dVumsykmMXSwND7tkkHB
Io/VVSAAD9vbV3db15nhMmWnPGBC3590GAK42RIqrHRQ94fd/2Az88K911wCmX6
swF1NBLGuKFl1J9qkyrr+OOQqu1rAy2AB2UThGCJJetELFsTv4mLmiHdG1cUqPj=
-----END RSA PRIVATE KEY-----
```

Decoding encrypted network traffic

Observer can decode network traffic that is encapsulated within Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols, but the traffic must first be decrypted. (Supported Cipher Suites)

**Prerequisite:** Observer Expert or Observer Suite

This feature of Observer allows you to make meaningful interpretation of encrypted traffic that you are authorized to view. A private key is required; you cannot decrypt any traffic without having the private key, ensuring you are the facilitator of the encrypted traffic.
You can also choose whether and how to translate the SSL/TLS port number (443) in the output. For example, if decrypting encrypted HTTP, you may want to change the port number to 80.

You can also optionally strip all TCP flow control packets (the SYN requests and ACKs used to establish and maintain the connection) from the decrypted output.

**Note:** Decryption can only be performed post-capture, and the actual decryption process is performed locally. There is no central repository for private keys in either Observer or Observer Management Server (OMS) (if you own it), so each Observer installation wanting to decrypt a stream must have a local copy of the private key.

**Note:** If you are decrypting network traffic using a private key via a SafeNet HSM card and that card is located on a OMS server, you must provide the slot number under "Use SSL RSA Private Key From SafeNet HSM Card on OMS" seen in Figure 27 (page 108).

If you are concerned about security for the decoding of your encrypted traffic, there are three methods available to you:

- **Use SSL Private Key from File.** Even though the private key provides a certain level of security, this is the least secure option because of access to the private key file itself may be compromised. Even this option though provides greater access control than not using any security at all.

- **Use SSL RSA Private Key from HSM.** This is a more secure than the above option because the private key is managed by HSM. Since the HSM maintains the private key, more access control exists.

- **Use SSL RSA Private Key from HSM on OMS.** This is the most secure option. OMS controls Observer’s access. Additionally, a key must be issued by the HSM. To use the key, you must know the token name of the HSM and provide it to decrypt the conversation. It is not stored in Observer. Observer passes the token name to OMS, OMS compares the name that was passed to its list of names, if one matches, it is passed to HSM where access is granted or denied. No key itself is ever passed during this entire process. Most likely, a security team manages and maintains the HSM and is a separate group from the network administrators. Using the private key from HSM on OMS, Observer is only able to decrypt the selected client/server connection or port pair. If another client/server connection or port pair must be decrypted, then a new key must be obtained.

To decode encrypted network traffic, complete the following steps.

1. Click the File tab, and click **Options > Fallback Instance**.
2. Choose the probe instance with the settings you want to use to decode the buffer file. For more details about why this important, see Opening files from unknown locations (page 104).
3. Click the File tab, and click **Open > Local Packet Captures > Load and Analyze**.
4. Navigate to the capture file you want to load, and select it.
5. Click Open. The capture file loads into Observer and you arrive at the Decode and Analysis tool.
6. Do one of the following:
Click the **Expert Analysis** tab. Then, click the TCP Events or UDP Events group tab and select the target encrypted conversation.

Click the **Decode** tab. Then, select the target encrypted conversation.

7. Right-click the encrypted conversation and select Decrypt SSL Conversation. The SSL/TLS Decryption Parameters dialog appears.

Figure 27: Provide the location of your private key here

8. Provide the location of your private key file.

9. (Optional) Further customize your decryption by changing the extra options, including if you use a SafeNet HSM card for FIPS 140-2 compliance. Contact your SafeNet HSM card administrator or your corporate key librarian for the specifics about the slot number, key name, and user PIN. See Security, privacy, and regulatory compliance (page 149) for more information.

10. Click **OK** to begin decrypting a client-server connection only, all connections for the client-server pair, connections to the selected Server IP/Port, connections with selected Application, or all SSL/TLS Encrypted Packets. The length of time decryption requires is proportional to how many packets are processed.

You successfully decrypted the conversation and can now decode and analyze its contents.

After completing this task:

If you cannot locate the private key file used for SSL decryption or an error states “Error Loading the Private Key File!,” there are two possible reasons:

- You cannot locate, or do not have access to, the private key file necessary for decryption. You must obtain it.
- The private key file you do have is improperly formatted or encrypted, and will not work. You must decrypt it.
In either of these scenarios, you must find the location of the private key file to begin troubleshooting. The location differs for each web server application, so the following are instructions for Apache Web Server and Windows IIS Web Server. If you don’t use either of these web server applications, please refer to the documentation for your specific web server application.

Decoding NetFlow or sFlow streams

If you set up a standard probe instance (non-NetFlow or non-sFlow) to monitor a segment that includes NetFlow or sFlow reporting streams, these packets are treated as any "other" network traffic.

Observer’s statistical displays, such as Top Talkers, do not include the data reported through NetFlow/sFlow.

Therefore, to force Observer to recognize and interpret the NetFlow/sFlow data and update statistical displays accordingly, complete the following steps:

1. Click the File tab, and click **Options > Fallback Instance**.
2. Choose the probe instance with the settings you want to use to decode the buffer file. For more details about why this important, see [Opening files from unknown locations](#). (page 104).
3. On the Home tab, in the Capture group, click **Configuration > Packet Capture**.
4. Click the **Decode** button. The Decode and Analysis window appears.
5. Click the **Decode tab**, then choose **Tools > Process NetFlow or sFlow data**. The Select Data Source window appears.
6. Choose the data source you want to process.
7. (Optional) Change your ToS/QoS settings if necessary.
8. Click **OK**.

A temporary post-filter buffer is created in memory that interprets the NetFlow or sFlow statistics and updates Observer’s statistical displays accordingly.

Configuring a NetFlow device

To configure a NetFlow device to work with Observer, you must first set up a cache on the router or switch to hold statistics for each interface (i.e. device port) being monitored, then define the IP address and UDP port of the collector (i.e., Observer or probe). On a Cisco router running IOS, the commands look like this:

1. Define which interfaces to monitor:
   
   ```
   Router1#config t  
   Router1(config)#int ser0/0  
   Router1(config-if)#ip route-cache flow  
   [Repeat for each interface being monitored]
   ```
2. Define the IP address and UDP port of the collector:
   
   ```
   Router1#config t  
   Router1(config)#ip flow-export version 9  
   Router1(config)#ip flow-export destination 192.168.1.12 9996
   ```

Configuring an sFlow device

To configure an sFlow device to work with Observer, you must define the collector IP address and UDP port, and optionally configure a polling interval and sampling rate (although in most cases the default interval and sampling rate are
appropriate). Here is what the commands might look like on a Foundry Layer 3 switch:

1. **Define which interfaces to monitor:**
   ```
   Switch1(config)#interface ethernet 1/1 to 1/8
   Switch1(config)#sflow forwarding
   ```

2. **Define the IP address and UDP port of the collector:**
   ```
   Switch1(config)#sflow destination 10.10.10.1 9099
   ```

   Specifying a UDP port is optional; the default is 6343. In most cases, the default polling interval and sampling rate are appropriate, but if you need to adjust them, use the sFlow polling-interval and sFlow sample commands:
   ```
   Switch1(config)#sflow poll-interval 120
   Switch1(config)#sflow sample 30
   ```

   This would cause the device to push sFlow data to the target collector every 120 seconds, with a sampling rate of 1 packet in 30.

## Registering custom decode DLLs

Observer allows you to integrate custom-written decode applications into its environment.

### Prerequisite(s):

Observer allows you to write your own protocol decoder, if you have expert knowledge in the following:

- The protocol you are writing the decoder for
- The C++ Programming Language

In addition, it helps if you have Microsoft C++ Developer’s Studio, as VIAVI has included an example project file for that environment along with the example source code. The Custom Decode Kit is contained in the **C:\Program Files\Observer\Drivers\CustomDecodeKit** directory (CustomDecodeKit.exe, which is a self-extracting archive). Along with the example project and source files, use the **Using the Custom Decode Kit** information that outlines the steps in building a DLL.

Once you have built a DLL and placed it in the **Program Files\Observer** directory, select Register Custom DLL from the Tools menu and add the new DLL to the list of registered DLLs. Once a DLL has been registered, the new decode will be available in the Decode and Analysis tree control.

### Note:

Custom decodes are only available in Observer Suite. Also, VIAVI does not provide technical support for creating or maintaining custom decodes—only the tool itself.

To register a custom decode DLL:

- On the Home tab, in the Tools group, click **Custom Decodes**.
Replaying a packet capture

Replay Packet Buffer mode, like Traffic Generator mode, permits the user to create traffic on the network. Unlike Traffic Generator, however, Replay Packet Buffer mode sends some or all of a previously saved capture buffer onto the network.

Prerequisite(s):
Classic mode (page 35) must be enabled.

To replay a packet capture, you must be using a local probe instance. The probe instance on which you want to replay a packet capture cannot be on a remote system.

Note: Replaying a packet buffer is not the same as stream reconstruction. For stream reconstruction, see Reconstructing TCP data streams (page 130).

To replay a packet capture:
- On the Classic tab, in the Tools group, click **Replay Packet Buffer**.
- Dial displays—the left dial displays the speed (packets per second) of the buffer as it is being replayed. The right dial displays the speed (bytes per second) of the buffer as it is being replayed.

Statistics pane:
- This pane displays totals transmitted for the replay, bit rates, and animation to show that a replay is in progress.

Settings pane:
- Select buffer and button—allows you to enter the name of the buffer (.BFR) file to be transmitted. Enter the name and address of the file to be transmitted or click the **Select buffer** button to browse to it.
- First packet—allows you to set the number of the first packet in the buffer to be transmitted.
- Last packet—allows you to select the number of the last packet in the buffer to be transmitted.
- Speed (pkt/sec)—allows you to set the speed, in packets per second, which you would like to attempt to transmit the buffer.

If the speed is set at a higher number than the Observer computer’s NIC is capable of, it will only be able to transmit the buffer at the NIC’s maximum rate.

Generation Mode:
- Time period to generate (1-65500 sec)—packets will be generated at the configured speed for the number of seconds specified in the edit box. If the specified contents of the buffer are completely transmitted before the end of that period, the transmission will loop back to the first packet as chosen above.
- Number of times to replay this buffer—the buffer file, or the selected portion of it, will be replayed the number of times specified in the edit box.
Working with packets

1. On the Home tab, in the Capture group, click **Configuration > Packet Capture**.
2. Click the **Decode** button. The **Decode and Analysis** window appears.
3. Click the **Decode tab**, then select a packet.
4. Right-click and a menu appears with many options. Those options are described in Table 16 (page 112).

   This list is configurable and contextual, that is, it varies based on the type of packet that is selected.

<table>
<thead>
<tr>
<th>Menu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Packet Capture on Hardware/IP Address</td>
<td>Starts a new packet capture filtered on source, destination, or both, using either hardware or IP addresses to identify systems.</td>
</tr>
<tr>
<td>Fast Post-Filter on Hardware/IP Address</td>
<td>Applies a filter to the current buffer. Observer will open a new decode window, loading only the packets you have chosen to include.</td>
</tr>
<tr>
<td>Create Filter on Hardware/IP Address</td>
<td>Same as Start Packet Capture options described above, except these options let you preview and edit the filter without actually starting a capture.</td>
</tr>
<tr>
<td>Set Flag on Hardware/IP Address</td>
<td>Flags all packets that have the same address criteria (source, destination, pair) as the selected packet.</td>
</tr>
<tr>
<td>Remove Offset Flags</td>
<td>Removes any offset flags that have been set.</td>
</tr>
<tr>
<td>Remove Hardware/IP Address Flags</td>
<td>Removes all address flags that have been set.</td>
</tr>
<tr>
<td>Connection Dynamics</td>
<td>Opens a Connection Dynamics chart of the selected TCP conversation. See Using Connection Dynamics (page 131).</td>
</tr>
<tr>
<td>Add Comment</td>
<td>Allows you to add comments to specific packets in the buffer file.</td>
</tr>
<tr>
<td>TCP Dump</td>
<td>Sometimes may options after it such as (HTTP) or (NetBIOS session) when it can identify the type of packets. When selected the packets are processed and appear in the Expert Analysis tab.</td>
</tr>
<tr>
<td>Reconstruct Stream</td>
<td>Reconstructs the TCP stream and any files or other data objects exchanged. See Reconstructing TCP data streams (page 130).</td>
</tr>
<tr>
<td>Decrypt SSL Conversation</td>
<td>Shows you the decrypted SSL conversation if you have the SSL key.</td>
</tr>
<tr>
<td>Decrypt TACACS+ Conversation</td>
<td>Shows you the decrypted TACACS+ conversation if you have the TACACS+ shared secret.</td>
</tr>
<tr>
<td>Previous/Next Packet in Conversation</td>
<td>Lets you follow a TCP conversation backward and forward in time.</td>
</tr>
<tr>
<td>Maximize Pane</td>
<td>Zoom in to the current pane (headers, decode, or hex window).</td>
</tr>
<tr>
<td>Packet List Color Setup</td>
<td>Displays the Color dialog.</td>
</tr>
</tbody>
</table>
### Menu option | Description
--- | ---
Set Decode Relative Time Origin to Selected Packet | Resets timestamps.
Calculate Cumulative Bytes | Displays the byte count from the beginning of the capture (or the relative time origin) to the current packet.

5. For additional settings, choose **Settings > General tab**. These settings are described in Table 17 (page 113).

### Table 17. Expanded packet options

| Menu option | Description |
--- | --- |
Set focus on the last packet | Causes the packet display to set focus on the last (rather than the first) packet in the capture, allowing you to see the most recently captured information. This is particularly useful when viewing a capture live where the user wishes to examine data as it arrives. |
Expand 2nd level trees | Causes the tree decode display to expand all second level trees. |
Expand 3rd level trees | Causes the tree decode display to expand all third level trees. |
Expand 4th level trees | Causes the tree decode display to expand all fourth level trees. |
Use EBCDIC for displaying SNA data | If the packet contains SNA (Service Network Architecture) data, selecting this box causes Observer to use EBCDIC for representing characters as numbers when displaying SNA data. EBCDIC is used almost exclusively on IBM mainframe computers. |
Use EBCDIC for all data | Observer uses EBCDIC for representing characters as numbers when displaying all data. EBCDIC is used almost exclusively on IBM computers. |
Decode TCP payload in packets with bad checksum | Observer decodes the packet payload even if the checksum for that packet fails. The default behavior is to not decode these packet payloads. |
Show full duplex 'Port' or 'Link' in 'DCE/DTE' parameters | Observer shows which side of a full-duplex connection the packet was captured from. |
Show preview of summary comment text | Shows a truncated version of any comments you have added to the packet in the packet comment column. |
When loading a local buffer file, exclude expert packets from the display | Choose to enable/disable the display of Observer Expert packets (the packets are not actually stripped from the file, they are just filtered from display). |
Bytes Per Row in Hexadecimal Display radio buttons | Choose 16 or 10 bytes per row. |
Show decode list using radio buttons | Choose either fixed-point or variable space font. |
Packet timing display resolution list | Allows you to select the packet timing display resolution. |
## Using the Decode pane

The Decode and Analysis tab is where the captured buffer is decoded and the packet conversations can be examined and analyzed in detail.

This pane has several tabs on it that show you specific information about your packet decode. These include:

<table>
<thead>
<tr>
<th>Expert Analysis</th>
<th>Displays all general, non-conversation specific problems that Observer finds when analyzing the packet capture. See Using the Expert Analysis feature.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decode</td>
<td>Shows the raw packets for you to examine yourself. The tab has three sections. The top section shows the list of packets. Right-click any of the packets to see a list of actions you can take on it. The middle section is detailed information about the selected packet. The bottom section is the contents of the packet in hexadecimal and EBCDIC. Press F4 to maximize this bottom section to see more of the packet contents. There are numerous settings, such as colors and protocol forcing, that you can configure by clicking the Settings button. You can save buffers, search for packets and other actions using options under the Tools menu.</td>
</tr>
<tr>
<td>Summary</td>
<td>Summarizes network details, errors, data rates, packets, and utilization for the traffic Observer saw. The information on the Summary tab is only for the packets seen on the Packet Capture window or in the buffer file you loaded.</td>
</tr>
<tr>
<td>Protocols</td>
<td>Lists the protocols seen and shows how many packets and bytes of that protocol were seen, what percentage of the total packets or bytes that is, and utilization.</td>
</tr>
<tr>
<td>Top Talkers</td>
<td>Shows what devices are the most active on your network. The MAC address, DNS name, IP address are listed. There are several tabs to see the data in different ways. There are numerous settings that you can configure by clicking the Settings button. This feature is very similar to the Top Talkers covered in Discovering current top talkers on the network (page 46).</td>
</tr>
<tr>
<td>Pairs (Matrix)</td>
<td>Graphs the top 10 most active device pairs by packets per second. This feature is very similar to the Pairs Matrix in Discovering conversations between local devices and the Internet (page 39).</td>
</tr>
<tr>
<td>Internet Observer</td>
<td>Has three tabs that show a graph of the packets total by device on the Internet Patrol tab, and lists of IP Pairs and IP Subprotocol. There are numerous settings that you can configure by clicking the Settings button. This feature is very similar to the Internet Patrol in Discovering conversations between local devices and the Internet (page 39).</td>
</tr>
<tr>
<td>Application Transaction Analysis</td>
<td>Contains several tabs for the applications that Observer analyzes, including response time and statistics, URL statistics, FIX, and SQL. For more details about Application Transaction Analysis, see Understanding Application Transaction Analysis (page 163).</td>
</tr>
<tr>
<td>VLAN</td>
<td>Lists a summary and stations of VLAN activity. Shows packets, bytes, broadcasts, multi-casts, and utilization. You can configure how the list appears by using the Settings button. This feature</td>
</tr>
</tbody>
</table>
Forensic Analysis | Displays anomalies based on Snort rules on the Forensics Summary or Forensics Analysis Log tabs. You can choose what Snort rules to use to analyze the data by clicking the Settings button. This feature is similar to Forensic Analysis described in Examining your network traffic with forensic analysis (page 330).

Access Point (AP) Statistics | Shows wireless access point statistics. This is similar to Viewing wireless access point statistics (page 42).

Fibre Events | Shows details related to your Fibre traffic.

Figure 28: Decode tab

After you are in the view screen, select a packet in the top window to display the packet decoded information in the middle window. There are three window panes:

- the packet header pane.
- the decode pane.
- the raw packet display pane.

The three panes are fully sizable by dragging the borders up or down. Packets that Observer does not recognize are shown in raw mode in the decode and raw panes. Each pane has a context-sensitive right-click menu. For example, you can right-click a packet header, and (if it is not a broadcast packet) immediately jump to a connection dynamics display of the network conversation.

The packet header pane shows the following:

- Packets—the number of packets currently in the buffer.
- First—the first packet number in the buffer.
- Last—the last packet number in the buffer.
- Offset—the offset display is only shown if you have highlighted a section of the decode screen. When a section of the decode screen is highlighted, Observer’s active highlight option is activated. This option shows the highlighted sections of actual data in the raw area of the packet decode.
screen, including the offset of the value from the beginning of the packet. This information can be used to configure an offset filter for that value.

You can highlight an item of the decode in the Raw Packet Display area and right-click it. Two options will be displayed: Start Packet Capture on Segment/Offset or Create Filter on Segment/Offset. These options are only available in this area.

For details about the packet header menu, see Working with packets (page 112).

**Saving a packet capture**

1. On the Home tab, in the Capture group, click **Configuration > Packet Capture**.
2. Click the **Decode** button. The Decode and Analysis window appears.
3. Click the **Decode** tab, then choose **Tools > Save Capture Buffer**. The Save Packet Capture dialog opens.
4. Complete the dialog and click Save As and choose a file name. Observer can save the file as BFR, CAP, ENC, PCAP, or XML.

<table>
<thead>
<tr>
<th>First packet</th>
<th>Allows you to set the first packet in the capture buffer to be saved to the file. By default, this is packet 1.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last packet</td>
<td>Allows you to set the last packet in the capture buffer to be saved to the file. By default, this is the last packet in the capture buffer.</td>
</tr>
<tr>
<td>Save as button</td>
<td>Displays a dialog that lets you choose from various formats to use when saving the capture buffer, including Observer’s native file format, various Sniffer formats, and XML. Unless you have a specific reason to do otherwise, choose Observer’s native .BFR format.</td>
</tr>
<tr>
<td>Append packets to existing file</td>
<td>When selected, allows you to add packets to the existing file.</td>
</tr>
<tr>
<td>Recombine ATM Packets</td>
<td>If this box is left unchecked, Asynchronous Transfer Mode (ATM) packets will be saved as they were captured off the wire (in other words, the 53-byte cell units used by ATM switching networks). Check the box to have Observer recombine the packets into Ethernet frames.</td>
</tr>
<tr>
<td>Store alias names inside file</td>
<td>When selected, the Discover Network Names-derived alias list is included with the packet capture. If you do not save the alias information along with the capture buffer, statistical displays will list hardware addresses rather than meaningful names.</td>
</tr>
<tr>
<td>Save Partial Packets</td>
<td>When selected, you can set how much of each packet to save (in bytes). This allows you to collect packet headers without payloads, which may be useful from a privacy or security standpoint.</td>
</tr>
<tr>
<td>Replace hardware address in all saved packets</td>
<td>When selected, enables hardware address substitution in the saved buffer. You can have Observer substitute either MAC addresses, IP addresses, or both. In either case, the controls are the same: Original address—allows you to specify which addresses will be searched for during the replacement. Wildcard substitution with the asterisk character allows you to select multiple addresses. The last 10 specifications entered are conveniently available in a drop-down menu.</td>
</tr>
</tbody>
</table>
New address—allows you to specify which hardware address will be substituted in place of the original. An asterisk (*) or x used in the same position as the Original address specification causes that portion of the address to be retained in the saved file. For example, specifying Original address: 123.123.100.* New address: 10.20.30.*

will replace all addresses that match the 123.123.100 address segments with 10.20.30 and retain the address segment of the original where there is an asterisk. Hence the original address: 123.123.100.12 becomes the new address: 10.20.30.12, and the original address: 123.123.100.4 becomes the new address: 10.20.30.4.

As the changes are made in the saved buffer file, and not in the buffer loaded into Observer, to change several hardware addresses, it will be necessary to change while saving and then reload the buffer file for each subsequent change.

### Decrypt 802.11 WEP Encrypted Packets
If checked, you can select from several preconfigured WEP key profiles. The profiles themselves are configured as part of 802.11 setup.

### Decompress FRF.9 compressed packets
If you have captured frames from a VIAVI WAN probe, Observer can decompress the frames before saving them. Decompression will not work unless the probe captured all the packets from the beginning of a connection initialization between the router and the CSU/DSU. You can force an initialization during data collection by resetting either the CSU/DSU or the router.

### Searching for a specific packet
1. On the Home tab, in the Capture group, click **Configuration > Packet Capture**.
2. Click the **Decode** button. The Decode and Analysis window appears.
3. Click the **Decode** tab, then choose **Tools > Find Packet**. The Find Packet window appears.
4. Using the information in **Table 18 (page 117)** choose how you want to search the capture buffer.

#### Table 18. Searching a packet capture

<table>
<thead>
<tr>
<th>Raw Packet Data</th>
<th>Searches the entire raw (i.e., not decoded) packet for the given string.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decoded Data</td>
<td>Searches only the decoded packet for the given string.</td>
</tr>
<tr>
<td>ASCII</td>
<td>Interprets the buffer as ASCII-encoded text and searches for the given sequence. A maximum of 16 characters are allowed in the string. ASCII searches are case-sensitive.</td>
</tr>
<tr>
<td>EBCDIC</td>
<td>Interprets the buffer as EBCDIC-encoded text and searches for the given sequence. A maximum of 16 characters are allowed in the string. EBCDIC searches are case-sensitive.</td>
</tr>
<tr>
<td>Hexadecimal</td>
<td>Interprets the buffer as hexadecimal code and searches for the given sequence of codes (separated by spaces; e.g., C0 FF CC). The maximum value for a code is FF.</td>
</tr>
<tr>
<td>Decimal</td>
<td>Interprets the buffer as decimal code and searches for the given sequence of codes (separated by spaces; e.g., 102 90 87). The maximum value for a code is 255.</td>
</tr>
</tbody>
</table>
Find Sequence
Allows you to enter the exact string of characters or codes to search for.

Find All Conversations Containing Search Sequence
Find up to 1024 different IP/port pairs. A list of found pair is displayed. From the list you may choose up to 75 pairs to post filter.

Filtering your saved packet capture
1. On the Home tab, in the Capture group, click Configuration > Packet Capture.
2. Click the Decode button.
   The Decode and Analysis window appears.
3. Ensure you are on the Decode tab, then choose Tools > Post Filter.
4. Select your filter(s) and click OK.
   The filtered decode appears.
   For more details about the post-capture filters and for a faster filtering method, see Post-filtering your packet captures (page 97).

Processing NetFlow or sFlow data
1. On the Home tab, in the Capture group, click Configuration > Packet Capture.
2. Click the Decode button. The Decode and Analysis window appears.
3. Click the Decode tab, then choose Tools > Process NetFlow or sFlow data.
   The Select Data Source window appears.
4. Choose the data source you want to process.
5. Change your ToS/QoS settings if necessary and click OK.
   A new Decode and Analysis tab opens with your process flow information.

Packet View Settings
The Packet View Settings window is used for customizing the packet decode pane. Packet View Settings is located at Live > Packet Capture, and then click Decode > Settings and then.
Configure SNMP MIBs

The **Configure SNMP MIBs** tab displays all available compiled MIBs. Any selected are used for decoding SNMP traffic and displaying any relevant traps in packet captures.

**General**

The **General** tab controls how frames and packets are displayed in the decode pane.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto determine dynamic protocols by bit patterns</td>
<td>Designates a protocol as dynamic if that behavior can be determined</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Decode packets with bad checksums</td>
<td>Decodes packets that fail CRC checks.</td>
</tr>
<tr>
<td>Expand 2nd level trees</td>
<td>Auto-expands the tree view at the second folds.</td>
</tr>
<tr>
<td>Expand 3rd level trees</td>
<td>Auto-expands the tree view at the third folds.</td>
</tr>
<tr>
<td>Expand 4th level trees</td>
<td>Auto-expands the tree view at the fourth folds.</td>
</tr>
<tr>
<td>Mark packets in the same conversation</td>
<td>When a packet is selected, all packets in the conversation are visually identifiable by a lowercase 'c'.</td>
</tr>
<tr>
<td></td>
<td>(shown as (c) before a packet number)</td>
</tr>
<tr>
<td>Set focus on the last packet during live</td>
<td>The latest packet to arrive is always in focus and auto-scrolls the window.</td>
</tr>
<tr>
<td>packet capture</td>
<td></td>
</tr>
<tr>
<td>Show filter name window before automatic</td>
<td>Provides the opportunity to name your new filter before creating a filter using the right-click menu.</td>
</tr>
<tr>
<td>filter creation</td>
<td></td>
</tr>
<tr>
<td>Show full duplex 'Port' (or 'Link' and</td>
<td>Port information is displayed when using a Gen3 capture card.</td>
</tr>
<tr>
<td>'DCE/DTE') parameters</td>
<td></td>
</tr>
<tr>
<td>Show preview of summary content text</td>
<td>Displays a preview of summary content.</td>
</tr>
<tr>
<td>Use EBCDIC for displaying SNA data</td>
<td>Use Extended Binary Coded Decimal Interchange Code (EBCDIC) for displaying legacy IBM Systems Network Architecture (SNA) data.</td>
</tr>
<tr>
<td>Use EBCDIC for all data</td>
<td>Instead of ASCII, use Extended Binary Coded Decimal Interchange Code (EBCDIC) for displaying data.</td>
</tr>
<tr>
<td>When loading a local buffer file, exclude</td>
<td>Hides any captured Expert Information Packets when viewing a local buffer file.</td>
</tr>
<tr>
<td>expert packets from display</td>
<td></td>
</tr>
<tr>
<td>Enable type script filters</td>
<td>Allows filter creation by command-line.</td>
</tr>
<tr>
<td>Bytes per row in hexadecimal display</td>
<td>Sets how many bytes per row are shown. Depending on your preference, one may be easier for locating specific offsets.</td>
</tr>
<tr>
<td>Show decode list using</td>
<td>Sets the font display style.</td>
</tr>
<tr>
<td>Packet timing display resolution</td>
<td>Sets the precision of time stamps displayed. These options do not affect any data.</td>
</tr>
<tr>
<td></td>
<td><em>1 millisecond</em></td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1 microsecond</td>
<td></td>
</tr>
<tr>
<td>1 nanosecond</td>
<td></td>
</tr>
<tr>
<td>OUCH version</td>
<td>Sets the version of the NASDAQ trading OUCH protocol.</td>
</tr>
<tr>
<td>Auto-determine v 4.0</td>
<td></td>
</tr>
<tr>
<td>v 3.1 and prior</td>
<td></td>
</tr>
<tr>
<td>MPEG transport stream type</td>
<td>Sets which transport stream type is used when decoding.</td>
</tr>
<tr>
<td>MPEG-2 Part 1</td>
<td></td>
</tr>
<tr>
<td>DVB</td>
<td></td>
</tr>
<tr>
<td>ATSC</td>
<td></td>
</tr>
<tr>
<td>ISDB-T</td>
<td></td>
</tr>
</tbody>
</table>

**Protocol Colors**

The **Protocol Colors** tab configures the text and background colors used for specific protocols. If selected, the protocol is colored accordingly. If cleared, the protocol is not colored accordingly.

**Protocol Forcing**

The **Protocol Forcing** tab forces recognition of unknown protocols by assigning each a custom offset.

**Summary**

The **Summary** tab sets the information shown in the summary column of the decode window.

**TCP/UDP/SCTP Application Colors**

The **TCP/UDP/SCTP Application Colors** tab configures the text and background colors used for specific applications. If selected, the application is colored accordingly. If cleared, the application is not colored accordingly.
Chapter 7: Expert Analysis

Expert analysis events can tell you if something is wrong with the network, based on thresholds you configure. Expert analysis also allows you to use or view server analysis, time interval analysis, TCP stream reconstruction, response time and network delay calculations, and connection dynamics.

Preparing expert decoding techniques

Real-Time Expert is the collection of tools in Observer that help you identify network problems and determine a course of action; these tools provide expert decoding techniques.

With Real-Time Expert, you can obtain post-capture expert event identification, explore expert analysis, reconstruct TCP streams, and model network traffic.

There are several ways to approach a network problem with Real-Time Expert. As with any network problem, you should first determine if you can reproduce the problem. If you can reproduce the problem, set up a capture to collect data for the entire event (start to finish) and then use the Expert in post-capture mode to identify possible causes of the event. Otherwise, begin using Real-Time Expert while a packet capture is running—this is real-time mode.
To begin using Real-Time Expert and its advanced decoding techniques, you must first configure the Expert system; this is a two-step process, which is described in these sections:

- Configuring global settings (page 123)
- Configuring expert thresholds (page 134)

Follow the configuration steps described in each section. When both steps are complete, you can begin using Real-Time Expert with confidence in its results.

**Configuring global settings**

Real-Time Expert allows you to configure its global settings via the Expert Global Settings window. These global settings influence how Real-Time Expert displays its results and how you, as a user, interpret their meaning.

*Note:* This section assumes you are familiar with creating packet captures and the packet capture window in general. See Capturing network traffic (page 84) for more information.

To configure global settings for Real-Time Expert, complete the following steps:

1. On the Home tab, in the Capture group, click **Configuration > Packet Capture**.
2. Click the **Decode** button. The Decode and Analysis window appears.
3. Ensure the Expert Analysis tab is selected.

Figure 31: Expert Analysis tab location
4. Click the **Settings** button. The Expert Settings window appears.

5. Change settings in any or all the tabs to suit your needs.

6. Click **OK** to confirm and save your changes.

You completed the first of two configuration steps for making Real-Time Expert work best on your network. If you previously have not, follow the instructions in the second step, **Configuring expert thresholds (page 134)**.

After completing this task:

The options on the General tab allow you to enable or disable each analysis type (TCP, UDP, and so on). Changes made here are global to the local Observer and impact the current window and all newly opened windows after making any changes. When an item is disabled, it is not visible on the Expert Analysis tab and the corresponding packet processing does not occur. These changes affect packet decoding only. Network trending is not affected.

### What is goodput?

Goodput is a reported value for some events, especially TCP Events, UDP Events, and Time Interval Analysis. **Goodput** is the application level throughput, i.e. the number of useful information bits, delivered by the network to a certain destination, per unit of time. The amount of data considered excludes protocol overhead bits as well as retransmitted data packets. This is related to the amount of time from the first bit of the first packet is sent (or delivered) until the last bit of the last packet is delivered.

### Network delay calculation

Network delay is calculated using the SYN - SYN/ACK - ACK packets. If you are not seeing any SYN, SYN-ACK and ACK packets, network delay cannot be calculated.

**Note:** If we later see an ACK to DATA that is faster than the TCP handshake shown in Figure 32 (page 125), we would reduce the network delay to that faster time.

The time between a client sending a SYN and it receiving a SYN/ACK from the server provides the **server network delay**, and the time between the server sending a SYN/ACK to when the server receives this ACK from the client indicates the **client network delay**. This is shown in Figure 32 (page 125).
Response time calculation

Response time is calculated using the time difference between data packet request to data packet response. Response time is not calculated with SYN, SYN/ACK, or ACK packets.

There is one circumstance where SYN-ACK is used for calculating client response time. The very first client response time is calculated by measuring the time difference between the server SYN-ACK and the client’s first data packet. In all other circumstances, the time between data request and data response is used for calculation, as shown in Figure 33 (page 125).

Figure 33: Response time calculations

Using Expert Summary

Expert Summary displays all general, non-conversation specific problems that Observer finds when analyzing the packet capture. Over 700 different expert...
events can appear here, which you can right-click to further interact with. Expert Summary also provides easy access to viewing utilization rates.

The Expert Summary group tab includes three panels:

- Summary graph (top)
- Network Conditions Summary table (middle)
- Expert Analysis panel (bottom)

The Network Conditions Summary table automatically alerts you of many network events, and one is the presence of duplicate IP addresses. Observer does not have an option that shows cloned MAC addresses. However, seeing duplicate IP addresses can help you see cloned MAC addresses, depending on your network environment.

Furthermore, there are three scenarios which can trigger seeing duplicate IP addresses and potentially retransmissions or duplicate packets because of it:

- Two MAC addresses (IP address is traveling layer 3)
- Two static IP addresses
- Cloned MAC addresses

If you see duplicate packets or retransmissions caused by duplicate addresses, clear the option "IP Duplicate Address and Routing Problems" from the Network tab of the Expert Thresholds (OSI Model) window.

**Note:** Expert Summary panels. The Summary graph shows utilization by percent of bandwidth and packets per second. If an expert threshold has been exceeded, the top line of the graph (labeled with the alarm) will show a red bar; hovering your cursor over the bar will show details of the event. The Network Conditions Summary table shows any expert thresholds exceeded, including the number of occurrences and a description of the event. Right-click any item to view more details. The Expert Analysis display panel offers general instructions on what options are available in the display and may offer a short explanation of the highlighted item.

### Using Time Interval Analysis

The Time Interval Analysis displays TCP or UDP Event conversations in a table format showing the conversation split up by the user-defined period.

To access the Time Interval Analysis display, right-click a conversation in either the TCP Events or the UDP Events. Select Time Interval Analysis and then choose your connection option.

Time periods can be defined by either right-clicking on the display and selecting Properties, or by selecting the Time Interval Analysis tab from the Expert Global Settings.

Columns include Network Utilization and Network Packets/sec to help determine, for each Time Interval Analysis, what the overall network conditions were and how that may have affected the errors observed.

If you are not seeing any values under Network Utilization, make sure that you have the option to collect Expert Load Information Packets checked on in the Packet Capture setup.

The Notes section displays the type of conversation and the stations listed.
Using Server Analysis

Server Analysis shows how well a server is responding under various load conditions. For best results, you should analyze a packet capture obtained over a range of typical load conditions for that server.

To perform Server Analysis, right-click any connection to the server you are interested in—TCP Events or UDP Events—and click Server Analysis. The Server Analysis window appears.

If there is a smooth, linear increase in response times as the number of simultaneous requests increases, then this kind of pattern (or a chart that shows little increase in response time) means that the server is handling observed loads well. If the chart shows a more exponential increase after a certain number of simultaneous requests, it means that you should perhaps obtain faster processors or hard disks for your database server.

The Server Analysis displays are designed to help evaluate a server’s or system’s response time under various load scenarios. The server in Server Analysis can be selected in several ways. From either the TCP Events or UDP events, right-clicking on any conversation will offer access to Server Analysis for either station in the right-click menu, or by clicking the Server Analysis button and selecting the server from the drop-down list at the top of the display.

The graph on the top of the Server Analysis display shows the response times for each level of simultaneous requests. An average line is shown for baselining purposes.

Using End-to-End Analysis

With End-to-End Analysis you can determine the exact time conversations between two network points occurred. Observer provides in-depth conversation information on the exact network delay between the two points.

**Prerequisite(s):**

For End-to-End Analysis to determine the exact time conversations occurred between two network points, the three-way handshake must be seen. Additionally, the handshake must be seen on a known protocol.

Observer monitors point-to-point connections using the End-to-End Analysis feature.

**Note:** End-to-End Analysis does not support MultiHop Analysis. For that you must use the MultiHop Analysis feature. See Using MultiHop Analysis (page 135).

To configure end-to-end analysis, complete the following steps:

1. Ensure you have two saved capture files to compare.
2. On the Home tab, in the Analysis group, click Server Analysis.
3. Click the Select Files to Analyze button. The End to End Server Analysis Settings window appears to the Files tab.
4. Click Add to select the files to analyze. You may add several files to the list; however, you may only compare two files at a time.
5. If any address translation (NAT) occurs, define the address in the IP Mapping section.
6. Click the **General Tab**.
7. Click **OK**.
8. Expand the server list and choose one or more servers and click Server Analysis.

   The Server Analysis window shows server and network delay, load, and utilization.
9. To view the connection dynamics, hop summary, and summary statistics, click the End to End Drill Down tab.

### Using “What-if” modeling

**Prerequisite:** Observer Expert or Observer Suite

Observer What-if Analysis tools lets you virtually test different network and server configuration scenarios based on actual usage patterns captured from your network. It helps you answer the following types of questions:

- Will buying more bandwidth improve response times for my users, or would my money be better spent on faster servers, hard disks, or clients?
- How would telecommuting over a modem or DSL line affect a particular user's response time?
- How would adding more users to a database application affect server response times?

To display the What-if Analysis for any conversation, right-click any conversation that shows a delayed response time and select What-If Analysis from the popup menu. You can change various parameters in the dialog below the what-if graph and see the results immediately.

The top of the display shows transfer rate, response time, or utilization rate given various network bandwidths, extrapolated from the data measured on your network's bandwidth (which is identified by a reference line. As with any such extrapolation, the more data sampled, the more accurate the predictions.

### Tell me more about the What-if Analysis tool

What-If live modeling and analysis offers both a predictive tool for modeling potential response times, utilizations, or packets per second at different network speeds, and also permits you to change different conversational and network metrics to predict changes in performance with the new values.

The What-If Analysis starts with a conversation collected from your network and bases all predictions on your actual network data. Different system formulas are used for different types of systems to be modeled.

To begin your What-If live modeling session, right-click a conversation from either the TCP or UDP Events display and select What-If Analysis.

You can only do What-If modeling on conversations that have a recorded server (the second address in any conversation) delay.

The top of the display will show which stations are currently being modeled. The client is on the left, the server is on the right.
The X-axis of the graph will always display different network speeds. If the data collected was from Observer, a vertical reference line will be displayed showing the network speed at which the data was collected.

The Y-axis will display different values depending on the graph type selected. A key display will show the different items on the graph and their associated colors.

The items below the graph initially represent the actual data from the captured conversation. Items can be changed to model changes in the network.

Observed Connection Parameters (derived directly from the conversation data collected):

**Average Packet Size (Bytes)**—displays the average size of the packets sent from the client and the server. Changing these values in the Client or Server options will model changes in network performance.

**Latency (mSec)**—displays the average latency time as observed in the transaction conversation. Values are shown for packets sent from the client and the server. Changing these values in the Client or Server options will model changes in network performance.

**Transaction Packet Ratio**—displays the transaction packet ratio of the packets sent from the client and the server.

**Utilization from other sources (%)**—sets the network utilization to simulate. This would be beyond the current conversational conditions recorded, and only changes the modeled values if the option to Include utilization from other sources in What-If Analysis is checked in the Expert Global Settings, What-If tab setup.

User-Defined Parameters are initially set in the Expert Global Settings, What-If tab. Changing the values here will only affect the current calculation and will not be preserved for subsequent modeling sessions.

**Graph type**—changes what modeling results will be displayed in the graphic view. Options include Packets/sec, Response time (sec), and Utilization (%). While all three views are related, select the view that displays the option you are interested in.

**Simultaneous users**—sets the number of users to simulate.

**Processing Time (ms)**—the amount of time, in milliseconds, that the server or client will take to process the request.

Server Characteristics:

**Server type**—options include Database, FTP, Level, and web servers. Each different server selection causes the expert to use a different formula suited for the selection. A level server offers a formula for a typical server.

**Start thread time (ms)**—taken into account when the Server type item is defined as web. The value is the amount of time it takes to process a thread on the server.

**Arrival rate (trans/sec)**—taken into account when the Server type item is defined as Database. The number of transactions per second that are being requested of the (Database) server.
Maximum adapter card throughput (Mbps)—taken into account when the Server type item is defined as FTP. This item defines the server’s maximum throughput. This may be the rated speed of the adapter, but most likely it is some fraction of the maximum theoretical speed (utilization) of the network. The default of this item is set in the Expert Global Settings, under the What-If tab.

One way to get a value for this option is to run Observer on the server using the packet generation mode. Set the generation rate very high and view the utilization that the server can create using Observer’s utilization modes. The maximum utilization will reflect the NIC card’s ability to generate traffic.

Restore Original Values—resets all values to the initial settings for the analyzed pair.

Set Reference—sets the current graph lines to the reference line. For example, if you change the number of simultaneous users from 1 to 100, a What-If prediction line will be displayed and the original reference line will be displayed. If the Set Reference is pressed, the new What-If prediction line will become the reference line for further What-If modeling.

Reconstructing TCP data streams

Prerequisite: Observer Expert or Observer Suite

When analyzing a previously-saved buffer that includes TCP communications, you can right click any such communication from the decode, connection dynamics, or TCP Events displays and choose Reconstruct Stream or TCP Dump from the popup menu.

Note: Stream reconstruction can only be performed post-capture.

Both Reconstruct Streams and TCP Dump show you the stream, but they do show in different manners. If you need a quick view of the stream, choose Reconstruct Streams. If what you need is not available there and you need to dig deeper into the stream, choose TCP Dump.

The streams that Observer can reconstruct are:

- DAAP (iTunes sharing)
- FTP
- HTML
- HTTP
- IMAP4
- NNTP
- POP3
- RTSP (streaming audio/video)
- Shoutcast (streaming audio)
- SMTP
- Telnet
- WMPNSS (Windows Media Player sharing)

Note: Several media codecs are supplied with Observer so that Observer can reconstruct numerous media types. If you have an application that uses a codec that is not part of Observer, you can still reconstruct that media stream if the codec is installed on the analyzer system. Before reconstructing a media file Observer searches its own list of codecs. If it does not find a suitable codec, it searches the Windows system for one. If it finds one, you can reconstruct the stream. For a list of supported codecs and protocols, see .
Tell me more about stream reconstruction

You can change the display format to raw data, packet headers, or packet headers with links to any files that were reconstructed (which is the default setting). You can also have Observer display only the links. To change the format, right click anywhere on the reconstructed display and choose Format from the popup menu, then the format option you wish to apply. Where links are displayed, clicking on them opens the file using the default application for the particular file type. For example, HTML files will be opened in your operating system’s default web browser.

Using Connection Dynamics

Connection Dynamics show a selected conversation graphically illustrating the inter-packet delays as spacing between packets.

**Prerequisite:** Observer Expert or Observer Suite

Packet-to-packet delay times are shown graphically, allowing instant identification of long latency and response times. Retransmissions and lost packets are flagged in red for quick identification. The packet display can contain either a brief or detailed view of each packet’s contents.

To access Connection Dynamics, right-click a conversation in either the TCP Events or the UDP Events and select Connection Dynamics. Once a conversation has been displayed in Connection Dynamics, it can be reviewed by clicking the Connection Dynamics button on the Expert button bar.

Connection Dynamics show a selected conversation graphically illustrating the inter-packet delay as a spacing between packets. Packet-to-packet delay times are shown graphically, allowing instant identification of long latency and response times. Retransmissions and lost packets are flagged in red for quick identification. The packet display can contain either a brief or detailed view of each packet’s contents. For example, if you see delays in query response time from a database server, it could mean that your server’s processor is overloaded and needs to be upgraded. It could also help pinpoint problems with custom applications running on servers.

After accessing Connection Dynamics—the tool itself—the time line format lets you quickly see long latencies and delayed response times. Retransmissions and lost packets are flagged in red.

Place your mouse cursor over a packet; it will turn blue. At the bottom of the screen (above the lower tabs Expert Analysis, Decode, Summary, and others) more detailed information for that packet is shown. In general, the information has abbreviated titles:

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S^1</td>
<td>Sequence Number</td>
</tr>
<tr>
<td>A^1</td>
<td>Acknowledgment Number</td>
</tr>
<tr>
<td>EA^1</td>
<td>Expected Acknowledgment Number. This value is calculated by Observer and is not part of any byte within the TCP header.</td>
</tr>
<tr>
<td>W</td>
<td>Window Size</td>
</tr>
<tr>
<td>P</td>
<td>Port Number</td>
</tr>
<tr>
<td>DataLen</td>
<td>Data Length</td>
</tr>
<tr>
<td>Seq</td>
<td>Sequence Number</td>
</tr>
</tbody>
</table>
### Table 1. Connection Dynamics Definitions

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ExpAck</td>
<td>Expected Acknowledgment Number</td>
</tr>
<tr>
<td>Ack</td>
<td>Acknowledgment Number</td>
</tr>
<tr>
<td>Wnd</td>
<td>Window Size</td>
</tr>
<tr>
<td>Port</td>
<td>Port Number</td>
</tr>
<tr>
<td>AbsoluteTime</td>
<td>Absolute Time</td>
</tr>
<tr>
<td>TSN</td>
<td>Transmission Sequence Number</td>
</tr>
<tr>
<td>DupTSN</td>
<td>Duplicate TSN detected. This value is reported by the SACK packet.</td>
</tr>
<tr>
<td>GapACK</td>
<td>Gap in TSN sequence detected. This value is reported by the SACK packet.</td>
</tr>
</tbody>
</table>

1. These are used to validate that data has been received properly. The time difference between packets 9 and 10 is the length of time it took the server side (the system on the right) to respond back to the clients request (the system on the left).

Now, by right-clicking any packet you can:

- jump to the Decode window display of that particular packet,
- toggle the display packet Details on or off, or
- change the zoom level of the Connection Dynamics window.

Press the **Tools** button and select **Find Packet**. This opens the Find dialog box so you may specify search criteria. Use this tool to help you find what you are looking for in a long sequence of packets.

### Tell me more about the Connection Dynamics tool

The Connection Dynamics display consists of the graphical display and a status bar that changes as you hover your mouse over a particular packet.

When no packet is under the mouse, the status bar displays the type of conversation in the display (TCP or UDP), the conversation's duration (in seconds), and packet count. Connection Dynamics uses the TCP or UDP sequence and acknowledgment numbers to determine the packets color and type.

#### Color codes and packet types

The packet square under the cursor will always be blue. When a packet is not under the cursor, the color of the packet squares and accompanying packet frame gives information about the packet. Packets are colored according to the following rules.

- **Blue** – The selected packet.
- **Green (Dark)** – One of these:
  - Default – Expected packet data.
  - SCTP SACK Gap ACK – Indicates that gap ACK blocks were found.
- **Magenta** – Application.
- **Magenta (Dark)** – Skipped packet (shortened to “Skip pkt”). Observer sees a sequence number that is higher than the expected acknowledgment. The expected acknowledgment is a calculation that Observer does—it is not something that is in the actual packet. It is the sequence number plus the total data length to determine the expected acknowledgment.
- **Orange (Dark)** – Keep alive packet. A keep alive packet is sent between stations to keep the TCP session open even though no actual data is being sent. This is very typical of an application which requires user input

This is a typical example of a skip packet, which is a packet that is not in sequence with the rest of the packets.
to continue, such as a Telnet session. Eventually the session may time out, but this is due to the application settings and not an issue within the network itself. Observer identifies a keep alive packet by seeing the sequence number from one packet to the next going backwards by 1. If the sequence number of one packet #1 was 938475892 and the second packet was 938475891, and the second packet contained no data, this would be a keep alive packet. If the second packet contained data, it would most likely be a resent packet, though you rarely would ever see a data packet with only one byte of data.

♦ Red – One of these:
  - Retransmitted packet (shortened to “Retrans”). This is based on Observer seeing two packets with data having the same sequence number.
  - Reset. The RST flag is set and the conversation abruptly ended. It may have ended for any number of reasons, including the port not being open or the intended service is not running. Reset packets may also be considered part of an RST attack.
  - Red (Dark) – Zero window. The Window Size within the TCP header indicates a size of 0. This means no data can be received by the device sending the Zero Window TCP packet. This halts communication until another packet indicates it has a window size above zero.
  - Red (Medium) – Out of order packet. An out of order packet is exactly what it sounds like. It is a packet whose sequence number indicates that packets came into the NIC out of sequence, for example 1, 3, 2, 4 instead of 1, 2, 3, 4).

♦ Yellow – One of these:
  - Rerouted packet. Observer sees a duplicate packet, but the MAC addresses (source and or destination – typically both – are different between the duplicate packets). This usually affects the TTL within the IP header when packets are routed, but Observer ignores this and pays attention only to the sequence numbers.
  - Warning packet. Observer sees a Re-ACK packet. A packet was sent saying that data was received, then another packet is sent again using the same acknowledgment number saying data was received and this new packet contains no data, so it is a duplicate of the previous packet.
  - SCTP SACK Dup TSN. Observer sees a duplicate TSN in the SACK chunk.

What are skipped packets, and why are they appearing?

When a series of TCP packets comes into Observer, each packet will contain a sequence number. Packets should arrive in numerical order. If, however, a packet is missing, Observer identifies that missing packet as a “Skip pkt” if the client side acknowledges the missing packet.
For example, if you see packets 1, 2, 3, 4, 6, 7, and 8, Observer would identify packet 5 as “Skip pkt”, because there is a gap in the sequence between packets 4 and 6. There are two reasons why this could happen:

- The amount of data coming into the capture adapter is so high that Observer dropped packets. This is indicated by a red line in the Packet Capture tool.
- To resolve this issue, you should limit the amount of data being spanned into the system, as this is a CPU issue on the switch rather than an issue within the Observer application or the hardware it is using to do the capture.

## Configuring expert thresholds

Expert thresholds define what parameters are used when determining if a particular event is a problem or not. Thresholds are set for all Expert events, and for some events, more than one threshold is set. For example, for TCP Bad Checksums, only the number of frames during the entire capture process is set. Conversely, for FTP Session delays, values are set for slow connect and slow response, including values for grading marginal and critical for each.

**Note:** This section assumes you are familiar with creating packet captures and the packet capture window in general. See Capturing network traffic (page 84).

To configure expert thresholds, complete the following steps:

1. On the Home tab, in the Capture group, click **Configuration > Packet Capture**.
2. Click the **Decode** button. The Decode and Analysis window appears.
3. Ensure the Expert Analysis tab is selected.
   Figure 34: Expert Analysis tab location

4. Click the **Expert Thresholds** button. The Expert Thresholds (OSI Model) window appears.
   Figure 35: Expert Thresholds button location

5. Click **OK** to confirm and save your changes.

You completed the second of two configuration steps for making Real-Time Expert work best on your network. If you have not already done so, follow the instructions of the first step, Configuring global settings (page 123).
Tell me more about expert thresholds

Expert thresholds are set for all Expert events, and for some events more than one threshold is set. For example, for TCP Bad Checksums, only the number of frames during the entire capture process is set. For FTP Session delays, values are set for slow connect and slow response, including values for grading marginal and critical for each. Values for network and WAN/Internet response times values are also set.

Because of the potentially large number of values that are required and because many different network/WAN/Internet configurations dictate predictable value sets, Real-Time Expert Thresholds permit the user to save profiles for sets of values. The thresholds configuration displays are loosely based on the OSI model, separating different expert items from where in the communications stack the item is found.

Using MultiHop Analysis

Prerequisite: Observer Expert or Observer Suite

MultiHop Analysis is a powerful tool in Observer; it graphically shows you network conversations that traverse multiple network hops, making it easy to determine if delays are due to a particular router hop. For example, if you have a corporate LAN spread across remote offices, MultiHop Analysis can tell you which routers are causing network delay between remote offices and corporate headquarters.

If you ever encounter problems with MultiHop Analysis, see Troubleshooting synchronization errors (page 140) or call the support team if you encounter issues specific to your network environment.

Tip! VIAVI included sample capture files so you can try MultiHop Analysis. These files are located in the \data subdirectory of wherever Observer was installed (C:\Program Files\Observer by default).

Before using the MultiHop Analysis tool, we recommend you become familiar with the user interface and creating packet captures from multiple probe instances—see Capturing from multiple probe instances (page 84) for details.
To use MultiHop Analysis, complete the following steps:

1. Create and save multiple capture files—simultaneously—from multiple probe instances.

   When capturing from multiple probe instances, there exists an option to immediately bring those captures into the MultiHop Analysis tool. For the sake of example, however, the proceeding steps ignore using that option.

2. On the Home tab, in the Analysis group, click MultiHop Analysis.

3. Click the Select Files to Analyze button. The MultiHop Analysis Settings window appears.

4. Ensure the Files tab is selected, and click the Add button. The Edit Segment File dialog appears.

   Figure 37: The Edit Segment File dialog

Note: MultiHop Analysis only operates in post-capture mode; therefore, to make the tool work, you must absolutely save (or have saved) your capture files to disk and have access to those files.
5. Type a descriptive name for your segment. In MultiHop Analysis, each capture file is called a segment.

6. Browse to or type the file location of the first capture file.

7. (Optional) If you know or anticipate that IP addresses will not match between hops, enable the Apply IP Mapping option and click the Settings button.
   
   IP mapping keeps track of network entities as they undergo network address translation. For more information about this option and its use, see How to use IP mapping in MultiHop Analysis (page 141).

8. Click OK to confirm this segment's inclusion.

9. Repeat step 4 through step 8 for each capture file (segment) that you want to add to your MultiHop Analysis session. Up to ten segments can be added during this step; ten is the maximum.

10. Ensure you return to the MultiHop Analysis Settings window (which appeared in step 3), and click OK.
   
   You successfully prepared the MultiHop Analysis tool and can now view and analyze the results.

Tell me more about the MultiHop Analysis tool

All of the connections detected are listed in the upper left corner of the MultiHop Analysis display. Choose each connection you want to analyze by clicking on its corresponding check box. For the MultiHop Analysis display, it is usually more useful to look at one connection at a time.

The Hop Summary view shows delay data from the selected connections in aggregate, giving you the average delay time from multiple conversations over time. Knowing what is “normal” can help you determine when applications or third party service providers are performing adequately.

Most of the metrics (minimum and maximum delay times in total and by segment, for example) should be self-explanatory. Lost Packet Delay Time measures how much delay was introduced by dropped packets having to be re-sent.

The Summary Statistics view of MultiHop Analysis gives you a textual display of the selected connections (computed in the MultiHop Delay Analysis – Connection Dynamics view). You may select one or many connections. The statistics summary gives you details on the analyzed packets, such as: number of packets analyzed, delay time, matched packets, direction of packets, dropped packets (will be displayed in red type), time of first packet, and time of last packet.

The first part of the summary shows paths to all of the buffer files currently being analyzed and summarizes settings in effect. The second part of the summary shows essentially the same measurements as the MultiHop connection dynamics and MultiHop Analysis displays, summarized in a list format. As in the MultiHop Analysis display, Lost Packet Delay Time measures how much delay was introduced by dropped packets having to be re-sent.

Quickly using MultiHop Analysis

Your method of using MultiHop Analysis can differ depending on how you obtain, or obtained, the capture files you want to work with. For example, using MultiHop Analysis can be difficult if you have capture buffer files obtained
at different times or from probe instances you have no personal access to but someone else does and has sent you captures. Those circumstances are best handled using the process described in Using MultiHop Analysis (page 135)—and not this section.

This section describes the most efficient, easiest, and quickest way to use MultiHop Analysis but unlike the other section, it requires the following criteria be met for the process to work correctly:

- You must have access to all target probe instances from your local Observer (i.e. from the local machine). Ensure that each is in your probe list, is configured, and connected.
- You must have sufficient capture buffer sizes across all target probe instances; you do not want one of the probe instance capture buffers to max out too early—leaving you with too little data.
- Like other captures, you must have sufficient disk space to save the file(s). This becomes increasingly important when using MultiHop Analysis because you are simultaneously creating and saving more than one capture file, and the disk space required is increased accordingly.

To quickly use MultiHop Analysis, complete the following steps:

1. On the Home tab, in the Capture group, click Configuration > Capture Multiple.
2. Select each probe instance that you want to capture from.
3. (Optional) Set a pre-filter on any probe instance by selecting a probe instance and clicking Set Filter for Selected Instance.
4. Click Start to begin the packet capture on multiple instances.
   The Multiple Instance Packet Capture dialog appears, indicating the capture is actively running. Allow this dialog to remain on your screen.
5. In the Multiple Instance Packet Capture dialog, ensure both “Transfer and Save Packet Captures” and “Start MultiHop Analysis” are enabled.
6. In the Multiple Instance Packet Capture dialog, click Stop. The MultiHop Analysis Settings window appears—automatically loading and listing your new capture files.
7. (Optional) Configure any additional settings now.
8. Click OK. The MultiHop Analysis tool opens, and your analysis can now begin.

You successfully used MultiHop Analysis quickly and efficiently. This method is the quickest way to perform MultiHop Analysis, although this method does have necessary requirements.

Configuring MultiHop Analysis settings

Click the Settings button on the MultiHop analysis tool bar to specify capture files and other configuration options. Usually, the default settings will provide satisfactory results; only adjust if you run into performance problems.

The first tab, Settings, has options to specify the methods that MultiHop analysis uses to identify connections and synchronize timestamps on the files.

| IP Address + IP ID (Port mapped) | This option is best for networks that implement Network Address Translation (NAT) firewalls between segments. |
IP Address + IP ID + TCP/UDP Ports (Ports will match) | Choose this option (which is the default) for networks without address translation or port mapping.
---|---
IP Address + TCP Sequence number (TCP only, port mapped) | Choose this option if your network includes Network Address Translation (NAT) firewalls, and the volume of packets in the captures is causing the IP ID numbers to be recycled (i.e., reset to 0).
---|---
IP Address + TCP Sequence number (TCP only, ports will match) | Choose this option if your network does not have any Network Address Translation or port mapping, and the volume of packets in the captures is causing the IP ID numbers to be recycled (i.e., reset to 0).
---|---
Maximum packets to analyze per connection | Allows you to select the maximum number of packets you want to analyze; only active if the Enable is selected.
---|---
Enable | Allows you to limit the number of packets to be analyzed.
---|---
Defaults | Changes the settings back to their default values.

**File Synchronization Method**

File synchronization is at the heart of MultiHop Analysis. By aligning the files in time and determining whether timestamp differences are the result of delay versus clock drift and other collection artifacts, Observer can show you not only aggregate delay, but also the proportion of delay with each hop.

**Identifying how much data to synchronize and where to start**

There are many possible methods that Observer can use to synchronize the files. The best one to use depends on two factors: How long were the captures? and How closely in time were the captures started and stopped?

This is because of a phenomenon called clock drift: two system clocks inevitably drift apart because no two clock crystals are exactly the same, and even if they were, ambient temperature differences also affect clock rates. On shorter captures (i.e., four minutes or less), this is not usually an issue, so choose the first option. For longer captures (more than four minutes), the best method to choose depends on how closely the buffer files’ start and stop times conform to each other.

- Synchronize using all data from both files—This method is best for shorter captures (of four minutes or less) where all the captures were started and stopped within a second of each other, and clock drift is not an issue.
- Synchronize using a sliding window having the smallest variance—Using this method, Observer analyzes the two packet captures to find a window of time where the timestamps coincide with the least variance. This method is best for finding transactions across longer captures that were not very precisely synchronized regarding start and stop times.
- Synchronize at the beginning of the files with a clock drift correction—This method (the default) corrects for the inevitable differences between probe system clocks by comparing the beginning and end packets of all captures to determine clock drift. This method is best for longer captures (of four minutes or more) where all the captures were started and stopped within a few seconds of each other.
Identifying synchronization artifacts versus actual delay

Different methods work better for determining synchronization artifacts (such as clock drift and other system clock differences) versus actual delay caused by the network.

- Calculate synchronization using average delay times—Choose this option if delay times are fairly uniform and short (such as delay times typical between local network segments).
- Calculate synchronization using minimum delay times—Choose this option (the default) if there are longer delays between segments, or delay times vary from short to long (such as delay times that would be typical of a WAN connection to a remote segment of your network that experiences congestion).
- Time Synchronization Window (msecs)—Use the default value (20000) in most cases. If packet IDs are being recycled (e.g. reset to zero) because they are being used up too quickly due to the volume of traffic, you can set this value lower.

Use Header following the GRE or GTP Header for Encapsulation/Tunneling—GRE (Generic Routing Encapsulation) and GTP (GPRS Tunneling Protocol) are two encapsulation protocols that may have been deployed on your network. To show the encapsulation IP addresses, leave the box unchecked; to show the nested IP addresses, check the box.

Troubleshooting synchronization errors

File synchronization is essential to MultiHop Analysis, and it is automatically attempted by Observer. By aligning the capture files in time and determining whether timestamp differences are the result of delay versus clock drift and other collection artifacts, Observer shows you not only total delay, but also the proportion of delay with each hop.

This, however, is the reason why synchronization errors are troublesome while using MultiHop Analysis—errors must be avoided for the tool to work as intended. If you cannot avoid synchronization errors, there exists a troubleshooting method called user offset, which could fix the issue.

Tip! Typically, user offset never needs adjusting because Observer automatically synchronizes your segments. However, adjusting user offset is useful when manual control is your absolute top priority.

Note: The following steps assume you have already loaded two or more segments into MultiHop Analysis. See Using MultiHop Analysis (page 135) and Quickly using MultiHop Analysis (page 137).

To troubleshoot synchronization errors, navigate to the user offset values by completing the following steps:

1. On the Home tab, in the Analysis group, click MultiHop Analysis.
2. Click the Settings button.
3. Click the Synchronization tab. This tab lists your loaded segments and the time synchronization(s) currently applied to them.
4. Adjust the values in the User Offset (sec) column.
After completing this task:
Some experimentation may be required when adjusting your user offset values; this process is iterative, so you can keep adjusting until you are satisfied with the results.

How to use IP mapping in MultiHop Analysis

Many devices in your network environment can perform Network Address Translation (NAT), such as routers and load balancers. As NATing occurs, the IP address of the network device changes, and, if not accounted for in Observer, would cause issues with the MultiHop Analysis tool because it is designed to follow an address through its entire journey. The IP mapping option exists so you can tell Observer, for example, that local IP address 10.0.36.100 is the same station/device as 218.xx.xx.xx on the full Internet.

**Tip!** IP mapping assumes you know exactly how one IP address translates to another after NATing. After you study how the devices in your network are NATing, IP mapping becomes a quick and simple process.

**Note:** The following steps assume you have already loaded two or more segments into MultiHop Analysis. See Using MultiHop Analysis (page 135) and Quickly using MultiHop Analysis (page 137).

To use IP mapping in MultiHop Analysis, complete the following steps:

1. On the Home tab, in the Analysis group, click **MultiHop Analysis**.
2. Click the **Select Files to Analyze** button.
3. Double-click a file segment to edit it. The Edit File Segment dialog appears.
4. Enable the Apply IP Mapping setting.
5. Click the **Settings** button. The IP Mapping Settings window appears.
6. **(Optional)** In the Profile area, click Add to create a new profile.
7. Click the **Add** button, and type the IP addresses that should correspond to each other after NATing.
   
   For example, specify that the IP address 10.0.36.100 is the same station/device as 218.xx.xx.xx on the full Internet.
8. **(Optional)** Repeat the process for each desired IP mapping and for each segment file (if necessary).
9. Click **OK** twice to confirm and save your changes.
Chapter 8: Alarms

Alarm can be made in Observer with triggers and actions. A trigger is an event on your network, while an action is what should happen or who will be automatically notified if necessary.

Configuring and using alarms

Using alarms, you can trigger pre-defined actions to occur when network conditions are met, making network management simpler and more predictable.

Alarms are a powerful and often overlooked feature of Observer. Best of all, alarms allow you to proactively manage your network no matter where you are physically located.

There are two locations in Observer where alarms can be enabled, disabled, and configured. You may enable or disable all alarms associated with a specific probe instance or you may choose to disable individual alarms.

Alarms can be triggered on ATA response times measured in milliseconds (for example, 0.001).

Enabling probe instance alarms

Probe instance alarms are tied directly to your probe instances. Each probe instance alarm is the alarm gatekeeper for one probe instance.

This means individual alarms only function if its respective probe instance alarm is enabled. The benefit of this design allows you to enable or disable all alarms without affecting the enabled/disabled status of the underlying individual alarms.

Note: If you are using Observer in analyzer mode and switch to its Expert Probe interface, any alarms you had directed to the analyzer are
To enable a probe instance alarm, complete the following:

1. Click the **Alarms Settings** button, near the bottommost portion of Observer’s window (circled in the image).

   Figure 38: Click the **Alarm Settings** button

2. Enable any probe instance alarm by enabling your chosen probe instance.
3. Click **OK** to save your changes.

You successfully enabled the probe instance alarm for your chosen probe instance; this setting persists until disabled. Individual alarms can now be configured and used, and such information can be found in [Enabling individual alarms](page 143).

---

**Enabling individual alarms**

Individual alarms are individual, trigger-based network alarms. Before these alarms can prove useful, they must be enabled. There are four basic types of alarms in Observer:

- **Predefined Alarms**—These are alarms created by VIAVI and includes alarms for packet size, checksum, Bit Torrent, duplicate IP addresses, microbursts, VoIP, and more.
- **Trading Multicast Dropped Sequence Alarms**—These alarms must be wholly created and configured by you because it requires specific details about your trading and network environment. There are several pre-defined trading multicast protocols that you can import for the alarm.
- **IPTV Alarms**—These alarms must be wholly created and configured by you because it requires specific details about your multicast stream and device environment.
- **Filter Based Alarms**—These alarms based on packet capture filters that exist in Observer.

**Note:** You cannot set an alarm for excessive retransmissions or high latency, nor can either be custom created. Instead, you can see these events (if they occur) using Expert Analysis. See .

Enable individual alarms by completing the following steps:

1. Click the **Alarms Settings** button, near the bottommost portion of Observer’s window. The Alarm Settings window appears.
2. Click a probe instance to highlight it.
3. Click the **Selected Instance Alarm Settings** button. The Probe Alarms Settings window appears.
4. Enable each alarm you want to enable.

   Until you customize the alarms, Observer uses the built-in, default triggers and actions for each. If necessary, see these pages:
   - Customizing triggers and actions (page 146)
   - Creating filter-based alarms (page 144)

5. (Optional) Select “Enable Probe SNMP trap generation” and configure up to 10 Observer or other network management systems (for instance, HP OpenView or IBM Tivoli) to receive the SNMP traps. By enabling SNMP trap generation here, an SNMP trap is generated even when no Observer are connected to the probe.

6. Click **OK** to save your changes.

You successfully enabled individual alarms. Remember, individual alarms remain disabled if the probe instance alarm they are associated with is disabled—even if the individual alarms are enabled.

**Creating filter-based alarms**

A filter-based alarm is an individual alarm created from an Observer filter. This means any filters you create in Observer can be used as alarms.

The first step in creating a filter-based alarm is to become familiar with Observer alarms in general; see Configuring and using alarms (page 142) if you have not already.
To create a filter-based alarm, complete the following steps:

1. Click the **Alarms Settings** button, near the bottommost portion of Observer’s window. The Alarm Settings window appears.

2. Click a probe instance to highlight it.

3. Click the **Selected Instance Alarm Settings** button. The Probe Alarms Settings window appears.

4. In the Filter Based Alarms area, click New. The Alarm Filter window appears.

   Figure 40: Creating a new filter-based alarm

5. Now, select a filter you previously created from the list, or click New Filter to create a new filter.

6. Save all of your filter changes (if any), and select the new alarm to enable it.

7. Click **OK** to confirm and save your changes.

Your filter-based alarm is now enabled and triggerable. If you need to customize the triggers, follow the procedure in Customizing triggers and actions (page 146).

Remember, you can enable any number of filter-based alarms, but each filter-based alarm can only be created from one filter.

### Resetting statistical alarms

Statistical alarms (as opposed to filter-based alarms) maintain cumulative counts of various network statistics, triggering only once upon exceeding the threshold. Therefore, triggered (tripped) statistical alarms must be reset before they can trigger once again.

SNMP devices have a different method for resetting alarms.

To reset SNMP device alarm counters of a currently selected SNMP device:
- On the Home tab, in the Probe group, click **Setup > Reset SNMP Device Alarm Counters**.

To reset SNMP device alarm counters for all SNMP devices:
- On the Home tab, in the Probe group, click **Setup > Reset All SNMP Device Alarm Counters**.

To reset the counters and enable the alarms to once again trigger, click **Alarm Settings** at the bottom of the log window. Select the probe with the alarms you want to reset by clicking on the probe list, then click **Reset Probe Alarms**.
Customizing triggers and actions

An alarm has two components: a trigger and an action. Explore how a simple car alarm works: a thief breaks a car window (the trigger) and the car responds by sounding a loud siren (the action). Observer alarms behave in the same manner, except you can customize your own triggers and actions—and any amount of them.

Before continuing, we recommend becoming familiar with enabling individual alarms.

Customizing alarm triggers

Alarms triggers are highly flexible; you can customize the sensitivity of each trigger based on your needs. There are almost 200 predefined alarm triggers. Different background colors are used to distinguish one type of alarm from another type.

Some notes about the triggers.

- Analysis interval—The analysis interval can be unique for each trigger. It can be as low as 1 second. For VoIP the minimum analysis interval is 60 seconds (1 minute for the “Repeat alarm for chronic condition” setting). For triggers that do not have a configurable analysis interval, it is 15 seconds.
- Minimum active calls—For VoIP triggers, the minimum active calls is the number of active calls during that analysis interval. It does not mean the number of active calls above or below your defined threshold.

Try customizing some triggers yourself:

1. Click the Alarms Settings button, near the bottommost portion of Observer’s window. The Alarm Settings window appears.
2. Click a probe instance to highlight it.
3. Click the Selected Instance Alarm Settings button. The Probe Alarms Settings window appears.
4. Enable any alarms by selecting them. At least one alarm must be enabled before step 5 operates correctly.
5. Click the Triggers tab. Triggers for all enabled alarms now appear.
6. Customize any or all alarm triggers to your liking.
7. Click OK to save your changes.

You successfully customized the triggers of your enabled individual alarms. You can repeat this process at any time in the future and for any reason.

Customizing alarm actions

Prerequisite: Observer Suite

Alarm actions are extremely powerful as they allow Observer to automatically react to triggered alarms any way you feel necessary. Customize the actions of any of your enabled alarms by completing the following steps:

Note: By default, Observer uses the same alarm actions for all enabled individual alarms. If, instead, you want to configure independent alarm
actions per individual alarm, disable this setting: Apply the Same Action to All Enabled Alarms (end-result shown in Figure 41 (page 147)).

1. Click the **Alarms Settings** button, near the bottommost portion of Observer’s window. The Alarm Settings window appears.
2. Click a probe instance to highlight it.
3. Click the **Selected Instance Alarm Settings** button. The Probe Alarms Settings window appears.

Figure 41: Independent alarm actions can now be customized

4. Select each alarm you want to enable. At least one alarm must be enabled before step 5 operates properly.
5. Click the **Actions tab**. Actions for all enabled alarms now appear.
6. Customize any or all alarm actions to your liking.
7. Click **OK** to save your changes.

You successfully customized the actions of your enabled individual alarms. You can repeat this process at any time in the future and for any reason.

**Sharing alarms with others**

Observer alarms can be shared using the included import and export functions. Sharing is useful for making your alarms uniform across multiple installations, and it can even be used as a backup tool.

**How to export alarms**

To share alarms, the alarms must first be saved to a file. Create your file by following this export process:

1. Click the **Alarms Settings** button, near the bottommost portion of the Observer window. The Alarm Settings window appears.
2. Click a probe instance to highlight it.
3. Click the **Selected Instance Alarm Settings** button. The Probe Alarms Settings window appears.
4. Select each alarm you want to export.
5. Click the **Export Checked Alarms** button.
6. Give your file a name, and click Save.

You successfully exported your alarms to an *.ALM file. You can now share this file with other Observer installations or keep it as a backup copy.
How to import alarms

To import alarms, you need access to an exported *.ALM file. You must bring this file back into Observer using the import process described here:

1. Click the Alarms Settings button, near the bottommost portion of the Observer window. The Alarm Settings window appears.
2. Click a probe instance to highlight it.
3. Click the Selected Instance Alarm Settings button. The Probe Alarms Settings window appears.
4. Click the Import Alarms button.
5. Navigate to, and select, your file; click Open.

You successfully imported an alarm file. The alarms contained within are now part of your local collection, including the triggers and actions associated with each alarm.
Chapter 9: Security and Privacy

Learn about the web certificate trust model and how probe instance communication is encrypted by it. Also read about how to use Observer with regulation compliance and end-user and institutional privacy and security in mind.

Security, privacy, and regulatory compliance

Regardless of how any sensitive information is gathered, being a processor of it subjects your institution to all regulations, laws, statutes, and policies that may apply, and Observer can help you achieve and maintain compliance with many of them.

Security and privacy concerns are a reality for most businesses—perhaps even greater for worldwide enterprises. Fortunately, Observer accommodates virtually any privacy or security need that arises within or outside of your company, including any governmental regulations.

Observer is a software application that collects network traffic, and as sensitive or personal information flows over the network (as it does), it too is collected. The following are some examples of sensitive information that Observer may collect:

- IP and MAC addresses
- Web form submissions, including passwords
- Email and visited web sites
- Instant messages and chats
- Application usage statistics
- Downloaded and uploaded content
- Sensitive files on network storage
- Employee or client records
 Payment transactions
 Phone calls (VoIP only)

**Tip!** Observer is compatible with hardware security modules that comply with the Federal Information Processing Standards (FIPS) number 140. See Decoding encrypted network traffic (page 106) for more information.

To become better aware of how you might follow regulations, here are some (non-exhaustive) examples of decisions to consider while configuring Observer and/or Observer GigaStor:

♦ Data retention length—how long should you keep data?
♦ User accounts—who gets access to privileged data?
♦ Encryption—does our data need to be impenetrable?
♦ Exclusions—should some data never be collected, ever?
♦ Sharing—how can we share our data safely and securely?
♦ Physical security—do we need to isolate our equipment?
♦ Notification—who else should know we collect data?

Ultimately, your institution alone is responsible for regulation compliance, but Observer can help you meet those requirements.

### Configuring user accounts for secure access

If you want to create and use user accounts, set probe permissions, or use third-party authentication like Active Directory, OMS is required.

If you are using OMS to control user accounts, you must control the accounts from the OMS interface. See Understanding user accounts in the OMS User Guide for more details.

### Sharing packet captures with third-parties

Unless necessary, it is generally unwise to share “full” packet captures with outside sources because you could end up sharing too much information—information that should not be shared.

To prevent this from happening, Observer allows you to create a filtered packet capture from a larger capture. Filtered captures behave exactly like full captures—as they are indeed a complete capture file—except they only contain packets of your choice.

Creating a filtered capture can be done locally either before or after the initial capture is made. Post-filtering is not possible from the GigaStor Control Panel, from local probe instance redirected to another system, or from remote probe instances. We recommend you become familiar with both processes before continuing.

**Note:** You can also configure Observer to create partial packet captures regardless of protocol. See Configuring Observer to capture partial packets (page 81).
To create a filtered packet capture fit for sharing, ensure the full packet capture is loaded in Observer then:

1. On the Home tab, in the Probe group, click **Filters > Configure Software Filter**.
2. From the Active Filters window, click **New Filter**. Give your filter a name, and click **OK**.
3. Right-click the new filter, and select **Edit Rule As > Packet Partial Capture**.

   ![Creating a partial packet capture](image)

4. Within the Partial Packet Payload for TCP/UDP Filter window, set up rules for how the filter is applied.
   Specifically, the uppermost portion of the window is for filtering by IP address, range or subnet, and MAC or IPv6 address. The lowermost portion is for filtering application or protocol.
5. Click **OK** to confirm your changes.
6. Click **OK** to save your filter.
7. Enable your new filter to activate it, and click **OK** to save your changes.

### Password protecting the ability to change partial packet capture size

To password protect the ability to change partial packet capture size, choose **Options > Security tab**, and enable **Require a Password to Change Partial Packet Capture Size**.

Password protecting this option helps ensure your partial captures remain partial, saving you disk space and enhancing data subject privacy because payload is not recorded in full.

### Trimming data from your captures

Packet headers may contain the most useful information because they contain routing information and protocol details. You can discard the packet payload for more efficient troubleshooting.

Under these circumstances, you may want to truncate most payload data from the packet header(s). In Observer, the result is a **partial packet capture**.
Some benefits of partial packet captures include:

- Smaller capture sizes
  - More overall storage space for packet captures
  - Greatly increases the effective storage size of a GigaStor (or other capture buffer)
- Performance metrics remain intact
- Increased overall privacy
- Least resource intensive capturing

Some disadvantages of partial packet captures include:

- Not all network traffic is stored to disk
  - Forensics may be hindered without full payload data
  - Data stream reconstruction may not work
- Most resource intensive capturing
  - Increases CPU utilization

1. Choose Configuration > Packet Capture > Settings > Capture Options.
2. Enable Capture Partial Packets (Bytes).

![Packet Capture Settings](image)

It is possible to decrease or increase the default 64-byte partial packet capture size. Click the Change Size button to set a custom value. From then on, each packets' bytes following the target value are discarded from capture.

**How to encrypt captured data at rest**

Captured data at rest can be encrypted using the 256-bit Advanced Encryption Standard (AES) algorithm. This significantly increases the security of your at-rest data.

**Prerequisite(s):**

- You must have a special Observer license to enable and use this feature. There is no extra charge for the license.
- You must have a GigaStor hardware appliance. This feature is not available to GigaStor Software Edition. See the differences in software and hardware (page 304) offerings for GigaStor.

Data at rest encryption is prevents visibility into any packets or even the metadata about the packets stored on the GigaStor. Any packets that are captured by the GigaStor are considered “data” and while they are stored on the...
GigaStor they are considered "at rest." Should any of the drives in the GigaStor be removed or misplaced, the data on the drives is protected. There is no remote access to this data apart from Observer’s own analyzer, and the data tagging methods for organizing and retrieving data can only be used in conjunction with Observer.

The GigaStor can capture 10 Gb line rate while simultaneously encrypting the traffic with AES-256 encryption without any significant performance impact on write or read speeds of the GigaStor. The RAID hardware is responsible for the encryption, and the data is encrypted before it is written to disk.

These instructions describe how to apply data at rest encryption to a GigaStor already in your possession. If your GigaStor shipped from the warehouse with the data at rest security already enabled, you do not need to complete this process unless two or more drives in your RAID have failed.

**Caution:** This procedure deletes all of the data on your GigaStor! Ensure you have a backup of any data you wish to keep.

1. Download the latest firmware for the Areca 1882 Series RAID card or contact VIAVI Support for the file.

2. Choose **Start** > **All Programs** > **Areca Technology Corp** > **ArcHttpSrvGui** > **Areca HTTP Proxy Server GUI**. The program starts. You should see something similar to the Figure 44 (page 153) image.

![Figure 44: Areca RAID application](image)

3. Select Controller#01 and click Launch Browser. If the controller is not running, click the **Start** button then launch the browser. The Areca RAID application attempts to connect to its web server.

4. Type the user name and password. The default user name is **admin**. There is no default password. Click **OK** to open the browser.

   In the browser you can see the RAID set, IDE channels, Volume, and capacity.

5. In the web browser, choose **System Controls** > **Upgrade Firmware**. In the **Browse** field, choose each of the four files from the firmware package you downloaded or received from Technical Support in step 1 and click
Submit. Choose the files in the order they are listed below. After adding the arch1882firm.bin file you are prompted to restart the system. Ignore that restart request and add the fourth file.

ARC1882BIOS.BIN
ARC1882BOOT.BIN
arc1882firm.bin
ARC1882MBR0.BIN

6. Restart the GigaStor.

7. Choose Volume Set Functions > Delete Volume Set. Select the volume, then select Confirm The Operation and click Submit. This deletes all of the existing data on the RAID.

8. Choose Volume Set Functions > Create Volume Set. Set the following options to these values, select Confirm The Operation, and click Submit.

<table>
<thead>
<tr>
<th>Option</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Volume RAID Level</td>
<td>Raid 5</td>
</tr>
<tr>
<td>Greater Two TB Volume Support</td>
<td>64bit LBA</td>
</tr>
<tr>
<td>Volume Initialization Mode</td>
<td>Foreground Initialization. It may take several hours (six hours for 48 TB) to initialization the volume. While the volume is being initialized, the GigaStor cannot be used. If you choose Background Initialization, you may use your GigaStor, but it will take significantly longer to complete and performance will be negatively affected.</td>
</tr>
<tr>
<td>Volume Stripe Size</td>
<td>128</td>
</tr>
<tr>
<td>Volume Cache Mode</td>
<td>Write Back</td>
</tr>
<tr>
<td>Volume Write Protection</td>
<td>Disabled</td>
</tr>
<tr>
<td>Full Volume Encryption</td>
<td>256Bit Key, AES Key</td>
</tr>
<tr>
<td>Tagged Command Queueing</td>
<td>Enabled</td>
</tr>
<tr>
<td>SCSI Channel</td>
<td>0:0:0</td>
</tr>
<tr>
<td>Volumes To Be Created</td>
<td>1</td>
</tr>
</tbody>
</table>


Because this is the first time that Observer is opened with the new license, it does not yet have a key for the encrypted volume. A window appears indicating that the volume is locked.

10. Click Generate Key and save the key file in a secure location following your organization’s security policy.

- When rebooting, the system needs access to key in order to unlock the drive. This is the key necessary to write to and read from the RAID volume.
- Observer will not open unless it can find the key. Without the key present neither packet capture nor packet analysis can occur. You can choose to remember the key file location so that Observer opens automatically, or, if left cleared, each time Observer is opened you must provide the path to the key file.
● Securely storing the key is a critical part of your responsibility.

11. Close Observer until the rest of this procedure is complete.

12. In Control Panel > Administrative Tools > Computer Management > Storage > Disk Management select the RAID volume, right-click and choose Initialize. In the Initialize Disk window, select Disk 1 and GPT (GUID Partition Table). Convert the volume to a Simple Layout, assign a drive letter (typically, D:), and provide a name (typically, DATA).

13. Repeat this process for each RAID volume for your GigaStor.

14. Open Observer.

Understanding the certificate trust model

The certificate trust model allows Observer Platform products to securely communicate using TLS encryption. It also provides resistance to man-in-the-middle attacks by requiring administrator intervention when a known certificate has changed.

All product-to-product communication is encrypted by default using SHA2. A web of trust between Observer Platform products is created by requiring certificates from each participating software application. The main benefit is that this ensures encryption of communication (page 156) between all parts of the Observer Platform.

Each software application owns a unique certificate. This certificate is automatically created during the first installation of an Observer Platform application, for example, Observer Apex. The unique application certificate is labeled Local when viewed from inside that software application. Upgrading to newer software versions does not create a new certificate, so no certificate maintenance is typically needed. However, uninstalling and reinstalling (fresh installs) creates a new certificate. The new certificate will be automatically rejected by other products that had a pre-existing association with the asset ID of the reinstalled software.

The first time two products communicate, each checks to see if they have the certificate for the asset ID of the other software application. If they do not, then certificates are exchanged, marked Trusted, and associated with the asset ID of the participating device. This enables the "easy configuration" model. After an association is made, each application will expect to see the same certificate (to remain trusted) when communicating.

Note: Prior to version 17 of the Observer Platform, encryption was available but not enabled by default. This has changed to become the default out-of-the-box behavior in Observer Platform version 17 and later, and it also uses a stronger cipher suite.

Certificates are automatically rejected when trust cannot be verified. If a certificate is associated to an asset ID, and an inbound connection from that asset (determined by the asset ID) occurs using a different certificate, the administrator must inspect and manually accept the certificate because the certificate is in a Rejected state. A rejected certificate breaks the trust model, so any offending device(s) and software are banned from product-to-product communication until an administrator investigates and accepts the certificate.
Certificates can be manually rejected by administrators. In the event that product-to-product communication must be immediately severed because of an imminent threat or other security risk, an administrator can manually reject certificates.

**How to view certificates**

You can view every certificate that Observer has collected. This information shows certificate trust state, certificate ID, fingerprints, last time seen, last network location, signature algorithm, and more.

To view certificates:

1. On the Home tab, in the Probe group, click **Filters > Configure Software Filter**.
2. Under the **System** tab, click **Certificates**.
3. (Optional) Select a certificate and click **Details** to view its full details.

You successfully viewed the certificates that this installation of Observer has collected.

**Certificate details**

<table>
<thead>
<tr>
<th>Certificate ID</th>
<th>Asset type</th>
<th>Asset ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>State</td>
<td>Issuing time</td>
<td>SHA1 Fingerprint</td>
</tr>
<tr>
<td>MDS Fingerprint</td>
<td>Asset name</td>
<td>Last seen IP</td>
</tr>
<tr>
<td>Last seen time</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**How to change the trust of a certificate**

The trust of a certificate can be changed between trusted and rejected states. The certificate must remain trusted for communication to occur.

To change the trust of a certificate:

1. On the Home tab, in the Probe group, click **Filters > Configure Software Filter**.
2. Under the **System** tab, click **Certificates**.
3. Click a certificate to select it.

You successfully changed the trust state of a certificate.

View the certificate details (page 156), such as the signature algorithm, to ensure it matches your expectations.

**Certificates and how they are used**

Certificates ensure secure communication between Observer Platform products. The certificates encrypt this communication and help you maintain the authenticity of device communication.

Certificates use public key infrastructure (PKI) to encrypt all product-to-product communication using the Transport Layer Security (TLS) cryptographic protocol. The communications that are encrypted include, but are not limited to:

- Probe instance redirections
- Capture data transfers
- Trending data transfers
- All other data transfers

**Note:** The initial handshake between Observer Platform products is not encrypted.
Chapter 10: Network Trending

Network trending records statistical data over long periods for other Observer Platform products to consume and display, such as Apex. Learn about, configure, and ultimately use network trending to see how your network is performing over time.

Understanding the Network Trending tool

The Network Trending tool allows you to collect, store, and analyze network traffic statistics over long periods of time.

Network trending provides a broader view of your network and gives you trending information about network applications. This information may be useful for solving a specific problem or can be used for long-term planning. For example, you can collect statistics about the applications on your network for weeks, months, or years and be able to analyze changes over time.

<table>
<thead>
<tr>
<th>Observer Analyzer feature set</th>
<th>Real-Time Statistics</th>
<th>Packet Captures</th>
<th>Network Trending&lt;sup&gt;1&lt;/sup&gt;</th>
<th>NetFlow/ sFlow&lt;sup&gt;2&lt;/sup&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>Viewing current network activity</td>
<td>++</td>
<td>+</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Viewing long-term network activity&lt;sup&gt;3&lt;/sup&gt;</td>
<td>-</td>
<td>+</td>
<td>++</td>
<td>++</td>
</tr>
<tr>
<td>Viewing network errors (CRC, alignment, etc.)</td>
<td>++</td>
<td>++</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>Capturing packets for analysis</td>
<td>-</td>
<td>++</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Analyzing servers and applications</td>
<td>+</td>
<td>+</td>
<td>++</td>
<td>+</td>
</tr>
</tbody>
</table>
Understanding Application Performance Analysis

Application Performance Analysis (APA) is a feature of the Network Trending tool. Using APA allows you to monitor performance trends for any application, server, and client by primarily analyzing Layer 4 of the OSI Model.

**Prerequisite:** Observer Expert or Observer Suite

Application Performance Analysis collects response times based on Layer 4, which is the Transport Layer (TCP in this case). All statistics which include server response time, client response time, server network delay, client network delay and round trip delay in the TCP events window of Expert Analysis corresponds to analysis performed on the transport layer data packets and not SYN, SYN-ACK, and ACK packets.

Application Performance Analysis cannot account for whether fulfillment of the application took place as expected by the user. In many ways, this means APA is...
broad but limited. Also, response times in Application Performance Analysis are calculated as described in. Response times are calculated by actual data packets, not SYN or SYN-ACKs (see Response time calculation (page 125)), while network delay times are calculated exclusively with SYN and SYN-ACKs (see Network delay calculation (page 124)).

How to configure Application Performance Analysis

Application Performance Analysis is an always-on feature, meaning that Observer is always collecting metadata about the performance of numerous applications on your network. It cannot be disabled, only configured.

Prerequisite(s):

If you are unfamiliar with Application Performance Analysis, see Understanding Application Performance Analysis (page 159) before beginning.

The "always-on" nature of Application Performance Analysis is when both Observer and the probe are both at 17.2.0.0 or later. In certain circumstances your Observer may not match the version of your probe. This table describes what happens in those situations.

<table>
<thead>
<tr>
<th>Observer 17.2.0.0 and newer</th>
<th>Probe 17.2.0.0 and newer</th>
<th>Always on. Cannot be disabled.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Observer 17.1.1.4 and older</td>
<td>Probe 17.2.0.0 and newer</td>
<td>Probe collects and sends APA data to Observer even though the feature appears disabled in Observer.</td>
</tr>
<tr>
<td>Observer 17.2.0.0 and newer</td>
<td>Probe 17.1.1.4 and older</td>
<td>APA may be turned off. Since the probe collects the trending data and the probe does not have the new always-on functionality, therefore Observer can be configured to have the older probe honor the functionality it does have, which is the ability to turn APA on or off.</td>
</tr>
</tbody>
</table>

1. On the Home tab, in the Capture group, click Network Trending > Network Trending.
2. Click the Settings button. The Network Trending Settings window appears.
3. Click the Application Performance Analysis group tab.
4. Settings can be changed in each tab.
General tab

The General tab allows you to set TCP retransmission settings and whether to track certain discovered servers.

Table 19. General tab

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Default selection or value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Track only servers using IP addresses with associated ports defined in “Protocol Definitions and Server Application Discovery”</td>
<td>Enable this setting to track only defined servers. See Discovering server applications on the network (page 62).</td>
<td>Disabled</td>
</tr>
<tr>
<td>Count rerouted as resent</td>
<td>Choose this if you want rerouted TCP transmissions to be considered resent, instead.</td>
<td>Disabled</td>
</tr>
<tr>
<td>Retransmission too fast</td>
<td>Set this value if necessary, but the default is appropriate in most cases. This value defines when a retransmission is too fast.</td>
<td>180 (ms)</td>
</tr>
<tr>
<td>Resent minimum time</td>
<td>Set this value if necessary, but the default is appropriate in most cases. This value defines the minimum amount of time needed for a resent to be considered such.</td>
<td>100 (ns)</td>
</tr>
</tbody>
</table>
Applications tab

The Applications tab allows you to configure TCP, UDP, and SCTP applications to monitor.

Table 20. Applications tab

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Default selection or value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Track servers using the following applications</td>
<td>Allows APA to track servers using the protocols in the protocol list. Enabling this option allows changes to be made in this tab.</td>
<td>Enabled</td>
</tr>
<tr>
<td>Protocol (list)</td>
<td>When “Track servers using the following protocols” is enabled, the protocols in this list are tracked in APA.</td>
<td>N/A</td>
</tr>
<tr>
<td>Add button</td>
<td>Click the Add button to add an application protocol to the list of tracked servers.</td>
<td>N/A</td>
</tr>
<tr>
<td>Remove button</td>
<td>Remove an application protocol from the list by selecting one or more and clicking Remove. You can use SHIFT-click to select a range or CTRL-click to select multiple items.</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Subnet Ranges tab

The Subnet Ranges tab allows you define on what subnets your application servers are located.

Table 21. Subnet Ranges tab

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Default selection or value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Limit tracked server connections to defined IP subnet ranges</td>
<td>Allows IP subnet ranges to be defined in this tab. This setting must be enabled for any settings in this tab to be active.</td>
<td>Disabled</td>
</tr>
<tr>
<td>Type</td>
<td>Choose the IP type of the target address range. Your options are IP (IPv4) or IPv6.</td>
<td>IP (IPv4)</td>
</tr>
<tr>
<td>Servers are located in this subnet</td>
<td>Enable this setting if servers are located in the leftmost subnet range (the subnet range on the left side of the arrow icon). If left disabled, all tracked server connections from this subnet are seen as clients.</td>
<td>Disabled</td>
</tr>
<tr>
<td>Filter traffic between two subnets</td>
<td>Enable this setting if you want to track server connections between two unique subnet ranges. If left disabled, server connections are tracked</td>
<td>Disabled</td>
</tr>
</tbody>
</table>
Understanding Application Transaction Analysis

Application Transaction Analysis (ATA) is a feature of the Network Trending tool. Using Layers 5-7 of the OSI Model, ATA allows you to monitor response times, errors, request and response trends for any supported server application protocol.

The server application protocols listed in Table 22 (page 163) can be configured for ATA. Most importantly, ATA can track and trend successes and failures of these client-server transactions, including response times at the application layer.

Table 22. Protocol name

<table>
<thead>
<tr>
<th>Application's protocol name</th>
<th>Acronym or abbreviation</th>
<th>Transport layer protocol(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common Internet File System</td>
<td>CIFS</td>
<td>TCP</td>
</tr>
<tr>
<td>Server Message Block</td>
<td>SMB</td>
<td>TCP</td>
</tr>
<tr>
<td>Cisco Skinny Call Control Protocol</td>
<td>SCCP</td>
<td>TCP</td>
</tr>
<tr>
<td>Citrix Independent Computing Architecture</td>
<td>ICA</td>
<td>TCP</td>
</tr>
<tr>
<td>Dynamic Host Configuration Protocol</td>
<td>DHCP</td>
<td>UDP</td>
</tr>
<tr>
<td>Dynamic Host Configuration Protocol for IPv6</td>
<td>DHCPv6</td>
<td>UDP</td>
</tr>
<tr>
<td>Domain Name System</td>
<td>DNS</td>
<td>UDP</td>
</tr>
<tr>
<td>Diameter</td>
<td>Diameter</td>
<td>TCP, SCTP</td>
</tr>
<tr>
<td>Financial Information eXchange</td>
<td>FIX</td>
<td>TCP</td>
</tr>
<tr>
<td>File Transfer Protocol</td>
<td>FTP</td>
<td>TCP</td>
</tr>
<tr>
<td>H.245 (control channel)</td>
<td>H.245</td>
<td>TCP</td>
</tr>
<tr>
<td>H.255.0 (gatekeeper comm. or RAS)</td>
<td>H.255.0</td>
<td>UDP</td>
</tr>
<tr>
<td>H.255.0 (end-to-end communication)</td>
<td>H.255.0</td>
<td>TCP</td>
</tr>
<tr>
<td>Hypertext Transfer Protocol</td>
<td>HTTP</td>
<td>TCP</td>
</tr>
<tr>
<td>Internet Message Access Protocol</td>
<td>IMAP</td>
<td>TCP</td>
</tr>
</tbody>
</table>
### Analyzing servers and applications using ATA

Critical application servers should be added to Expert Analysis for Application Transaction Analysis.

**Prerequisite:** Observer Expert or Observer Suite

Application Transaction Analysis (ATA) is a tool that shows you the following information about your applications and servers in Layers 5-7.

- Application response time
- Application errors (if any)
- Total application requests
- Network delay
- FIX Statistics

**Tip!** If you are not sure why you would want to add any servers or applications to ATA, see Understanding the Network Trending tool (page 158). Until you configure the tool, nothing useful appears. Follow the steps provided in this section to complete the prerequisite configuration.
process and begin using Application Transaction Analysis. If you need a better idea of what ATA provides, see Figure 46 (page 165) for an example.

Note: All response times shown in Observer are relative to the location where the capture takes place (that is, wherever the probe is located). If your probe is in London and you are in New York with your Observer, the capture times are relative to the time in London, not New York. Be mindful of this during any analysis.

Figure 46: An example of Application Transaction Analysis

To begin configuring Application Transaction Analysis, complete the following steps:

1. Choose how to add the server.
   - Right-click an expert conversation and choose Add Server to Application Transaction Analysis.
   - Complete the following steps.
2. On the Home tab, in the Capture group, click Network Trending > Network Trending.
3. Click the Settings button.
4. Select the Application Transaction Analysis group from the leftmost panel.
5. Ensure the Response Time Analysis grouping is selected, located at the leftmost portion of the window.
6. Click Discover or Add.
7. Ensure Live Statistics and Network Trending Statistics are selected.

Importing or exporting a server profile

You can import or export servers that you monitor from one Observer to another. This can save time and reduce typing errors if you have several Observer which you want to have the same servers be analyzed for application transaction analysis.

Tip! You can also logically group server applications and switch between profiles quickly by choosing a profile from the Profiles list.

1. On the Home tab, in the Analysis group, click Application Transactions.
2. Click the **Settings** button to define any application servers you want to monitor.

3. Click the **Import** or **Export** button.

   First you must define the server applications and then export the server to create the *.ata file that you can later import.

**Global Settings**

*Network Trending > Network Trending > Application Transaction Analysis* on the **Global Settings** tab you can configure how response times are handled and whether URLs or SQL statement should be tracked.

**Figure 47: ATA Global Settings**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Track by URL</td>
<td>URLs can be tracked by specific URLs or by content types. You can also limit the level to which they are followed.</td>
</tr>
<tr>
<td>Track by SQL Statements</td>
<td>You can set the maximum statement length, track specific SQL statements, or track statements that include a specific command or token.</td>
</tr>
<tr>
<td>Ignore response time longer than</td>
<td>Transactions whose responses take longer than the specified value are ignored. The default is 10 seconds.</td>
</tr>
<tr>
<td>Collect distribution</td>
<td>A comma-separated list of values in milliseconds used as thresholds for statistics and graphs. A maximum of six values may be listed. A value may have up to three decimal places (for instance, <strong>1.500</strong>). The default values are: 5, 15, 50, 150, 500, 1500.</td>
</tr>
</tbody>
</table>
## Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exclude specific URLs from Response Time Analysis</td>
<td>A list of URLs to ignore.</td>
</tr>
<tr>
<td>Server requests for DIAMETER</td>
<td>DIAMETER server requests will be monitored.</td>
</tr>
</tbody>
</table>

### ATA is reporting inaccurate values

If ATA is showing data for **Response Time** or **Response Packets** and other columns that does not meet your expectations, check the **Ignore response times longer than setting**. It may be set too high or too low for your environment affecting the statistics reported.

ATA is based on statistical analysis. By default, Observer ignores any response time greater than 10 seconds. This is to present you with reasonable statistics while removing any outliers that take an exceedingly long time to respond. You can lower this value to exclude even more values (thereby showing reporting on a smaller, tighter data set) or increase the value to include a greater range of response times as necessary based on your environment.

1. On the Home tab, in the Capture group, click **Network Trending > Network Trending**.
2. Select the server that is reporting data you believe to be inaccurate and choose **Edit**.

Figure 48: Add/Edit Application Transaction Analysis Server
3. Change the **Ignore response times longer than** option to a value that meets your needs.

   This value is server specific, so you may need to change or adjust this value for each of your servers. It also means that servers can have different values that are appropriate to their environment and your expectations for it.

   The reported statistics should begin to match your expectations. If not, repeat this process until you find a value that works for you.

---

### Collecting network trending data

To collect network trending data, complete the following steps:

1. On the Home tab, in the Capture group, click **Network Trending > Network Trending**.
2. (Optional) Click the **Settings** button to configure your collection parameters.
3. Click the **Start** button. If you see progress bars, Observer is actively collecting data.

After completing this task:

To schedule the collection of network trending data instead of using it on-demand as described above, see [Configuring your network trending settings](page 169).

---

### Viewing network trending data

Apex Lite, installed with your Observer application, allows you to view collected network trending data in a series of reports in your web browser.

To view collected network trending data:

- On the Home tab, in the Capture group, click **Network Trending > View Apex Reports**.

---

### Deleting your network trending data files

Network trending has the possibility to produce large amounts of data that it stores on your hard drive. If your trending files are large, you may want to implement a management strategy so that you have the information that you need for as long as you need it, but that you delete information you no longer need.

If you allow network trending data to accumulate without a deletion strategy, you could experience the following problems:

- The operating system drive runs out of free space (or free space becomes too low) and no new trending data is collected.
- System performance is severely degraded because not enough space is available to the Windows paging file to remain efficient, if it exists at all in your hardware configuration.
- If this Observer/GigaStor is feeding Observer Apex, Apex might not receive the latest trending data because Observer could no longer collect new network trending on the full disk drive.

**Tip!** Each network trending file can grow to a maximum of 4 TB.
By default, the trending files are kept for each trending instance in C:\Program Files\Observer\NetworkTrending. You can delete them using Windows Explorer.

Additionally, Observer can automatically delete old trending data for you when you set **Delete oldest trending data on the probe...** in **Network Trending > Network Trending** on the **Home** tab. Then choose **Settings > General** to find the option. When this option is set, you will virtually never need to worry about filling up the C: drive with too much network trending data. However, only the oldest two (2) files are deleted for each new trending file that is created. Because at least one new trending file is created each day, this means that each day when a new trending file is created, the two oldest network trending files are deleted. This is a net deletion of one (1) network trending file per day. The files are deleted at midnight UTC; this option is not configurable. (See the current UTC time and determine your offset.) You will want to set the amount of trending days retained to no more than you can store on the target disk drive. See **How to determine disk space requirements for network trending** (page 170).

The purpose of this design is to maintain disk write performance that might otherwise degrade if multiple, large deletions are made each day. Remember, you can delete trending files manually at any time from C:\Program Files\Observer\NetworkTrending, which is the default storage location. The automated tool operates with disk write performance as its highest priority—so it should be used—but if you are confident and wish to delete multiple network trending files manually through Windows, you can. Be aware that you risk negatively impacting the new, incoming network trending data **being collected at the very same time** as when multiple network trending files are being deleted through Windows Explorer.

If you are using Apex, you can safely delete the trending files after the data has been transferred to Apex. If you are not using Apex, then delete the trending files only if you are certain you no longer need the data.

### Configuring your network trending settings

Network trending can be configured to monitor only the kinds of statistics you want to store, thereby limiting resource consumption to the information that interests you.

**Note:** If you want the ability to view web reports, Network Trending must be configured using the steps in this section. Then, Network Trending must be running/collecting data.

There are two high-level tasks you must complete for network trending to function. First, you need to configure your network trending settings as described in this section. Network trending settings include trending types, specific servers to monitor (if any), and a schedule (if any). Second, you need to actually collect the network trending data.

To configure your network trending settings, follow these steps. These point to other locations in this section, which provide the steps you need to complete:

1. Choose the trending types you want to follow—see .
2. Schedule the collection of data from those trending types—see Scheduling your network trending data collection (page 170).

3. Add specific servers to trend—Adding specific servers to network trending (page 172).

Scheduling your network trending data collection

You can configure Observer to run network trending data collection continuously or at certain days and times.

To do this, complete the following steps:

1. On the Home tab, in the Capture group, click **Network Trending > Network Trending**.
2. Click the **Settings** button. The **Network Trending Settings** window appears.
3. Ensure the General group tab is selected, and click the Schedule tab.
4. Select a scheduling type for network trending data collection.
5. Click **OK** to save your changes.

The trending types you enable continue to be collected according to schedule.

You have configured your network trending settings and should continue on to Adding specific servers to network trending (page 172).

How to determine disk space requirements for network trending

Because network trending can consume a lot of disk space, you need to know how much disk space to reserve.

Network trending data consumes hard disk space. Depending on where you store trending data (page 171) and your storage requirements for network trending data, the network trending data could fill that drive to full capacity—this is a problem. Therefore, determine your typical 24-hour data rate and how many days of trending data you want to retain. The result indicates how much storage space is required.

To determine the amount of space required to store your desired amount of trending data:

1. Determine your typical 24-hour data rate.
   
   **Example:** 15 MB or 20 GB.
   
   The **data rate** is amount of trending data collected in one 24-hour period.

2. Multiply your typical 24-hour data rate by the number of days you want to retain.
   
   **Example:** 15 MB x 365 days = 5.475 GB
   
   **Example:** 20 GB x 30 days = 600 GB
   
   The result is the amount of hard drive space required to retain the trending data.
You can use the numbers you calculated to inform your decisions when deleting network trending data (page 168).

How to reduce the disk space consumed by network trending files

The size of your most recent network trending file increases whenever network traffic is seen. However, the file size is strongly affected by the volume of traffic (number of network connections), the network trending types you choose to track, and certain options within network trending settings. You can best reduce the disk space consumed by network trending files by limiting what you track.

Each network trending file is a summary of one day’s traffic as tracked by the Network Trending tool (page 158). In this way, the more network trending files you are able to retain in your storage directory (page 171)—without sacrificing all of your available disk space to do so—the more days of historical data can be transferred to Apex or viewed using Apex Lite.

Unless you want to rely on scheduled deletions of trending data (page 168) as your only disk space strategy, you can reduce the overall space consumed by network trending files by limiting what you track. This decreases the size of future network trending files, enabling you to retain more of them and for longer durations before deletions are necessary.

To reduce the disk space consumed by future network trending files, and your most recent in-progress file, perform any or all of the following steps:

♦ Decide if some network trending types are not useful to collect in your network environment, and turn them off.

♦ Set one or several options for Application Performance Analysis that limits tracking to protocols in the protocol list, server connections between defined subnets, or explicitly defined servers only.

How to configure Application Performance Analysis (page 160)

By following any or all of these steps, you should see a reduction in the disk space consumed by future network trending files.

How to change where network trending is stored

Network trending data can be stored anywhere. By default, the trending files are kept for each trending instance in C:\Program Files\Observer\NetworkTrending.

The storage limits for the network trending data files are limited only by the hard drive space available. Your GigaStor license only limits how much packet capture data you may have; it has no effect on limits for storing network trending data. You may collect a limitless amount of network trending so long as your hard drive (or RAID) supports it.

1. Click the File tab, and click Options > General Options.
2. Click the Folders tab.
3. Change the Network Trending Folder to a new location of your choice.

We do not recommend pointing to networked directories or mapped drives. Network trending data will be saved to its new location.
Given the potential volume of data stored by network trending, you may need to consider a management strategy to delete older files.

Adding specific servers to network trending

When you add specific servers to the Network Trending tool, you are adding server applications that Application Transaction Analysis recognizes.

See Understanding Application Transaction Analysis (page 163) for a complete list of applications you can add; you cannot add servers—using the method described in this section—that do not use an application appearing in Understanding Application Transaction Analysis (page 163).

Note: This section represents one of several steps required for configuring your network trending settings. To return to the overall list of steps, see Configuring your network trending settings (page 169).

Tip! More information about Observer’s address book can be found at Building and saving an address book (page 58).

Tip! If you have already created the server definition on a different Observer, you can import it here. See Importing or exporting a server profile (page 165).

1. On the Home tab, in the Capture group, click Network Trending > Network Trending.
2. Click the Settings button. The Network Trending Settings window appears.
3. Click OK to save your changes.

You successfully added a server to the Network Trending tool. Each added server is monitored for response time and other metrics, so, over time, you can see long-term trends in these areas.

Structure of an .ipsubnetrange file

An .ipsubnetrange file can be imported into, and exported from, various network trending settings. These files have a specific structure and allow subnet designations to be maintained outside of Observer. There is an expectation that such a file be “round tripped” back into Observer after changes are made.

Some limitations exist in how many subnets can be explicitly tracked for each network trending type. Explicitly tracked means that additional network trending statistics are measured for each defined subnet as a whole; however, these limitations do not influence how many subnets can be observed by Observer. These maximum tracked subnet ranges also means that your ipsubnetrange file(s) cannot have more entries than a network trending type supports. If you import an ipsubnetrange file having more entries than is supported by the target network trending type, only the first N-number will be successfully imported. These tracking limitations are as follows:

<table>
<thead>
<tr>
<th>Network trending type</th>
<th>Maximum tracked subnet ranges</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Performance Analysis</td>
<td>4 subnet ranges</td>
</tr>
</tbody>
</table>
Because IP Trending supports the largest number of maximum tracked subnet ranges, its `ipsubnetrange` file structure is the one you should mimic when maintaining your list of subnet ranges. The file structure of IP Trending’s `ipsubnetrange` file can be imported into the subnet tracking of any other network trending type. Be aware that if you have a list of 128 subnet ranges in an `ipsubnetrange` file and import it into a different trending type than IP Trending, only its first four entries will be imported into Application Performance Analysis or Application Transaction Analysis respectively; only its first 16 entries will be imported into Microburst; and only its first 16 entries will be imported into VoIP and Videoconferencing.

This is an example of an `ipsubnetrange` file exported from the IP trending network trending type. The file extension must always be `ipsubnetrange` and the spacing between commas is can be space characters or tabs. The use and positions of commas in these examples is important. This is how the file is structured, and multiple examples are shown of the same file to examine different pieces of the whole.

**The version number of the file format is highlighted. Always keep this at version 1.**

```
1,4,4(IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0
```

**The number of entries in this file is highlighted. Change it to match your list length.**

```
1,4,4(IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0
```

**The “original” type of ipsubnetrange structure is highlighted. Keep as is.**

```
1,4,4(IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0
```

**The configurable name of this subnet entry is highlighted. Keep these short.**

```
1,4,4(IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0
```
The IP version type of ipsubnetrange entry is highlighted. 1=IPv4, 2=IPv6.

1,4,4 (IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0

The scope of the subnet range is highlighted. 0=one subnet, 3=analyze traffic between two subnets.

1,4,4 (IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0

Network speed in bits per second for this subnet is highlighted. Change accordingly, or set to '0' to use defaults.

1,4,4 (IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0

The first address of the first subnet range is highlighted.

1,4,4 (IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0

The last address of the first subnet range is highlighted.

1,4,4 (IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0

The first address of the second subnet range is highlighted.

1,4,4 (IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0

The last address of the second subnet range is highlighted.

1,4,4 (IP Trending)
subnet 16 1,0,100000000,0,0,0,0, 10.0.16.1, 10.0.16.254, 0.0.0.0, 0.0.0.0
s48 to 64 1,3,100000000,0,0,0,0, 10.0.48.1, 10.0.48.254, 10.0.64.1, 10.0.64.254
subnet 64 1,0,100000000,0,0,0,0, 10.0.64.1, 10.0.64.254, 0.0.0.0, 0.0.0.0
subnet 23 1,0,250000000,0,0,0,0, 10.1.23.1, 10.1.23.254, 0.0.0.0, 0.0.0.0
Chapter 11: VoIP and Teleconferencing

Observer has dedicated tools for monitoring the quality of VoIP and teleconferencing traffic. These tools require some unique settings and configuration. You can also learn about VoIP best practices.

Collecting VoIP or video conferencing trending data

By default, VoIP data is not collected by Observer’s network trending tool. Instead, you must manually add it to the list of data streams that network trending collects.

Tip! You can learn more about Observer’s network trending tool by seeing Understanding the Network Trending tool (page 158)—a wealth of information is provided there should you need it.

Despite enabling the collection of VoIP data in Observer, VoIP data streams can only be parsed by Observer if it (the analyzer) has visibility of RTP or RTCP packets. Usually, this visibility is regulated by the VoIP system itself; please refer to your VoIP system documentation for more details.

To enable VoIP data collection in network trending—so Observer collects VoIP data—complete the following steps:

1. On the Home tab, in the Capture group, click **Network Trending > Network Trending**.
2. Click the **Settings** button.
The **Network Trending Settings** window appears.

3. Select the **VoIP and Videoconferencing Trending** data collection type.

4. Select the desired VoIP trending types from the two boxes directly below **VoIP and Videoconferencing Trending**.

5. Click **OK** to confirm and save your changes.

You successfully configured network trending to collect VoIP data. You can further configure your VoIP collection settings by seeing **Configuring network trending settings for VoIP or video conferencing** (page 180).

You can start the actual collection process by following the instructions at **Collecting network trending data** (page 168).

### Importing and exporting VoIP or video conferencing settings

Settings for VoIP can be imported or exported into the Network Trending tool. Doing either is very useful depending on what you are trying to accomplish. For example, if you want to backup your settings or share your VoIP settings with other Observer installations, you should export your VoIP settings.

To import and/or export your VoIP settings, complete the following steps:

1. On the Home tab, in the Capture group, click **Network Trending** > **Network Trending**.
2. Click the **Tools** button.
3. Click Import or Export Settings. A file dialog appears, which allows you to complete the process.

## Analyzing VoIP or video conferencing traffic

Observer constantly monitors network conditions to calculate the R-factor, and allows you to customize the non-network impairment factors such as room noise, loudness rating of the telephone, etc.

**Prerequisite(s):**

Either start a packet capture or import a capture file.

Analyzing VoIP traffic follows the same rules and behaviors as when analyzing any packet capture; you can analyze the packets in either real-time or post-capture modes. Real-time mode is simply analyzing packets as they arrive (i.e. the packet capture is currently running), while post-capture is analyzing packets from inside a saved packet capture file at a later time. This section describes both real-time and post-capture VoIP analysis.

Tip! You cannot create a pre-filter that filters for a specific phone number. However, you can select **Find in VoIP ID stream** from a right-click search through the **VoIP Events / Calls** tab based on a phone number. After you find the conversation in question, right-click it and select the **Fast Post Filter** option to filter out the particular VoIP call.

You can learn more about decoding/analyzing network traffic by seeing **Decoding network traffic** (page 103)—a wealth of information is provided there should you need it.

To analyze VoIP traffic, begin by starting a packet capture or loading a saved capture file. If necessary, see the instructions for doing so at **Capturing network traffic** (page 84).

1. On the Home tab, in the Capture group, click **Configuration > Packet Capture**.
2. Click the **Decode** button.
3. Ensure the **Expert Analysis** tab is selected.

![Figure 50: Expert Analysis tab location](image)

4. Click the **VoIP Events** group tab.
5. (Optional) Click the **VoIP Settings** button to view or change VoIP-specific settings.

These settings are shared with the settings described in Configuring network trending settings for VoIP or video conferencing (page 180).

6. (Optional) Click the **Expert Threshold** button to view or change settings that determine VoIP-specific decode settings.

By using MOS score and R-factor when looking at your VoIP environment, you can determine if your users are experiencing poor call quality. From the **VoIP Events** group tab, you can perform meaningful decoding of VoIP packets, including the ability to see call statistics as they arrive.

The Table 23 (page 178) lists the abbreviations used in the VoIP Events tab for various packet types.

<table>
<thead>
<tr>
<th>A</th>
<th>Audio</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>Control</td>
</tr>
<tr>
<td>D</td>
<td>Data codec (non-audio or video data)</td>
</tr>
<tr>
<td>Q</td>
<td>Quality for RTP Packets (always RTCP)</td>
</tr>
<tr>
<td>V</td>
<td>Video</td>
</tr>
</tbody>
</table>

### How to extract VoIP and video calls from your GigaStor

VoIP and videoconferencing calls can be extracted from a GigaStor if you know the approximate time the events occurred.

**Prerequisite(s):**

You must understand how to select a time frame from your GigaStor. See Selecting a time frame to analyze (page 324).

**Note:** This process is only compatible with SIP data.

Locating and extracting SIP-based voice and video data from your GigaStor is a straightforward task. All of the SIP setup and teardown packets are extracted along with any payload, such as audio and video, to ensure you retrieve complete sessions. This includes all person-to-person audio calls and videoconferencing as well as conference calls and conference video where multiple endpoints are present. An endpoint could be a person holding a handset, wearing a headset, or a line that is open for hold music or for recording.

To extract VoIP and videoconferencing calls from your GigaStor:

1. Select a time frame you want to analyze.
2. Click the **Update Reports** button to get the latest data from the time frame selected.
   
   This step is unnecessary if Auto-update GigaStor chart on statistics tab or selection change is enabled in the GigaStor settings. See Setting the GigaStor general options.
3. Click the **Analyze** button.
4. In the **Analysis Options** section, choose VoIP and Videoconferencing calls by SIP tag. Click the **Settings** option and choose your call search criteria.
Analyzing VoIP or video conferencing traffic

Chapter 11: VoIP and Teleconferencing

### Option Description

- **A --> (ANY)**: Extract call(s) where pattern A is in the SIP "From" field.
- **A <-- (ANY)**: Extract call(s) where pattern A is in the SIP "To" field.
- **A <-> (ANY)**: Extract call(s) where pattern A is in the SIP "From" or "To" field.
- **A <-> B**: Extract call(s) where pattern A and pattern B is in either the SIP "From" or "To" field.
- **A --> B**: Extract call(s) with pattern A in the SIP "From" field and pattern B is in a SIP "To" field.
- **Call-ID**: Extract call(s) with the specified pattern in the SIP "Call-ID" field.

#### 5. (Optional) Enable one or more search pattern modifiers:
- **Use regular expression(s)**—Perl 5 regular expressions. For details and examples, see...
- **Match case**—case sensitive search

#### 6. Type a string for the GigaStor to search for in the Call-ID Pattern.

#### 7. Choose one of the result options:
- **Stop searching when one matching call is found**. This provides you the results more quickly, but the tradeoff is that if the endpoints identified by search criteria had multiple separate calls within the timeframe selected, only the first call is extracted and any subsequent calls are excluded.
- **Search for all matching calls within the GigaStor analysis time range** (up to the filtering limit).

#### 8. Click **OK** to save your settings.

#### 9. Choose your analysis type. The options are described in Mining data from your GigaStor (page 321).
- **Expert analysis and decode**
- **Decode without expert analysis**
- **Third party decoder**

If your search pattern found results, the results are displayed in a new tab and can be further analyzed.

---

**VoIP MOS**

The Mean Opinion Score (MOS), as estimated using the E-model. By using the E-model to estimate MOS, provides you with a highly accurate prediction of how a current user would rate the voice quality of your VoIP network. Examining the Burst Percentage and Burst Density metrics can often give you a clue as to what is driving MOS scores down.

Note that the traditional method of obtaining a Mean Opinion Score is to survey actual users listening to sample sentences, rating audio quality from 1 (poor) to 5 (excellent). The E-model was developed because this type of testing is simply not practical for most VoIP installations, and in any case cannot be updated in real time.

---

**VoIP R-Factor**

The E-model uses cumulative measurements of impairments to estimate what their effect would be on users' perception of quality. In its simplest form, the E-
model subtracts the impairments from the R-factor to come up with a score of 0 to 100:

\[ R = R_0 - I_s - I_d - I_e + A \]

Where \( R_0 \) is the undistorted original signal (a constant of 100), \( I_s \) measures the distortion of the speech signal from the telephone hardware, \( I_d \) measures network delay and jitter, \( I_e \) measures the signal degradation due to speech encoding. \( A \) adds the users' typical expectations for the type of connection being used, accounting for the fact that people are willing to accept lower voice quality in exchange for some other benefit, such as the cost savings of DSL, or the mobility of wireless.

Observer constantly monitors network conditions to calculate the R-factor, and allows you to customize the non-network impairment factors such as room noise, loudness rating of the telephone, etc.

**Configuring network trending settings for VoIP or video conferencing**

This section describes how to access the VoIP settings menu and guides you through its most noteworthy settings.

**Prerequisite:** Observer Expert or Observer Suite

Just as network trending has a menu for general settings, it also has a menu specifically for VoIP settings. We recommend visiting these settings only after you are comfortable using the network trending tool.

To configure network trending settings for VoIP, complete the following steps:

1. On the Home tab, in the Capture group, click **Network Trending > Network Trending**.
2. Click the **Settings** button. The **Network Trending Settings** window appears.
3. Click the **VoIP and Videoconferencing** group tab.

![Figure 51: The VoIP settings menu](image)
You successfully accessed the VoIP settings menu. Like most other menus in Observer, this menu consists of multiple tabs. Each tab brings you to a specific subset of settings, and they are described in the proceeding sections.

**General tab**

The General tab allows you to specify how Observer interacts with VoIP packets, such as which packets identify a new call and how jitter is displayed. See Table 24 (page 181) for a list of noteworthy settings.

<table>
<thead>
<tr>
<th>Setting(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Identifying new calls</td>
<td>These settings tell Observer which VoIP packets are recognized as a new phone call. If you ever have trouble seeing VoIP calls in network trending, try experimenting with these settings.</td>
</tr>
<tr>
<td>Allow multiple concurrent calls on an IP pair</td>
<td>Some VoIP phones allow multiple, concurrent calls between the same IP addresses. By default (setting disabled), Observer stops looking for calls once it finds setup information exchanged between a pair of IP addresses until that call is closed. Enabling this setting causes Observer to further process the packets to look for multiple call streams, which can take more time but allows for more accurate call tracking.</td>
</tr>
<tr>
<td>Track SIP by IP pair and Call-ID</td>
<td>When selected, Observer identifies a VoIP call based on an IP address/port pair combination along with a Call ID. The call ID is generated by the telephone initiating the conversation. If unchecked, only the IP address/port pair is used. Disabling this option is not recommended.</td>
</tr>
</tbody>
</table>

**MOS tab**

The MOS tab allows you to specify which sources of delay are used in MOS score calculations, and it allows you to configure your E-Model parameters if its defaults do not suffice. This tab becomes especially important for tracking the performance and clarity of VoIP calls.

See Table 25 (page 182) for a list of noteworthy settings.

If you are using a VoIP codec that Observer does not recognize by default, change the value of the E-Model parameter impairment for unrecognized codecs to the appropriate value shown in Table 26 (page 182).

The E-model based on conditions, equipment, and expectations at your site. Some of the values (Send and Receive Loudness Ratings, for example) are functions of your phone specifications. Others (Room Noise levels, for example), are functions of ambient conditions at your site. Typically, the default values should work fine. To fine-tune the E-model to exactly match the conditions at any particular site is an involved process that requires test equipment and a thorough understanding of the E-model. See the ITU G.107 specification for a more detailed discussion of the E-model.

**Tip!** The default settings in the MOS tab do not need to be changed unless there is reason for doing so—the defaults work well for many VoIP networks!
### Table 25. MOS settings

<table>
<thead>
<tr>
<th>Setting(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MOS score network delay</td>
<td>These settings tell Observer which source of delay should be used in MOS calculations; the first found source of delay is used, and the items at the top of the list take precedence over lower items.</td>
</tr>
<tr>
<td>E-Model parameters</td>
<td>These settings allow you to customize your E-Model parameters. The E-Model parameters have a direct effect on how your MOS score is determined. We recommend leaving these at their default values until you have reason to change them. If you are using a VoIP codec that Observer does not recognize by default, change the value of the E-Model parameter <code>impairment for unrecognized codecs</code> to the appropriate value shown in Table 26 (page 182).</td>
</tr>
<tr>
<td>Defaults button</td>
<td>Clicking the Defaults button will restore the E Model parameters to their original values. This button does not affect the MOS score network delay settings.</td>
</tr>
</tbody>
</table>

### Table 26. Codecs

<table>
<thead>
<tr>
<th>If you use this codec</th>
<th>Use this value...</th>
</tr>
</thead>
<tbody>
<tr>
<td>G.711</td>
<td>7</td>
</tr>
<tr>
<td>1016 8K</td>
<td>17</td>
</tr>
<tr>
<td>G.721</td>
<td>7</td>
</tr>
<tr>
<td>G.723</td>
<td>17</td>
</tr>
<tr>
<td>DVI4 8K</td>
<td>17</td>
</tr>
<tr>
<td>DVI4 16K</td>
<td>17</td>
</tr>
<tr>
<td>G.722</td>
<td>17</td>
</tr>
<tr>
<td>16 Bit Linear (2 Channel)</td>
<td>17</td>
</tr>
<tr>
<td>16 Bit Linear (1 Channel)</td>
<td>17</td>
</tr>
<tr>
<td>QCelp 8K</td>
<td>21</td>
</tr>
<tr>
<td>MPA 90K</td>
<td>17</td>
</tr>
<tr>
<td>G.728 8K</td>
<td>13</td>
</tr>
<tr>
<td>DVI4 11K</td>
<td>17</td>
</tr>
<tr>
<td>DVI4 22K</td>
<td>17</td>
</tr>
<tr>
<td>G.729</td>
<td>15</td>
</tr>
<tr>
<td>G.711 (a-Law) 64K</td>
<td>7</td>
</tr>
<tr>
<td>G.711 (a-Law) 56K</td>
<td>17</td>
</tr>
<tr>
<td>G.711 (u-Law) 64K</td>
<td>7</td>
</tr>
<tr>
<td>G.711 (u-Law) 56K</td>
<td>17</td>
</tr>
<tr>
<td>G.722 56K</td>
<td>17</td>
</tr>
<tr>
<td>G.722 48K</td>
<td>17</td>
</tr>
<tr>
<td>G.722-1</td>
<td>17</td>
</tr>
<tr>
<td>G.722-2</td>
<td>17</td>
</tr>
<tr>
<td>G.723-1</td>
<td>17</td>
</tr>
<tr>
<td>G.723-1 Annex C</td>
<td>17</td>
</tr>
</tbody>
</table>
If you use this codec | Use this value...
---|---
G.726-16 | 40
G.726-24 | 25
G.726-32 | 7
G.726-40 | 2
G.728 | 7
G.729 | 15
G.729 Annex A | 20
G.729 Annex B | 20
G.729 Annex A & B | 20
G.729 Extensions | 20
IS11172 | 11
IS13818 | 11
GSM Full Rate | 20
GSM Half Rate | 23
BV 16K | 17
BV 32K | 17
VBD | 17
ILBC | 17
Speex | 17
IMA ADPCM | 17
LPC10 | 17
Telephony Event | 17
Audio Tone | 17
G.711 (A-law) with PLP | 17
G.711 (U-law) with PLP | 17

**Device IP Addresses tab**

The Device IP Addresses tab allows you to add VoIP devices to network trending via their IP addresses. After you add the IP addresses of any VoIP devices on your network, each will be recognized and “trended” by the network trending tool now and in the future. See Table 27 (page 183) for a list of noteworthy settings.

**Table 27. Device IP Address options**

<table>
<thead>
<tr>
<th>Setting(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VoIP device list</td>
<td>A list of all your configured VoIP devices. After you populate the list, you can simply use the Device IP Addresses tab as an organizational tool for VoIP devices.</td>
</tr>
<tr>
<td>Add button</td>
<td>Clicking the Add button allows you to add VoIP devices to the list. See the list of device types in Table 28 (page 184).</td>
</tr>
</tbody>
</table>

If you choose to add a VoIP device, you are asked to tell Observer which type of VoIP device is being added. The types are described in Table 28 (page 184).
Table 28. VoIP device types

<table>
<thead>
<tr>
<th>VoIP device type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administration/Registration Server IP</td>
<td>A server which performs administration/registration operations but does not act as a call server. An example would be a SIP registration server which handles only the SIP REGISTER message and not the INVITE messages. When configured as this type, an IP may be listed as a server for admin calls but not for normal calls.</td>
</tr>
<tr>
<td>Control Processor IP</td>
<td>Avaya's proprietary server for managing call setup and tear down.</td>
</tr>
<tr>
<td>Media Processor IP</td>
<td>Avaya's proprietary server for managing actual voice data.</td>
</tr>
<tr>
<td>Non-server IP</td>
<td>An IP which should not be interpreted as a server on any call. This type provides a mechanism to override our normal inference of servers based upon traffic between IPs. In other words, it should generally only be used if we are incorrectly presenting a non-server IP as a server.</td>
</tr>
<tr>
<td>Outside IP</td>
<td>Link to PSTN or other outside network.</td>
</tr>
<tr>
<td>Server IP</td>
<td>Generic VoIP Server such as Cisco.</td>
</tr>
</tbody>
</table>

Caller ID Determination tab

The Caller ID Determination tab allows you to tell Observer which source of information creates the caller ID text displayed on calls. Connection and devices IDs, too, are determined from settings in this tab. See Table 29 (page 184) for a list of noteworthy settings.

Table 29. Caller ID Determination tab

<table>
<thead>
<tr>
<th>Setting(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify call IDs</td>
<td>These settings tell Observer which source of information creates the caller ID text. The first found source of information is used, and the items at the top of the list take precedence over lower items.</td>
</tr>
<tr>
<td>Specify device IDs and connection IDs</td>
<td>These settings tell Observer which source of information creates the device ID shown in VoIP network trending. The first found source of information is used, and the items at the top of the list take precedence over lower items.</td>
</tr>
</tbody>
</table>

IP Range Filters tab

The IP Range Filters tab allows you to specify which IP addresses, ranges, or subnets are either included or excluded from VoIP network trending. See Table 30 (page 184) for a list of noteworthy settings.

Table 30. IP Range Filters tab

<table>
<thead>
<tr>
<th>Setting(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Examine/exclude</td>
<td>Allows you to change Observer’s behavior toward the IP ranges you add to the list. Only one behavior can be used.</td>
</tr>
<tr>
<td>Add button</td>
<td>Clicking the Add button allows you to add an IP address, range, or subnet to the list. Each entry in the list is subject to the examine/exclude behavior selected in this tab.</td>
</tr>
</tbody>
</table>
Enabling VoIP alarms

Alarms are a powerful and often overlooked feature of Observer. Using alarms, you can trigger pre-defined actions to occur when network conditions are met, making network management simpler and more predictable. Best of all, alarms allow you to proactively manage your network no matter where you are physically located.

**Tip!** You can learn more about Observer alarms by seeing Configuring and using alarms (page 142)—a wealth of information is provided there should you need it.

To enable alarms for VoIP, complete the following steps:

1. Click the **Alarms Settings** button, near the bottommost portion of Observer’s window. The Alarm Settings window appears.
2. Click a probe instance to highlight it.
3. Click the **Selected Instance Alarm Settings** button. The Probe Alarms Settings window appears.
4. In the alarm list, click VoIP Alarms to expand the list of VoIP-specific alarms.
5. Enable one or more VoIP alarms by checking the appropriate boxes. Likewise, you can disable any VoIP alarm by clearing them.
   
   Until you customize the alarms, Observer uses the built-in, default triggers and actions for each. If necessary, see Customizing triggers and actions (page 146) and Creating filter-based alarms (page 144).
6. Click **OK** to save your changes.

You successfully enabled one or more VoIP alarms, and you can repeat this process at any time.
VoIP Top 10 best practices

Use this valuable list of the best practices when implementing or troubleshooting VoIP. Keeping these steps in mind will help you get the most from your VoIP network.

1. **Understand and measure call quality components.** There are a variety of metrics you can use to assess VoIP call quality, including jitter, MOS, R-Factor, gap density, burst density, Quality of Service prioritization, and compression techniques. Ensure you are accurately analyzing VoIP communication by learning how to measure these attributes.

2. **Implement Quality of Service prioritization.** Incorrectly set QoS precedence for VoIP traffic leads to delays in packet delivery and reduced call quality.

3. **Conduct site surveys.** The more you know about your network, the better prepared you are to properly integrate VoIP. Conduct a site survey to review current WAN bandwidth levels, traffic flows, and existing switches for bottlenecks and choke points. Then, identify or determine specific needs through testing and modeling.

4. **Deploy analysis tools strategically for maximum visibility.** Placing network analysis consoles and probes on your network requires a clear understanding of VoIP traffic patterns. Are you concerned with monitoring VoIP traffic locally, over WAN links, both? Depending on your objectives, place your analysis tools to ensure optimal visibility of VoIP communications.

5. **Implement VLANs to isolate and monitor VoIP issues.** Organize your VoIP traffic by VLAN user groups. This practice will greatly simplify problem resolution.

6. **Monitor rollouts to ensure a positive user experience.** Determine whether users are receiving a positive experience by reviewing cumulative VoIP metrics, codecs, and other network performance variables during VoIP deployment. By evaluating VLAN setups and overall link utilization, you can judge overall network performance and quickly make adjustments during implementation.

7. **Compare jitter to overall network bandwidth utilization to understand response time.** When jitter becomes a problem, look at the big picture. A correlation between jitter and bandwidth usage means the problem is overall network usage. If there is no direct correlation, excessive jitter might be caused by isolated network factors that require further investigation.

8. **Set up Observer to proactively monitor VoIP activity.** Utilize monitoring and notification tools to speed problem resolution. Determine “normal” or “acceptable” levels of activity for your network and its users. Then set up thresholds within your analyzer to alert you when thresholds are broken or in danger.

9. **Automate problem resolution.** Expert Analysis functionality eliminates unnecessary trial and error when troubleshooting VoIP issues by automating problem resolution. Utilize Expert Analysis on VoIP communication to quickly pinpoint the source of common VoIP problems.

10. **Baseline network traffic.** For comprehensive understanding of VoIP traffic, capture and store long-term network data. Only with critical trending data can you accurately perform baselining activities. Baselining validates VoIP
performance, helps future capacity planning efforts, and provides long-term understanding of VoIP health.

**Network Jitter and Delay**

Real-time voice communications are sensitive to delay and variation in packet arrival times. Codecs require a steady, dependable stream of packets to provide reasonable playback quality. Packets arriving too early, too late, or out of sequence result in jerky, jumbled playback. This phenomenon is called jitter.

Because no network can guarantee a perfectly steady stream of packets under real-world conditions, VoIP phones use jitter buffers to smooth out the kinks. A jitter buffer is simply a First-In, First Out (FIFO) memory cache that collects the packets as they arrive, forwarding them to the codec evenly spaced and in proper sequence for accurate playback.

While a jitter buffer can successfully mask mild delay and jitter problems, severe jitter can overwhelm the jitter buffer, which results in packet loss (see below). Increasing the size of the jitter buffer can help, but only to a point: A jitter buffer that increases overall round-trip delay to 300 ms will make normal conversation difficult.

Figure 53: Jitter buffering and packet loss concealment

VoIP packets can arrive at a receiving phone out of sequence, late, or not at all. IP phones use a **jitter buffer** to reconstruct the packet stream at the receiving end, duplicating missing packets or filling in with white comfort noise when necessary.

**Differences between Jitter (RTP) and Jitter (ms)**

Jitter is calculated in two different ways: the first uses Real Time Protocol (RTP) time stamps, and the second uses packet time stamps. When jitter is represented in milliseconds (ms), the calculation is made using packet time stamps and not RTP time stamps.

Observer performs this calculation on every packet. Jitter max is the highest calculated jitter observed. Jitter itself is the latest calculated jitter value (most recent). Also note that jitter requires a minimum of 16 packets before a value will be displayed in Observer.

Observer displays jitter values for both jitter calculation methods. This is how the numbers are created in Observer:

1. Translate the packet time to RTP time units.
   
   \[
   \text{packet rtp-based time} = \left(\frac{\text{packet time stamp in ns}}{1000}\right) \times \text{(sampling rate in ms)}
   \]

   where the sampling rate (in ms) depends on the codec. For example, for an H.323 codec:

   \[
   \text{packet rtp-based time} = \left(\frac{\text{packet time stamp in ns}}{1000}\right) \times 20 \text{ ms}
   \]

   and

   \[
   \text{packet rtp-based time} = \left(\frac{\text{packet time stamp in ns}}{1000}\right) \times 30 \text{ ms}
   \]

   for an H.323 codec.
2. This time is used to calculate the difference between this packet and the previous packet.
   \[
   \text{packet time difference} = (\text{packet rtp-based time}) - (\text{previous packet rtp-based time})
   \]

3. The jitter is then calculated exactly as the RTP specification describes using the RTP time stamps.
   \[
   \text{jitter} = \text{jitter} + ((\text{packet time difference}) - \text{jitter}) / 16.0
   \]

4. Then for the jitter in milliseconds (ms), the time is converted using the sampling rate.
   \[
   \text{jitter\_ms} = \text{jitter\_ms} + ((1000 \times \text{packet time difference}) / (\text{sampling rate}) - \text{jitter\_ms}) / 16.0
   \]

Packet Loss

Packet loss can be the result of the jitter buffer being overwhelmed. Other reasons include landline media failure and poor wireless signal quality. The latter can be a big problem with VoFi (Voice over WiFi) service. Regardless of the source, VoIP phones and gateways attempt to conceal this type of signal degradation by duplicating packets to fill in the missing data. As with jitter, these techniques can maintain voice quality only to a point.

Packet loss on data networks has long been characterized as a “bursty” phenomenon, which is another way of saying “it never rains, it pours.” Networks tend to either sporadically drop single packets (these periods are called “gaps” in packet loss), or large numbers of contiguous packets in a “burst.” Packet loss concealment techniques typically have no problem handling packet loss during gap periods; it is the sustained bursts you must watch out for.

Managing VoIP Quality

You can manage only what you can measure. Managing a VoIP deployment therefore requires some hard numbers beyond subjective user assessments of quality (although these are obviously important as well).

Beyond monitoring the network parameters discussed in this paper, having an overall quality score such as a Mean Opinion Score (MOS) or R-factor score can also be a useful VoIP network health index.

VoIP monitoring tools calculate the MOS and R-factor scores using a formula known as the E-model. Using the statistics it has collected from the network, the analyzer calculates how much the various impairment factors (such as codec compression, jitter, delay, and packet loss) would affect the typical user’s perception of call quality.

MOS and R-factor are used to gauge user satisfaction with call quality. MOS levels under 3.5 and R-factor below 80 mean trouble.
VoIP terminology

This section describes common VoIP terminology. If you are new to VoIP networking or just need more information about a certain term, this section may help.

Table 31. VoIP terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
<th>Significance</th>
</tr>
</thead>
<tbody>
<tr>
<td>R-factor and MOS</td>
<td>These are overall quality ratings, based on the E-model, which take into account network conditions, equipment ratings, and other variables to come up with an objective Quality score. The R-factor is a scale from 0-100; MOS ranges from 1 to 5. In both cases, higher readings indicate better quality.</td>
<td>The R-factor is more useful for live, real-time assessment of what users are experiencing. Unavoidable degradation means that 93.2 is the highest reading you will see on an actual VoIP call; scores below 80 typically result in dissatisfied users. The MOS (Mean Opinion Score) measures how a user would assess quality, from 1 (poor) to 5 (excellent). Although it is also useful as a real-time measure of VoIP health, it is especially useful for pre-deployment tests where you compare the MOS scores of call data from both ends of various connections to identify and resolve bottlenecks. Scores</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
<td>Significance</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Jitter</td>
<td>Using computer networks to transmit and reproduce sound requires a steady, predictable stream of packets to arrive at the receiving devices. Jitter is the variability in arrival time, too much of which can degrade call quality.</td>
<td>Understanding jitter can help you improve overall call quality by adjusting jitter buffers or providing more bandwidth through QoS prioritization or other mechanisms.</td>
</tr>
<tr>
<td>Bursts and Gaps of packet loss</td>
<td>Packets can get dropped for many reasons on a network, some more serious than others. For example, a temporary spike in bandwidth utilization causing a few packets to get dropped is usually not a problem, as VoIP equipment is designed to fill in the missing data. Following long-standing conventions of telephony periods where packet loss is minimal are called gaps. In contrast, burst periods (i.e., periods when a high percentage of packets are being lost) usually does degrade call quality, and may point to more serious problems. Density refers to the rate of packet loss during bursts and gaps.</td>
<td>Understanding the density and duration of bursts and gaps can help you quickly respond to (and sometimes prevent) voice degradation on the VoIP network. For example, an extremely high burst density (20% or more) coupled with extended burst duration times (more than a second or two) can suggest problems with hardware either failing or being completely overwhelmed by traffic. Gap densities climbing over time, coupled with low-density, short-duration &quot;burstiness&quot; can mean the VoIP network is attempting to service too many calls given the available bandwidth.</td>
</tr>
<tr>
<td>QoS</td>
<td>Also called a Type of Service (ToS) or Precedence, the QoS bit is part of the TCP header that certain routers and switches recognize so they can prioritize traffic according to what particular kinds of applications require. VoIP typically requires the highest level of priority.</td>
<td>Incorrectly set QoS can lead to contention of VoIP and other data on a network. Contention can cause VoIP jitter and packet loss, leading to poor voice quality and dissatisfied users.</td>
</tr>
<tr>
<td>Codec</td>
<td>Codec is an abbreviation for Coder/Decoder, referring to the algorithm used to convert the analog voice signal into packets on the network, and back again.</td>
<td>Different codecs use different sampling rates to implement different levels of compression. Lower sampling rates can compromise call quality, although sometimes a lower sampling rate can reduce contention and prevent worse degradation. Here are some of the more common codecs and their sampling rates:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
<th>Significance</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
<th>Significance</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
<td>Significance</td>
</tr>
<tr>
<td>----------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>E-Model</td>
<td>The E-Model is based on conditions, equipment, and expectations at your site. Some of the values (Send and Receive Loudness Ratings, for example) are functions of your phone specifications. Others (Room Noise levels, for example), are functions of ambient conditions at your site. To fine-tune the E-model to exactly match the conditions at any particular site is an involved process that requires test equipment and a thorough understanding of the E-model. See the ITU G.107 specification for a more detailed discussion of the E-model.</td>
<td>R-Factor and Mean Opinion Scores (MOS) are derived from the E-Model. The E-Model is based on ITU-T Recommendation G.107, and takes into account the many types of network impairments that can affect voice quality. VoIP, unlike some other network applications, is quite sensitive to packet delay and jitter. To prevent network conditions from affecting voice quality, many VoIP deployments use Quality of Service (QoS) prioritization so that VoIP traffic is favored over other less delay-sensitive traffic. Even with QoS, a saturated network can mean poor voice quality, which will be reflected in lower R-factor and Mean Opinion Score (MOS) readings. In most deployments, users will start to complain about quality when MOS scores fall below 3.5 and R-Factor scores fall below 80 or so.</td>
</tr>
</tbody>
</table>
Chapter 12: Reports

Observer can notify you of network events using email alerts, text messages, and even pager services.

Setting up email notifications

For Observer Analyzer to send notifications to email addresses, you must configure Observer’s outgoing email settings.

To set up email notifications, configure your outgoing email server settings by completing the following steps:

1. Click the File tab, and click Options > General Options.
2. Click the Notifications tab.
3. In the E-mail Settings area, provide your outgoing SMTP server credentials.
4. (Optional) Click the E-Mail Test button to test your settings.
5. Click OK to save your changes.

Observer can now send notifications to email addresses. If you want to receive notifications as text messages on your mobile device, see Setting up text message notifications (page 192).

Setting up text message notifications

Observer can also send notifications to your mobile device/phone in the form of text messages. Receiving notifications via text messages could, sometimes, arrive quicker than receiving an email, or perhaps you share a common mobile device with others in shifts—these are both good reasons to set up text message notifications.

Remember, text messages notifications are not facilitated by VIAVI servers; the entire process described in this section relies solely on an established connection.
between your outgoing SMTP server, your wireless carrier, and the target mobile
device.

**Note:** VIAVI cannot guarantee the following email address conventions will
work indefinitely, although they were operational at the time of writing.
Contact your wireless carrier for more details.

To set up text message notifications, complete the following steps:

1. Create or edit a user account, and type an email address reflecting the
   conventions.

<table>
<thead>
<tr>
<th>Wireless carrier</th>
<th>Email-to-text address convention</th>
</tr>
</thead>
<tbody>
<tr>
<td>AT&amp;T</td>
<td><a href="mailto:mobilenumber@txt.att.net">mobilenumber@txt.att.net</a></td>
</tr>
<tr>
<td>Verizon Wireless</td>
<td><a href="mailto:mobilenumber@vtext.com">mobilenumber@vtext.com</a></td>
</tr>
<tr>
<td>T-Mobile</td>
<td><a href="mailto:mobilenumber@tmomail.net">mobilenumber@tmomail.net</a></td>
</tr>
<tr>
<td>Sprint PCS</td>
<td><a href="mailto:mobilenumber@messaging.sprintpcs.com">mobilenumber@messaging.sprintpcs.com</a></td>
</tr>
<tr>
<td>Virgin Mobile</td>
<td><a href="mailto:mobilenumber@vmobil.com">mobilenumber@vmobil.com</a></td>
</tr>
<tr>
<td>US Cellular</td>
<td><a href="mailto:mobilenumber@email.uscc.net">mobilenumber@email.uscc.net</a></td>
</tr>
<tr>
<td>Nextel</td>
<td><a href="mailto:mobilenumber@messaging.nextel.com">mobilenumber@messaging.nextel.com</a></td>
</tr>
<tr>
<td>Boost Mobile</td>
<td><a href="mailto:mobilenumber@myboostmobile.com">mobilenumber@myboostmobile.com</a></td>
</tr>
<tr>
<td>Alltel</td>
<td><a href="mailto:mobilenumber@message.alltel.com">mobilenumber@message.alltel.com</a></td>
</tr>
</tbody>
</table>

**Setting up pager notifications**

You may have to modify some settings to adapt to the local environment. It
will be necessary to choose among the provided services or install a new paging
service and substitute the local pager access number, if any, for the supplied one.

**Note:** When a VIAVI application (except Observer Apex) starts, it also starts
a separate Windows process called VIAVI Paging Service, which you can find
in the system tray. After configuring the pager, verify the settings for the
paging service match your needs. Choose **Tools > Program Options >
Notifications**.

1. Click the File tab, and click **Options > General Options**.
2. Click the **Notifications** tab.
3. Select the Default pager configuration from the menu.
   If your pager is not on the list, click the **New** button. The Paging Service
   Properties dialog will be displayed.
4. To view the initial pager configuration dialog, click the **Properties** button.
The Paging Service Properties dialog will be displayed.
5. Enter the Service name. This is the name of the service used to access the
   pager; the Service name you selected from the list is your default.
6. Enter the Service phone number—use the international number format (e.g., +1 (123) 1234567) to allow TAPI to work with the Windows location settings. This option will not be displayed if you are using a SNPP pager service, as SNPP uses TCP/IP to communicate with the paging service, rather than a modem.

If it is necessary to wait for an outside line, insert one or more commas at the beginning of the string (e.g., ,,+1 (123) 123-4567).

Additional spaces and the hyphen in the phone number are optional; they make the number more easily readable by you, but will be ignored when dialing: Observer will dial only the numbers and pause for approximately one-half second for each comma character.

7. Select a Service protocol from the list. Observer supports four different pager service protocols: TAP, UCP, SNPP, and Voice. Selecting the appropriate service protocol and clicking the Configure button enables you to enter service-specific configuration data. Each protocol displays a different set of options that need to be set. Those options are described below for each protocol.

8. Enter the maximum message length for the pager.

9. Click the **OK** button.

10. Check the Apply advanced pager settings and click the **Advanced** button to display the Phone Pager Schedule dialog.

11. Check the desired scheduling option. You can add or edit start times by using the buttons at the bottom of the dialog.

   After the paging server starts, you can send a page or view logs of what pages have been sent. See Sending a page (page 194) and Viewing the Paging Server logs (page 194).

### Sending a page

After you have configured the paging server using the instructions in Setting up pager notifications (page 193), you can choose to send a page.

**Figure 55: Windows Taskbar icon**

![Windows Taskbar icon](image)

The paging server is running in the Windows task bar.

1. Right-click the paging server and choose Send Page.
2. Type your message and click Send now.

### Viewing the Paging Server logs

After you have configured the paging server using the instructions in Setting up pager notifications (page 193), you can choose to send a page.

The paging server is running in the Windows task bar. Right-click the paging server and choose View Logs.
Chapter 13: SNMP Management Console

Any network administrator, systems consultant, or network programmer will find SNMP Management Console useful. SNMP Management Console and its related utilities are designed to meet the needs of network professionals, ranging from beginner to expert.

Introduction to SNMP

**Prerequisite:** Observer Suite

SNMP Management Console is available in Observer Suite, bringing the cross-platform Simple Network Management Protocol (SNMP) standard to Observer.

Simple Network Management Protocol (SNMP) is not as simple as its name implies; it is a difficult concept to understand. This section provides a brief overview and description of SNMP, yet it is by no means a comprehensive tutorial. Ultimately, using Observer’s SNMP Management Console becomes easier with a basic understanding of how SNMP works.

Any network administrator, systems consultant, or network programmer will find SNMP Management Console useful. SNMP Management Console and its related utilities are designed to meet the needs of network professionals, ranging from beginner to expert.

**Tip!** SNMP Management Console is most useful for network administrators who want to monitor their LANs and manage SNMP-aware devices from a single location.

Simple Network Management Protocol (SNMP) is an application-layer protocol designed to facilitate the exchange of management information between
network devices. The SNMP system consists of three parts: SNMP Manager, SNMP Agent, and MIB.

- **SNMP manager**—uses information in the MIB to perform operations on each object.
- **SNMP agent**—gathers data from the MIB, which is the repository for information about device parameters and network data. The agent also can send traps, or notifications of certain events, to the manager.
- **Management Information Base (MIB)**—stores the information about each managed object.

From the perspective of a network manager, network management takes place between two major types of systems: those in control, called managing systems, and those observed and controlled, called managed systems. The most common managing system is called a Network Management System (NMS). Managed systems can include hosts, servers, or network components such as routers or intelligent repeaters.

Note: The exchange of information between managed network devices and a robust NMS is essential for reliable performance of a managed network. Because some devices have a limited ability to run management software, most of the computer processing burden is assumed by the NMS. The NMS runs the network management applications that present management information to network managers and other users.

Instead of defining a large set of commands, SNMP places all operations in a **GetRequest**, **GetNextRequest**, **GetBulkRequest**, and **SetRequest** format. For example, an SNMP manager can get a value from an SNMP agent or store a value in that SNMP agent. The SNMP manager can be part of a NMS, and the SNMP agent can reside on a networking device such as a router. If SNMP is configured on a router, the SNMP agent can respond to MIB-related queries being sent by the NMS.

**Figure 56: SNMP simple diagram**

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GetRequest</td>
<td>supplies a list of objects and values they are to be set to (SetRequest). The agent returns GetResponse.</td>
</tr>
<tr>
<td>GetNextRequest</td>
<td>retrieves the next instance of information for a particular variable or device.</td>
</tr>
<tr>
<td>GetResponse</td>
<td>informs the management station of the results of the GetRequest or SetRequest by returning an error indication and a list of variable/value bindings.</td>
</tr>
<tr>
<td>GetBulkRequest</td>
<td>similar to GetNextRequest, but fills the GetResponse with up to a maximum repetition number of GetNext interactions.</td>
</tr>
<tr>
<td>SetRequest</td>
<td>alters the value of objects which can be written to the MIB.</td>
</tr>
<tr>
<td>Trap</td>
<td>an unsolicited message sent by an SNMP agent to an SNMP manager indicating that some event has occurred.</td>
</tr>
</tbody>
</table>
With this operation, an SNMP manager does not need to know the exact variable name. A sequential search is performed to find the needed variable from within the MIB.

In a managed device, specialized low-impact software modules, called agents, access information about the device and make it available to the NMS. Managed devices maintain values for several variables and report those, as required, to the NMS. For example, an agent might report such data as the number of bytes and packets in and out of the device, or the number of broadcast messages sent and received. In the Internet Network Management Framework, each of these variables is referred to as a managed object. A managed object is anything that can be managed, anything that an agent can access and report back to the NMS. All managed objects are contained in the Management Information Base (MIB), a database of the managed objects.

An NMS can control a managed device by sending a message to an agent of that managed device requiring the device to change the value of one or more of its variables. The managed devices can respond to commands such as set or get commands. The set commands are used by the NMS to control the device. The get commands are used by the NMS to monitor the device.

### Configuring Observer Suite for SNMP devices

Included with Observer Suite is a full-function SNMP management console that allows you to poll and configure any device that has an SNMP agent, regardless of make or manufacturer.

To query and manage SNMP devices on your network, you must first define these devices within Observer Suite's SNMP Console. For each SNMP device you wish to monitor with Observer Suite, you must know:

- The IP address of the device
- The SNMP community string for the device (either read or write, but must be write if you want to manage and also monitor the device)
- The version of SNMP supported by the device (if unsure, choose SNMPv1, which every SNMP device supports)
- The make, model, and manufacturer of the device can be helpful as well

To set up an SNMP device in Observer Suite:

1. On the Home tab, in the Probe group, click **Setup > Add SNMP Device**.
2. For the device type, click the button to display a list of request files for various SNMP devices were included for your convenience. Request files provide a mechanism for filtering complex MIB definitions down to relevant information, delivered in the format you want. If you cannot find a request file that exactly matches your device, you can easily build one yourself using Observer Suite's MIB Editor. Rather than create the whole request file from scratch, you can make a copy of the "standard" request file (conforming to RFC1213), and modify as necessary. Beyond the general settings on the first tab, two other tabs let you set notification and logging options. They are optional.
3. Repeat the Add Device process for every SNMP device on your network you want to monitor and manage. As you add devices, they are displayed in the SNMP Devices Tree on the left side of the Observer main window.
What can Observer’s SNMP console tell me about a problem switch?

After you have narrowed down a problem to a particular switch, Observer Suite lets you easily look up any SNMP-supported statistic or registered value to further diagnose the problem.

1. Click a device in the SNMP device list to expand the tree of available SNMP objects included in the request file for that device.

   You can select a different request file in the Probe or Device Properties dialog, which is available by right-clicking on the SNMP device.

   To add or change charts, tables, and forms within a request files, use Observer Suite's MIB Editor, which is described in Adding triggers based on SNMP chart values (page 203).

2. Click any chart or other request file item in the tree to display data in the agent information window. For example, the supplied request file for a Cisco 2900-3500 XL switch returns the Utilization by Port Per Sec chart.

3. If you have opened multiple charts, use the tabs at the bottom of the agent information window to browse the open request file results.

Resetting SNMP device alarm counters

To clear alarm counters for the current SNMP device:

- On the Home tab, in the Probe group, click **Setup > Reset SNMP Device Alarm Counters**.

To clear alarm counters for all SNMP devices:

- On the Home tab, in the Probe group, click **Setup > Reset All SNMP Device Alarm Counters**.

About MIBs

A Management Information Base (MIB) is a formal description of a set of network objects that can be managed using the Simple Network Management Protocol (SNMP).

The unit of data collected is called the SNMP object. For each device, a set of SNMP objects and rules for addressing the objects are defined in a MIB file. MIBs are key to the logical, orderly functioning of SNMP. MIB objects (OIDs) are represented by a tree hierarchy; each object has a unique address based on its position in the tree. The address count begins from the root of the object tree; one number is added to the address with each new branch. The root of the tree is unnamed and splits into three main branches: Consultative Committee for International Telegraph and Telephone (CCITT), International Organization for Standardization (ISO), and joint ISO/CCITT.
These branches and those that fall below each category have short text strings and integers to identify them. Text strings describe object names, while integers allow computer software to create compact, encoded representations of the names.

The object identifier in the Internet MIB hierarchy is the sequence of numeric labels on the nodes along a path from the root to the object. The Internet standard MIB is represented by the object identifier 1.3.6.1.2.1. It also can be expressed as iso.org.dod.internet.mgmt.mib. The format of the MIB is defined as part of the SNMP. (All other MIBs are extensions of this basic management information base.) MIB-I refers to the initial MIB definition; MIB-II refers to the current definition. SNMPv2 includes MIB-II and adds some new objects.

Each MIB has a name, a syntax, and an encoding.

- **Name**—identifies the object
  - 1.3.6.1.2.1.1.1=the object identifier
  - SYSDESCR=the object descriptor

- **Syntax**—defines the object’s structure (e.g., octet string, integer).

- **Encoding**—an object’s representation using the object’s syntax (e.g., the local IP address for this TCP connection, Read Only, or Mandatory).

  **Object**: TCPConnLocalAddress  
  **Syntax**: Integer  
  **Definition**: The local IP address for this TCP connection  
  **Access**: Read only  
  **Status**: Mandatory

When requested, the SNMP agent transfers an SNMP message across the network in a standard format, as specified by the set of SNMP Request for Comments (RFCs). Related MIB objects often are combined into MIB groups. MIB groups make it easier to manage a large number of MIB objects. Some MIBs, such
as the standard MIB-2, contain many MIB groups. Proprietary MIBs usually have only one, or a few, groups.

**Configuring SNMP agents**

For the SNMP Management Console to work with SNMP agents on the network, both must be configured, and this section describes how to accomplish that.

**Note:** In this section, the term SNMP agent is used to mean the actual agent on the network device, rather than the representation of that device in Observer’s SNMP Extension.

First, the SNMP agents on the network must recognize SNMP Management Console as a management station that is permitted to access their MIB information. To poll the agents for information, the SNMP Management Console must know the IP addresses and community names of each agent.

A device’s community name is, in effect, its password. In many environments, the default read community name is public and the default write community name is private.

To add a new agent entry, complete the following steps:

1. On the Home tab, in the Probe group, click **Setup > Add SNMP Device**.
2. Type the SNMP agent’s information; provide as much detail as possible.
   
   A device’s community name is, in effect, its password. In many environments, the default read community name is public and the default write community name is private.
3. Click **OK** to add the agent entry to Observer and save your changes.

After completing this task:

Repeat this process for every SNMP device on the network. Remember, the overall implementation of SNMP may vary for each SNMP agent on your network, so we recommend you refer to each device’s documentation for more information on configuring and enabling SNMP.

**OIDs**

An Object Identifier (OID) is a unique identifier assigned to a specific object. The identifier consists of a sequence of numbers that identify the source of the object, as well as the object itself. This sequence of numbers is variable in length, so in addition to the sequence of numbers, there is a length field. OIDs are organized in a tree structure; the sequence of numbers identifies the various branches of the subtree that a given object comes from.

The root of the tree is the ISO (International Standards Organization) trunk. Its value is one (1). Each branch below the root further identifies the source of the given object. All SNMP objects are members of the subtree identified by iso.org.dod.internet or 1.3.6.1.

Each additional component further defines the exact location of an object. The numbers for each subtree are assigned by the IETF to ensure that all branches are unique. While it is good to know that OID identification structure exists, in general, OID management is done by SNMP Management Console and no specific OID knowledge is required to use SNMP Management Console.
SNMP Management Station

The SNMP Management Station is a program designed to poll SNMP agents, collect information, and display the collected information in an easy-to-view format. Because each SNMP agent on a network can support a unique MIB, the SNMP management station must load MIB information for all the agents it intends to access. Without this information, the management station cannot make sense of proprietary MIBs and cannot obtain information from their agents.

The management station polling process typically includes the following steps:

- The management station composes an SNMP request that includes one or more MIB objects.
- The management station sends the request packet to an agent, located on a network device.
- The agent receives the request, checks the values of the objects requested, composes a reply packet, and sends it back to the management station.
- In the case of SNMP Management Console, the data is displayed in chart, form, list, or table format.

Through the management station, SNMP agents can provide information to a network administrator without the administrator physically attending to the device.

Almost any network device can be equipped with an SNMP agent. However, because the addition of an SNMP agent typically will increase the cost of the device, many devices are available without the SNMP agent installed. Typical examples of SNMP-aware devices are: routers, network cards, Ethernet and Token Ring switches, network printers, UNIX hosts, NetWare servers, and Windows 2000/XP servers and stations.

Using SNMP Management Console

The SNMP Management Console is integrated into the Observer interface. Make certain that you have the SNMP Management Console Agent List visible.

When Observer is licensed to include SNMP Management Console, the Console is running at all times. To view the Console windows, just click on one of the SNMP agents in the List of SNMP Agents.

When an agent is selected, Observer’s interface turns into the SNMP Management Console interface. You will notice that the menus, button bars, and main display areas change. You can return to the Observer interface by selecting a probe from the List of Probes.

The SNMP Management Console interface is divided into three main sections:

- List of SNMP Agents pane—displays each agent as an icon. Agents are queried by request files that define five types of requests: charts, forms, lists, tables, and traps. When an agent is selected, the requests are displayed in the SNMP Agent Requests pane.
SNMP Agent Request pane—SNMP Agent Requests are shown in this pane. Selecting a chart, form, list, table, or trap will display the associated request output in the Agent Display pane.

Agent Display pane—all data is displayed in one window per agent. Each item (charts, forms, lists, tables, and traps) is selected by the associated tab at the bottom of the Agent window.

Additionally, SNMP agents can be displayed in map format alongside of Observer probes. The map format lets you display graphically (either geographically or topologically) your network layout, including the positions of SNMP agents and the connections between them and Observer probes. You can scan in or draw a map or diagram and place your servers, hosts, and other SNMP agents in their appropriate locations. SNMP Management Console includes a set of bitmaps for different devices, or you may add your own bitmaps for map objects (in Windows BMP format).

SNMP Management Console lets you add, edit, or delete agent entries. When you add a new agent entry, you must associate a request file with it. Assigning a MIB also makes available a set of preconfigured menu requests used to poll the agent for data. A request file defines a set of objects for monitoring from one or more MIB groups. You can remove request items or create and add new request items using the MIB Editor.

SNMP Management Console polls SNMP agents and displays the collected information in a chart, form, list, or table. To accomplish this, the SNMP Management Console creates request packets in SNMP format and sends these packets to agents using the UDP protocol as the carrier. The SNMP packet, often called a PDU (Protocol Data Unit), consists of one or more SNMP objects.

When SNMP Management Console sends an SNMP packet to an SNMP agent, it either asks for information about an object (a Get request), or asks to set the value of an object (a Set request). When the agent receives the SNMP packet, it checks whether the object exists in the agent’s MIB, finds object values, creates a reply packet, and returns the reply packet to the SNMP Management Console.

Because SNMP uses UDP (User Datagram Protocol) to transfer requests and replies, and because the UDP protocol does not require the receiving station to acknowledge receipt of a packet, there is a chance that either the request or reply packet will be lost.

To address this potential problem, SNMP Management Console uses a timeout-retry mechanism. You can specify the amount of time SNMP Management Console will wait before deciding that the request was lost and the number of times SNMP Management Console will resend the packet. When the maximum number of retries is reached and no reply has been received, SNMP Management Console considers the SNMP agent not present, out of order, or turned off, and displays a timed out message in the agent log.

## Using the MIB editor

Observer Suite’s Trace Window (the bottom pane of the Observer main window) shows you any traps it has received, whether or not the trap is included in your request file.

The SNMP agent on the device must send the trap. Refer to the manufacturer’s documentation to determine what traps the device’s agent can send. If the
manufacturer supplies a MIB file that includes the supported traps, you can use that MIB after it has been compiled to drag and drop the traps into your request file. If the manufacturer of the device does not supply a MIB, the standard MIB-2 (supplied with Observer) includes most standard traps and may be useful to you.

The request file lets you set actions (such as emails, pages, or program launches) that are triggered when a trap is received.

To add a trap to a request file, follow these steps:

**Note:** The OID can be searched by its name, but not by its location.

**Tip!** The MIB Editor has two panes: compiled MIBs are displayed in the left pane; request files are in the right pane.

1. On the Home tab, in the Tools group, click **SNMP > MIB Editor**.
2. Select a MIB from the Model Compiled MIBs folder that includes the traps you are interested in.
3. Because the Network Instruments-supplied request files are locked, you must make an unlocked copy of the request file before you can modify it. Right-click the request file and select Copy Model Device Type As from the pop-up menu. A writable copy of the request file will be placed in the request file pane's browser.
4. To easily find all the traps embedded in a particular compiled MIB, right-click on the MIB and choose Find.
5. Check the Find traps only box. Type a search string in the Find what field if you are looking for a particular trap. Otherwise, leave the space blank to find all traps in the MIB. Click Find to list the OIDs of any traps that are found.
6. After you have located the trap or traps you want to include in the request file, click each trap in the compiled MIB pane, and drag it to the appropriate request file's trap section.
7. After you have added all the traps, you can configure them by right-clicking on the trap in the request file pane and choosing Properties Click the Set Triggers tab to configure the trap.
8. Check each box to set the desired action. Click the action (rather than the check box) to display the configuration options for that action (for example, you can enter a pager or email message). The pager numbers and email address for notifications are set in the Observer General Options dialog. Click OK to save the changes when finished.

**Adding triggers based on SNMP chart values**

Observer Suite's SNMP request file format also allows you to set triggers on any SNMP value. For example, if the request file includes a bandwidth utilization chart, you can configure an email alarm to trigger when a utilization threshold has been exceeded.

Observer Suite's SNMP functionality does not just provide read access to SNMP objects. You can use an SNMP form request to manage your network from Observer.

1. To configure a request file chart item to set alarms triggered by SNMP values, open a writable request file and select the chart for which you want to set an alarm. Right-click and choose Properties from the pop-up menu.
2. Double-click on any item in the chart to edit its properties. The Chart Item Properties wizard appears.

3. Click **Next** three times.

4. Check the upper and/or lower threshold you want to set an alarm for, and click the Edit Alarm Response button to set up log, pager, email, or application launch behavior when the given threshold is met. Click **Finish** to return to the MIB Editor. To save your work, right-click on the unsaved request file icon and choose **Save file** from the popup menu. The request file icon changes to show that all edits have been saved to disk.

### Adding, modifying, and deleting SNMP agents

To collect information from your SNMP-enabled network devices, you must add an agent entry for each SNMP agent on your network.

To add a new SNMP agent entry:

- On the Home tab, in the Probe group, click **Setup > Add SNMP Device.**

<table>
<thead>
<tr>
<th>Name</th>
<th>Name that is displayed to the right of the agent icon in the SNMP Agents list. Enter any descriptive name.</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP Address</td>
<td>IP address of the SNMP agent you want to add.</td>
</tr>
<tr>
<td>Device type</td>
<td>A request file based on the RFC1213 standard MIB request file is included with SNMP Extension. Click the <strong>browse (…)</strong> button to browse the desired request file.</td>
</tr>
<tr>
<td>Comment</td>
<td>Allows you to fill in any comment you want here.</td>
</tr>
<tr>
<td>SNMP Version</td>
<td>SNMP Management Console supports both SNMPv1, SNMPv2, and SNMPv3. SNMPv2 includes a superset of the SNMPv1 features. SNMPv3 adds security and encryption to SNMPv2, while remaining backward compatible with SNMPv1 and SNMPv2. Some SNMP devices do not support SNMPv2 and SNMPv3. If in doubt, leave this setting at the default, SNMPv1.</td>
</tr>
<tr>
<td>Security user name</td>
<td>Provide the user name by which Observer will access the agent.</td>
</tr>
<tr>
<td>Context engine ID</td>
<td>The context engine ID uniquely identifies the SNMP entity; check the HEX box if you wish to enter the string as a hexadecimal entry (for example, 80 FF 00).</td>
</tr>
<tr>
<td>Community/ context name</td>
<td>The community name. This is typically public. By convention, SNMP uses the community name and management station IP address the same way login name and password are used in a Telnet (terminal) session.</td>
</tr>
</tbody>
</table>

Some SNMP agents will respond to a menu request only if the management station IP address exists in the agent’s list and if the request contains the proper password.

In SNMPv1 and SNMPv2, the community string provides rudimentary password protection. To remain accessible to any SNMP station, most SNMP agents use the default community name public.

If you do not specify the correct community name (or, in the case of those agents who maintain an IP address table, if your SNMP Management Console IP address is unknown to the SNMP agent), the agent will not respond to your requests. SNMP Management Console will re-send the request until it times out.
If you are polling the SNMP agent for the first time, a failure to respond may be caused by any one, or more, of the following:

♦ The SNMP agent is up and running, but SNMP Management Console is not entered as a management station in the agent’s database.
♦ The community name is wrong.
♦ SNMP services are not enabled on the device.
♦ The SNMP agent’s device is down.

If you have previously successfully polled the SNMP agent, only the last one is possible, unless the configuration of the SNMP agent’s device has changed.

Table 32. SNMP security options

| Apply USM key localization to passwords | USM key localization allows a principle to share unique authentication and encryption key with each remote engine, while maintaining only a single set of keys locally. |
| Authentication protocol menu | Specifies the mechanism used for authentication: noAuth (none), HMAC - MD5, HMAC - SHA1 |
| Authentication password (key) | The password used for authenticating users. |
| Privacy protocol | Specify the encryption method to use when transferring data between the agent and the management console. |
| Privacy password (key) | Specify the password to use when transferring data between the agent and the management console. |
| Authentication time window (seconds) | When messages are delivered outside the time window, SNMPv3 security will not process them. This provides a way of ensuring that previously captured messages are not being replayed. |

Notify on Trap/Alarm:

♦ e-mail address—allows you to enter the e-mail address to send notifications to (from traps or alarms for this agent).

This is a different issue from the IP address (of the computer running Observer with SNMP Extension) to which the SNMP agent itself is to send traps. In this case, you are specifying the e-mail address of the person who is to be notified when a trap message is received by SNMP Extension.

Time to log data (24 Hour Clock):—You can choose to have device data logged all the time, or schedule times to collect and log data on particular days of the week within particular hours.

Keep polling even if not logging Chart Request data—Check this box to have the SNMP agent poll the device even if it is not logging chart request data.

**Using agent information windows**

The information collected from agents by SNMP Extension is displayed, upon request, in an Agent Information Window. When you select an agent entry from the SNMP Agents list, or from the map display, an Agent Display pane opens.

An agent display is an MDI child window. It cannot be moved outside the display area. You can open multiple agent windows simultaneously and tile them in horizontal, vertical, or cascading formats. One window per agent is opened. Select a tiling choice from the Windows menu or click the appropriate tiling choice on the button bar.
The total number of agent windows you can open simultaneously is limited only by your available Windows resources.

Each agent window can display any combination of lists, charts, tables, or forms. Each new list, chart, table, or form creates a new tab at the bottom of the agent window.

When multiple agent windows are open, you can select an active window by selecting it from the Windows menu. The Windows menu also includes commands for arranging icons and closing all open windows.

Agent windows can be minimized (its icon will appear at the bottom of the Agent Display Area) or maximized to completely fill the Agent Display Area. When the agent window is maximized, it will change in size as the Agent Display Area is resized.

Each agent information window contains an Event Log tab that displays the local event log. This window cannot be closed. Errors appear only if the agent is down or malfunctioning. When an agent is down, the Event Log displays a message indicating that SNMP Management Console exceeded the number of retries while attempting to poll the agent. Another type of error is reply packet parsing errors. If these errors appear, either the SNMP agent is malfunctioning or it's sending reply objects not supported by SNMP Extension.

Collecting SNMP agent information

After opening an Agent Information window, you may collect information from SNMP agents for display in charts, lists, forms, or tables. Charts are used for time-dependent information. Lists and tables are used for both time-dependent and time-independent information. Forms display SNMP data in a graphical format.

Collecting chart information

Chart displays are limited to numerical time-dependent information; therefore, MIB objects such as IP addresses, octet strings, hardware addresses, bitfields, enumerated integers, and different constant integers are not candidates for chart requests. In general, three types of variables do not fit well in charts:

- Non-numerical variables that cannot be displayed in any reasonable way in the chart format (e.g., names).
- Constants: change of a value in time (the differential of the value) will always be equal to zero.
- Table objects are not displayed in charts.

Chart requests are created and modified using the MIB Editor. See The MIB Editor (page 210) for details.

To receive chart information from an agent, select the Charts tree item in the SNMP Agent Requests area. Then double-click on the chart you would like to view. This will display the chart in the current agent information window if one is open, or will open a new agent information window if one is not currently running.

When you select a chart request, SNMP Extension begins polling the agent. You can define the length of the request period and define chart display parameters by right-clicking on the chart and selecting Chart Properties. See .
Chart information can be saved from the agent window. You can save the chart data in a file then import it into a spreadsheet program (e.g., Microsoft Excel or Lotus 1-2-3).

Customizing charts

![Note: When changes are made to a chart from the Chart Properties display window, the changes are effective for the present session only. Persistent changes must be made to the chart from the MIB Editor.]

1. When agent information is displayed in chart format, several options are available for customizing the display. To define the following settings, right-click on the chart and select Chart Properties.

Collecting list information

When you request agent information using the list format, SNMP Extension polls the agent once to receive a snapshot of agent objects defined in the list request.

Lists have only one limitation regarding type of object: they cannot display tabular objects. Lists can display text, IP addresses, descriptions, and numeric variables, but not tables.

Lists are best for objects that have a one-to-one relationship. For example: a statistic that does not change, such as SystemName; or a statistic that does not have a variable number of data points, such as RouteMetrics. Tables are best to display items that may have a variable number of responses, such as a list of current connections by IP address.

To receive list information from an agent, select the Lists item in the SNMP Agents request area, then select the List tree item you wish to view.

List requests are created and modified using the MIB Editor.

When you select a list menu request, SNMP Management Console sends the request to the agent and (if the agent is running and configured properly) receives a reply, which can be viewed in the list display in the agent information window. If necessary, SNMP Extension will re-send the request.

Read Values Display

Some objects in the list are writable, which means you can use SNMP Management Console to set the value of the object remotely. Writable objects display [RW] in the Access column of the display. Read-only objects show [RO] in the Access column.

Writable Object Setting

To define a setting for a writable object:

1. Select the writable object entry in the agent window.
2. Enter or select a new value for the object in the box that is displayed at the bottom of the window.
3. Click the Set button. SNMP Management Console sets the value of the writable object and repeats the original request to make sure that the value was changed.
4. The updated list information will be displayed.

After completing this task:
Collecting SNMP agent information

Depending on the type of table and the constraints imposed by the agent MIB design, you may be able to change the values of writable table objects, add additional lines to the table, or both.

Collecting forms information

Forms are SNMP Management Console's way of displaying SNMP data in a flexible graphical format. Forms can be groups of items that show objects in a clean, colorful formatted view; bitmaps of devices with ports that change color, depending on the value of the SNMP response; or multiple choice writable SNMP lists for configuring a server.

Any type of SNMP object can be placed on a form. Each object’s display format can be adjusted to meet the needs of your display requirements. Example forms include an IP route form that allows you to view or set the status of multiple IP routes from the devices route table, or a System Information form that lets you set certain system information writable objects.

To modify the sampling behavior of a form, right-click on the form and select Form Properties. The Form Properties dialog will be displayed.

Forms are created and modified using the Forms Designer in the MIB Editor. List requests are created and modified using the MIB Editor.

Collecting table information

SNMP tables are collections of different types of objects. Picture the SNMP table as a spreadsheet. Each row contains fields of data related to an object. Access to the SNMP MIB table is similar to reading the spreadsheet row by row.

SNMP works in the following way: SNMP Extension requests the values of all or some objects from the first line in the SNMP MIB table. After receiving a reply, it displays the values in the table and requests information for the next line. SNMP Extension continues to collect information row by row until it reaches the end of the table. This process is called traversing the table in SNMP terminology.

To receive table information from an agent, select the table tree item in the SNMP Agent Request area, and double click on the table you wish to view.
Tables are created and modified using the Forms Designer in the MIB Editor. List requests are created and modified using the MIB Editor.

**Read Values Display**

SNMP Extension will read the table and display the values of the table objects line by line. Tables can contain more than one writable object. Writable objects display [RW] in the Access column of the display. Read-only objects show [RO] in the Access column.

**Traps**

An SNMP device may be configured by its manufacturer to send trap messages which notify the SNMP management station (in this case, SNMP Extension) of certain conditions. Unlike get and set requests, a trap message doesn’t require a request from SNMP Extension. It’s sent by the device automatically when there is an error, a certain level of activity, or other condition. SNMP Extension collects incoming trap messages constantly.

Trap and trap message are used interchangeably.

To receive trap messages with SNMP Management Console, SNMP Management Console's IP address must be included in the trap configuration table of the SNMP agent. Trap configuration is usually separate from general SNMP configuration.

If you configure one but not the other, you may be able to poll the SNMP agent, but receive no trap messages.

The SNMP agent doesn’t expect confirmation for trap messages. If the message doesn’t reach its destination, SNMP Management Console has no way of knowing the message was sent, and the agent has no way of knowing whether a message was received.
Under normal circumstances most of the trap messages do reach their destinations. The limitation of traps comes from the lack of verification capabilities built into the relevant RFC specifications.

The MIB Editor

The MIB Editor is where MIBs are compiled and MIB objects are placed in requests to create SNMP Management Console lists, charts, tables, forms, and traps.

- MIB—a MIB is a text file in Abstract Syntax Notation One (ASN.1) format, which describes in a structured way the objects an SNMP device supports.
- Compiled MIBs—a compiled MIB is a binary file created from a MIB file in preparation for creating requests to be submitted to an SNMP agent.
- Device Types (Requests)—a request file is the actual file sent to an SNMP agent, polling and/or setting the states of various MIB objects or OIDs.

The MIB Editor displays compiled MIBs on the left pane of the window and request files on the right pane. Both compiled MIBs and requests are displayed in a familiar Windows tree format. The MIB Editor is used to compile MIBs and create/edit requests.

Understanding a MIB file

MIBs are text files that the creator of an SNMP agent provides to describe the variables the particular agent keeps track of. These variables are called SNMP objects.

Often, in the context of SNMP, they are simply referred to as objects.

MIBs have a very specific structure for the organization of objects; any SNMP management console (SNMP Management Console in this case) can use the MIB to form queries of the SNMP agent on a specific device. MIBs are supplied by the manufacturer of the device.

There are two logical sets of statistics that every agent (in theory) should keep track of:

- The standard MIB-2 (RFC1213) set or MIB-1 (RFC1066), and
- Any proprietary MIB(s) objects.

SNMP is structured this way so that each device can offer standard (MIB-1/2) data that would be common between all network devices (e.g., packets in, packets out), and data that is device-specific (like number of sheets printed on a network printer). MIB-2 is a superset of MIB-1. Sometimes these two sets of MIB objects are combined into one MIB file. Other times you may find that the manufacturer only provides you with a proprietary MIB and expects you to use the RFCMIB-2 (or MIB-1) to view the standard data objects. Unfortunately, there are manufacturers that only offer a subset of objects in the standard MIB(s). In these cases, you can ask the agent for the objects that are missing, but the agent will not respond.

All SNMP agents keep track of some or all of the objects in the standard MIBs (MIB-1 or MIB-2). If you do not have access to a proprietary MIB for your device, you may be able to get all the information you require from the standard MIBs.
Understanding a Request file

A request file is built within SNMP Management Console to organize, group, and define specific SNMP requests that may be made of an agent.

Each request can be for one or more SNMP objects, and the response to the request may be displayed in list, chart, table, or form format. A number of request files come with SNMP Management Console, but in general, request files are built by you to suit your specific needs with regards to the matrix that your site needs to collect.

When SNMP Management Console polls an SNMP agent for information, a request allows it to receive information about many different objects simultaneously. You can create your own requests (or edit the requests provided) using the MIB Editor.

Compiled MIBs

SNMP Management Console compiles the MIB prior to using it to create requests. This is done to save on memory when parsing request responses and to make drag-and-drop request building faster.

Your path to begin building requests (lists, charts, tables, or forms) will begin by determining whether SNMP Management Console includes a suitable MIB for your device.

If you have a specific MIB that was included with your device, you should begin by compiling the MIB. See Compiling MIBs below.

If you do not have a specific MIB for your device and the device is not listed on the list of MIBs, you can still use the standard MIBs to create requests for that device. In that case, you will use the standard RFC1213 or RFC1066 MIB to build your requests.

Compiling MIBs

Prior to building a request, you may need to compile a MIB. You will need to do this if you have a MIB that was distributed with your device or have received a new MIB for a device. If you don’t have a specific MIB for your device and want additional information on what the standard MIBs provide, you must obtain a MIB from the manufacturer.

Once you have the MIB, you compile it using the MIB Editor. Compiling the MIB is not much more complicated than opening a file. However, some companies do not strictly follow the MIB file format, so you may need to modify the MIB text file. Also, after compiling the MIB file, you must create your own requests.

The MIB Compiler parses MIB text files and converts them into a format that can be used by SNMP Management Console and its utilities. The MIB Compiler is used when you don’t have a pre-compiled MIB for a particular SNMP device. You may also need to use the MIB Compiler to recompile a MIB after editing the device MIB file (for example, to correct an error in a manufacturer-supplied MIB file) or to update a manufacturer-supplied MIB file for a new device.

The MIB Compiler expects ASN1-formatted MIB text files which have the MIB Management Console (e.g., RFC1213.MIB).
ASN.1 (Abstract Syntax Notation One) is the standard way, defined by two ISO (International Organization for Standardization) standards, to describe a message that can be sent or received in a network.

ASN.1 is defined in two different places:

The rules of syntax for describing the contents of a message in terms of data types and content sequence or structure is defined by the ISO 8824/ITU X.208 standard.

How you actually encode each data item in a message is defined by the ISO 8825/ITU X.209 standard.

The compile process

1. On the Home tab, in the Tools group, click **SNMP > MIB Editor**.
2. Select Compile MIB Source File. This opens the Import MIB Source dialog, which lets you select a file to compile.
3. Select the MIB file (*.MIB) you wish to compile. The Save Compiled MIB As dialog will be displayed.
4. Insert the desired file name and click the **Next** button.
5. The MIB will be compiled and the resulting file (with a .MIC extension) will be placed in the Program Files\Observer\SNMP directory.
6. Once the MIB is successfully compiled, it will be automatically listed in the MIB Editor with the other compiled MIBs.
7. Should the compiler have problems compiling your MIB, the compiler will exit to the MIB Editor and the log will display the errors, listing which MIB line caused the error. Click the **Edit Source** button to edit the MIB file and correct the error.
8. After correcting the error, simply compile the MIB again. If there are any further errors, the compiler will stop again. Repeat until the MIB successfully compiles.

Building Expressions

Expressions permit you to take SNMP agent data and derive useful mathematical results.

Raw data that SNMP Management Console receives from SNMP agents can be very useful but, often it's only the starting point. An SNMP agent on a switch may keep track of the number of data packets the switch has received, the number of packets it has discarded, and the number of packets it has passed along. However, the network administrator may be more interested in the percentage of packets discarded since this may signal a problem with the system.

1. To create a new expression, from the MIB Editor, click on Expressions, then select **Mode Commands > New Expression** or right-click and select New Expression.
2. From the left pane of the MIB Editor, select any MIB objects that you intend to use in the expression and drag-and-drop them on the new expression.

There may be a slight performance penalty caused by including unnecessary MIB objects in an expression. In terms of system efficiency, it's best to add only those you need. If you find you need additional MIB objects to create
your expression, you can easily add them at a later time by the same drag-and-drop method.

3. Right-click on the new expression to rename it, if desired.

4. Right-click on the renamed expression and select Edit Expression to display the Modify Expression dialog.

Figure 59: Edit Expression

The Modify Expression dialog box is, in effect, a numeric calculator, permitting the creation and modification of mathematical expressions using selected MIB objects, constants, and mathematical operations.

5. Numbers can be entered from the keyboard; mathematical functions can be entered either via the keyboard, or from the buttons of the dialog. The Insert MIB Object button can be used to insert MIB objects that have been dragged to the expression.

6. Click OK to save the edited expression.

Now that the new expression has been built, it can be used in a chart.

Adding new MIB objects and traps to request files

Rather than re-compiling a MIB to add a new object or trap, sometimes it is convenient to add new items to a MIB that is already compiled.

The SNMP MIB editor lets you accomplish this by right-clicking on objects in the request file pane (right side of the MIB editor) and choosing the appropriate option from the pop-up menu.

Once you have created the new object or trap in the request file, you can simply drag the item from the request pane to the compiled MIB pane (left side of the MIB editor).
Adding a new MIB object

This section describes how to add a new MIB object and the MIB Object Properties.

1. To add a new MIB object to a request file, right-click on the request to which you want the object added, and select New MIB Object from the pop-up menu.
2. ID—The Object ID (O.I.D.) of the object you wish to add.
3. Name—A descriptive name for the MIB object.
4. Object Type: The data type of the object (i.e. Integer, counter, etc.). Choose an option from the drop-down menu.
5. Access—Define whether the object can be changed. Choose an option from the drop-down menu.
6. Enumerated values—For MIB objects of type Integer, define the possible values for the integer by clicking the Add (or Edit) buttons to the right of the Enumerated Values table. A dialog is then displayed that allows you to define and label the enumerated value.
7. Description—A free-form text description of the object.
8. Absolute value—When selected the current absolute value is used, otherwise the delta between the current poll and the previous poll is used.
9. After you have filled out all of the fields appropriately, Click OK to add the new MIB object to the compiled MIB.

Adding a Trap

1. To add a trap to a compiled MIB, right-click on the Trap branch of the MIB to which you want to add a trap and choose New Trap from the pop-up menu.
2. The New Trap dialog is displayed
3. Fill out the fields as described below:

<table>
<thead>
<tr>
<th>Name</th>
<th>A descriptive name for the trap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>An integer specifying the generic trap type. How an integer is interpreted is defined by the MIB.</td>
</tr>
<tr>
<td>Enterprise OID</td>
<td>The trap’s base Enterprise Object Identifier.</td>
</tr>
<tr>
<td>Enterprise Name</td>
<td>The name of the last node in the OID chain of the compiled MIB.</td>
</tr>
<tr>
<td>Variables</td>
<td>List the variable data fields bound to the trap, separating variable names with a comma. These are for user reference only</td>
</tr>
<tr>
<td>Reference</td>
<td>Optional textual cross-reference to a trap, event, or alarm, defined in some other document or MIB module.</td>
</tr>
<tr>
<td>Description</td>
<td>A free-form text description of the trap.</td>
</tr>
</tbody>
</table>

Using the MIB Walker

SNMP MIB Walker lets you walk a MIB to determine what objects it contains.

To do this, choose Tools > SNMP MIB Walker.

The MIB Walker automatically browses through the hierarchy of an SNMP Management Information Base (MIB) and displays what objects it contains.
To open SNMP MIB Walker, select Tools > SNMP MIB Walker. If this is the first time you have run the mode, the setup screen is displayed, which allows you to select and configure MIB Walker profiles:

Select a device or click New Device to configure a new device. The MIB walker profile creation dialog includes the following controls:

After you have a profile (or multiple profiles) defined:

1. Select a MIB Walker profile.
2. By default, the initial OID for the walk will be 1.3.6.1.4.1. If you prefer to have your MIB walk begin from another OID, enter it in the Initial OID or use the drop-down arrow if you have recently used another starting point.
3. 1.3.6.1.4.1 is the root of the proprietary part of the MIB tree. A walk from 1.3.6.1.4.1 will give you information on the proprietary OIDs. To get information from the standard OIDs, start the walk at 1.3.6.1.2.
4. Click the Start button to start.
5. SNMP Extension’s MIB Walker will step through all higher branches of the MIB tree (starting at the initial OID) and display the results in the Walk Network Device MIB Table Viewer.

<table>
<thead>
<tr>
<th>Profile name</th>
<th>Choose a name that is descriptive enough to be meaningful to you later.</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP Address</td>
<td>Allows you to enter the IP address to be used for the profile.</td>
</tr>
<tr>
<td>Community</td>
<td>Allows you to enter the community for the profile (public or private).</td>
</tr>
<tr>
<td>SNMP version</td>
<td>Allows you to select the SNMP version.</td>
</tr>
<tr>
<td>Initial OID</td>
<td>Allows you to enter the initial OID.</td>
</tr>
<tr>
<td>Comment</td>
<td>Allows you to enter comments regarding this walk.</td>
</tr>
<tr>
<td>Choose existing SNMP devices button</td>
<td>Allows you to pick an SNMP device to create a MIB profile from a list of SNMP devices that have already been defined in or discovered by Observer.</td>
</tr>
</tbody>
</table>

### Viewing the MIB tree

Selecting the View Tree button from the Walk Agent MIB dialog displays the Walk Agent MIB Tree Viewer. The Walk Agent MIB Tree Viewer displays the structure, although not the values, of the discovered MIB tree.

### Setting values

One of the main uses of the MIB Walker and the Walk Agent List Viewer is to permit you to explore the SNMP agent by setting values to see what effect different values have on the actual device and to be sure that objects are writable.

1. To set a value, double click any object on the Walk Agent List Viewer. The Set Value dialog will be displayed. Before attempting to make any changes, note the present value, so that you can restore the device to its original state.
2. Type an appropriate real or test value into the Value box.
3. Click the Set Value button. SNMP Extension will attempt to set the given OID to the entered value.
4. If the attempt to set the value succeeds, the dialog box will be redisplayed with the Status line reading Done. Be careful to use the proper type of value when setting the value. If you attempt to set an integer SNMP value to a character string (e.g., Bob) it will be set to zero.

5. If the attempt to set the value fails, an error dialog will be displayed, and the Status line on the Set Value dialog box will read Failed instead of Done.

After completing this task:

Failure can happen for one or both of two reasons:

- The MIB object you are attempting to set is Read-Only and cannot be reset, or
- You do not have the proper read-write community name for this device.

**SNMP MIB Walker**

The MIB Walker is accessed by selecting an SNMP device from the SNMP Agents pane and clicking Tools > SNMP MIB Walker.

1. To walk an agent MIB, right-click on the desired SNMP Agent in the SNMP Agent pane and select Walk Network Device MIB.

2. By default, the initial OID for the walk will be 1.3.6.1.4.1. If you prefer to have your MIB walk begin from another OID, enter it in the Initial OID or use the arrow if you’ve recently used another starting point. Note that 1.3.6.1.4.1 is the root of the proprietary part of the MIB tree. A walk from 1.3.6.1.4.1 will give you information on the proprietary OIDs. To get information from the standard OIDs, start the walk at 1.3.6.1.2.1.

3. Click the **Start** button to start.

4. SNMP Management Console’s MIB Walker will step through all higher branches of the MIB tree (starting at the initial OID) and display the results in the Walk Network Device MIB Table Viewer.

**SNMP technical overview**

Simple Network Management Protocol (SNMP) was proposed in 1988 as a set of Requests for Comments (RFCs) defining the basic principles and implementation for a protocol that would establish a standard for Internet monitoring and management, as a replacement for the myriad of vendor-specific network management solutions available at the time.

Since then, SNMP has gained considerable popularity. Although it hasn’t replaced all proprietary solutions, it has become a widely accepted standard for network management. Subsequent RFCs for SNMP have corrected problems and supplemented the original standard Management Information Base (MIB).

The standard MIB, defined by RFC1213, defines numerous objects in ten groups—system, interfaces, address translation, IP, ICMP, TCP, UDP, EGP, transmission, and SNMP.

However, manufacturers are constantly adding capabilities to their products, and some of them are not covered by the standard objects and groups. To bring the benefits of SNMP monitoring and control to additional features, software and hardware vendors have developed proprietary MIBs.
Most major computer hardware manufacturers now offer lines of networking products that support SNMP, including network cards, hubs, bridges, routers, switches, and printers. Because adding an SNMP agent to network hardware often increases the price of the product, manufacturers usually offer versions with and without SNMP support.

Most operating systems, including UNIX and Microsoft Windows systems, implement SNMP agents in their architecture.

In early 1990, the original SNMP specifications were revised and updated. New MIB groups were added and some old MIB objects became obsolete. In general, the new MIB specification, called MIB II (or MIB-2) is compatible with the original MIB, now called MIB I.

By the end of 1991, the standard SNMP MIB specification was extended by the Remote Network Monitoring MIB (RMON). RMON provides a set of SNMP objects related to network analysis and monitoring. Information provided by RMON is somewhat different in scope from the typical SNMP information provided by network devices. Usually, a device collects information about the device itself, in connection to either operation of the device or its relationship to the network. The RMON agent, on the other hand, attempts to collect information about network traffic to and from other devices on the network (aside from the agent device), including network statistics, history, information about hosts on the network, connections, and events. An RMON agent can set filters and capture traffic to and from specific devices on the network.

Security concerns related to SNMP prompted development of a secure SNMP called S-SNMP, and the first S-SNMP RFCs appeared in mid-1992. S-SNMP adds security enhancements to the original SNMP protocol but does not offer any additional functionality. S-SNMP is not compatible with the original SNMP.

About the same time, a considerable design effort focused on enhancing the SNMP protocol, incorporating the security features provided by S-SNMP and adding new MIB functionality. The result of this effort is SNMP Version 2, or SNMPv2.

SNMPv2 was not received enthusiastically by many software and hardware vendors. Many had devoted considerable effort to the development of SNMP MIB I and MIB II agents, and in many cases security was not important for users. Most agents currently provided by vendors are SNMP MIB II, not SNMPv2.

SNMP MIB II with proprietary functionality is currently the defacto standard among SNMP users. This overview addresses the general principles of SNMP without addressing the details of SNMPv2.

General principles

SNMP is designed around the concept of a relationship between a management station and managed agents.

A management station is the location where a network administrator can view, analyze, and even manage local network devices. A management station can be a dedicated computer or workstation, or software running on a general-purpose workstation—like a personal computer running SNMP Extension on Windows 2000/XP.

An SNMP agent is a program that runs on the managed device. It collects information about device operation. For example, if the object is a TCP/IP router,
the agent can collect information about network traffic passing through the router and information about the behavior of the router itself under different load conditions.

The SNMP agent maintains a database called the Management Information Base (MIB). The agent uses the MIB to track and systematically update data. Information in a MIB is organized in a tree structure. Each piece of data can be considered a leaf on various branches of the tree. Individual pieces of data are called data objects.

When the management station needs information from an SNMP agent, it sends an SNMP request. SNMP specifications allow the station to ask for more than one MIB object in a single request.

When the SNMP agent receives the request, it searches its local MIB, finds the current values of the requested data, forms a response packet (PDU), and sends the PDU back to the management station.

The management station receives the PDU, decodes it from the SNMP PDU format, and displays the information as a list or in a graphical format that allows the network manager to view, analyze, and modify the information.

The following sections review the concepts above in more detail.

**SNMP MIB objects, groups, and addresses**

A MIB is a set of SNMP objects organized in a tree address structure. Each object in a MIB has a unique address called an object identifier, and each branch on the tree is identified by a number.

The ISO 8824 specification defines the lower branches of the SNMP MIB tree as: iso(1).org(3).dod(6).internet(1) or, as expressed in Structure of Management Information (SMI) language, 1.3.6.1 (see illustration).

The SNMP tree resides under the Internet subtree. Four branches after the Internet subtree can be used by SNMP: The directory(1) subtree is reserved for future use by OSI.

- The mgmt(2) subtree includes standard SNMP MIBs I or II (RFC1156 and RFC1213).
- The experimental(3) subtree is reserved for Internet experiments.
- The private(4) subtree provides space for vendor-specific MIBs. All private MIBs are located under enterprises(1) branch. Any private object ID (OID) should begin from the base address 1.3.6.1.4.1.

The address 1.3.6.1.2.1 or iso.org.dod.internet.mgmt.mib represents the address of the standard SNMP MIB I or II on the ISO tree. Inside the MIB branch, SNMP objects are organized beneath higher level branches called MIB groups. Because of the large number of objects—the standard MIB II includes almost two hundred —MIB groups have been created to simplify addressing. Groups consist of related objects: for example, ICMP, TCP, EGP, and other statistics object groups.

The object address is the path from the MIB’s root to an object. For example, the object sysDescr in the MIB(1) System Group has the address 1.3.6.1.2.1.1.1 (see illustration).
Types of SNMP MIB objects

SNMP objects accommodate many different types of data in the tree structure, including numbers, text, addresses, bitfield assigned descriptions, and object IDs. Two specifications are used to describe the MIB objects: Abstract Syntax Notation One (ASN.1) and Basic Encoding Rules (BER).
Chapter 14: Integrating Observer with HP OpenView or Tivoli

Integrating with IBM Tivoli NetView

Some third-party applications integrate with Observer especially well, and this section describes how to configure them to work in tandem with Observer.

1. On the system running Observer, find and copy the NETINST-MIB.MIB in C:\Program Files\Observer\SNMP to the system running NetView.
2. On the NetView system, in NetView choose Tools > MIB > Loader, then click Load and choose the NETINST-MIB.MIB file. Click Load again and the file appears on the Loaded MIBs list in that window.
3. Choose Options > Trap Settings, then select NETINST from the Enterprise list.
4. Click the New button, and provide input for the New Trap dialog.
   - Trap Type—Default
   - Trap Name—choose a name like NIEvent or NICriticalEvent
   - Event Description: $A $12 $4

After completing this task:
See the NetView help for an explanation of these and other available parameters for Event Description.

Integrating with HP OpenView

All Observer -family analyzers include the tools you need to integrate Observer into Hewlett-Packard’s OpenView administrative interface. This will allow you to see and control Observer -equipped PCs from the HP OpenView administrative interface.
Observer’s HP OpenView integration is compatible with any currently supported version of HP OpenView Network Node Manager (NNM). You must install Network Node Manager from HP OpenView before you can install the Observer integration support files.

To install the Observer support files for HP OpenView integration, simply copy the contents of the NNM directory (located in the HPOV_Integration directory within the Observer installation directory) into the HP OpenView’s NNM directory:

1. Browse to the C:\Observer Files\HPOV_Integration directory (or wherever you installed Observer) and right-click on the NNM directory. Choose Copy from the popup menu.
2. Browse to the HP OpenView directory (by default, this will be in the Windows Program Files\HP OpenView directory). Right click and choose Paste from the popup menu. This merges the contents of Observer’s NNM directory with HP OpenView’s NNM directory.

The next time you start HP OpenView’s Network Node Manager, you can perform the following Observer functions from within HP OpenView:

3. Launch Observer from HP OpenView’s Tools > Observer menu.
4. Associate an Observer probe instance with the current NNM map. Because Observer may have multiple probe instances, it is necessary to define which Observer probe instance to use when setting filters and capturing packets on a particular map. You will be prompted to define the association the first time you try to set a filter or capture packets. In subsequent sessions the association is remembered.
5. Associate the currently selected network interface object with an Observer probe instance. As a rule, multiple interface objects within an NNM map should be associated with separate Observer probe instances.
6. Set up a filter based on the currently selected node (or pair of nodes, or on the network interface object) from within HP OpenView. This is useful if you want to add additional filter rules (such as filtering for errors) on the NNM-managed nodes. After setting up the filter, you can start capturing the desired packets.
7. Start an Observer packet capture immediately on a network node (or pair of nodes, or on a network interface object) by selecting the object(s) from the NNM map and choosing the corresponding Observer integration menu item. This sets up the correct filter rules and automatically starts the packet capture.

After completing this task:

The packet capture and filter options are also accessible by right-clicking on a NNM network device or interface object. You can also associate a probe instance with a network interface or the NNM map through the right-click menu. If you right-click on an NNM object when multiple objects are selected, the menu actions will only apply to the object that you right-clicked on. To capture packets or set up filters on pairs of devices, select the devices and use the Tools > Observer menu.
Chapter 15: Observer Suite Custom Decode Kit

Using the Custom Decode Kit

The DLL code can be built using the Microsoft Development Studio C++ compiler. The DLL entry points are of extern C type for maximum compatibility.

You can use any other C or C++ compiler as long as the entry point API function definitions are preserved intact and the functions are explicitly exported in a .def file.

A new decode DLL can be renamed to something other than CustomDecode.DLL by changing the output module name and a LIBRARY name in the CustomDecode.DEF file. It is necessary to use multiple, distinct names if Observer Suite is going to use multiple decode DLLs.

Currently, Observer Analyzer supports up to eight (8) simultaneously loaded custom decode DLLs.

The code can be written in generic C++ or the programmer can create a DLL project with MFC support and include in it CustomDecode.cpp, CustomDecode.h, CustomDecode.def, UserDefinedFunctions.cpp and UserDefinedFunctions.h. In this case, it will be necessary to name the project something other than CustomDecode and to delete the DllMain() function code from CustomDecode.cpp file.

Introduction

Prerequisite: Observer Suite

Observer Suite’s Custom Decode Kit gives an experienced C++ programmer the ability to add custom, proprietary, or additional protocols to Observer decodes.
The Custom Decode Kit is provided as a Microsoft Development Studio v6.0 C++ project. This project should be used as an example and template.

The Custom Decode Kit is an add-on for Observer Suite and is not available with the basic Observer or Real-Time Expert products. To upgrade your Observer to the Observer Suite, please contact your Network Instruments’ sales representative, dealer, or distributor.

**Warranty**

The Custom Decode Kit is provided as is and without any warranty. VIAVI does not give technical support for the Custom Decode kit, instruction in C++ programming, or training on how to use the Custom Decode Kit.

**Installation**

To install the Custom Decode Kit, run CustomDecodeKit.exe. This will, by default, be found in the `C:\Program Files\Observer\Drivers\CustomDecodeKit` folder. Specify the location where you want to install the Custom Decode Kit. By default, it will install to `C:\CustomDecodeKit`

Run Microsoft Development Studio and open the Custom Decode project.

**How the Custom Decode API Works**

The Custom Decode API provides an interface that displays custom decodes in the decode module for Observer. A custom decode is inserted in the protocol decode window (the middle pane in the Decode and Analysis window).

The purpose of the Custom Decode DLL is to add lines to the Tree Control in Decode and Analysis.

The Custom Decode DLL entry point functions: CustomDecodeFrame(), CustomDecodeIP(), CustomDecodeUDP(), and CustomDecodeTCP() are called from Observer to permit a programmer to add a custom decode.

For example, if you decide to write a decode for UDP port 8765, when your CustomDecodeUDP() function is called, you have to check in the UDP header whether or not the port is 8765.

If it is, you do your decode, adding lines to the Tree Control in a way similar to the CustomDecode sample project. When you are finished, you return TRUE from CustomDecodeUDP().

If the port is not 8765, just return FALSE from CustomDecodeUDP() and Observer will perform the default processing. See the Custom Decode sample project code for more details.

**Files Included**

The CustomDecode project includes the following files:

*CustomDecode.cpp, CustomDecode.h, and CustomDecode.def*

These files include four entry point functions, defined as follows:

```plaintext
//decode starting at a frame protocol header
extern C BOOL FAR PASCAL CustomDecodeFrame
void * pFrameStart,
void * pProtocolFieldStart,
```
long nProtocolLength,
long nOffsetFromBeginningOfPacket,
long nBitmapLevel,
DWORD dOpenTreeList,
HWND hwndTree,
void * pPrintStruct);
//decode starting after IP protocol header
extern C BOOL FAR PASCAL CustomDecodeIP ( 
void * pIpHeaderStart,
void * pIpDataStart,
long nIpDataLength,
long nOffsetFromBeginningOfPacket,
long nBitmapLevel,
DWORD dOpenTreeList,
HWND hwndTree,
void * pPrintStruct);
//decode starting after UDP protocol header
extern C BOOL FAR PASCAL CustomDecodeUDP ( 
void * pUdpHeaderStart,
void * pUdpDataStart,
long nUdpDataLength,
long nOffsetFromBeginningOfPacket,
long nBitmapLevel,
DWORD dOpenTreeList,
HWND hwndTree,
void * pPrintStruct);
//decode starting after TCP protocol header
extern C BOOL FAR PASCAL CustomDecodeTCP ( 
void * pTcpHeaderStart,
void * pTcpDataStart,
long nTcpDataLength,
long nOffsetFromBeginningOfPacket,
long nBitmapLevel,
DWORD dOpenTreeList,
HWND hwndTree,
void * pPrintStruct);

In addition, the files include helper functions used in the user-defined sections of
the code.

UserDefinedFunctions.cpp and UserDefinedFunctions.h

These files include the user code. They contain implementation functions that
map all four functions onto user modifiable functions. They also contain a very
simple example decode in the SimpleDecodeSample() function.

StdAfx.cpp and StdAfx.h

These are the standard Microsoft Development Studio AFX files.

Only an experienced C++ programmer should modify any of the source files in
the Observer Suite Custom Decode Kit.
Chapter 16: Probes and Probe Instances

About Probes and Instances

Discover the basics of probes, probe instances and what type is right for you, and how probes work with switches.

As a network administrator, when something goes wrong on your network, seeing what is happening on the wire can quickly lead you to a solution. Use this guide to assist you with choosing, deploying, configuring, and using your probes. The probes, along with Observer software, let you see all traffic on the network to which it is connected. To monitor multiple networks from a single analyzer, probes must be installed at every point where network visibility is required.

Probes collect and report network traffic and statistics (usually from a switch) to an Observer. This enables you to detect and anticipate problems on both local and remote portions of the network. Probes gain insight and visibility into every part of the network, access remote networks as easily as local networks, eliminate the time and expense of traveling to remote sites, and speed troubleshooting.

A probe is a hardware device on your network running VIAVI probe instance software. Each hardware probe has at least one probe instance that captures packets from your network to analyze. The probe hardware device could be an appliance purchased from VIAVI or you could install the probe software on your own hardware.

The probe can be located on the same system as the analyzer (every Observer includes a “local probe”), or the probe can communicate with remote analyzers over TCP/IP.

Probes monitor the following topologies:
- 10/100 Mb, 1/10/40 Gb Ethernet (half- and full-duplex)
- Wireless (802.11 a/b/g/n)
shows how probes provide visibility into your network. It may be obvious, but it also shows that you cannot see traffic on portions of your network where you do not have a probe. Finally, you can put Observer anywhere on your network so long as it has TCP connectivity to the probe.

Figure 60: Typical network

What is a probe instance?

Observer has only one kind of probe instance: the probe instance. If you have a GigaStor then you have two special probe instance types available to you: the active probe instance and the passive probe instance.

Observer uses probes to capture network data. In some cases you may want or need more than one probe in a specific location. You can achieve that through probe instances. A probe instance provides you the ability to look at multiple network interfaces, have multiple views of the same interface, or to publish to multiple Observer.

Table 33 (page 226) compares the features of active and passive probe instances with an Observer probe instance found on all non-GigaStor probes.

Table 33. Active vs. passive GigaStor instances and Observer probe

<table>
<thead>
<tr>
<th>Better suited for troubleshooting</th>
<th>GigaStor Active probe instance</th>
<th>GigaStor Passive probe instance</th>
<th>Observer Probe</th>
</tr>
</thead>
<tbody>
<tr>
<td>Better suited for data capture</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Start packet capture</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Stop packet capture</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Start GigaStor packet capture</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Schedule packet capture</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Change directories where data is stored</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>GigaStor Active probe instance</td>
<td>GigaStor Passive probe instance</td>
<td>Observer Probe</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------------------------</td>
<td>--------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Able to set permissions</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Able to redirect to different analyzer, etc.</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

1. An Observer probe is the Single Probe, Multi Probe, or Expert Probe software running on a non-GigaStor probe.

A passive probe instance may capture packets to RAM and allows you to do reactive analysis or look at real-time statistics for troubleshooting. The passive probe instance binds to a virtual adapter or a network adapter that has data coming to it that you want to capture. You can change whichever adapter a passive probe instance is bound to without affecting any active probe instance. By default a passive probe instance uses 12 MB of RAM. You can reserve more memory for passive probe instances if you wish.

**Caution:** With a GigaStor you have the option of which NIC to bind the passive probe instance. Do not bind any passive probe instances to the capture card adapter if at all possible. A copy of all packets is sent from the adapter to every passive probe instance attached to it. If you have several passive probe instances attached to the capture card adapter, the capture card’s performance is significantly affected. Instead attach the passive probe instances to either a 10/100/1000 adapter or to a non-existent one.

If you have a passive probe instance connected to a GigaStor, you can mine data that has already been written to the RAID disk by using an active probe instance. There should be one passive probe instance for each simultaneous Observer user on a GigaStor. By using a passive probe instance, instead of an active probe instance, only one copy of data is being captured and written to disk, which reduces the processor load and the required storage space. For troubleshooting and most uses in Observer passive probe instances are appropriate.

An active probe instance on a GigaStor captures network traffic and writes it to the RAID array. An active probe instance should have as large of a RAM buffer as possible to cushion between the network throughput rate and the array write rate. Like a passive probe instance, it can also be used to mine data from the hard disk, however a passive instance is better suited for the task. An active probe instance cannot start a packet capture while the GigaStor Control Panel is open.

By default there is one active probe instance for GigaStor. It binds to the network adapter and its ports. If you have a specific need to separate the adapter’s ports and monitor them separately, you can do so through passive probe instances or you can create separate virtual adapters.

- Only one active probe instance per GigaStor.
- Set scheduling to Always for the active probe instance so that it is constantly capturing and writing data. Use a passive probe instance to mine the data.
- Do not pre-filter, unless you know exactly what you want to capture. Of course, if something occurs outside the bounds of the filter, you will not have the data in the GigaStor.
- Do not allow remote users access to the active probe instance.
Figure 61 (page 228) shows how one active probe instance captures and writes to the GigaStor RAID. Passive probe instances 1 and 2 mine data from the RAID array. As a best practice, the passive probe instances are bound to the slowest network adapter in the GigaStor.

Additionally, passive probe instance 3 and 4 are each capturing packets separate from each other and separate from the active probe instance. However, since they are also bound to the same adapter as the active probe instance, they are capturing the same data as the active probe instance.

**Which software probe is right for you?**

Software probes are an economical choice for many situations.

For companies that cannot invest in dedicated hardware probes, Observer Platform software probes provide a low-cost monitoring option and are easy to install and configure. Software probes support Ethernet, Gigabit and wireless and are appropriate for analyzing speeds of up to 1000 Mbps or for low-utilization gigabit networks via a SPAN/mirror port on a switch. The Observer software can handle fast network speeds (including 40 Gigabit), but it is the network adapter that is the bottleneck on home-grown systems. VIAVI uses a custom-designed network adapter removing the bottleneck in our probes. These levels of software probes are available:

- Single probe—Single probes have only one probe instance and it is not user-configurable. Single probes are appropriate for sites with small
administrative staffs where only one user needs to look at a probe at a time.

- **Multi Probe**—Multi probes may have one or more probe instances. Multi probes allow multiple users to each connect to the probe and use their own probe instance. Each probe instance can be looking at the same packet capture or different capture.

- **Expert probe**—Expert probes are the same as a Multi probe except that they have local expert analysis and decode capabilities in the probe that allows for remote decoding and expert analysis in real time. The Expert probe software comes pre-installed on most hardware probes from VIAVI.

<table>
<thead>
<tr>
<th>Hardware &gt;</th>
<th>GigaStor, Portable probes, Probe Appliances, 3rd party hardware</th>
<th>Dual port Ethernet Probe, 3rd party hardware</th>
<th>Ethernet Single probe, 3rd party hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Installed software &gt;</strong></td>
<td><strong>Expert Probe</strong></td>
<td><strong>Multi Probe</strong></td>
<td><strong>Single Probe</strong></td>
</tr>
<tr>
<td>Sends entire buffer¹</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Alarms</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Trending</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Triggers</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Wireless</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Encrypts buffer transfer (page 155)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Simultaneous multi-topology support</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Simultaneous users²</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Supports multiple NICs (page 271)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Use reserved memory outside of Windows (page 272)</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Integrated reporting with Apex</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Able to switch between probe and analyzer mode (page 286)</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Full-duplex³</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MPLS (page 264)</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>NetFlow (page 247)</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Port bonding (page 296)</td>
<td>X</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

¹ Sends entire buffer enables the probe to send the entire packet capture buffer to the probe instance.

² Simultaneous users allows multiple users to connect to the probe simultaneously.

³ Full-duplex allows the probe to capture traffic in both directions at the same time.
<table>
<thead>
<tr>
<th>Hardware</th>
<th>GigaStor, Portable probes, Probe Appliances, 3rd party hardware</th>
<th>Dual port Ethernet Probe, 3rd party hardware</th>
<th>Ethernet Single probe, 3rd party hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installed software</td>
<td>Remote decode of GigaStor captures</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Sends expert summary &amp; decode packets</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>VoIP expert, APA, ATA (page 286)</td>
<td>X</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1. Buffers are sent to Observer where the decoding and analysis is performed. This is less efficient than sending the expert summary and decode packets, which is available with Expert Probe.

2. Simultaneous users are supported when each user has his own probe instance.

3. Only available on hardware probes from VIAVI.

4. Decoding and expert analysis are performed by the probe and a summary is sent to Observer reducing network bandwidth use.

5. Application Performance Analysis and Application Transaction Analysis. Applications are generally OSI Layer7 applications like HTTP, FTP, RTSP, SMB, and so on.

How probes work with switches

The purpose of a switch is to isolate traffic to the local network, thereby reducing the amount of traffic each device on that network must see and process. Although a protocol analyzer puts a network interface card in “promiscuous” mode, the analyzer only sees packets addressed to or transmitted from the port that it is connected to on the switch.

To operate a probe in a switched environment, you must choose a method that provides network visibility to the port where the probe is connected. Most switches provide a function that “mirrors” all packets received or transmitted from either a single port of interest (for instance, a server or router), or multiple ports of interest. The mirrored traffic can then be captured or analyzed by connecting your analyzer (or in this case, the probe) to the “mirror port” (which is sometimes called a SPAN port).

**Note:** Switches typically provide two options for configuring the SPAN/mirror port settings. You can either use a command line interface (CLI) or web-based interface included with your switch to set the port (or ports) to be mirrored.

To SPAN/mirror ports, Observer can use SNMP to directly query your switch and report port-based statistics or use RMON to report any internal RMON statistics the switch may have. Selecting the method right for you depends on your switch, and the level of detail you need to troubleshoot the problem at hand. For packet capture, decode and Expert Event identification, only static port mirroring provides all the information required for a complete picture of what is happening on your network.
Allocating RAM

Observer and probe software must be within the same major release. This may require you to upgrade your probe software.

How a probe uses RAM

A Windows computer uses Random Access Memory (RAM) as a form of temporary data storage. Windows separates all available memory into three sections: protected memory, user memory, and reserved memory. An Observer probe, depending on how it is configured, uses these types of memory differently.

The *protected memory* is used to load critical operating system files, such as device drivers. If any of this RAM is dedicated to a driver or some other critical file, it cannot be used by another program. However, after Windows finishes loading its drivers, the memory is freed and any program may access the remaining protected memory.

*User memory* is all available memory beyond the protected memory. It is available to any application at any time. The probe uses this memory to temporarily store statistical information, such as Top Talkers data.

*Reserved memory* is user memory that you have specifically set aside for use by the Observer probe. Only the probe may use that portion of RAM. When the RAM is reserved for the probe not even the operating system may access it—even when Observer is closed.

By having RAM reserved specifically for the Observer probe, you ensure that the probe has the memory necessary to capture packets and store these packets for statistical processing. If Observer runs without any reserved memory, it requests and uses the operating system’s protected memory for capturing packets. There is no adverse effect of running an Observer probe without reserved memory, but it is not the most efficient way to run the probe. By default, the probe uses no reserved memory. Our recommendation is that you reserve memory for Observer so that the probe runs efficiently and leaves the protected memory for the operating system and other programs to use.

Packet captures are always written sequentially from the first open byte of RAM in reserved memory or in Windows protected memory. They are written until all available space is used. If you are using a circular buffer, then the first packet is overwritten with the newest packet. This is first-in, first out (FIFO). With Windows protected memory, your capture space is limited to about 50 to 80 MB, but with reserved memory you have the potential to store many gigabytes in memory. Figure 62 (page 232) describes the two different ways that Observer runs.
Whether using protected memory or reserved memory, Observer uses the RAM to store data for things such as (and creates a section within the RAM dedicated to):

- Packet capture
- Statistics queue buffer
- Collected statistical memory

Network packets seen by Observer are passed to both the packet capture memory and to the statistics queue buffer. After a packet is processed by the statistics queue buffer, the statistical information is passed to the statistical memory. All packets in both the packet capture memory and the statistical queue buffer stay in memory until the buffer is full and the oldest packets are replaced by newer packets (using FIFO).

Figure 63 (page 232) shows what options in Observer control the size of various portions of memory.

Packet capture buffer and statistics buffer

There are two kinds of buffers that a probe uses to store data in real-time: capture buffers and statistical buffers. The capture buffer stores the raw data.
captured from the network while the statistical buffer stores data entries that are snapshots of a given statistical data point.

Selecting an appropriate capture buffer size given system resources is all most users need to worry about; the default settings for the statistical buffers work perfectly fine in the vast majority of circumstances.

However, if you are pushing the limits of your probe system by creating many probe instances, you may be able to avoid some performance problems by fine-tuning the memory allocation for each probe instance.

For example, suppose you want to give a number of remote administrators access to Top Talkers data from a given probe. You will be able to add more probe instances within a given system’s memory constraints if you set up the statistics buffers to only allocate memory for tracking Top Talkers and to not allocate memory for statistics that no one will be looking at.

Observer has no limitations on the amount of RAM that can be used for a buffer. Note that when run on a 64-bit Windows, there is no 4 GB limitation for the capture buffer; you are limited only by the amount of physical memory installed on the probe.

In all cases, the actual buffer size (Max Buffer Size) is also reduced by 7% for memory management purposes. Should you try and exceed the Max Buffer Size an error dialog will be displayed indicating the minimum and maximum buffer size for your Observer (or probe) buffer.

For passive probe instances, which are most often used for troubleshooting, the default settings should be sufficient. If you are creating an active probe instance (one that writes to disk and not just reads from it), then you may want to use the following formula as a rough guideline to determine how much RAM to reserve for the probe instance when doing a packet capture. (This formula does not apply when doing a GigaStor capture to disk. It is only for probe instances doing packet captures.)

Use this formula to determine your RAM buffer size:

\[
\text{Network Speed} \times \frac{\text{Average Throughput (MB/second)}}{\text{Seconds of data storable in RAM}}
\]

**Tip!** You want a buffer that will handle your largest, worst case unfiltered burst.

Use this formula to determine how much hard drive space a capture requires (in GB) and Observer's write-to-disk capability. There is no limitation to the amount data Observer can write to disk other than the disk size itself.

\[
\frac{(\text{Trafﬁc Level} \div 8 \text{ bit}) \times 3600 \text{ Seconds}}{1024 \text{ bytes}} \text{ Gigabytes per hour}
\]

For instance a fully utilized 1 Gb port (1 Gbps is 125 MBps):

\[
\frac{(125 \text{ MBps} \div 8 \text{ bit}) \times 3600 \text{ Seconds}}{1024 \text{ bytes}} \approx 54.93 \text{ GB per hour}
\]
Running Observer without reserved memory

Single probes cannot use reserved memory. By default, no memory is reserved for Observer if you install it on your own system.

Prerequisite(s):

♦ All versions of Observer Expert, Observer Suite, Expert Probe software, and Multi Probe software installed on your own hardware, unless modified.
♦ Single Probe software at all times
♦ NetFlow probes

Observer without reserved memory is the default, but not recommended, configuration. It is the default because each network is unique and you must determine how you want Observer to be configured for your system.

Note: This section does not apply to the GigaStor or other hardware products from VIAVI. They are properly configured at the factory.

Tip! If you need more RAM for the statistics queue buffer, you may need to lower the amount of RAM dedicated to packet capture so that it is freed and available to add to the statistics queue.

After you install Observer and first open the program it does not have any reserved memory. Observer allocated a portion of the available protected memory for its use. This creates a “Windows memory pool" for Observer of about 50 to 80 MB (depending on the amount available from Windows, and cannot be increased). This is a limitation of the Windows memory pool and the Windows operating system.

Single Probes, unlike Multi-Probes and Expert Probes, cannot use reserved memory because of their design. By default, 16 megabytes is available for the Packet Capture and Statistics Queue buffer. Single Probes have a maximum of 52 megabytes that can be assigned from the Windows memory pool. Because of the Windows memory pool constraint, Single Probes are limited to a Packet capture buffer maximum of 72 megabytes, assuming you set the Statistics queue buffer to its minimum (12 megabytes). The Statistics queue buffer maximum is 76 megabytes if the Packet capture buffer is set to 0 megabytes.

1. Click the Memory Management tab to display the list of probe instances and their buffer sizes.
2. Click the Configure Memory button at the top of the window to view and modify how Observer uses the protected memory for this probe instance. The Edit Probe Instance window opens.

On the Edit Probe Instance window, you can see how memory is allocated for:

- Packet capture
- Statistics queue buffer

You can also see how much protected memory is still available in the Windows memory pool.
3. Use the arrows to the right of the Packet capture and Statistics queue buffer to increase or decrease the amount of RAM you want dedicated to each. See How to allocate the reserved RAM (page 238) to help determine how to divide the memory.

Running Observer with reserved memory

Reserved memory helps Observer run more efficiently by dedicating memory for its exclusive use.

Prerequisite(s):

- Observer Expert
- Observer Suite
- Expert Probe software
- Multi Probe software

Observer uses reserved memory for packet capture and the statistics queue buffer. It is highly-recommended that you use reserved memory. (GigaStor appliances running Observer are preconfigured this way.) You must determine how you want Observer to be configured for your system.

Caution: Never change the reserved memory settings of VIAVI hardware unless VIAVI instructs you do so. Reserved memory settings should only be modified on non-VIAVI hardware, such as a desktop computer running Observer.
If you need more RAM for the statistics queue buffer, you may need to lower the amount of RAM dedicated to packet capture so that it is freed and available to add to the statistics queue.

Tip! If you need more RAM for the statistics queue buffer, you may need to lower the amount of RAM dedicated to packet capture so that it is freed and available to add to the statistics queue.

Reserving memory allows Observer to allocate RAM for its exclusive use. This ensures that Observer has the necessary memory to store packets for statistical analysis, or for capturing large amounts of data for decoding. The more memory you reserve for Observer, the larger the packet capture and statistical queue buffers can be.

If the memory buffer for the statistics queue buffer is too small, you may end up with inaccurate statistical data because some data may get pushed out before it can be processed. Observer processes packets on a first-in, first out (FIFO) basis, so it is important that the buffer be large enough to allow for processing.

When reserving RAM for Observer you are taking RAM away from the operating system. Table 34 (page 236) shows how much memory is required by the operating system. Anything beyond this amount may be reserved for Observer.

Table 34. Reserved memory requirements

<table>
<thead>
<tr>
<th>Operating System</th>
<th>RAM required for the operating system</th>
</tr>
</thead>
<tbody>
<tr>
<td>64-bit with less than 4 GB RAM</td>
<td>800 MB</td>
</tr>
<tr>
<td>64-bit with 4 GB RAM</td>
<td>4 GB</td>
</tr>
<tr>
<td>64-bit with 6+ GB RAM</td>
<td>4 GB</td>
</tr>
<tr>
<td>32-bit</td>
<td>256 MB (although 400+ MB is recommended)</td>
</tr>
</tbody>
</table>

1. Because of how 64-bit Windows loads its drivers when 4 GB of RAM is installed all 4 GB is used by Windows. This is sometimes referred to as the BIOS memory hole and means you cannot reserve any memory for Observer. To capture packets on 64-bit Windows install either more than or less than 4 GB of RAM.

2. 32-bit operating systems do not support more than 4 GB of RAM. Observer cannot use any RAM above 4 GB.

1. To see how much protected memory the probe has, click the Memory Management tab.

2. Click the Configure Memory button at the top of the window to view and modify how Observer uses the protected memory for this probe instance. The Edit Probe Instance window opens.

   On the Edit Probe Instance window, you can see how memory is allocated for:
   - Packet capture
   - Statistics queue buffer

   You can also see how much protected memory is still available in the Windows memory pool.

3. Use the arrows to the right of the Packet capture and Statistics queue buffer to increase or decrease the amount of RAM you want dedicated to each. See
How to allocate the reserved RAM (page 238) to help determine how to divide the memory.

4. After reserving memory for Observer you must restart the system for the changes to take affect. After you restart the system you can allocate the memory to the different probe instances.

How packet capture affects RAM

When you start a packet capture (Capture > Packet Capture and click Start), all packets that Observer sees are placed into the packet capture buffer (a specific portion of the protected memory). The packets stay in this protected memory until the buffer is cleared. If you are using a circular packet buffer, new packets overwrite old ones after the buffer is full.

Figure 65 (page 237) shows how Observer receives a packet and distributes it throughout RAM, and how it is written to disk for packet capture and GigaStor capture.

Packets received by the network card are passed to Observer, where Observer puts each packet into RAM, specifically in the packet capture memory buffer and the statistical queue buffer. If a packet must be written to disk for either a GigaStor capture or a Packet Capture, it is copied from the RAM and written to the disk.

Figure 65: How packets move through Observer’s memory

- The capture card receives data off the network.
- The capture card passes data into RAM. In the RAM it goes into the packet capture buffer and the statistics queue buffer.
- The statistics queue buffer passes the information to the statistics memory configuration.
- The statistics memory configuration passes the data to the real-time graphs.
- The Network Trending Files receive data from the statistics queue buffer through the NI trending service, where they are written to disk.

The following steps occur only if you are writing the data to disk through a packet capture to disk or a GigaStor capture.
If you are using packet capture to disk, the packet capture buffer passes the data to the operating system's disk.

If you are using GigaStor capture, the statistics queue buffer and the packet capture buffer passes the information to the RAID.

A few notes about how some buffers are used:

- Packets received by the statistics queue buffer are processed and put in the collected statistics buffer.
- Data for network trending comes from the statistics queue buffer, then it is written to disk, and finally flushed from the buffer every collection period.
- The collected statistical buffer does not use first-in, first-out to determine statistics. Therefore, after the statistic limit is reached the remaining data is no longer counted; however, data for known stations continue to be updated indefinitely.
- Regardless of whether Observer is using reserved memory, the statistics memory, statistics queue buffer, and packet capture buffer function the same. The storage space available for storing packets in memory increases though when you reserve memory.

How to allocate the reserved RAM

After you have the RAM reserved for Observer, you must allocate it for the probe instances. Here are our basic recommendations for allocating the memory. These are just recommendations and may be changed or modified for your circumstances.

If you are using a GigaStor hardware appliance, read this section, but also be sure to consider the information in Recommendations for the VIAVI capture cards (page 239).

How many probe instances will you have on this system? How are you using the probe instance(s)? Are you using it to capture packets or to analyze statistics? After you know how you want to use the probe instance, you can decide how to properly divide the memory amongst the probe instances, and further how you will allocate the memory between the packet capture and statistics queue buffers.

You want to create and use as few probe instances as absolutely necessary. Each probe instance you create divides the memory pool into smaller chunks. The more probe instances you have, the more processing the system must do.

**Note:** If you have a lot of network traffic, then you may need to allocate at least one gigabyte of RAM to the packet capture buffer, the statistics queue buffer, or both.

For each probe instance determine:

- If you want to mostly capture packets, then allocate 90% of the reserved RAM to packet capture and 10% to the statistics queue buffer. At a minimum, you should allocate 12 MB to collect statistics. If you are using a GigaStor, you should allocate the vast majority of the reserved RAM for the active probe instance to packet capture.
If you want to collect statistics or trending data, or use analysis, then allocate 90% (or even 100%) of the reserved RAM to the statistics queue buffer.

If you want to do both, determine which you want to do more of and allocate the memory accordingly.

**Recommendations for the VIAVI capture cards**

There are capture card requirements and considerations if you are using a GigaStor appliance, as the appliance may have a Gen3 capture card or Gen2 capture card installed.

Here are some special configuration issues to consider when dealing with these capture cards:

- For either the Gen3 capture card or Gen2 capture card, you need a minimum of 100 MB allocated to the capture buffer of any probe instance that is bound to the capture card. Allocating less than 100 MB to a probe instance monitoring a VIAVI capture card may cause instability.

- If you are using any hardware accelerated probe instance, you must have at least 80 MB for both packet capture and the statistics queue buffer. No packets are captured if either or both are below 80 MB. 80 MB is the minimum, but consider substantially raising this amount. The more RAM that you can allocate to packet capture and statistics, the better your GigaStor probe will perform.

- When using multiple probe instances on a GigaStor, ensure that only one probe instance is associated with the capture card. (If you are using virtual adapters to monitor disparate networks, then you may have more than one active instance bound to the capture card.) For performance reasons, all other probe instances should be associated with a different network card.

If you feel a capture card is not performing as expected, ensure that there is only one probe instance bound to it. If there is more than one, verify that the other probe instances are not collecting any statistics. It is possible that the probe instance you are looking at is not collecting any statistics, but one of the other probe instances may be. (This is only an issue if there are multiple probe instances connected to the Gen3 capture card or Gen2 capture card. This does not apply if the other probe instances are connected to a regular network card.)

**Troubleshooting common issues**

Use the information in this section to assist you if you have a problem with your probe not connecting to your analyzer, your probe does not have a network adapter available, or if you are using an nTAP and want to capture NetFlow traffic or several other common issues.

If you feel your probe is slow, see Troubleshooting a slow probe system (page 240).

Although most installations of Observer proceed without any trouble, due to the vast number of network configurations and hardware/software options that Observer supports, sometimes difficulty arises.

If you experience trouble in setting up Observer, keep a number of things in mind.
First and foremost, try to simplify your configuration in any way possible. This means if you have a screen saver loaded, disable it. If you are running some network add-on peer-to-peer jet engine turbo stimulator, remove it. This does not mean that you will not be able to use Observer with your other products but, if you can determine where the problem is, you can focus on that piece of the puzzle and you may be well on your way to solving the problem.

Second, do not trust anyone or anything. The only way to really know what your hardware settings are is to have the card or device in one hand and the documentation in the other. Programs which discover interrupts and other settings only function properly when everything is working correctly — exactly when you do not need them. Do not blindly trust other network drivers — they may or may not be reporting the correct information.

Third, do not, under any circumstances, share interrupts, I/O ports, or memory addresses between adapters. No matter what has worked before or what might work in the future, sharing interrupts or memory settings is not a valid configuration.

Troubleshooting checklist:

Does your network work without any Observer programs or drivers loaded? If not, check your network installation instructions. After your network appears to be running correctly, install Observer again. Try installing Observer on a different system and see if you experience the same problem. This does not mean that you will not be able to use Observer on the desired system. It may give you some insight into the problem that you are having.

Troubleshooting a slow probe system

If a probe is overloaded, consider whether any of the following affect the system. You can clear these one at a time to see if that resolves the system’s issue.

Although all of the settings discussed in this section are configured in Observer, they are saved to the probe.

- A scheduled capture can be causing a system slow down. Determine if any scheduled capture is occurring. On the Home tab, in the Capture group, click Live > Packet Capture and then Settings > Schedule.
- Some extra processing happens when you have triggers and alarms configured. Determine what alarms are enabled by clicking the Alarm Settings button in the lower left.
- Are you running real-time Expert Analysis? Observer requires some processing resources to get through the data, which could be a lot of data. Real-time expert processes data as it is received. This requires continuous processing of incoming data while the real-time expert is running.
- Are you collecting combined station statistics or protocol distribution summary for your network? If so, these could be causing the system to slow down. To determine if you are, click the File tab, and click Options > General Options. Scroll to Startup and runtime settings and clear these settings, if necessary:
  - Collect combined station statistics at all times
• Collect protocol distribution for the whole network
  ♦ Are you collecting network trending statistics? If so, is the sampling divider less than 10? If so, increase the sampling divider to 10 or greater. To determine your sampling divider, on the Home tab, in the Capture group, click Network Trending > Network Trending. Then click Settings > General tab. In the Collection Settings section, change the sampling divider.

A probe is not connecting to the analyzer or vice versa

If the probe is not connecting, it could be one of several reasons. The log window in Observer has useful information to give you an idea of why the connection is failing.

Verify the following:
  ♦ The probe is licensed. See Licensing and updating (page 21).
  ♦ Check that the Observer Platform ports are open on the firewall and if traffic is actually passing through it. Observer uses these ports to communicate with the probe. See Ports used by Observer Platform v17 and later (page 28) or depending on your version. Check any local system firewall as well as any network firewall. See also the information in Suspected NAT or VPN issues (page 245).
  ♦ Check that the security certificates are trusted between the Observer and the probe. If the settings do not match, you might get a message that says "Probe redirection Error <IPAddress> Authentication Negotiation Error" or "Probe authentication failed <IPAddress>." Either a certificate is untrusted by one of the assets or a certificate is pending your approval. In Observer, click Options > General Options and click the Security tab. Verify that the specific certificates are in a trusted state.
  ♦ The probe and Observer are within the same minor build range. See Upgrading the probe software (page 258).
  ♦ You can access the VLAN if the probe or Observer are on different VLANs. There is nothing you need to configure in Observer or the probe to enable a connection when they are on different VLANs. However, if you do not have network permissions to access a probe on a different VLAN, it is a network configuration issue (usually for security reasons) and you should contact the network administrator.

No network adapter available

After starting Observer, if you do not see any available adapters listed in the "Select Network Adapter" list, it means your NIC does not have the necessary driver or VMONI Protocol settings installed. Use this information to enable your adapter and to install the proper drivers.

1. If Observer is running, close it.
2. Ensure you are logged in to the system with an account with administrator rights.
3. From the Windows Start menu, choose Control Panel > Network and Sharing Center.
4. Click Change Adapter Settings.
5. Right-click any of the Local Area Connections and choose Properties.
6. Look at the list of installed components to verify that the VMONI Protocol Analyzer is listed. Then do one of the following:
   - If it is not installed, skip to step 7.
   - If the VMONI driver is listed, remove it. Select VMONI Protocol Analyzer and click the Uninstall button. After the VMONI driver is removed, restart the system and continue with step 7.
7. From the Local Area Connection Properties (step 5), choose Install > Protocol > Add > VIAVI – VMONI Protocol Analyzer and click OK. If the VMONI driver is not listed, click Have Disk, then browse to the VMONI.SYS file located in the Observer directory on your hard drive, select it, and click OK.

   The VMONI Protocol Analyzer will now be available to install.
8. Restart the computer after you have completed installing the driver.

   You should now be able to select an adapter when starting Observer.

Integrated adapters report all sent packets with bad TCP checksum

**Symptoms:** All TCP packets sent from Observer or probe station across an integrated network adapter contain bad TCP checksums.

**Causes:** Default driver settings for the card are incorrect. You must update the driver and then disable the "Offload Transmit TCP Checksum" option.

**Solutions:** Upgrade the driver for the integrated network adapter to the Network Instruments/Intel Pro 1000 adapter driver. This driver is located in the `\<Observer installation directory>\Drivers\IntelPro1000` directory.

1. After upgrading the driver, right-click the adapter and go to Control Panel > Network Connections > Properties.
2. On the General tab, click the Configure button.
3. Click the Advanced tab and find the Offload Transmit TCP Checksum option and disable it.
4. Restart your system.

“No VLAN” shown while using a Gigabit NIC

**Symptoms:** “No VLAN” is displayed in VLAN Statistics and/or no 802.1Q tag information is shown in your decode. The network adapter you use to capture traffic is a Gigabit NIC.

**Causes:** Observer is not seeing the 802.1Q tag on packets being captured. This is sometimes caused by your switch not sending tagged packets to Observer. See VLAN Statistics tool is not working (page 243) for explanation/resolution before proceeding.

**Solutions:** If you are using a Gigabit NIC to capture the traffic and you have checked the switch configuration, then try using this solution. For BCM5751M NetXtreme Gigabit chips found in IBM T43, HP laptops, and Dell Latitude laptops; there is a registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet can
cause the driver and chip not to strip the 802.1Q headers. To set that key, you
must find the correct instance of the driver in Windows registry and change it.

1. Open the Windows registry editor. **Start > Run > Command** and type
   `regedit`.
2. Search for “TxCoalescingTicks” and ensure this is the only instance that you
   have.
3. Right-click the instance number (e.g., 0008) and add a new string value.
4. Type `PreserveVlanInfoInRxPacket` and give it the value `1`.
5. Restart the computer.

The Gigabit NIC no longer strips VLAN tags, so the symptom in Observer is
resolved.

**VLAN Statistics tool is not working**

**Symptoms:** “No VLAN” is the only VLAN ID that shows up in the VLANs column
in VLAN Statistics. You are not seeing all VLANs you have on the network.

**Causes:** To display VLAN Statistics, Observer checks each packet for a VLAN
tag; if no tag is present, the packet is logged as “No VLAN.” Both 802.1Q or ISL
VLAN tags are stripped unless the SPAN destination port to which the analyzer is
attached has been configured to include VLAN tags.

**Solutions:** Configure the switch to retain the VLAN tags through the monitor
port. This may be an option in the Mirror or SPAN command on the switch, or
you may have to configure the port as a trunk prior to defining it as a SPAN port.
Even if the switch is monitoring a trunk or uplink port it may strip VLAN tags
unless you configure that port to retain the tags. Refer to the documentation
from your switch for details on configuring VLANs, trunks, and analyzer ports.

If connecting Observer to a Cisco switch, see the following link (it does require

If you use a Cisco Catalyst 4500/4000, 5500/5000, or 6500/6000 Series Switch
running CatOS you must configure the destination port as a trunk port prior to
configuring the SPAN port using the `set trunk` and `set span` commands:

```
set trunk
module/port
[on | off | desirable | auto | nonegotiate]
[vlan_range] [isl | dot1q | negotiate]
```

```
set span
source_port
destination_port [rx | tx | both]
```

For example, to configure module 6, port 2 for monitoring an 802.1Q VLAN setup,
you would enter the following commands:
```
switch (enable) set trunk 6/2 nonegotiate dot1Q
switch (enable) set span 6/1 6/2
```

For Cisco Catalyst 2900/3500, 4500/4000 and 5500/5000 Series Switches Running
IOS 12.1 or later, encapsulation forwarding is set as a part of the SPAN command,
which has the following syntax:
To monitor 802.1Q VLAN traffic passing through Fast Ethernet 02 via a SPAN port set up on Fast Ethernet 0/6, you would enter the following commands:

- C4000 (config) # monitor session 1 source interface fastethernet 0/2
- C4000 (config) # monitor session 1 destination interface fastethernet 0/6 encapsulation dot1q

For a 6500/6000 Series Switch running Native IOS 12.1 or later you must configure the destination port as a trunk port prior to configuring the SPAN, which have the following syntax:

- C6500 (config)#Interface Type slot/port
- C6500 (config-if)#Switchport
- C6500 (config-if)#Switchport trunk encapsulation { ISL | dot1q }
- C6500 (config-if)#Switchport mode trunk
- C6500 (config-if)#Switchport nonnegotiate

To monitor 802.1Q VLAN traffic passing through Fast Ethernet 02 via a SPAN port set up on Fast Ethernet 0/6, you would enter the following commands:

- C6500 (config) # interface fastethernet 0/6
- C6500 (config-if) #switchport
- C6500 (config-if) #switchport trunk encapsulation dot1q
- C6500 (config-if) #switchport mode trunk
- C6500 (config-if) #switchport nonnegotiate
- C6500 (config-if) #exit
- C6500 (config) # monitor session 1 source interface fastethernet 0/2
- C6500 (config) # monitor session 1 destination interface fastethernet 0/6

Using Discover Network Names on a Layer 3 switch that uses VLANS

**Symptoms**: While running Discover Network Names against a Layer 3 Switch that uses VLANS, you see only a limited number of MAC addresses, which typically have multiple IP Addresses associated with them.

**Causes**: Layer 3 Switches that have been configured to perform routing replace the originating station's MAC Address with the MAC Address of the switch port. For example, suppose CADStation1 has a MAC Address of 00:00:03:AB:CD:00 and an IP Address of 10.0.0.1. It is connected to switch port 1 through a hub. Port 1 of this switch has a MAC Address of 00:11:22:33:44:55.

When a probe is connected to a SPAN or mirror port of that switch, it shows CADStation1 with an IP of 10.0.0.1 and MAC address of 00:11:22:33:44:55 rather than 00:00:03:AB:CD:00 because of this substitution.

Now, suppose there is another station (CADStation2) with MAC address of 00:00:03:AB:EF:01 and has an IP address of 10.0.0.2 that is also connected to port 1 of the switch through a hub. Because Discover Network Names stores station information by MAC address (i.e., the MAC address is the unique station identifier), it changes the IP address of switch port 1's MAC address.

Because a switch configured as such hides originating station MAC addresses from Observer, MAC-based station statistics (such as Top Talkers-MAC, Pair...
Statistics matrix, etc.) can only be calculated by port. To make the Observer displays more useful, follow this solution.

**Solutions:** By examining the switch configuration you can obtain a list of MAC addresses that are associated with each port of your switch. Then, use Discover Network Names to edit the alias entry for 00:11:22:33:44:55, labeling it “SwitchPort1.”

The IP based statistical modes (Internet Observer, Top Talkers – IP (by IP Address) still show you statistics calculated from individual stations by their IP address. But MAC-based statistical modes (Pairs Statistics Matrix, Protocol Distribution, Size Distribution Statistics, Top Talkers –MAC (by hardware Address) will now show data by Port.

**Suspected NAT or VPN issues**

If you use network address translation (NAT) in your environment, you must make some configuration changes in Observer. Using the TCP/IP port information in , you should be able to set up the NAT properly.

If the probe is outside the network where Observer is running, you must forward port 25901 from the probe's address to the system running Observer.

When redirecting the probe, you must specify the NAT outside IP address instead of the address that Observer puts in automatically. By default, Observer tries to use its local IP address, which the probe will not be able to find. Select “Redirect to a specified IP address” in the Redirecting Probe or Probe Instance dialog and type the VPN client’s IP address.

**Running Observer passively affects NetFlow**

When analyzing a link using a TAP, which is common, Observer runs “passively.” Passive operation guarantees that analysis will not affect the link; however, it does have some implications when running NetFlow. Because there is no link over which the system can transmit packets or frames, the following features are unavailable:

- Traffic Generation
- Collision Test
- Replay Packet Capture

**Daylight Savings Time**

Observer is not coded with a specific date in mind. Daylight Savings Time is controlled by the operating system. When the clock rolls backwards or forwards Observer rolls with it, with one exception: packet capture/decode.

Packet capture provides nanosecond time resolution, which none of the rest of the product does. Because of this, packet capture does not rely on the system clock to provide time stamps. It relies on the processor time ticks. When Observer opens it requests the system time and the number of processor time ticks and uses those. This allows Observer to know what date and time it is when a packet is seen.

Because the Observer only asks the operating system for the system time when Observer is started, packet capture does not know that the time has jumped
forward or backward. To get this to happen you need restart Observer after the
time change. It is that simple.

Configuring Cisco 6xxx switches using a SPAN port to a full-
duplex Gigabit Probe

When using a full-duplex Gigabit Probe to capture directly from a SPAN/mirror
port, use a straight-through cable from the Gigabit port on the switch to either
port A or B on the Gigabit card in the probe. Do not use the Y-cable or TAP (the
TAP and Y-cable should only be used inline).

To use Observer with the Cisco 6xxx switch, you must disable auto negotiation.
With auto negotiation enabled, the switch and probe may create a link when first
starting the probe, but if the cable is unplugged or if a configuration change to
the SPAN/mirror port is applied, you will lose connectivity to the switch. To turn
auto negotiation off on the switch, follow the directions based on the OS you are
using on your switch.

Tip! Disabling Auto Negotiation is recommended on all models/brands of
switches when using a SPAN/mirror port to a full-duplex Gigabit Probe.

Cisco CatOS switches

1. To disable port negotiation:

   Console> enable
   Console>(enable) set port negotiation mod_num/
   port_num disable

2. To verify port negotiation:

   Console.(enable) show port negotiation [mod_num/port_num]

3. To enable port negotiation (should you remove the gigabit Observer product
   from the switch):

   Console>(enable) set port negotiation mod_num/port_num enable

Cisco IOS switches

1. To disable port negotiation:

   Console> enable
   Console# configure terminal
   Console(config)# interface gigabitethernet mod_mun/port_num
   Console(config-if)# speed nonegotiate

2. To verify port negotiation:

   Console# show interfaces gigabitethernet mod_mun/port_num

3. To enable port negotiation (should you remove the gigabit Observer product
   from the switch):

   Console(config)# interface gigabitethernet mod_mun/port_num
   Console(config-if)# no speed nonegotiate
Use Netflow in Observer

Using the NetFlow features in Observer

Watch a video about NetFlow in Observer, and see a list of some important NetFlow considerations to know.

♦ Choose the right probe for you.
♦ Ensure your ToS/QoS is set for your network so that your statistics are correct.
♦ There are two different types of NetFlow collectors. Learn the differences and see how to create one.
♦ Capturing NetFlow statistics does have some limitations that are different from packet capture.
♦ Decoding a NetFlow flow. This section also details how you may need to configure your NetFlow device so that Observer can see the flows.
♦ Open a saved NetFlow capture.
♦ Most NetFlow information comes from Network Trending.

Creating a NetFlow collector or NetFlow Trending collector

There are two types of NetFlow collectors in Observer. Choose the correct one for your needs, or create two different probe instances—one for the NetFlow collector and another for the NetFlow Trending collector.

**Prerequisite:** Expert Probe

**Note:** If you want to have scheduled collection of your NetFlow devices, use the settings on the Schedule tab.

NetFlow and sFlow collectors support the following versions of these technologies:

♦ NetFlow: 1, 5, 7, 9, and 10 (IPFIX)
♦ sFlow: 2, 4, and 5

There are two types of NetFlow collectors in Observer. Choose the correct one for your needs, or create two different probe instances—one for the NetFlow collector and another for the NetFlow Trending collector. In most cases, it will likely be the NetFlow Trending collector. The NetFlow Trending collector supports up to 50 NetFlow devices, whereas the NetFlow collector only supports one NetFlow device. That means you must add and configure a NetFlow collector for each NetFlow device in your environment.

<table>
<thead>
<tr>
<th></th>
<th>NetFlow Trending collector</th>
<th>NetFlow collector</th>
</tr>
</thead>
<tbody>
<tr>
<td>One flow per collector</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Up to 50 flows per trending collector</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Collects live statistics</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Use Netflow in Observer

<table>
<thead>
<tr>
<th>NetFlow Trending collector</th>
<th>NetFlow collector</th>
</tr>
</thead>
<tbody>
<tr>
<td>Collects historical trending</td>
<td>X</td>
</tr>
</tbody>
</table>

1. Live statistics are details about the flow that appear in Observer in as few as five seconds.
2. Historical trending data collection interval can be as few as 60 seconds.

See Creating a probe instance (page 262) for details about creating a NetFlow collector or a NetFlow Trending collector. In Creating a probe instance (page 262) choose NetFlow collector or NetFlow Trending collector and follow the on screen instructions. After the probe instance is created, there is no other configuration you must do and it is ready to use.

After the probe instance is created, you may want to configure the probe to tell it what type of traffic is seen.

2. On the General tab, configure the Timing and Statistics Packet Sampling sections for your needs and Click OK.
3. On the Home tab, in the Capture group, click Network Trending > Network Trending.
4. Click the Settings button.
5. Configure any settings for Network Trending here.
6. Click OK to close the Network Trending Settings window.
7. Click the Start button to begin monitoring the NetFlow devices.
8. After you have collected some data, click the Analysis button. The View Network Trending data dialog opens.
9. Choose “Transfer and view current day statistics” and click OK. This opens the Network Trending Viewer in a new tab. In the Network Trending Viewer you can see for your NetFlow devices:
   - Station Activity Time
   - Top Talkers
   - Packet Size Distribution
   - Bandwidth Utilization
   - Protocols
Chapter 17: Expert Probe Software

Observer Analyzer needs a probe to capture network traffic. The probe can be local to Analyzer or remote.

How to install or upgrade the software

This section describes the installation process and minimum requirements if you are installing Observer or probe on your system. This applies to physical and virtualized servers. If you virtualize the server, each server must meet these specifications.

Prerequisite(s):

♦ An administrator account is required to install and run any version of Observer or probe software except Observer Expert Console Only (ECO). Observer ECO requires an administrator account just for installation; a standard user account can be used for running Observer ECO.

♦ Standard network cards do not support “raw” wireless packets, nor do they enable “promiscuous” mode by default. Promiscuous mode captures all packets for the analyzer, not just those addressed to the network card. Both “raw” wireless packets and promiscuous mode are required by Observer. ErrorTrak drivers were needed in earlier versions of Observer. They are no longer necessary.

♦ If you do not meet the minimum requirements, the system may seem to operate in the short term, but be aware that even if a sub-minimum installation works momentarily, a later, heavier load on the system can cause it to fail. VIAVI sells hardware probes that are guaranteed to keep up with heavy loads. See the Observer Platform website for details.

♦ You may install the probe software on a virtual machine so long as it meets the system requirements. The installation process is the same. You may also want to consider using a virtual TAP. See Using the probe as a virtual TAP (page 288).
Caution: See the important information in How to upgrade to Windows 10 (page 19) if you want to upgrade the operating system!

1. Ensure your system meets the minimum requirements.
   See Minimum and recommended system specifications (page 18).

2. Choose one of the following:
   - How to install all versions (page 20)
   - How to upgrade version 17 and later (page 20)
   - How to upgrade version 16 and earlier (page 21)

After completing this task:
   ♦ License your software. See FAQ: Licensing and updating (page 21).
   ♦ If you are using a wireless network adapter to capture traffic, see Installing the wireless NIC driver on Windows 7/Vista (page 256).
   ♦ If you are using a USB wireless network adapter to capture traffic, see Installing a third-party USB wireless adapter (page 256).
   ♦ If you use Observer on a virtual machine and network traffic cannot be captured or BSODs (bluescreens) are occurring, see Virtual machine troubleshooting (page 24).

Comparing software probe features

Single Probes are appropriate for sites with smaller administrative staffs. This type of probe communicates with only one Observer at a time.

If you have a need for multiple network administrators to view packet decodes and analysis from the same probe simultaneously, choose a Multi Probe. The Multi Probe allows you to run multiple probe instances of the probe on a single system, which means that:
   ♦ You can install multiple network interface cards in a single Multi Probe system, allowing multiple “points of visibility” from that probe.
   ♦ You can connect multiple sessions of Observer to the same Multi Probe system. Any Observer session can see all of the networks available on the Multi Probe. The probe instances are securely encrypted and password-protected.

Although Multi Probes behave similarly to Single Probes, the Multi Probe has a different user interface for configuring the probe.

For the highest level of distributed performance, choose an Expert Probe. An Expert Probe provides Expert Analysis and capture/decode capabilities. This saves bandwidth when performing remote expert analysis, and also allows remote decode views and expert analysis in real time.

The Expert Probe can be configured to run as an Observer when you need to perform troubleshooting from where the probe is located.
<table>
<thead>
<tr>
<th>Hardware &gt;</th>
<th>Installed software &gt;</th>
<th>Observer GigaStor, Portable probes, Probe Appliances, 3rd party hardware</th>
<th>Dual port Ethernet Probe, 3rd party hardware</th>
<th>Ethernet Single probe, 3rd party hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Observer</strong></td>
<td>Sends entire buffer¹</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Multi Probe</strong></td>
<td>Alarms</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Single Probe</strong></td>
<td>Trending</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Wireless</strong></td>
<td>Triggers</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Encrypts buffer transfer (page 155)</strong></td>
<td>Wireless</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Dual port Ethernet Probe, 3rd party hardware</strong></td>
<td>Encrypts buffer transfer (page 155)</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Simultaneous multi-topology support</strong></td>
<td>Simultaneous users²</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Simultaneous users²</strong></td>
<td>Supports multiple NICs (page 271)</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Simultaneous users²</strong></td>
<td>Use reserved memory outside of Windows (page 272)</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Simultaneous users²</strong></td>
<td>Able to switch between probe and analyzer mode (page 286)</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Full-duplex³</strong></td>
<td>Full-duplex³</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>MPLS (page 264)</strong></td>
<td>MPLS (page 264)</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>NetFlow (page 247)</strong></td>
<td>NetFlow (page 247)</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Port bonding (page 296)⁴</strong></td>
<td>Port bonding (page 296)⁴</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Remote decode of GigaStor captures</strong></td>
<td>Remote decode of GigaStor captures</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Sends expert summary &amp; decode packets⁵</strong></td>
<td>Sends expert summary &amp; decode packets⁵</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>sFlow</strong></td>
<td>sFlow</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>VoIP expert, APA, ATA (page 286)⁵</strong></td>
<td>VoIP expert, APA, ATA (page 286)⁵</td>
<td>X</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1. Buffers are sent to Observer where the decoding and analysis is performed. This is less efficient than sending the expert summary and decode packets, which is available with Expert Probe.
2. Simultaneous users are supported when each user has his own probe instance.
3. Only available on hardware probes from VIAVI.
4. Decoding and expert analysis are performed by the probe and a summary is sent to Observer reducing network bandwidth use.
5. Application Performance Analysis and Application Transaction Analysis. Applications are generally OSI Layer7 applications like HTTP, FTP, RTSP, SMB, and so on.

Minimum and recommended system specifications

If you are installing the software on your own hardware or a virtual machine, these are the minimum and recommended specifications for a production environment.

Table 35. Observer Expert Console Only (ECO)

<table>
<thead>
<tr>
<th>Processor / CPU</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>RAM1</td>
<td>Dual core Pentium class processor</td>
<td>Quad core Pentium class processor</td>
</tr>
<tr>
<td>RAM1</td>
<td>2 GB RAM</td>
<td>8 GB RAM</td>
</tr>
<tr>
<td>Operating system2</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
</tr>
<tr>
<td>Network Card</td>
<td>Server-class</td>
<td>Intel server-class</td>
</tr>
</tbody>
</table>

1. If your system has 4 GB of RAM, you cannot reserve any memory for Observer. This is a limitation of Windows known as the BIOS memory hole. Either add more RAM or take some out.
2. See Supported Operating Systems (page 19) for a full list of supported operating systems.

Table 36. Observer or GigaStor Software Edition in a virtual server

<table>
<thead>
<tr>
<th>Processor / CPU</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>RAM1</td>
<td>Minimum 16 GB (8 GB for Observer and 8 GB for the operating system)</td>
<td>64 GB</td>
</tr>
<tr>
<td>Operating system2</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
</tr>
<tr>
<td>Network Card</td>
<td>Virtualized network adapter</td>
<td>Intel server-class</td>
</tr>
<tr>
<td>Capture Card3</td>
<td>Virtualized network adapter</td>
<td>Server-class onboard network adapter</td>
</tr>
</tbody>
</table>

1. If your system has 4 GB of RAM, you cannot reserve any memory for Observer. This is a limitation of Windows known as the BIOS memory hole. Either add more RAM or take some out.
2. See Supported Operating Systems (page 19) for a full list of supported operating systems.
3. A second network card that acts solely as a capture card is required (and must be in "promiscuous mode"). Alternatively, a dual-port NIC can be used. For further details, see Capture card driver requirements (page 23).

Current compatibility and incompatibility of virtual machines with the GigaStor Software Edition (GSE) is described in this list:

- VMWare ESXi Server
- ESXi 5.0 and higher is compatible with GSE.
- VMWare Workstation Pro is not supported with GSE
- Microsoft Hyper-V may function but is not supported with GSE

**Supported Operating Systems**

Your product must be installed on one of these operating systems to receive assistance from Technical Support.

Table 37. Supported Operating Systems

<table>
<thead>
<tr>
<th>Product Name</th>
<th>64-bit Windows</th>
<th>32-bit Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>GigaStor Software Edition</td>
<td>Windows 7 (SP1 or higher) to Windows Server 2012 R2</td>
<td>Not supported</td>
</tr>
<tr>
<td>Observer Apex</td>
<td>Windows Server 2008 R2 Enterprise, Standard, Web (SP1 or higher) to Windows Server 2012 R2</td>
<td></td>
</tr>
<tr>
<td>Observer Management Server (OMS)</td>
<td>Windows 7 (SP1 or higher) to Windows Server 2012 R2</td>
<td></td>
</tr>
<tr>
<td>Observer Expert Standard</td>
<td>Windows Server 2008 R2 Enterprise, Standard, Web (SP1 or higher) to Windows Server 2012 R2</td>
<td></td>
</tr>
<tr>
<td>Observer Suite</td>
<td>Windows 7 (SP1 or higher) to Windows Server 2012 R2</td>
<td>Windows 7 (SP1 or higher) to Windows Server 2012 R2</td>
</tr>
<tr>
<td>Observer Expert Console Only (ECO)</td>
<td>Windows Server 2008 R2 Enterprise, Standard, Web (SP1 or higher) to Windows Server 2012 R2</td>
<td>Windows Server 2008 R2 Enterprise, Standard, Web (SP1 or higher) to Windows Server 2012 R2</td>
</tr>
</tbody>
</table>

**How to upgrade to Windows 10**

Due to the way Microsoft has designed its Windows® 10 operating system upgrade feature, Observer will not function if you upgrade your operating system from Windows 7, Vista or Windows 8 to Windows 10 without first uninstalling Observer.

This information does not apply if you:
- Already uninstalled Observer.
- Are installing Windows 10 rather than upgrading to it.
- Are already using Windows 10.
- Are upgrading using the Observer Platform OS Upgrade product because it replaces the operating system rather than upgrading it. Additionally, it uses Windows Server 2012 R2.

**Note:** Unfortunately, if you have already upgraded the operating system and Observer was not uninstalled prior to upgrading to Windows 10, the only path to recovery is to reinstall the operating system. Back up (page 260) any Observer files on the operating system, reinstall the operating system, then install Observer and restore its files.

To upgrade a system with Observer to Windows 10:
1. Back up your settings (page 260).
3. Upgrade your operating system.
4. Install the Observer (page 20) software (page 20).
5. Restore your settings from step 1 using whatever method is best for you.
Observer is now available to use on Windows 10.

How to install all versions

Use this procedure to install all versions of the software.

**Prerequisite(s):**

An administrator account is required to install and run any version of Observer or probe software except Observer ECO. Observer ECO requires an administrator account just for installation; a standard user account can be used for running Observer ECO.

1. Insert the installation CD in your CD drive or use the latest installation image from our update site. If you copied the installation files from our web site, start the installation program.
   
   http://update.viavisolutions.com/latest/ObserverSetupx64.exe

2. When the setup program runs, follow the onscreen instructions.
3. Choose to install:
   - Observer.
   - Advanced Probe. Choose this for Single Probe or Multi Probe. Your license determines whether it is a Single Probe or Multi Probe.
   - Expert Probe
4. After the files have been installed on your system you must restart Windows. You will not be able to run the software until you restart your computer.

How to upgrade version 17 and later

Version 17 allows you to upgrade directly from within Observer or from OMS (if used).

If OMS is *not* controlling Observer, then do the following in Observer:
- Click the File tab, and click **Info > Update Observer**.

If OMS is controlling Observer:
- See How to manage software versions using OMS.

The software is updated to the latest version.

How to upgrade version 16 and earlier

Upgrading version 16 uses the same procedure as installing the software. The process is different for version 17 and later.

1. Insert the installation CD in your CD drive or use the latest installation image from our update site. If you copied the installation files from our web site, start the installation program.
   
   http://update.viavisolutions.com/latest/ObserverSetupx64.exe

2. When the setup program runs, follow the onscreen instructions.
3. Choose to install:
• Observer.
• Advanced Probe. Choose this for Single Probe or Multi Probe. Your license determines whether it is a Single Probe or Multi Probe.
• Expert Probe

4. After the files have been installed on your system you must restart Windows. You will not be able to run the software until you restart your computer.

Capture card driver requirements

If you are going to use a third-party capture card in your probe, the capture card must meet certain requirements so that Observer can report statistics and errors. The network card used to monitor or capture network traffic must have all of the mandatory and optional NDIS functions. The VIAVI capture card has all of the necessary features.

Most NIC vendors provide solid, functional NDIS drivers for all cards available within the Ethernet, Token Ring, and FDDI marketplace.

Accessing a standard network with a "normal" network device is somewhat different from what a protocol analyzer requires. While both share a number of driver functions, a protocol analyzer requires a set of features and functions that the average network device will never need. Examples of these optional functions are promiscuous mode, error tracking, and network speed reporting. (Examples of mandatory functions would include functions to determine the maximum packet size, functions to verify the number of sent packets, and functions to specify or determine a packets’ protocol.)

Microsoft made a number of the less used (by "normal" network users) functions "optional", as opposed to “mandatory” regarding driver requirements. The result has been that most vendors support all (or most) mandatory functions with the first release of the driver. As time passes, and the initial chaos of the first release of the card and driver passes, most manufacturers add some or all of the optional functions, as well as fix or complete all of the mandatory functions.

As part of the optional section of defined NDIS functions, Microsoft specified a number of counters that can be kept for Ethernet frame errors. These counters include CRC errors, Alignment errors, Packets Too Big (Jabbers), and Packets Too Small (Runts). Collisions are counted, but there are limitations of NDIS collision statistics. Four important points should be considered:

♦ These optional counts only provide a numerical value to the total number of errors on the segment (i.e. the number of CRC errors found), they do not specify where (which station) the error originated from.
♦ After the error packet is identified and the proper error counter is incremented, the packet is discarded, and not sent to Windows (this is the reason it is impossible to determine the source of an Ethernet error packet with standard NDIS drivers).
♦ A number of vendor’s NDIS drivers return a positive acknowledgment when the NDIS error function is queried for existence, but the error statistic is not actually kept.
♦ A few vendors (3COM, for example) do not keep any error statistics whatsoever.
If a NIC driver both reports that the optional Ethernet error statistics are being kept, and actually keeps data on these errors, Observer reports these statistics in the Network Vital Sign Display.

**Installing the wireless NIC driver on Windows 7/Vista**

See the information in Monitoring a wireless access point (page 287), which contains details about raw packets and promiscuous mode for the network card.

Follow these instructions to install the wireless driver for your network card:
1. Click **Start** and then right-click on the ‘Computer’ icon and choose Properties.
2. Click **Device Manager**.
3. Right-click on the wireless adapter you want to use as your capture card and choose **Update Driver Software**.
4. Choose “Browse my computer for driver software.”
5. Choose “Let me pick from a list of drivers on my computer.”
6. Click **Have Disk** and use the drivers in this location:
   - **Example:** C:\Program Files\Observer\DRIVERS\Wireless\Atheros_Vista
7. Click **Next** and Windows installs the driver for your wireless card.

To confirm that you correctly installed the driver for the wireless network card, open Observer. If the probe instance shows (Wireless) behind it, then it is correctly configured.

Figure 66: Probe instance using wireless adapter

If the probe instance shows (Ethernet), then either the network card driver was not correctly installed or the probe instance is not configured to use that network card. You can confirm the correct network card is selected, by choosing Actions > Select Network Adapter Card.

After completing this task:
- License your probe by following the instructions in Licensing and updating (page 21).
- If your wireless network uses an encryption key, you must add the encryption key information. See Configuring the probe’s adapter speed, ToS/QoS precedence, and statistics sampling (page 272).

**Installing a third-party USB wireless adapter**

You can capture wireless 802.11 traffic on systems lacking built-in wireless by installing a third-party USB wireless adapter. Wireless access point statistics and other features become usable as well. Installing a special driver on your USB wireless adapter is necessary.
Prerequisite(s):
The USB wireless adapter is only supported on systems running Windows Vista or 7 (32- or 64-bit).

**Caution:** For some wireless adapters you must install the software for the USB wireless adapter before you attach the adapter to your computer. This is not an Observer requirement, but one of the wireless adapter. If you attach the USB wireless adapter before installing the software, unplug the USB adapter, uninstall the software, restart your system, and then proceed with step 1.

**Note:** If using a Belkin N600DB USB wireless adapter, only revision number “F9L1101v1” is compatible. These adapters have a Broadcom chipset. The second revision, “F9L1101v2” does not have a Broadcom chipset and is incompatible.

1. Install the software that came with your USB wireless adapter.
2. Insert the USB wireless adapter into your system.
3. Choose **Control Panel > Network and Sharing Center > Change adapter settings** and then select your USB wireless adapter. Right-click and choose **Properties**.
4. From the **Networking** tab, click **Install > Service > Add**. Click **Have Disk** and locate this file: NiNdisMon.inf
   - 64-bit: C:\Program Files\Observer\DRIVERS\Wireless
   - 32-bit: C:\Program Files(x86)\Observer\DRIVERS\Wireless
5. Click **OK** to install the software as a Windows service.
6. Restart your system.
   Restarting allows the software and adapter to be fully recognized by your system and the Windows service to start. Observer will not be able to use the wireless adapter until you restart.
7. Start Observer, select the probe instance you want to associate with the USB wireless adapter.
8. On the Home tab, in the Probe group, click **Setup > Select NIC**.
9. Choose the USB wireless adapter you just installed.

The probe instance is now configured to use the USB wireless adapter. You can confirm this because the word "[Wireless]" appears after the probe instance name, and the **Wireless 802.11** tab of the probe instance is visible.

**Installing Windows updates and updating virus protection**

From time to time Microsoft releases updates for the operating system used for your probe or your virus protection software vendor updates their virus definitions. You should apply those updates as soon as feasible, however, you should always apply the updates manually.

We do not recommend that you allow Windows to automatically install the updates and restart the system. By manually applying the updates you ensure that the system restarts properly and that the probe starts correctly whether running as a Windows service or as an application.
For your anti-virus software, follow these guidelines:

- Ensure TCP ports 25901 and 25903 are open. All Observer Platform products communicate on these ports.
- Ensure UDP ports 25901 and 25903 are open if you use OMS.
- For all probes, disable any scanning of the Observer installation directory (typically C:\Program Files\Observer) and of D: (RAID) drive as scanning greatly diminishes the performance of writing data to disk.
- The performance of the operating system may be greatly diminished when using anti-virus software.

**Upgrading the probe software**

Observer and probe software must be within the same major release. This may require you to upgrade your probe software.

If the version of Observer or GigaStor that you are upgrading was installed on a 32-bit operating system and you have upgraded the operating system to 64-bit, the installer upgrades existing installation to 64-bit version keeping the same path.

Version 17 requires a 64-bit operating system. If you previously installed a 32-bit version, the same installation directory is used.

Use information from this section when upgrading to a new major version of the probe software. Before upgrading have the following available:

- Your probe license information.

**Note:** If you are using encryption keys with Observer, you can continue to use your existing keys or transfer them to your probe (and analyzer) as necessary.

**Upgrading the probe software directly**

On the probe:

1. Start the Observer installation program.
2. Follow the on-screen instructions and choose your probe type.
3. After the installer completes, restart the system.
   - New major builds may have new drivers or other files that require a restart.
4. Connect the probe to an Observer.

**FAQ: Licensing and updating**

Some customer concerns deal with licensing and updating issues. Explore this good resource for licensing and updating help, or call the Technical Support department for further assistance.

*How to license Observer and GigaStor*

To license and activate a compatible GigaStor, Observer, or Probe:

1. Install and launch the application.
2. After launching the application in DEMO mode, click the Help menu and select License Observer.
3. Click the Enter Name button in the lower left corner.
4. Type into the Contact/Department and Company boxes exactly what is listed in your license document.
5. Click OK, and then click Accept on the confirmation dialog.
6. Ensure the Identification Number matches the number on your license document. If they do not match, click Re-Type Name? to correct any mistakes.
7. Type the license number, from your license document, into the License Number box.
8. Click OK.

You successfully licensed and activated your product.

If licensing and activating your product remains unsuccessful, please contact Technical Support.

How to update your license

If Observer or GigaStor is already licensed and you need to modify, update, or change that license, you can do so.

Prerequisite(s):
This task requires you have already licensed (page 21) your Observer or GigaStor.
This task cannot be completed if the license to your Observer or GigaStor is managed by OMS. Instead, refer to How to edit an asset license.

Updating your license refers to changing, editing, or updating the license that is already applied to your product. Some reasons for needing to do this can include:

♦ Activating a new license. The new license might provide different or increased functionality over your existing license, like increased data storage for a GigaStor Software Edition (GSE).
♦ Changing a license. Perhaps you accidentally applied the wrong license to your product and need to change it.

To update a license:
1. Click the File tab, and click Info > License Observer.
2. Click OK to confirm you want to re-license.
3. Type the license number, from your license document, into the License Number box.
4. Click the Re-Type Name? button in the lower left corner.
5. Type into the Contact/Department and Company boxes exactly what is listed in your license document.
6. Click OK, and then click OK on the confirmation dialog.

You successfully updated your license. Observer begins using the license the next time Observer is launched.

Close and restart Observer for the new license to take effect. You may need to coordinate a suitable time to do so if restarting would affect many users or significantly interrupt your data collection.
Why is my license number not working?

Each license number is case-sensitive, so be sure to type it in exactly the way it was given to you. Also, if you copy-pasted the license number into the activation prompt, be sure you did not introduce a leading or trailing space character—those are not part of your license number.

Ensure you are licensing the correct version of Observer. License numbers are version-specific. License numbers work within equal major version numbers of the product only. For example, an 17.0 license can be used to activate 17.x versions but not 16.1, 16.0, 15.1, 15.0, etc.

Could I have my license re-sent to me?

Yes. If you lost the original information containing your license number, please contact us so we can resend your license document(s).

What type of license do I have?

The type of license you have is described in your license document. Each license document contains a license number, and the document describes which software version the license number applies to. If it does not, or you notice any other error, please call our support team for assistance.

Should I uninstall Observer before updating it?

If you wish to update your existing Observer software to a newly released version within the same major release number, you do not need to uninstall your existing version for the update process to succeed. Simply install the new version over the old.

Backing up your GigaStor settings

You can back up most Observer settings and configuration data. Backups are useful when migrating to new hardware, upgrading the operating system, or recovering from data loss.

**Caution:** If you are using data encryption on your GigaStor system, you must save the encryption keys before upgrading the operating system. Because the keys are typically stored on the operating system drive, they will be lost during the upgrade process. If you do not have a copy of the keys elsewhere, you will not be able to access stored data (packets) after the upgrade is complete.

Your Observer may not have each directory referenced in this topic, but you can back up those that are present. Use whatever backup method is best for you.

To back up many Observer settings and files, do the following:

- Copy the files and directories in Table 38 (page 261) to a backup location. This must be a location other than the operating system drive of the system you are planning to upgrade.

These are the default installation directories that contain Observer settings and configuration data:

- **For 32-bit Windows:** `C:\Program Files (x86)\Observer`
- **For 64-bit Windows:** `C:\Program Files\Observer`
## Directory or files to back up

<table>
<thead>
<tr>
<th>Directory or file</th>
<th>Description</th>
</tr>
</thead>
</table>
| Network Trending        | C:\Program Files\Observer\NetworkTrending  
This contains your Network Trending data. If you have changed the default location for Network Trending data, you must back up the new location. Use the Folders tab in Options > General Options to verify which folder is used for trending data. | |
| Protocol Definitions    | C:\Program Files\Observer\ProtocolDefs  
This contains any modifications or additions you have made to the protocol definitions list for each probe instance. Back up in all cases. | |
| Multicast Definitions   | C:\Program Files\Observer\MulticastDefinitions  
This contains the templates for defining trading multicast streams for Network Trending. Back up if you use trading multicasts in Network Trending. | |
| Settings                | C:\Program Files\Observer\Settings  
This contains alarms and triggers. Back up if you heavily use alarms or have alarm/trigger customizations that need to be retained. | |
| SNORT Rules             | C:\Program Files\Observer\Forensics  
This contains your SNORT information, such as rules, for detecting malicious activity in your packet captures. Back up if you use SNORT. | |
| Expert Thresholds       | C:\Program Files\Observer\ExpertSettings  
This contains your thresholds stored in Expert settings. These include TCP/UDP events and some triggers for problem identification. Back up if you have modified any Expert thresholds and want to retain those customizations. | |
| SNMP                    | C:\Program Files\Observer\SNMP  
This contains any custom MIBs, compiled MIBs, request files and SNMP trending data. Back up if you have made SNMP changes or have SNMP trending data. Use the Folders tab in Options > General Options to verify which folder is used for SNMP. | |
| Address Tables          | C:\Program Files\Observer\LocalAddressTable  
This contains your Discover Network Names list. Back up if you have run Discover Network Names and have saved the alias list.  
C:\Program Files\Observer\ProbeAddressTable  
This contains the Discover Network Names list from any remote probe that has connected to this Observer analyzer. Back up if you have run remote Discover Network Names and saved the alias list. | |
| Scripts                 | C:\Program Files\Observer\Scripts  
This contains the scripts for Observer. Back up if you have created or modified a script. | |
| Windows Registry        | Using Regedit, export the following registry branch:  
32-bit Windows operating system running any version, or 64-bit Windows operating system running version 16 or higher:  
HKEY_LOCAL_MACHINE\SOFTWARE\Network Instruments | |
Creating a probe instance

You can create a probe instance to monitor network traffic seen on a network adapter, explore saved packet captures, and have multiple people be able to see the captured data from their copy of Observer. Create a passive or active probe instance depending on what your goals are.

**Prerequisite:** Multi or Expert Probe.

When you open Observer for the first time, you assign memory to a probe instance. You can choose to use this one probe instance, or you can create other probe instances. Multiple probe instances are useful if you need multiple users using the same probe simultaneously or if you have specific needs for each probe instance (for instance, packet capture, trending, and so on). See Configuring connections to multiple NICs or Observer (page 271) for why you would want to use multiple probe instances.

**Note:** There are several different probe instance types. These include a packet capture-based probe instance used to capture packet traffic, two NetFlow collectors, an sFlow collector, and an MPLS probe. This section describes creating a packet-based probe instance, but the process is similar for the other probe instances, some of which are only available on the Expert Probe. For NetFlow, see Creating a NetFlow collector or NetFlow Trending collector (page 247). For MPLS, see Creating and configuring an MPLS probe instance (page 264). For sFlow, see .

To set up a probe instance, follow these steps:

1. **Do one of the following:**
   - On the probe: Click the **Adapters and Redirection tab**.
   - In Observer: Select a probe instance, right-click and choose Administer Selected Probe. Then click the **Adapters and Redirection tab**.

2. **In the upper left, click New Instance.** The Edit Probe Instance wizard opens.

   If the New Instance button is grayed out, it probably means you do not have enough Observer-allocated memory to add another instance.

   If you get a message that says that there is not enough reserved memory to create a probe instance, you must reduce the amount of memory used by another probe instance. By default all of the reserved memory on a GigaStor is assigned to the “Instance 1” active instance. By releasing some of the reserved memory you re-allocate memory from one probe to the pool of reserved memory from which you can create other probe instances, including passive probe instances on the GigaStor. Click the **Configure Memory** button and reduce the amount of memory for the packet capture buffer.

   You must have a minimum of 256 MB RAM to run the probe with a single instance, plus 12 MB for each additional probe instance. See Setting the total system memory reserved for probes (page 272) for details on allocating memory for Observer probes.
3. Ensure "Probe" is selected in the Instance type. Type a name and description and click **Next**.

4. Choose an appropriate capture buffer size given the local system's available memory and how much traffic you plan on capturing from the given network. Statistical reporting uses different memory—and much less of it—than packet capture.

   Although it is possible to customize the amounts of memory used by various Observer statistical displays (by choosing a statistics memory configuration), for most situations the defaults work perfectly well. For additional information, see Customizing statistics and capture buffers for probe instances (page 270).

   **a.** If you need to create your own memory configuration, click New. The New Statistics Memory Configuration window opens.

   **b.** Type a name and choose a default memory configuration to use. Click Finish. After choosing the memory configuration, you can change how the memory is allocated.

   **c.** Select your newly created memory configuration and click Edit. The Edit Statistics Memory Configuration window opens.

   **d.** Choose your network type. For each Observer statistic, choose how much memory is allocated for it. Click **OK**.

   **e.** Click **Next** to continue, and the Select Network Adapter and Redirection configuration dialog is displayed

5. Ensure the correct network adapter is selected and type the IP address of your Observer. Click Finish.

**Creating GigaStor active and passive probe instances**

**Prerequisite:** Expert Probe

GigaStor probe instance creation is only available when you are using the Expert Probe **locally** on a GigaStor probe and with the program in application mode, not as a Windows service. It is not available if you connect to the Expert Probe from a remote Observer analyzer.

If your GigaStor RAID has more than 256 TB, see How to use additional storage volumes on the GigaStor active instance (page 264) before continuing.

By default, the GigaStor has an active probe instance called "Instance 1" but does not have any passive probe instances. We recommend that you

- Rename the active probe instance by selecting Instance 1 and clicking Rename. Choose a name that is meaningful to you for the probe instance name and click **OK**. A typical name might be the physical location of this GigaStor.
- Have only one active GigaStor instance, unless you have specific reasons to have more.
- Create passive probe instances to use.
- See details about active and passive probe instances discussed in What is a probe instance? (page 226).
- After creating your active instance, if you want to change how much disk space is reserved for that active instance, click Configure Instance Storage.
To create a passive probe instance, follow the steps in Creating a probe instance (page 262). When you create a probe instance for an Expert Probe on GigaStor, it is automatically created as a passive probe instance.

If you want to change a passive probe instance to an active probe instance, follow these steps.

1. Do one of the following:
   - On the GigaStor probe: Click the GigaStor Instances tab.
   - In Observer: Select a probe instance, right-click and choose Administer Selected Probe. Then click the GigaStor Instances tab.

2. Select the passive probe instance you want to promote to an active instance and right-click.

3. Choose Make Instance Active. Your passive probe instance is now an active probe instance.

After completing this task:
You should then create passive probe instances for it.

Creating and configuring an MPLS probe instance

Prerequisite: Expert Probe

See Creating a probe instance (page 262) for details about creating an MPLS probe instance. In Creating a probe instance (page 262) choose MPLS Probe and follow the on screen instructions.

After the probe instance is created, you may want to configure the probe to tell it what type of traffic is seen.

2. On the General tab, use the options in the MPLS Analysis Settings to choose whether Observer should auto determine IPv4 and IPv6, what all other traffic is (ATM or Mac Header), and whether to use a four byte pseudowire word.
3. Click OK.

How to use additional storage volumes on the GigaStor active instance

When expanding your RAID array beyond 256 TB of usable disk space, you must add the additional volumes to your GigaStor active instance.

Prerequisite: Expert Probe

The maximum NTFS disk volume is 256 TB, but with a GigaStor you can have more storage than that by using the expanded disk arrays or striping through Windows.

1. On the GigaStor probe, click the GigaStor Instances tab.
2. Select the Use additional storage volumes option and click Configure.
3. In the message box that appears, click Yes.
4. Select the additional storage volumes you want to assign to your active probe instance, and click OK.
5. In the message box that appears, click Yes.
The additional storage is allocated. This may take a few moments.

**Connecting to a Probe**

You can connect to a probe from multiple direction: *from* or *to* a different Observer analyzer, to its own probe instance (connect to itself), and change the network adapter that is monitored on each probe instance.

**How to change the monitored network adapter**

If your probe has multiple network cards in it, you can choose which card you want to monitor.

This section applies to all probes and all versions of them, including Single Probe, Multi Probe, and Expert Probe on VIAVI or third party hardware.

**Note:** If you have a network card in your system, but it is not being seen or recognized by Observer, follow the instructions in No network adapter available (page 241).

**Tip!** If you are seeing only broadcast traffic, you do not have the correct network card selected or you do not have your switch port configured correctly as a SPAN/mirror port. Change the network adapter you are monitoring or configure the SPAN/mirror port.

*♦* When choosing the monitored adapter from within Observer for all probe versions:

1. In the probes list, select the probe instance.
2. Choose **Setup > Select NIC**.
   
   The **Select Network Adapter** window appears.
3. Select the network adapter you want to monitor, and click **Select**.

*♦* When choosing the monitored adapter on the probe for Multi Probe and Expert Probe:

1. Click **Adapters and Redirection**.
2. Select your probe instance and click **Configure Adapter/Redirection**.
   
   The **Edit Probe Instance** window appears.
3. In the **Selected Network Adapter** area, change the network card you are monitoring.

The probe instance is now using the newly selected adapter.

**Connecting to a probe for the first time from Observer**

1. Click the File tab, and click **Setup > Redirect Probe Instance(s)**.
2. Click **New** to add the probe to the Probe Administration and Redirection list.
3. Type the IP address that you assigned to the probe and click **OK**. You may leave the other fields blank. If you type a name, the name will change after Observer connects to the probe. The probe appears in the list of available probes.
4. Select the probe and then click Redirect Selected Probe.
5. Select the probe instance and click Redirect Selected Instance.
6. Choose the “Redirect to this Observer” option, then click the **Redirect** button. Within 30 seconds the probe will connect with the analyzer.

   Probe redirection can be password protected or disabled. Please see Connecting the Multi Probe or Expert Probe to an Observer (page 266) for details. If the probe is not connecting, see A probe is not connecting to the analyzer or vice versa (page 241). After the probe is connected, see Configuring the probe’s adapter speed, ToS/QoS precedence, and statistics sampling (page 272).

7. Close the Probe Instance Redirection window.

**Connecting the Multi Probe or Expert Probe to an Observer**

**Prerequisite:** Multi or Expert Probe.

There are two ways to connect the probe to an Observer. The method described here is from the perspective of the probe. All actions are done on the probe itself.

Each probe instance can be connected to only one Observer at a time. Connecting the probe instance with the analyzer is called “redirecting” it. This is because the probe instance may not be connected to any Observer or it may be connected to a different Observer than the one you want to connect it to. The connection can be done from within the analyzer or from the probe. This section describes how to redirect a probe instance from the probe and assumes that the probe software is running and that you already have a probe instance.

1. Click the **Adapters and Redirection tab**.

2. Select the probe instance you want to redirect and click the **Configure Adapter/Redirection** button at the top. The Edit Probe Instance window opens.

3. Select the “Redirect to a specified IP address or DNS name” option and provide the IP address or DNS name. When the probe instance is connected the “Redirected to” column lists the IP address of Observer system. If the probe is not connecting, see A probe is not connecting to the analyzer or vice versa (page 241).

4. After the probe is connected, see Configuring the probe’s adapter speed, ToS/QoS precedence, and statistics sampling (page 272).

**Connecting to a probe instance from an Observer analyzer**

**Prerequisite:** Multi or Expert Probe.

Probe instances can be redirected from one Observer to another or disconnected from any analyzer. This is done from Observer.

1. Click the File tab, and click **Setup > Redirect Probe Instance(s)**.

2. Select the probe instance you want to redirect and click the **Redirect Selected Probe Instance** button at the bottom. The Edit Probe Instance window opens.

3. If this is the first time you are connecting to the probe from Observer, you must add the probe to your list. See Connecting to a probe for the first time from Observer (page 265).

4. If the probe is not connecting, Probe redirection might be password protected or disabled. Please see Connecting the Multi Probe or Expert Probe to an
Connecting to a Probe

Chapter 17: Expert Probe Software

Observer (page 266) for details. If the probe is not connecting, see A probe is not connecting to the analyzer or vice versa (page 241).

5. After the probe is connected, see Configuring the probe’s adapter speed, ToS/QoS precedence, and statistics sampling (page 272).

Connecting the probe to an Observer

There are two ways to connect the probe to an Observer. The method described here shows you from the perspective of the probe. The second way is described in Connecting the Multi Probe or Expert Probe to an Observer (page 266). All actions are done on the probe itself.

1. Choose Options > Probe Redirection Settings. The Probe Redirection Settings dialog opens.

2. Use Table to complete the settings. If the probe is not connecting, see A probe is not connecting to the analyzer or vice versa (page 241).

<table>
<thead>
<tr>
<th>Observer IP address</th>
<th>Type the address of Observer you want this probe to connect to.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow Probe redirection for remote users</td>
<td>Allows remote users to redirect the probe to their Observer. If you want the probe to be able to connect to only one Observer, leave this option unchecked.</td>
</tr>
<tr>
<td>User name</td>
<td>By default any user can connect to the probe and no password is required.</td>
</tr>
<tr>
<td>Password</td>
<td>Password for the user account.</td>
</tr>
</tbody>
</table>

3. After the probe is connected, see Configuring the probe’s adapter speed, ToS/QoS precedence, and statistics sampling (page 272).

Redirecting a probe instance

Your local Observer may already have local probe instances defined, but you can add numerous remote probes, including GigaStor, too. You must first redirect the remote probe to your local Observer.

A probe may have multiple probe instances, which are useful if you need multiple users using the same probe simultaneously or if you have specific needs for each probe instance (for instance, packet capture, trending, and so on). When you connect to a probe, ensure you select the probe instance you need and not one being used by someone else.

Note: Probe redirection can either be password protected or disabled, depending on the target probe.

To redirect a probe instance, complete the following steps:

1. Click the File tab, and click Setup > Redirect Probe Instance(s).

2. Do one of the following:
   - If you see a remote probe instance you want to redirect, skip directly to step 6.
   - If your list is empty or missing the remote probe instance you want to redirect, proceed to step 3.

3. Click New.

   The Edit Remote Probe Entry dialog appears.
4. Type the IP address, or DNS address, of the remote probe. If you type a DNS name, it resolves to its IP address.

5. If necessary for probe access, type a user name and password, and click OK. Figure 67: Credentials may be needed

6. Select the remote probe instance from the list, and click **Redirect Selected Probe Instance(s)**.

   Allow time for the remote probe to redirect. How long this operation can take is limited by a timeout countdown.

   The probe instances of the remote probe are shown.

7. Select a probe instance from the list, and click **Redirect Selected Instance**.

8. Select the **Redirect to this Observer**, and click the **Redirect** button.
9. Close the **Probe Instance Redirection** window.

If the operation succeeds, the remote probe instance is now redirected to the local Observer. Now you can use the remote probe instance just as you would if it was running on your local machine.

**Probe Properties**

Observer and probe software must be within the same major release. This may require you to upgrade your probe software.

**Configuring a probe’s name and other probe options**

Set the probe network adapter speed, reserve system memory for probes, configure connections to multiple network adapters, set “always on” traffic capture, customize statistic and capture buffers, and more.

**Prerequisite(s):**

These steps assume you are viewing the probe interface, which is the only choice when using Expert Probe software. But if you are using a GigaStor, ensure that you are viewing the probe interface (page 286).

The probe has many options that you can configure.

1. **Choose **Options > Probe Options**.** The Probe Options dialog opens, which lets you configure the probe.
2. Use this table to complete the settings.
<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Probe name</td>
<td>Allows you to specify a name for the probe which appears in Observer probe list. The default name is a random mix of numbers and letters. We suggest renaming the probe to something meaningful to you. The name may be its physical location or any other standard you choose. The probe name is not the same as the probe instance name, although with a Single Probe you only have one probe instance. You define the probe instance name elsewhere. See Creating a probe instance (page 262).</td>
</tr>
<tr>
<td>Network Trending folder</td>
<td>Allows you to specify where the network trending data is saved. The default is <code>C:\Program Files\Observer\NetworkTrending</code>. Unless you have a specific reason to use another directory, we suggest using the default.</td>
</tr>
<tr>
<td>Folder for GigaStor</td>
<td>Allows you to specify where the GigaStor and network packet data will be saved. The default is <code>C:\Program Files\Observer\Data</code> if a software install or non-GigaStor probe or <code>D:\Data</code> if a GigaStor hardware appliance. Unless you have a specific reason to use another directory, we suggest using the default.</td>
</tr>
<tr>
<td>Maximum IP DNS resolution entries</td>
<td>Defines the maximum number of DNS entries the probe should maintain. The probe will keep up to the number of entries defined or what the probe can maintain in 10 MB of storage space, whichever is less. The probe keeps the first 10,000 entries (or whatever amount you define) it sees; it does not keep a rolling list of the last 10,000. After the limit is reached, no more entries are kept. They are discarded.</td>
</tr>
<tr>
<td>Run Probe as Windows Service</td>
<td>Select this option if you want to run the probe as a Windows service. This allows the probe to start without requiring a user to log in and start the probe. The probe starts whenever the system starts, which can be especially important for a remote probe. The change takes effect on the next system restart. When running the probe as a Windows service, some options are available to you that you do not have when running the probe as an application. Specifically, you can set Networking Trending and see CPU load of each probe instance. In both modes, you can configure memory management, configure security for each probe instance, reserve Windows memory for the probe, adjust for time drifts through clock synchronization, and enable the probe to be a virtual TAP.</td>
</tr>
<tr>
<td>View certificates from other Observer assets</td>
<td>Click the Certificates button to view trusted, untrusted, and pending trust, certificates that allow secure asset-to-asset communication. See Understanding the certificate trust model (page 155) for details.</td>
</tr>
</tbody>
</table>

**Customizing statistics and capture buffers for probe instances**

**Prerequisite:** Multi or Expert Probe.

Before changing any of the buffer sizes, you should understand how any changes you make affects the probe. See How a probe uses RAM (page 231).

- To change memory allocation for probe instances, see Running (page 235)Observer (page 235) with reserved memory (page 235).
- To fine-tune the Statistics Memory Configuration, see How to adjust the statistical buffer (page 77).
Configuring probes to collect data even when not connected to an analyzer

Probes (and probe instances) can be configured to collect data only when you tell it to—including manually starting/stopping the collection, having collection always running, or based on a schedule. The schedule and settings are saved with the probe instance. This means if you choose to have packet capture always running or running on a schedule that the probe instance does not need to be connected to an Observer.

To configure when packet capture should run, complete these steps:

1. In Observer, select a probe instance in the Probes list.
2. On the Home tab, in the Capture group, click Configuration > Packet Capture.
3. Click the Settings button. The Packet Capture Settings window opens.
4. Click the Schedule tab.
5. Choose the schedule you want (Always, daily, or specific days).
6. If you want to control the capture buffer’s size, click the Capture Options tab. The data is saved on the probe in C:\Program Files\Observer\Data.

Setting the probe’s time clock synchronization settings

At times your capture card drivers time clock may drift. They can be synchronized with the system clock, if you wish. Unless you notice a reason to enable this feature, we recommend that you do not synchronize your capture card’s time clock.

Some Other things to consider:
- The capture card synchronizes itself with the system clock at when the system starts.
- Generally, you are interested in relative time between packets, not the actual time a packet was seen.

1. Do one of the following:
   - On the probe: Click the Synchronization tab.
   - In Observer: Select a probe instance, right-click and choose Administer Selected Probe. Then click the Synchronization tab.
2. Click the Edit Schedule button.
3. Choose when and how you want the capture card’s time clock to synchronize with the system clock and click OK.

Configuring connections to multiple NICs or Observer

Prerequisite: Multi or Expert Probe.

With a Multi Probe, you can configure the probe to view multiple networks if multiple NICs are installed on the local system and to provide multiple Observer with views of the local network interfaces.

The probe accomplishes these capabilities by allowing multiple instances of itself. A probe instance is a virtual probe with attributes that define:
- Which network interface on the local system to capture data from.
- Which Observer (local or remote) to direct the data to.
Setting the total system memory reserved for probes

**Prerequisite:** Multi or Expert Probe.

Memory use is an important and vital part of using an Observer probe successfully. Before changing any of the reserved memory, you should understand how any changes you make affects the probe.

Configuring the probe’s adapter speed, ToS/QoS precedence, and statistics sampling

After connecting the probe instance to Observer Analyzer, there still may be some additional configuration that you must do. This is completely dependent on your network environment and your needs.

This section applies to all probes and all versions of them, including Single Probe, Multi Probe, and Expert Probe on VIAVI or third party hardware.

In Observer:
1. Select a probe instance in the Probes list.
2. Right-click and choose **Probe or Device Properties**.
3. Use the following tabs to further configure the probe for your environment. Not all of these tabs are present at all times. What tabs are visible depends on the type of probe you are configuring. For instance, the Gigabit tab is only visible when you are configuring a Gigabit Probe. For details about the fields on each tab, see the Configuring a probe’s name and other probe options (page 269).

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>Set the statistics sampling divider and MPLS settings. For field descriptions, see Probe Properties field-level descriptions (page 273).</td>
</tr>
<tr>
<td>Adapter speed</td>
<td>Verify that the adapter speed is registering correctly. Change the adapter speed if necessary. Changing the adapter speed here may be useful and necessary, because statistics, graphs, and reports generated by Observer are set using the adapter speed as the maximum. If, for some reason, Observer is not able to correctly identify your adapter speed your reports may be inaccurate. For field descriptions, see Probe Properties field-level descriptions (page 273).</td>
</tr>
<tr>
<td>ToS/QoS</td>
<td>Ensure these settings match your needs paying particular attention to the IP precedence bit for the ToS/QoS of your network. What you set here affects how the Observer analyzer displays information about VoIP, NetFlow, sFlow, and capture decodes. For field descriptions, see Probe Properties field-level descriptions (page 273).</td>
</tr>
<tr>
<td>Gigabit</td>
<td>Define the maximum frame size for your network. The default is 1514 bytes (excluding the frame checksum), which is appropriate for standard Ethernet. If the network link you are analyzing is configured to support jumbo frames (frames larger than 1514 bytes), you may want to change this setting to match the frame size of the Gigabit network, up to a maximum size of 9014 bytes. Observer will then discard frames that exceed this maximum frame size, generating a “Frame too large” error.</td>
</tr>
<tr>
<td>Wireless 802.11</td>
<td>Define what channels you want to monitor, what antenna you use for the wireless card, and your wireless encryption key if you use one for your network. See Monitoring a wireless access point</td>
</tr>
</tbody>
</table>
Your probe instance is now configured. You can begin collecting network traffic and statistics using it. Typically, this is done in Observer by choosing Capture > Packet Capture and clicking the Start button. See Configuring probes to collect data even when not connected to an analyzer (page 271) for details. You do not, however, need to start a packet capture to see statistics. See the list of statistics available under the Statistics menu in Observer.

**Probe Properties field-level descriptions**

This section include details about many of the fields and options for a probe.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Communication timeout</td>
<td>Allows you to define how long Observer will wait for the Probe to communicate before it assumes the connection is lost. Values are from 2 to 60 seconds.</td>
</tr>
<tr>
<td>Probe report period or local Observer information refresh time</td>
<td>Allows you to set how often the Probe sends a refresh packet or how often the local Observer’s dialogs are refreshed. This value has a minimum of 2 seconds with no maximum.</td>
</tr>
<tr>
<td>Statistics report (refresh) period</td>
<td>Allows you to set the statistics display refresh period. This value has a minimum of three seconds with no maximum.</td>
</tr>
<tr>
<td>Vital signs report (refresh) period</td>
<td>Allows you to set the Network Vital Signs refresh period. Values are from 10 to 600 seconds.</td>
</tr>
<tr>
<td>Sampling Divider</td>
<td>On probes with less processing power, high traffic rates (such as those typical of gigabit connections) can overwhelm the probe’s ability to keep up. A sampling divider tells Observer to only consider one of every n packets when calculating statistical displays, where n is the sampling divider. This setting only affects statistical displays such as Top Talkers, Internet Observer, etc. (packet captures are unaffected). A sampling divider of 2 registers every other packet; a sampling divider of 10 registers every tenth packet. Some statistical displays consider every packet regardless of this setting. Bandwidth Utilization looks at traffic as whole, so does Wireless Site Survey.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Encapsulated Traffic Analysis</td>
<td>GRE (Generic Routing Encapsulation) and GTP (GPRS Tunneling Protocol) are two encapsulation protocols that may have been deployed on your network. To show the encapsulation IP addresses, leave the box unchecked; to show the nested IP addresses, check the box. This setting also applies to L2TP and IPv4.</td>
</tr>
<tr>
<td>Nortel OEL2 Metro Ethernet Analysis Settings</td>
<td>Choose if frame headers should be analyzed as OEL2 headers.</td>
</tr>
<tr>
<td>MPLS Analysis Settings</td>
<td>Choose whether Observer should auto determine IPv4 and IPv6, what all other traffic is (ATM or Mac Header), and whether to use a four byte pseudowire word. Also choose whether to use the MAC addresses from encapsulated MPLS header.</td>
</tr>
</tbody>
</table>

Table 40. Parameters tab

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network type</td>
<td>Displays the probe's network topology, such as Ethernet, Token Ring, wireless, and WAN.</td>
</tr>
<tr>
<td>Network speed</td>
<td>Displays the network speed. The distinction here is between the actual, measured speed of the network and the speed that the NIC card, possibly incorrectly, reads from its connection. For example, a 10/100Mb NIC card on a 10/100Mb connection to a switch on a network where all the other stations are running at 10Mb will report the network speed as 100Mb. This item is the actual number that the NIC card driver sends Observer, so 10Mb Ethernet will be reported as 10,000,000. 100Mb Ethernet will be reported as 100,000,000.</td>
</tr>
<tr>
<td>NIC card name</td>
<td>Displays the name of the card as reported by the NDIS driver to the registry.</td>
</tr>
<tr>
<td>Probe version</td>
<td>Displays the probe version used by the local Observer or probe.</td>
</tr>
<tr>
<td>Number of adapters</td>
<td>Displays the number of cards the local Observer or probe has configured.</td>
</tr>
<tr>
<td>Instance memory (MB) and Capture Buffer (MB)</td>
<td>Displays the amount of RAM the instance or probe has available for statistics and capture buffer. Observer has no limitations on the amount of RAM that can be used for a buffer. The maximum allowable buffer size is displayed in the Options &gt; Selected Probe or SNMP Device Properties &gt; Probe Parameters tab.</td>
</tr>
<tr>
<td>View Probe Instance Memory Allocation</td>
<td>Lets you view and edit how the memory used for statistics is allocated for this probe instance.</td>
</tr>
<tr>
<td>Network errors Supported by the NIC NDIS driver</td>
<td>Displays the aggregate errors that your NDIS driver provides statistics for.</td>
</tr>
</tbody>
</table>

Table 41. Adapter Speed tab

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Network Speed</td>
<td>Your current speed reported by the network card.</td>
</tr>
<tr>
<td>Network Adapter Speed</td>
<td>Choose to let Observer and the NIC automatically determine the network speed, or to select from various values (in megabits per second) for the network speed to be used for calculations.</td>
</tr>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>------------</td>
<td>----------------</td>
</tr>
<tr>
<td>The primary use of this is to correct a mistaken NIC’s impression of overall network speed. A network card connected to a 10 megabit hub on a gigabit network will think that the entire network is only 1% as fast as it actually is.</td>
<td></td>
</tr>
</tbody>
</table>

Table 42. Autoupgrade tab

<table>
<thead>
<tr>
<th><strong>Option</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Autoupgrade probe within minor version release</td>
<td>Activates the autoupdate feature for minor version (i.e., point) releases (which do not require a new license).</td>
</tr>
<tr>
<td>Autoupgrade probe for major version release</td>
<td>Activates the autoupdate feature for major version releases. You must supply an ID and license key to update probes with a major version release. If the probe includes a capture card and the upgrade includes a Field Programmable Gate Array (FPGA) firmware update, the system must be manually shut down and restarted before the firmware update can take effect. A system restart will not complete the firmware upgrade (a shut down is required); however, the autoupgrade process will restart the probe system, thus completing the probe software upgrade. In most cases, the probe will still be operable with a software-only upgrade, but any of the benefits of the firmware update are not activated until you manually shut down and restart the probe.</td>
</tr>
<tr>
<td>Force Probe Autoupgrade to the current Observer version</td>
<td>This provides a manual mechanism for updating a probe.</td>
</tr>
</tbody>
</table>

Table 43. ToS/QoS tab

<table>
<thead>
<tr>
<th><strong>Option</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Collect Protocol Distribution by QoS</td>
<td>When enabled, QoS data is collected.</td>
</tr>
<tr>
<td>Use 802.11e Wireless TID/QoS</td>
<td>When enabled, QoS for wireless networks is collected.</td>
</tr>
<tr>
<td>IP ToS/QoS Standard</td>
<td>This tab is used for NetFlow and VoIP analysis. IPv4 supports the Type of Service (ToS) byte, also known as the Precedence byte. Different RFCs define different ways to interpret the byte: Default (RFCs 1349, 1195, 1123, and 791) OSPF V2 (RFCs 1248 and 1247) DSCP (RFC 2474) User Defined The information on the right shows the bit assignments. User-defined interpretations are also allowed. for the currently selected option. The User defined option displays entry fields that allow you to define the meaning of each bit position in the ToS byte.</td>
</tr>
</tbody>
</table>

Table 44. Wireless 802.11 tab

<table>
<thead>
<tr>
<th><strong>Option</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Profile</td>
<td>Site profiles allows you to save and retrieve wireless parameters, rather than re-keying the parameters every time you change sites.</td>
</tr>
</tbody>
</table>
### Table 45. DS3/E3/HSSI tab

<table>
<thead>
<tr>
<th>Setting</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WAN Type</strong></td>
<td>Choose DS3 (T3), E3 or HSSI to match the type of link you are analyzing, then choose the frame check sequence (FCS) standard: CRC-16 (the default) or CRC-32.</td>
</tr>
<tr>
<td><strong>Encapsulation</strong></td>
<td>You must set this to match the settings on the frame relay CSU/DSU.</td>
</tr>
<tr>
<td><strong>Subprotocol</strong></td>
<td>If ATM or LAPB is the selected encapsulation method, you must choose the sub-protocols on the link.</td>
</tr>
<tr>
<td><strong>Fractionalized</strong></td>
<td>Check if your link is configured for fractionalized operation. Fractionalized DS3 and E3 are not supported.</td>
</tr>
<tr>
<td><strong>Bandwidth (HSSI)</strong></td>
<td>Set to match the bandwidth and channel settings of the fractionalized HSSI link under analysis.</td>
</tr>
</tbody>
</table>

### Table 46. T1/E1 tab

<table>
<thead>
<tr>
<th>Setting</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WAN/Frame Relay Type</strong></td>
<td>Choose T1 or E1 to match the type of link you are analyzing.</td>
</tr>
<tr>
<td><strong>Encapsulation</strong></td>
<td>You must set this to match the settings on the frame relay CSU/DSU.</td>
</tr>
<tr>
<td><strong>Subprotocol</strong></td>
<td>If ATM or LAPB is the selected encapsulation method, you must choose the sub-projects on the link.</td>
</tr>
</tbody>
</table>
### Setting | Explanation
--- | ---
**Link 1 and Link 2 Channel Settings** *(Note that for the link and settings to be activated, you must check the On check box for that link).*

| Fractionalized | Check if this link is configured for fractionalized operation. |
| Channel selector check boxes | Choose the channels you want to be included in the analysis. |
| Include in Util. Thermometer. | Check if you want to include statistics from this link in the Bandwidth Utilization Thermometer. |

---

**Understanding the Packet Broker Integration tab**

When using network packet broker integration, you can dynamically reduce traffic flow to your GigaStor when it is at risk of oversubscription giving you the content you need. Additionally, metadata tags identify the network segment where the packets came from, providing you context when troubleshooting.

As a network administrator, you need really good content to be able to quickly troubleshoot your network environment. If you do not have the appropriate metadata or packets, determining where a problem is occurring and, more importantly, why the problem is occurring is very difficult. Content is king, and context is important. Dynamic traffic management gives you the content, and port tags give you the context.

**Dynamic traffic management**

Dropped packets are never desirable and they occur when a link is oversubscribed. If your analytics device does not have all of the packets of a conversation, troubleshooting is very difficult.

If your GigaStor is at risk of oversubscription, you should reduce the flow of traffic to the GigaStor. You have two options for reducing the traffic.

First, you can choose to **pre-filter traffic (page 89)** using fixed, preset filters that you create. This is the minimalist approach. Second, you can allow all traffic and dynamically exclude traffic only when oversubscription occurs. We’ll explore each choice in a bit more detail.

With the minimalist approach to packet capture, you only capture the traffic that you think is relevant. In other words, you exclude everything from packet capture except the specific traffic you allow. For instance, you may decide that YouTube is not critical to your business and do not need to troubleshoot problems with that traffic. Therefore, you would never capture and save YouTube traffic. It is excluded with a pre-filter. This gives you longer retention capabilities for the content you do capture because your capture devices are not filling as quickly. Also, by not seeing YouTube and other non-critical traffic you are not overwhelmed with unnecessary information when troubleshooting. When you do identify a problem in your network, you can allow in more traffic by changing your pre-filters to troubleshoot the problem.

The opposite approach is to capture everything and use **post-filters (page 97)** to find what you are looking for. If GigaStor is at risk of oversubscription, then using traffic filters that GigaStor dynamically and automatically apply to a Gigamon can reduce the flow. This eliminates the oversubscription risk while continuing to capture the most amount of traffic relevant to you. You can set the types of traffic that interest you up front and GigaStor automatically captures it. After the **initial configuration (page 279)**, it is no longer a manual process you need...
to remember to implement to capture the content you need. The dynamic filters allow you to focus on the business critical applications.

Figure 69: When filters are applied and removed

Unlike pre-filters, which can be used anytime, dynamic filtering is only available when using a Gigamon network packet broker.

Contextual visibility

Using Gigamon-applied port tags, you know which network segments are experiencing performance issues.

For context, you can have numerous streams of information coming into GigaStor, but, when you are troubleshooting, it is very helpful to know where in your network the packets came from. This is where port tags help. With port tags you have the context of knowing where in your network the problem occurred.

Figure 70: Contextual visibility

Using the port tags helps you solve correlative analysis issues. For example, if you are troubleshooting a VoIP call that shows excessive jitter or a low MOS score, it is important to know what portion of the network you are seeing in the packet captures. One network segment may not be experiencing any problems at all, while the other network segment does. By filtering on conversation and
port tags, you will be able to see the conversation from different perspectives and begin to draw conclusions.

**How to configure packet broker integration**

Using a network packet broker ensures that the Observer Platform has the right content at the right times so that you can troubleshoot your network.

Configuring packet broker integration allows GigaStor to work with systems such as GigaVUE.

Using filters created in GigaStor, you can filter traffic as it leaves your packet broker reducing the load the GigaStor. Using Gigamon-applied port tags allows you to identify packets that come from your network packet brokers.

**Prerequisite(s):**

Exactly these versions are required:

- Gigamon Fabric Manager 3.3
- Gigamon GigaVUE H series nodes 4.6

With this feature, you can choose to use port tags without enabling dynamic filters, or you can decide to use dynamic filters and not use port tags, or you can enable both. You decide what is best for your environment.

You might choose to filter traffic because you only want certain traffic to be kept on this GigaStor or because the traffic load temporarily exceeds the GigaStor FIFO abilities. If there are multiple filters, they are applied one at a time in descending order until the FIFO level drops below 50%.

1. Select a probe instance in the Probes list.
2. Right-click and choose **Probe or Device Properties**.
3. Choose the **Packet Broker Integration** tab.
4. Use the information in **Packet Broker Integration (page 280)** to configure GigaStor to work with your packet broker.
GigaStor sends commands to your packet broker whenever FIFO levels are too high (above 50%). This temporarily reduces the traffic load coming into the GigaStor until FIFO levels drop below 20%.

**What to do next:** Turn on the **NPB Port Tagging** tab in GigaStor Control Panel in Setting the GigaStor general options.

**Packet Broker Integration**

Use the packet broker integration settings to configure the connection between GigaStor and your packet broker (for instance, GigaVUE).

<table>
<thead>
<tr>
<th>Fabric Manager address</th>
<th>The DNS name or IP address of the GigaVUE-FM system.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cluster ID</td>
<td>The cluster name or IP address of the GigaVUE-FM visibility fabric node.</td>
</tr>
<tr>
<td>Username</td>
<td>Your GigaVUE-FM user name.</td>
</tr>
<tr>
<td>Password</td>
<td>The password for your GigaVUE-FM user name.</td>
</tr>
<tr>
<td>Test Configuration</td>
<td>Use this button to validate your packet broker settings, including addresses, user name, and password. If you enter any invalid ports, a message box returns with a list of valid ports for the cluster.</td>
</tr>
<tr>
<td>Enable Gigamon port tagging</td>
<td>Provides contextual visibility by using the GigaVUE-FM-applied VLAN 802.1Q port tags that are added to every packet. This allows for filtering in GigaStor. Be sure to turn on <strong>NPB Port Tagging</strong> in Setting the GigaStor general options to show the NPB Port Tagging tab in GigaStor Control Panel where you can</td>
</tr>
</tbody>
</table>
see the GigaVUE-FM port from which the packet came, the port tag, the number of packets from the port, the amount of bytes, and utilization.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Dynamic Filtering</td>
<td>Allows the GigaStor to send filters to GigaVUE-FM whenever the FIFO load on the GigaStor reaches 50% and there is a risk of dropping packets. When this option is enabled, GigaStor clears any existing filters on Gigamon and replaces them with the new filters. When disabled, GigaStor removes all filters.</td>
</tr>
<tr>
<td>Tool ports attached to this instance</td>
<td>A list of Fabric Manager ports that are associated with the GigaStor active instance. They are listed in the format required by Fabric Manager: Chassis/Slot/Port. For example, 1/1/x1.</td>
</tr>
<tr>
<td>Port (Chassis/Slot/Port)</td>
<td>The first value is the GigaVUE chassis in which the port is found, the second value is the slot within the GigaVUE chassis where the port is found, and finally is the port itself. All three values are required and must be separated by the / character.</td>
</tr>
<tr>
<td>Enable rollback of filters</td>
<td>If selected, any filters in the Applications to be filtered list that have been applied to the packet broker are removed after the specified number of minutes. The minimum is one minute. The time frame you choose allows for a smooth rollback of filters so that a momentary drop in network traffic does not cause filters to be repeatedly applied and removed in a short timespan.</td>
</tr>
<tr>
<td>Applications to be filtered</td>
<td>This section defines the filters to push to GigaVUE to exclude certain content before the traffic is sent to GigaStor. Each time you add, remove, change, or reorder these filters, all filters on the GigaVUE system are deleted and replaced with these filters. This ensures that only the filters you specify in this list and no others are used. The risk of dropping packets occurs when the FIFO reaches 50%. When that level is reached, a message is logged and the first filter in the list is applied. If applying the filter does not lower the FIFO level below 50% within one second, the next filter is applied. This process continues until the FIFO level remains below 50%. This ensures that a minimum number of filters is applied while allowing the most amount of traffic to be written to GigaStor. The order of the filters is important. Filters are applied in descending order. In other words, the filter listed at the top is applied first, then the next if necessary, and so on. If the FIFO does not drop below 50% even after all filters have been applied, you should identify other application traffic to exclude. Filters are removed in reverse order starting with lowest priority (last) filter, then the next lowest, and so on until all filters are removed only after the GigaStor FIFO (page 324) falls below 20% with that filter applied and the allotted time from the Enable rollback of filters field has passed. If the FIFO level goes back above 50% the filter that was just removed will be reapplied. The 50% and 20% threshold values are fixed and cannot be modified. Use the arrows buttons to change the order of your filters to find the arrangement that works best for you. The buffer size (page 320) of the active instance affects FIFO abilities. Changing the buffer size is described in Setting the GigaStor general options and may help in some instances; otherwise application filtering is needed.</td>
</tr>
</tbody>
</table>
You can choose to filter TCP-, UDP-, and SCTP-based applications, including any derived applications (page 71) you created in How to add application definitions (page 68).

In GigaStor, an application can be defined (page 68) using a port, port range, or port/IP address combination (or any combination of these). GigaVUE does not have a way to identify applications based on port/IP address. Therefore, the port/IP address combination will be removed from any filter before it is sent to GigaVUE. For example, if an application definition is 9000, 2343:10.74.33.101, only 9000 will be passed to GigaVUE; 2343:10.74.33.101 will be dropped from the filter. Again, this is a limitation of GigaVUE.

A maximum of 100 tool port filter rules can be created. An application that uses a port range (9001-9005) counts as one rule not as five rules.

GigaStor uses a REST API to communicate with GigaVUE. If there are communication interruptions between the two systems for whatever reason, GigaStor will attempt several times to reissue the command until it is successful. If it is still not successful after several attempts, a message will be written to the log.

**How Gigamon-applied port tags are identified**

GigaStor identifies packets with headers applied by Gigamon because a Gigamon system tags packets using an 802.1Q tag.

The Gigamon administrator may apply port tags to each ingress port on the GigaVUE. For each ingress port a unique VLAN 802.1Q tag is used. This tag is applied using the outermost VLAN tag. When there is a VLAN 802.1Q tag on the inner frame, only the information in the outermost 802.1Q tag is used.

GigaStor queries the list of port tags used by Gigamon and maintains a copy of that list. When traffic is received by GigaStor it is compared against the list. If there is a match, the GigaStor knows exactly which ingress port on the Gigamon was used and displays the information accordingly.

**Security and Encryption**

Observer and probe software must be within the same major release. This may require you to upgrade your probe software.

**How to encrypt captured data at rest**

Captured data at rest can be encrypted using the 256-bit Advanced Encryption Standard (AES) algorithm. This significantly increases the security of your at-rest data.

**Prerequisite(s):**

- You must have a special Observer license to enable and use this feature. There is no extra charge for the license.
- You must have a GigaStor hardware appliance. This feature is not available to GigaStor Software Edition. See the differences in software and hardware (page 304) offerings for GigaStor.
Data at rest encryption is prevents visibility into any packets or even the metadata about the packets stored on the GigaStor. Any packets that are captured by the GigaStor are considered "data" and while they are stored on the GigaStor they are considered "at rest." Should any of the drives in the GigaStor be removed or misplaced, the data on the drives is protected. There is no remote access to this data apart from Observer’s own analyzer, and the data tagging methods for organizing and retrieving data can only be used in conjunction with Observer.

The GigaStor can capture 10 Gb line rate while simultaneously encrypting the traffic with AES-256 encryption without any significant performance impact on write or read speeds of the GigaStor. The RAID hardware is responsible for the encryption, and the data is encrypted before it is written to disk.

These instructions describe how to apply data at rest encryption to a GigaStor already in your possession. If your GigaStor shipped from the warehouse with the data at rest security already enabled, you do not need to complete this process unless two or more drives in your RAID have failed.

**Caution:** This procedure deletes all of the data on your GigaStor! Ensure you have a backup of any data you wish to keep.

1. Download the latest firmware for the Areca 1882 Series RAID card or contact VIAVI Support for the file.

2. Choose **Start > All Programs > Areca Technology Corp > ArcHttpSrvGui > Areca HTTP Proxy Server GUI**. The program starts. You should see something similar to the Figure 72 (page 283) image.

![Areca RAID application](image)

3. Select Controller#01 and click Launch Browser. If the controller is not running, click the **Start** button then launch the browser. The Areca RAID application attempts to connect to its web server.

4. Type the user name and password. The default user name is **admin**. There is no default password. Click **OK** to open the browser.

   In the browser you can see the RAID set, IDE channels, Volume, and capacity.
5. In the web browser, choose **System Controls > Upgrade Firmware**. In the **Browse** field, choose each of the four files from the firmware package you downloaded or received from Technical Support in step 1 and click **Submit**. Choose the files in the order they are listed below. After adding the arch1882firm.bin file you are prompted to restart the system. Ignore that restart request and add the fourth file.

   ARC1882BIOS.BIN
   ARC1882BOOT.BIN
   arc1882firm.bin
   ARC1882MBR0.BIN

6. Restart the GigaStor.

7. Choose **Volume Set Functions > Delete Volume Set**. Select the volume, then select **Confirm The Operation** and click **Submit**. This deletes all of the existing data on the RAID.

8. Choose **Volume Set Functions > Create Volume Set**. Set the following options to these values, select **Confirm The Operation**, and click **Submit**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Volume RAID Level</td>
<td>Raid 5</td>
</tr>
<tr>
<td>Greater Two TB</td>
<td>64bit LBA</td>
</tr>
<tr>
<td>Volume Support</td>
<td></td>
</tr>
<tr>
<td>Volume Initialization Mode</td>
<td>Foreground Initialization. It may take several hours (six hours for 48 TB) to initialization the volume. While the volume is being initialized, the GigaStor cannot be used. If you choose Background Initialization, you may use your GigaStor, but it will take significantly longer to complete and performance will be negatively affected.</td>
</tr>
<tr>
<td>Volume Stripe Size</td>
<td>128</td>
</tr>
<tr>
<td>Volume Cache Mode</td>
<td>Write Back</td>
</tr>
<tr>
<td>Volume Write Protection</td>
<td>Disabled</td>
</tr>
<tr>
<td>Full Volume Encryption</td>
<td>256Bit Key, AES Key</td>
</tr>
<tr>
<td>Tagged Command Queueing</td>
<td>Enabled</td>
</tr>
<tr>
<td>SCSI Channel</td>
<td>0:0:0</td>
</tr>
<tr>
<td>Volumes To Be Created</td>
<td>1</td>
</tr>
</tbody>
</table>


   Because this is the first time that Observer is opened with the new license, it does not yet have a key for the encrypted volume. A window appears indicating that the volume is locked.

10. Click **Generate Key** and save the key file in a secure location following your organization’s security policy.

   - When rebooting, the system needs access to key in order to unlock the drive. This is the key necessary to write to and read from the RAID volume.
   - Observer will not open unless it can find the key. Without the key present neither packet capture nor packet analysis can occur. You can
choose to remember the key file location so that Observer opens automatically, or, if left cleared, each time Observer is opened you must provide the path to the key file.

- Securely storing the key is a critical part of your responsibility.

11. Close Observer until the rest of this procedure is complete.

12. In Control Panel > Administrative Tools > Computer Management > Storage > Disk Management select the RAID volume, right-click and choose Initialize. In the Initialize Disk window, select Disk 1 and GPT (GUID Partition Table). Convert the volume to a Simple Layout, assign a drive letter (typically, D:), and provide a name (typically, DATA).

13. Repeat this process for each RAID volume for your GigaStor.

14. Open Observer.

Using the Probe

The probe has two interfaces: the probe service and the analyzer user interfaces. You can switch between the two depending on what you want to accomplish. Also learn about monitoring a wireless access point (AP) and where to enable network trending.

Using the Expert Probe software

Learn how to create, configure, redirect, and delete both local and remote probe instances.

Prerequisite: Expert Probe

The Expert Probe is a step above the Multi Probe software and is the only probe software that runs on the GigaStor. The Expert Probe includes all the functionality of the Multi Probe, plus it displays remote expert analysis in real time for faster troubleshooting. If you are using the Expert Probe on a GigaStor(rather than a non-GigaStor probe) there are even more features available. Just like the Multi Probe, the Expert Probe has a number of tabs that allow you to control probe network connections and memory usage, administer probe security, and monitor probe activity.

Figure 73: Expert Probe on a GigaStor

An Expert Probe transfers decode data to an Observer only when you select the packet from the one-line summary pane, which is updated with packet header information in real time. This conserves network bandwidth by analyzing all data locally and sending only the results. This eliminates the need to transfer data packets over the wire. This differs from the Single Probe and Multi Probe
because those probes send the entire buffer to the analyzer and the decoding and analysis happens on the analyzer.

Another feature exclusive to the Expert Probe is its ability to switch between being a probe or an analyzer. This can be very useful depending on your needs. This gives you flexibility in using the probe both remotely and on site.

**VoIP Expert, Application Performance Analysis, and Application Transaction Analysis**

**Prerequisite:** Expert Probe

The Expert Probe provides unique insight into your OSI Model Layer 7 applications that the Multi Probe and Single Probe cannot provide. This is especially true for VoIP.

There is nothing that you need to configure on the probe to enable these features, but this information is only available when viewing the probe instance of an Expert Probe.

To use and configure VoIP, ATA, or APA:

1. On the Home tab, in the Capture group, click **Network Trending > Network Trending**.
2. Use the General, Application Transaction Analysis, Application Performance Analysis, and VoIP tab to configure your options.
3. Click the **Start** button to begin monitoring.
4. After you have collected some data, click the **Analysis** button. The View Network Trending data dialog opens.
5. Choose “Transfer and view current day statistics” and click **OK**. This opens the Network Trending Viewer in a new tab where you can see your data.

**Switching between the probe and analyzer user interfaces**

Most probes can be run as either a Windows service or in application mode. Some settings can only be made when the probe is in application mode.

**Prerequisite:** Multi or Expert Probe.

Depending on how you want or need to use your Expert Probe, it can be either an Observer to help you view your network data or it can be a probe to capture data and to which other Observer can connect. The Expert Probe software cannot simultaneously be an analyzer and a probe.

To change the Expert Probe interface to load as a fully-featured Observer, click **File** and **Options > Switch Interface**. You must restart the application to see the change.

**Note:** For a GigaStor, the Expert Probe software is running as a Windows service. You must stop the Expert Probe service before you can change its interface.

1. Right-click the **Probe Service Configuration Applet** in the system tray and choose **Open Probe Configuration**.
2. Choose **Options** > **Probe Options**.

3. Clear the option **Run Probe as a Windows Service** option, and click **OK**.

   This removes the VIAVI Expert Probe service from Windows.

4. Start Observer.

5. Click the File tab, and click **Options** > **Switch Interface**.


   This closes Observer.

7. Start Observer.

Observer is now set to use the analyzer interface.

When switching back to an Expert Probe on the GigaStor, you must reverse these steps and then you must manually start Expert Probe from the Windows Service Control Manager. It may take a moment before the service starts. You may need to restart the GigaStor for the setting changes to fully set.

### Enabling Network Trending and setting which statistics are collected

A probe can provide many different statistics about your network, but you must enable the collection of those statistics. Network Trending does not capture packets, but collects statistics about the traffic on your network. Many reports in Observer use the trending information, and we recommend you enable Network Trending.

1. To turn on the collection of a specific statistic, in Observer choose Statistics > and then select the statistic you want to have the probe collect and report.

2. On the Home tab, in the Capture group, click **Network Trending** > **Network Trending**.

### Monitoring a wireless access point

You can capture all wireless traffic with a wireless network card on a laptop or any system with a wireless network card if you use the VIAVI wireless driver. The default driver for your wireless card is not sufficient for Observer.

Standard network cards do not support “raw” wireless packets, nor do they enable “promiscuous” mode by default. Promiscuous mode captures all packets for the analyzer, not just those addressed to the network card. Both “raw” wireless packets and promiscuous mode are required by Observer. The VIAVI wireless driver enables these options.

When a network card is running in promiscuous mode, it cannot connect to a wireless access point. It can only capture traffic. If you are using a laptop and
Using the probe as a virtual TAP

Learn when to use a virtual TAP, its purpose and benefits, and how to configure them for use in a VMware ESX server.

**Prerequisite:** Multi or Expert Probe.

The Virtual TAP (sometimes called a vTAP) allows you to configure a virtual tap to monitor traffic within a virtual host environment.

Most virtual environments provide virtual adapters for each virtual machine, and these virtual adapters are logically connected to a virtual switch managed by the virtual host system. The virtual switch manages traffic flow to and from the virtual adapters by mapping each virtual adapter to a physical adapter in the host. When promiscuous mode is enabled on a virtual adapter (or virtual switch), all traffic flowing through the virtual switch—including local traffic between virtual machines and remote traffic from outside the virtual host—is sent to the promiscuous virtual adapter and can be monitored by Observer.

To use the virtual tap you must monitor all virtual machines in a host from a virtual machine within the host. This assumes you can use a SPAN/mirror port or the virtual NIC has a “promiscuous mode” setting. This functionality is available in VMware’s ESX and ESXi. It may also be available in other virtual server products.

Using the virtual TAP, you can then collect and re-direct all traffic internal to the virtual switch to a dedicated virtual NIC within the monitoring virtual machine that is then connected to Observer.

If there is any internal communication between virtual machines, the only way to monitor this data is by using a separate monitoring virtual machine with an analysis service (for instance, probe) gathering data from the internal virtual switch. Should you need to analyze or store data on a GigaStor, installing a...
Virtual TAP within the monitoring virtual machine provides complete visibility into all data flowing on the internal virtual switch.

You can create a port group on a switch and use a virtual machine (VM1) to monitor traffic of a second virtual machine (VM2) that resides on the same switch but in different port.

**Tip!** If you already have a 64-bit Windows virtual machine, we suggest you use it, because installing the probe there will be less resource intensive on the host than installing a new virtual machine on the host.

1. Do one of the following:
   - On the probe: Click the Virtual TAP tab.
   - In Observer: Select a probe instance, right-click and choose Administer Selected Probe. Then click the Virtual TAP tab.

2. Click Modify to set the source and destination adapters for the virtual tap.

3. Choose your source and destination adapters and select the Enable Virtual Tap option.

   You have now configured what you need to within Observer to enable the virtual tap feature, but you must modify a setting for your virtual switch.

4. Set the virtual NIC on the virtual switch within the host in SPAN/mirror mode, sometimes also called promiscuous mode. See your virtual machine’s documentation for further details.

**When to use a virtual TAP**

Monitoring network and application traffic in a virtualized environment containing one-to-many relationships between physical hardware devices (virtual hosts) and virtual application servers (virtual machines) presents a number of concerns.

Virtual environments are designed to include a virtual adapter (vNIC) for each virtual machine within the system. The vNIC is logically connected to a virtual switch, which is managed by the virtual host system (see the diagram below). This addresses communication which would remain in the VM host. In order to enable communication into and out of the VM host, a logical connection between the vNIC and the pNIC must be established.

Depending on the virtual server technology you have decided to implement, you have a number of options for network and application traffic visibility, and for the use of external devices for analysis. If all virtual machine communications take place between the virtual machines and the “outside” (i.e., outside the physical host), then monitoring the data flow from outside the host server may be the least complicated method by which to gain flow visibility. If there is any internal communication between virtual machines, the only way to monitor this data is by using a monitoring virtual machine (separate or existing) with an analysis service (i.e., probe) gathering data from the internal virtual switch. Should you need to analyze or store data on an external purpose-built device, installing a virtual TAP within the monitoring virtual machine provides complete visibility into all data flowing on the internal virtual switch.

Within the VMware ESX and ESXi environments, a virtual adapter can be set in “promiscuous mode.” When promiscuous mode is enabled on a virtual adapter, all traffic flowing through the virtual switch—including local traffic between virtual
machines and remote traffic originating from outside the virtual host—is sent to the promiscuous virtual adapter.

A number of challenges are presented when attempting to monitor applications with a virtualized environment.

1. **Lack of visibility.** Traffic between virtual machines within a virtual host will not be visible outside of the host. This causes a number of problems:
   a. Network engineers cannot monitor multi-tier applications partially or wholly located on multiple virtual machines within a single host.
   b. Should a virtual machine be compromised by malicious code or security breach, other virtual machines within the same host may also be compromised.

2. **Lack of analysis functionality.** A separate solution is required to push data streams flowing within virtual machines out to an external tool or a purpose-built device. This functionality is necessary for network and application monitoring and analysis, compliance, and security audits. Virtual TAPs (software applications placed inside a virtual machine to export all data through a designated pNIC to an external device) can alleviate this problem.

**Options**

The goal is to not only see all traffic flowing within a VM host but also export that data for powerful analytics and reporting. There are three primary ways to monitor both traffic flow from within applications on virtual machines and from the virtual host.

1. Monitor the host using an external analysis device as you would any other system, via SPAN technology or a physical TAP. This option works well for environments not needing to track internal virtual machine-to-machine traffic.
within a host. However, it may not catch a security breach compromising multiple virtual machines within a host.

2. Monitor all virtual machines in a host by establishing a new virtual machine within the host. This option assumes the ability to SPAN or set in promiscuous mode the virtual switch within the host. This option provides visibility at the statistics and packet levels of all traffic within a virtual host. It does not,
however, allow packet-level traffic to be analyzed by an external physical device (IDS, retrospective analysis device, etc.).

3. Use a virtual TAP to collect and redirect all internal virtual machine traffic to a dedicated virtual NIC within the monitoring virtual machine that is connected to an external purpose-built device for analysis or compliance enforcement. Depending on the functionality of the external device the traffic is being copied to, this option may provide all the functionality of option two while
taking advantage of the physical capabilities of the purpose-built external device.

Option two combined with option three offers the most extensive and comprehensive monitoring solution. In a VMware environment, you can use promiscuous mode on the internal virtual switch and direct a copy of all traffic from all virtual machines to a virtual machine monitoring instance. This allows you to collect metrics and perform real-time analysis; and using a virtual TAP, you can re-direct packet streams out a separate NIC to a GigaStor probe.

Benefits of a virtual TAP

Mirroring all traffic within a virtual host to an external device provides a number of advantages, including total visibility into VM application traffic and the ability to run greater analytics for comprehensive reporting and faster problem resolution.

For example:

- **Application Performance Monitoring.** Feed VM traffic to an enterprise reporting engine for comprehensive monitoring of virtualized environments. Set and track performance baselines and respond quickly when performance deviates from the norm. Tracking VM traffic over time helps determine if your VM server load has increased to the point of requiring action.

- **Application Performance Troubleshooting.** The virtual TAP can also output data to a GigaStor probe, which stores it for later access. The GigaStor can help isolate problems within your virtual environment and troubleshoot these issues using Application Analytics.

The Virtual TAP option bridges the visibility gap, allowing complete real-time analysis, Retrospective Network Analysis, and full-scale reporting on all virtualized traffic.
Configuring VMware ESX Server

A virtual machine is a convenient way to add monitoring capabilities to your network. Use this information to create a virtual switch.

**Prerequisite(s):**
- Your virtual machine meets the minimum specifications (page 18)
- Multi or Expert Probe is installed
- A free physical NIC

The default policy for Promiscuous Mode for the vSwitch itself should remain in the Reject setting. Only the new port group within the vSwitch should be set to Accept Promiscuous mode. You can use the virtual machine properties dialog to identify the Network Connection, listed in the Windows Network Connections dialog, by unchecking the “connected” option.

In the virtual switch to be monitored, add a virtual port group and set it to run in Promiscuous Mode.

**Caution:** Do not choose the same source and destination for the Virtual TAP Settings. This could cause broadcast/multicast loops and would noticeably impact your network.

1. Open VI Client and highlight the VMware ESX Server Entry.
2. Click the **Configuration** tab.
3. Click **Hardware – Choose Networking**.
4. Find the vSwitch for which you would like to monitor traffic and choose Properties.
5. In the vSwitch Properties dialog (Ports tab), click **Add**.
6. In the Add Network wizard, choose Virtual Machine [port group], give the group a name (“Promiscuous Port Group”), and finish the wizard.
7. In the **vSwitch Properties** dialog, highlight the new port group and click **Edit**.
8. Click the **Security tab**.
9. Select the **Promiscuous Mode Policy Exception** option and change the list to **Accept**.
10. Setup a second virtual switch and bind a second physical NIC to that virtual switch.

See Figure 76 (page 295) Virtual Infrastructure Client > Configuration tab. Then see Figure 78 (page 296) Add Networking > Add Network Wizard > Virtual Machine.

11. Create a virtual switch.

12. Select the appropriate NIC entry (i.e. Physical NIC 2 on ESX Server).

13. Name the vSwitch (i.e. “vTAP OUT to GigaStor”) and finish.

The result should be similar to Figure 77 (page 296). See your VMware ESX Server documentation if you need more detailed information on adding a virtual switch.
14. Edit the Virtual Machine that contains the Observer to use the Port Monitor Group and second vSwitch.

15. Select the first network adapter.

16. Change the Network label to the new Port Monitor Group, and add a second virtual NIC if needed.

17. Select the second virtual NIC and change the Network label to the second vSwitch (i.e., vTAP OUT to GigaStor) and click OK.

18. Verify that the Virtual Machine containing Observer is located in both virtual switches.

19. Within the virtual machine, setup Observer to VTAP Local Area Connection 1 to Local Area Connection 2.

20. Connect the cable from “NIC 2” on the VMware ESX Server to the GigaStor capture card.

How to assign physical ports to probe instances

By default, the active instance monitors network traffic from every physical port of your capture card—all the traffic is aggregated. If you want to instead “divide” your monitored network traffic by physical ports, to help you monitor certain SFPs separately from others, then you can use virtual adapters to assign specific physical ports to probe instances.
Prerequisite(s):

Your hardware appliance must have one of the following:

♦ Gen2 capture card
♦ Gen3 capture card

For example, suppose you are deploying an 8-port Gen3 capture card as follows:

♦ Ports 1-4 are monitoring a collection of trunked links
♦ The remaining ports are each connected to the SPAN (or mirror) port on a switch

In this scenario, it makes sense for Observer to view ports 1-4, for example, as a single stream of network traffic and to separate each of the four remaining ports into separate data streams. Virtual adapters are a convenient way to accomplish this separation or aggregation in real time, rather than depending on filters to sort through the traffic post-capture.

These are the general steps for assigning physical ports to a probe instance:

♦ Create a virtual adapter (or have one already).
♦ Assign physical ports to this virtual adapter.
♦ Set a probe instance to use this virtual adapter as its NIC.

Tip! As a general reminder, you risk severe performance loss when using more than one active instance. These instructions do not create multiple active instances.

To assign physical ports to a specific probe instance:

1. In Observer, right-click the Gen3 capture card-equipped probe instance from the probe list, and click Probe or Device Properties.

A Gen3 capture card-equipped probe instance shows (Gigabit) or similar after the name.

2. Click the Virtual Adapters tab.
3. Select a virtual adapter, and click **Edit Adapter**.

4. Select physical ports from the **Available Ports** list, and click **Add**.

   You can select more than one physical port by holding **CTRL** as you click.

5. Click **OK** to return to the **Virtual Adapters** window.

6. Click **OK** to save the virtual adapter and close the **Virtual Adapters** window.

   Changes to virtual adapters are not be saved until **OK** is clicked in the **Virtual Adapters** window.

   The virtual adapter appears in the list of available network adapters when creating a probe instance. This allows you to assign the virtual adapter to a specific probe instance, among other benefits.
Next, you should change the monitored network adapter of a probe instance to use the virtual adapter.

Use Netflow in Observer

Using the NetFlow features in Observer

Watch a video about NetFlow in Observer, and see a list of some important NetFlow considerations to know.

♦ Choose the right probe for you.
♦ Ensure your ToS/QoS is set for your network so that your statistics are correct.
♦ There are two different types of NetFlow collectors. Learn the differences and see how to create one.
♦ Capturing NetFlow statistics does have some limitations that are different from packet capture.
♦ Decoding a NetFlow flow. This section also details how you may need to configure your NetFlow device so that Observer can see the flows.
♦ Open a saved NetFlow capture.
♦ Most NetFlow information comes from Network Trending.

Creating a NetFlow collector or NetFlow Trending collector

There are two types of NetFlow collectors in Observer. Choose the correct one for your needs, or create two different probe instances—one for the NetFlow collector and another for the NetFlow Trending collector. The NetFlow Trending collector supports up to 50 NetFlow devices, whereas the NetFlow collector only supports one NetFlow device. That means you must add and configure a NetFlow collector for each NetFlow device in your environment.

<table>
<thead>
<tr>
<th>NetFlow Trending collector</th>
<th>NetFlow collector</th>
</tr>
</thead>
<tbody>
<tr>
<td>One flow per collector</td>
<td>X</td>
</tr>
<tr>
<td>Up to 50 flows per trending collector</td>
<td>X</td>
</tr>
</tbody>
</table>

Prerequisite: Expert Probe

Note: If you want to have scheduled collection of your NetFlow devices, use the settings on the Schedule tab.

NetFlow and sFlow collectors support the following versions of these technologies:

♦ NetFlow: 1, 5, 7, 9, and 10 (IPFIX)
♦ sFlow: 2, 4, and 5
<table>
<thead>
<tr>
<th><strong>Collects live statistics</strong></th>
<th>NetFlow Trending collector</th>
<th>NetFlow collector</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

| **Collects historical trending** | X | X |

1. Live statistics are details about the flow that appear in Observer in as few as five seconds.
2. Historical trending data collection interval can be as few as 60 seconds.

See [Creating a probe instance](page 262) for details about creating a NetFlow collector or a NetFlow Trending collector. In [Creating a probe instance](page 262) choose NetFlow collector or NetFlow Trending collector and follow the on-screen instructions. After the probe instance is created, there is no other configuration you must do and it is ready to use.

After the probe instance is created, you may want to configure the probe to tell it what type of traffic is seen.

1. On the Home tab, in the Probe group, click **Setup > Probe Properties.**
2. On the General tab, configure the Timing and Statistics Packet Sampling sections for your needs and Click **OK.**
3. On the Home tab, in the Capture group, click **Network Trending > Network Trending.**
4. Click the **Settings** button.
5. Configure any settings for Network Trending here.
6. Click **OK** to close the Network Trending Settings window.
7. Click the **Start** button to begin monitoring the NetFlow devices.
8. After you have collected some data, click the **Analysis** button. The View Network Trending data dialog opens.
9. Choose “Transfer and view current day statistics” and click **OK.** This opens the Network Trending Viewer in a new tab. In the Network Trending Viewer you can see for your NetFlow devices:
   - Station Activity Time
   - Top Talkers
   - Packet Size Distribution
   - Bandwidth Utilization
   - Protocols
Chapter 18: GigaStor Control Panel

The GigaStor Control Panel is the interface in Observer Analyzer that works specifically with your GigaStor.

**Getting started using your GigaStor**

A GigaStor probe is a hardware device with many terabytes of storage space to capture, store, and analyze your network traffic.

**Prerequisite(s):**

Follow these steps to get started with your GigaStor. The installation happens in two main parts. The first part is at the GigaStor probe in the server room. The second part continues at a desk using Observer Analyzer to connect to the GigaStor probe.

Before getting started with your GigaStor probe, these tasks should already be complete:

1. It has been decided where to install the GigaStor probe as discussed in [Deciding where to place probes in your network](#).
2. The GigaStor probe has been installed into a server rack. It is important to install the RAID drives into the correct slots. Ensure that monitoring interfaces are connected to the appropriate data feeds (SPAN or mirror ports, TAPs, aggregation devices). Ensure the configuration of these third-party devices is done properly so data flows to the GigaStor.

All GigaStor probes use the Expert Probe software. Learn more about the Expert Probe in [Using the Expert Probe software](#) (page 285).

To get the most out of your GigaStor, you need:

- A good working knowledge of your network. You can use Observer to gather information from your routing protocols and verify your network configurations, which is helpful when updating your network map.
To get started with your GigaStor probe:

1. By default the GigaStor probe’s name is a random mix of letters and numbers. Change the name of the GigaStor probe to something identifiable (such as the physical location or purpose).

2. Connect to the GigaStor probe from your Observer.

3. By default the active instance is called Instance 1 and there are no passive instances. Rename the active instance to something more meaningful (for instance, Active Instance) and create at least two passive instances. (You can create more passive instances later if you wish.) Although you renamed the GigaStor probe in step 1, renaming the probe instance is different. For details, see Creating a probe instance (page 263). Pay attention to the special instructions if your GigaStor array is larger than 256 TB.

4. Set the adapter speed for the active instance. See Configuring the probe’s adapter speed, ToS/QoS precedence, and statistics sampling (page 272).

5. To capture network traffic, you must have the GigaStor capture running. See Configuring probes to collect data even when not connected to an analyzer (page 314).

6. Using a passive probe instance, begin analyzing the traffic you are capturing. See Using the GigaStor Control Panel (page 306).

After you have collected data, you will want to see what is happening on your network.

- Mining data from your GigaStor (page 321).
- Reconstructing streams of HTTP, VoIP, and more (page 343).
- Examining your network traffic with forensic analysis (page 330).
- Analyzing FIX transactions (page 347).

Although not a complete list, these are common optional settings you may want to change. Use these options along with the rest of the information in Using the GigaStor Control Panel (page 306) to fine-tune your GigaStor.

7. (Optional) If you want to track physical ports individually, ensure you enable Track statistics information per physical port. See Setting the GigaStor general options.
Tip! All GigaStor probes come with a capture card. Details about this unique capture card, including physical port indexing or virtual adapters, is covered in.

8. (Optional) If you want to define the different subnets of your network so that GigaStor can track and report on them, see Defining your subnets in GigaStor (page 319).

9. (Optional) Your reports and displays may be more complete and readable if you add devices to the GigaStor probe’s address book and define any custom applications to the list maintained by the probe.

10. (Optional) The default settings for Observer is to be unaware of TCP connections that were opened after the GigaStor or packet capture started. You can change this default setting by doing the following:
    a. Mine some data from the GigaStor by following Analyzing data without any filters (page 326).
       This opens the Decode and Analysis tab.
    b. Ensure the Expert Analysis tab is selected, and click the Settings button at the top.
       The Expert Global Settings window appears.
    c. Click the TCP/IP tab and clear the Follow only newly opened TCP connections.
       (Optional) A newly opened TCP connection is any connection established after Expert Analysis was started. If the conversation started before Expert Analysis was started, Observer cannot see it.

By following the steps, you successfully configured the GigaStor probe to collect network traffic. You also made some configuration changes that help the GigaStor probe work well in your network. Also, you mined data from the GigaStor probe.

What is the GigaStor?

The GigaStor is a specialized probe appliance for capturing, storing, and analyzing high levels of network traffic over long periods of time.

It includes a high-performance RAID coupled with the capture card in a rack unit. The capture card allows you to capture a number of different full-duplex media by swapping standard SFP or SFP+ modules in and out. When Observer is connected to a GigaStor probe, the GigaStor Control Panel is enabled. The GigaStor Control Panel eases many tasks involved in capturing, storing, and retrieving massive amounts of network traffic.

Tip! Place the GigaStor in the cores of data centers. Locate near servers to capture their server-to-server traffic. The distribution layer is another optimal position for GigaStor.

By utilizing network TAPs, you can insert and remove the GigaStor around the network without disruption of flow. The GigaStor reports back to Observer Expert and Observer Suite analyzers for in-depth analysis.

If desired, GigaStor can be configured as a local console for on-site analysis.
Differences between GigaStor Software Edition and GigaStor

The GigaStor Software Edition (GSE) is identical in most ways to a hardware GigaStor purchased from VIAVI. However, there are differences that exist due to GSE naturally lacking GigaStor hardware components like the capture card and high-performance RAID card(s).

<table>
<thead>
<tr>
<th>Capability</th>
<th>GigaStor Software Edition</th>
<th>GigaStor as Appliance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mining &amp; Analysis Interface</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Packet Capture</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Real-Time Statistics</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Trending</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Triggers and Alarms</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Data-at-Rest Security</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Capture card</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Hardware Acceleration</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Hardware Filtering</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Packet Deduplication</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Physical Port Indexing</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Precision Time Stamping</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Virtual Adapters</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>High-performance RAID card</td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

Minimum and recommended system specifications

If you are installing the software on your own hardware or a virtual machine, these are the minimum and recommended specifications for a production environment.

Table 47. Observer Expert Console Only (ECO)

<table>
<thead>
<tr>
<th>Processor / CPU</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>RAM^1</td>
<td>2 GB RAM</td>
<td>8 GB RAM</td>
</tr>
<tr>
<td>Operating system^2</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
</tr>
<tr>
<td>Network Card</td>
<td>Server-class</td>
<td>Intel server-class</td>
</tr>
</tbody>
</table>

1. If your system has 4 GB of RAM, you cannot reserve any memory for Observer. This is a limitation of Windows known as the BIOS memory hole. Either add more RAM or take some out.
2. See Supported Operating Systems (page 19) for a full list of supported operating systems.
Table 48. Observer or GigaStor Software Edition in a virtual server

<table>
<thead>
<tr>
<th>Processor / CPU</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Four core</td>
<td>Six core Intel</td>
</tr>
<tr>
<td>RAM(^1)</td>
<td>Minimum 16 GB (8 GB for Observer and 8 GB for the operating system)</td>
<td>64 GB</td>
</tr>
<tr>
<td>Storage</td>
<td>Packet capture - Hardware: Determined by your product</td>
<td>Same</td>
</tr>
<tr>
<td></td>
<td>Packet capture - GigaStor Software Edition: Determined by your license.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Network trending: See How to determine disk space requirements for network trending (page 170).</td>
<td></td>
</tr>
<tr>
<td>Operating system(^2)</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
<td>64-bit Operating System Windows 7 to Windows Server 2012 R2</td>
</tr>
<tr>
<td>Network Card</td>
<td>Virtualized network adapter</td>
<td>Intel server-class</td>
</tr>
<tr>
<td>Capture Card(^3)</td>
<td>Virtualized network adapter</td>
<td>Server-class onboard network adapter</td>
</tr>
</tbody>
</table>

1. If your system has 4 GB of RAM, you cannot reserve any memory for Observer. This is a limitation of Windows known as the BIOS memory hole. Either add more RAM or take some out.
2. See Supported Operating Systems (page 19) for a full list of supported operating systems.
3. A second network card that acts solely as a capture card is required (and must be in “promiscuous mode”). Alternatively, a dual-port NIC can be used. For further details, see Capture card driver requirements (page 23).

Current compatibility and incompatibly of virtual machines with the GigaStor Software Edition (GSE) is described in this list:

- VMWare ESXi Server
  - ESXi 5.0 and higher is compatible with GSE.
- VMWare Workstation Pro is not supported with GSE
- Microsoft Hyper-V may function but is not supported with GSE

Storage limits of packet capture for GigaStor Software Edition (GSE)

The disk storage capacity usable for packet capture and of GigaStor Software Edition (GSE) is governed by your GSE license. This allows flexible cost options when considering the storage available to the computer, or virtual machine, that you are installing GSE on.

GSE licenses are available at these maximum storage sizes:

- 256 GB
- 1 TB
- 4 TB
- 16 TB
- 32 TB
- 48 TB
64 TB

*Maximum storage size* is a measure of how much network data (in the form of packets) can be retained by the GigaStor Software Edition before the oldest GigaStor data is removed in a first-in first-out (FIFO) storage scheme. The maximum storage size is not an indication of how much disk space the GigaStor Software Edition will consume on your hard disk. For example, the program files and libraries, storage of network trending data (not packets), and other executables are not governed by your GSE license and do not count towards the maximum storage capacity.

Network trending storage is a separate issue from packet capture storage and they are not connected in any way except both require writing data to the hard drive. When estimating file size, retention, and system maintenance, you may want to look at the system holistically and consider both simultaneously. Read more about network trending in Configuring your network trending settings (page 169).

**How to determine disk space requirements for network trending**

Because network trending can consume a lot of disk space, you need to know how much disk space to reserve.

Network trending data consumes hard disk space. Depending on where you store trending data (page 171) and your storage requirements for network trending data, the network trending data could fill that drive to full capacity—this is a problem. Therefore, determine your typical 24-hour data rate and how many days of trending data you want to retain. The result indicates how much storage space is required.

To determine the amount of space required to store your desired amount of trending data:

1. Determine your typical 24-hour data rate.
   
   **Example:** 15 MB or 20 GB.
   
   The *data rate* is amount of trending data collected in one 24-hour period.

2. Multiply your typical 24-hour data rate by the number of days you want to retain.
   
   **Example:** 15 MB x 365 days = 5.475 GB
   
   **Example:** 20 GB x 30 days = 600 GB

The result is the amount of hard drive space required to retain the trending data. You can use the numbers you calculated to inform your decisions when deleting network trending data (page 168).

**Using the GigaStor Control Panel**

This section covers the GigaStor Control Panel, its settings, and its use when you choose GigaStor from the Capture group in the Home tab.

**Note:** Packet decoding, Connection Dynamics, and analysis types like TCP, UDP, or VoIP Events are covered elsewhere.

After the GigaStor probe is up and running on the network, you can use an Observer to view captures from the probe. In the Observer you use a special
section of the analyzer called the GigaStor Control Panel. The major section of the GigaStor Control Panel are listed in Figure 80 (page 307).

Figure 80: GigaStor Detail and Outline Charts

The GigaStor Control Panel shows traffic on a time line graph, allowing you to select packets for decoding, analysis, and display by defining the time period you want to view, and the types of packets you want to include.

Use the sliders at the top of the time line chart to select the time period you are interested in analyzing, then click **Update Chart** and **Update Reports** to update everything to the new time frame. Right-click in the top chart to open additional controls.

Figure 81: GigaStor Control Panel Summary tab

If desired, you can further constrain the display of packets by MAC Stations, IP Stations, IP Pairs, etc., by clicking on the appropriate statistics tab and selecting the items you want to see on the **Detail Chart**.
Press the **Settings** button. Under **General Options**, clear **Enable Analysis types** for whichever analysis types you do not need. This will remove them from the **Reports/Statistics** ribbon.

Use the left/right arrow on the **Reports/Statistics** ribbon to move it to the right to see the Maximize button if needed. Clicking this button maximizes or minimizes the section. Now you can more easily work with and view reports and statistics for your selected time frame. You can filter or select a specific area of interest, such as HTTP. Press the **Analyze** button and choose **Filter Using Selected GigaStor Entries** to open **Expert Analysis** and decode tools focused on just your area of interest.

### Non-GigaStor-specific settings

The GigaStor Control Panel is a portion of Observer. Some settings in Observer affect the GigaStor.

Some things you may want to configure in Observer include:

- Discovering host names so that GigaStor resolves and uses host names. See the Discovery section in the Observer User Guide.
- Protocol definitions. This is particularly important if you have custom protocols you want to monitor. See the Discovery section in the Observer User Guide.
- TCP/UDP/Server applications. By defining specific applications Observer can provide more detailed reports to you. Observer has many applications already defined, but you can add more if you wish. See the Discovery section in the Observer User Guide.
- The default settings for Observer is to not be aware of TCP connections that were opened after the GigaStor or packet capture started. You can change this default setting.
- Mine some data from the GigaStor. See Analyzing data without any filters (page 326). This opens the **Decode and Analysis** tab.
- Ensure the Expert Analysis tab is selected, then click the **Settings** button at the top. The **Expert Global Settings** window opens.
- Click the **TCP/IP** tab and clear the **Follow only newly opened TCP connections** option. A newly opened TCP connection is any connection established after Expert Analysis was started. If the conversation started before Expert Analysis was started, Observer cannot see it.

### Setting the GigaStor general options

The **General Options** tab configures packet capture and buffer size; whether partial packets are captured; indexing of MAC, IP, VLANs; capture and analysis options; sampling; analysis types; and more.

This tab lets you configure many options for the GigaStor.

1. On the Home tab, in the Capture group, click **GigaStor**.
2. Click the **Settings** button.
3. Click **General Options**. See Table 49 (page 309) for a description of each field of the GigaStor **General Options** tab.
Figure 82: GigaStor General Options

- Packet capture and GigaStor buffer size—This only applies to the active probe instance.
- Partial packet capture size—This only applies to the active probe instance.
- GigaStor indexing options—You may need to adjust the indexing information based on your network.
- Capture and analysis options—What protocols are on your network? Are they all standard protocols, or do you have some custom or home grown protocols?
- Other general GigaStor Control Panel options.

Table 49. GigaStor configuration options

| Capture Buffer size | Only available if you are configuring an active GigaStor instance. Allows you to set the amount of Windows memory that Observer will set aside to store captured packets. Observer will show the buffer percentage full and give you an idea of what the best buffer size is for a particular situation. You will want to capture an event in as little time with as little buffer space as possible. Observer has no limitations on the amount of RAM that can be used for a buffer. On 64-bit systems, you are limited only by the amount of physical memory installed on the Observer PC. It is not recommended that you use Observer to view packets going to or coming from the Observer PC. If you need to look at the traffic to/from the Observer PC, install Observer on another system. |

Table 49. GigaStor configuration options

| Capture Buffer size | Only available if you are configuring an active GigaStor instance. Allows you to set the amount of Windows memory that Observer will set aside to store captured packets. Observer will show the buffer percentage full and give you an idea of what the best buffer size is for a particular situation. You will want to capture an event in as little time with as little buffer space as possible. Observer has no limitations on the amount of RAM that can be used for a buffer. On 64-bit systems, you are limited only by the amount of physical memory installed on the Observer PC. It is not recommended that you use Observer to view packets going to or coming from the Observer PC. If you need to look at the traffic to/from the Observer PC, install Observer on another system. |
PC. There are many reasons why this is not a good idea but, in general, you will see varying amounts of your own data with a protocol analyzer on your own PC. This is due to the architecture of the PC and the inability of Windows to multi-task the receiving and analysis of the data going and coming from the Observer PC.

<table>
<thead>
<tr>
<th>Capture Partial Packets</th>
<th>by default, Observer will capture the entire packet. This option allows you to define a specific amount of each packet to capture to the buffer. For example, a setting of 64 bytes will result in Observer only capturing the first 64 bytes of every packet. Most of the pertinent information about the packet (as opposed to the information contained in the packet) is at the beginning of the packet, so this option allows you to collect more packets for a specific buffer size by only collecting the first part of the packet. In some forensic situations, a warrant may only allow an officer/agent to collect, for example, email headers. Also, if the system is having trouble keeping up with bandwidth spikes, collecting partial packets can resolve the issue. To change the number of bytes captured in each packet, click <strong>Change Size</strong>. This setting affects all analyzers that connect to this probe. You cannot change this setting unless you have administrative privileges to do so.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Collect and Show GigaStor Indexing Information by</td>
<td>Choose whether to show or hide the following tabs in the GigaStor Control Panel: MAC Stations, IP Pairs, IP Addresses, TCP Applications, UDP Applications, VLANs, MPLS, Physical Ports, and Network Packet Broker (NPB) Port Tagging. These options are for controlling statistical display only. All packets that the GigaStor sees are written to disk and is available for analyzing using the <strong>Analyze</strong> button. The value configured in these boxes determine the maximum number of stations that are indexed by the GigaStor and shown in the GigaStor Control Panel. If you are limiting MAC stations to 1000 (the default), it is the first 1000 MAC stations the GigaStor sees—not the most recent 1000. The maximum allowable IP Addresses is 200,000 (the default is 1000). See Discovering current top talkers on the network (page 46) for tips on how to narrow your time slice.</td>
</tr>
<tr>
<td>Capture and Analysis Options</td>
<td><strong>Enable intelligent TCP protocol determination</strong>: Displays only known applications while hiding dynamic ports by using the TCP three-way handshake (SYN SYN+ACK ACK). Clearing this option shows all ports. <strong>Limit to ports defined in “Protocol Definitions”</strong>: Select this option to limit the ports shown to only those listed in the Protocol Definitions. See the Discovery section in the Observer User Guide. <strong>Track statistics information per physical port</strong>: When selected, causes the GigaStor to index the data it collects by capture card physical ports. You can then display GigaStor Control Panel statistics by physical port. If this option is selected, then you also may want to enable the “Use physical port selections...” option also on this tab. <strong>Collect counts for all IP protocols in addition to TCP and UDP</strong>: Select this option to collect counts for all IP protocols (such as ICMP, OSPF, Multicast, etc.) not just TCP and UDP. If this option is not selected, TCP and UDP counts are still collected.</td>
</tr>
</tbody>
</table>
### Enable Analysis Types:

Choose whether to enable the GigaStor Control Panel to process and display these types of data. By clearing these options, the corresponding tab is hidden in the GigaStor Control Panel and you cannot analyze packets for these data types:

- **Forensic Analysis (uses Snort rules)**
- **FIX Analysis**: used to process FIX financial transactions.
- **Microburst Analysis**: used to process data to identify microbursts on your network, typically a concern for network administrators in trading firms, but also other companies.
- **Trading Multicast Analysis**
- **IPTV Analysis**

### GigaStor Packet Sampling

Packet sampling applies to the GigaStor Control Panel statistical displays, not saved packets. On probes connected to highly-saturated networks (especially multi-port probes), sometimes it is desirable to adjust the rate of statistical indexing to conserve probe processing and storage resources. The default (and recommended) setting is for Observer to automatically scale back the packets it uses to update the analyzer display based on system load. Alternatively, you can specify a fixed sampling ratio to consider when updating the GigaStor Control Panel charts and statistical displays. A sampling ratio of 1 means every packet is analyzed, and a ratio of 10 means every 10 packets are analyzed. From a statistics perspective analyzing every 10 or even 100 packets will provide the trends you need without burdening the system by analyzing every packet.

For even more details, see Differences between statistics and packets (page 315).

### Use physical port selections...

You can choose this option to display statistics sorted by capture card physical port. This is useful when you want to troubleshoot the individual links without having to load the capture buffer by clicking **Analyze**.

If selected, you must also select the **Track statistics information per physical port** option in the **Capture and Analysis Options** section on this tab.

### Auto-update GigaStor chart...

When selected, causes the listed actions to have the same effect as clicking the **Update Chart/Statistics** buttons.

### Keep focus on GigaStor...

Keeps the focus in the GigaStor Control Panel instead of switching to the decode pane.

### Update display...in 30 second intervals

When selected all tables will update in 30 second intervals. This does not affect web-based reports, only the real-time displays in the analyzer.

### Display only defined subnets

When selected only defined subnets are displayed. The subnets must be defined on the **Subnet** tab. See Defining your subnets in GigaStor (page 319) for details about defining a subnet.

### Enable IP DNS resolution

Select this option to enable IP DNS resolution within the GigaStor. If you have several thousand hosts, you may wish to disable this option as it may take a long time to resolve names for reports.

### Enable packet time charting...

Because the charts can be configured to show sub-second intervals that means that some packets will cross the boundaries of your chosen intervals. This makes it hard to tell in the chart how long your scenario occurred. When enabled, this setting
You set the general options for your GigaStor system. These options have a large effect on the operation of the GigaStor system, so if anything seems wrong or you are not seeing all the packets you anticipated, return to these settings and see if they should be changed.

Shorten your time slice to find a top talker

The Top Talker list may appear to be missing entries. This occurs because of a combination of two settings in your GigaStor Control Panel. Temporarily adjust these settings to get the data you want.

If you are trying to find what system or systems are responsible for certain traffic on your network, you’d typically use Top Talkers to identify them. There is, however, a limit to the number of systems that Top Talkers identifies. By default, that limit is 1000. As soon as the 1000th system is identified in a time slice—chronologically—all remaining systems are ignored even if they were “chattier” (that is, causing more traffic on the network) than any of the first 1000 systems. In other words, the GigaStor Control Panel does not show the 1000 most talkative systems, but the first 1000 systems it encounters.

The solution is to shorten your time slice, perhaps down to milliseconds if necessary so that the Top Talker list does not reach the 1000 stations. Additionally, you can increase the number of IP Addresses allowed in the list up to a maximum of 200,000.

Also keep in mind that in the GigaStor Control Panel you are looking at statistics, not actual packet data. Therefore, you could set the GigaStor Control Panel sampling ratio to 1 and set the maximum number of entries allowed to a very high number (100,000 or even higher). This won’t give you 100% accurate data, but you will get a very good idea of the situation based on statistics.

Caution: If you change the maximum IP address or sampling ratio, consider changing its value back after you have identified your top talker. The reason is that both settings affect memory and can adversely affect performance if there is a high number of IP address and extremely low sampling ratio. Returning these values to their defaults (10,000 IP Addresses and a sampling ratio of 10) will restore GigaStor performance.

The GigaStor Control Panel indexing maximums and sampling ratio are configured in Setting the GigaStor general options.

Understanding GigaStor protocol and port settings

Allow the GigaStor to get smarter by collecting more information. Over time as the GigaStor sees more of your network’s traffic, it gets smarter about the traffic on your network.

Unless you have a specific reason to do so, we recommend that you leave these options selected:

**Enable intelligent TCP protocol determination**—when checked, all new data collected is indexed by protocol, only if SYN-SYNACK-ACK packets are observed
at the start of the conversation. If this combination is found, reports show this conversation by protocol name (or custom name), IANA name, or port number (based on statistics lists setting). Otherwise the conversation is not listed. If you try to analyze data prior to the time that this option was enabled, you will not see this data. Data must be collected with this option enabled for GigaStor reports to present the data correctly using the Update Reports button. By clearing this option, you ensure you get all protocol information regardless of SYN-SYNACK-ACK packets.

Limit to ports defined in “Protocol Definitions”—limits the displayed data to the ports specifically defined in the Options > Protocol Definitions dialog. Again, this is written to the internal GigaStor index. This option only shows custom protocols defined on new data collected after a protocol port has been defined. You must also choose Apply Protocol to all Instances to ensure this data is shown on all instances used for analysis. By clearing this setting, all ports are used.

If you want to track statistical information for each port on your capture card, then you should ensure Track statistics information per physical port option is selected.

For even more information about what these settings affect, see Differences between statistics and packets (page 315) and Understanding GigaStor indexing (page 316).

Capturing packets with the GigaStor

The GigaStor allows packet captures to be scheduled, trimmed (partial packet captures), and all its data can be exported for archiving. Also learn about GigaStor indexing and the difference between statistics and packets.

A GigaStor can accumulate terabytes of stored network traffic. To manage the sheer volume of data, the GigaStor probe indexes the data. You use the GigaStor Control Panel within Observer to manage the capture, indexing, and storage of large numbers of packets over long periods of time. While the GigaStor Control Panel is active, standard packet captures are unavailable for that probe instance. You cannot run the two types of captures simultaneously.

While actively capturing packets, the GigaStor Control Panel tracks network statistics and indexes them by time as it saves the packets to disk. This allows you to quickly scan the traffic for interesting activity and create filters to focus on specific traffic using the slider controls and constraint options.

The GigaStor Control Panel also automates storage management by deleting the oldest data before storage runs out. This maintains a multi-terabyte "sliding windows" of time within which you can review and decode traffic. It also allows for passive (in other words, virtual) probe instances, which allow users to have their own instances (and security credentials) without duplicating data collection or storage.

You can view the sliding window as a time line chart. Depending on what constraint are in effect and your display options determine what appears on the chart. By using time selection sliders and other options, you can quickly acquire and analyze the packets by clicking the Analyze button. This opens the standard packet decode and analysis window. From there you can view packets, save them, and perform further filtering if desired.
Setting a schedule for when data captures should occur

One way to ensure you always have timely packet captures is to schedule them. For example, you may want to automatically start a packet capture at the beginning of business hours each day; you can accomplish this by scheduling your packet captures accordingly.

To schedule packet captures to begin at preset times, complete the following steps:

1. On the Home tab, in the Capture group, click GigaStor.
2. Click the Settings button.
   The GigaStor Settings window appears.
3. Click the Schedule tab.
4. Select one of the following scheduling types. For the GigaStor active instance you should choose Always unless you have a specific reason to choose a different option.
   • No scheduling—captures are never scheduled
   • Always—capture runs at all times
   • Daily at specified times—capture runs at same time each day
   You must specify a capture begin and end time by clicking the Add button for each day you select. Multiple time intervals are configurable, per day, if the times do not conflict.
5. In the Reserve scheduling for section, select GigaStor and click OK.
   You may receive a notice about scheduling reservation. If you do, click Yes to change the scheduling.
6. Click OK to confirm and save your changes

Trimming data from your captures for space or privacy

Typically, packet headers contain the most useful information because they contain routing information and protocol information. The packet payload counterpart, however, is sometimes wasteful to collect because most troubleshooting is done just with the header and the payload may contain sensitive information.

Under these circumstances, you may want to truncate most payload data from the packet header(s). In Observer, the result is a partial packet capture.

Some benefits of partial packet captures include:

♦ Smaller capture sizes
  • More overall storage space for packet captures
  • Greatly increases the effective storage size of a GigaStor (or other capture buffer)
♦ Performance metrics remain intact
♦ Increased overall privacy
♦ Least resource intensive capturing
Some disadvantages of partial packet captures include:

- Not all network traffic is stored to disk
  - Forensics may be hindered without full payload data
  - Data stream reconstruction may not work
- Most resource intensive capturing
  - Increases CPU utilization

To configure the GigaStor probe to trim all packet data beyond the first 64-bytes, choose Live > Packet Capture and then Settings > Capture Options. In that tab, enable Capture Partial Packets (Bytes).

1. On the Home tab, in the Capture group, click GigaStor.
2. Click the Settings button.
3. Click the General Options tab. See Setting the GigaStor general options for a description of each field.
4. Enable the Capture partial packets option and choose how many bytes to include in the capture. The rest of the packet beyond what you define is excluded and is not saved to disk.

It is possible to decrease or increase the default 64-byte partial packet capture size. Click the Change Size button to set a custom value. From then on, each packets' bytes following the target value are discarded from capture.

**Password protecting the ability to change partial packet capture size**

Password protecting this option helps ensure your partial captures remain partial, saving you disk space and enhancing data subject privacy because payload is not recorded in full.

In Observer, to password protect the ability to change partial packet capture size:

- Click the File tab, and click Options > General Options.
- Click the Security tab, and enable Require a Password to Change Partial Packet Capture Size.

**Differences between statistics and packets**

Observer uses packets and statistics about your traffic to provide you with information about your network. This topic describes why each is useful and why there may appear to be discrepancies between a statistical view and the actual packets.

At times you may notice what appears to be a discrepancy between what you see in the GigaStor Control Panel and what you see when you are analyzing packets in a selected time frame. The difference stems from the fact that the GigaStor Control Panel displays statistics based on a sample of the packets seen, but when you are analyzing a specific time frame you are viewing all of the actual packets.

The GigaStor uses samples for a couple of reasons. First, it is more efficient to sample large sets of data rather than to process each data point individually. Network traffic is ideally suited for statistical sampling. Second, statistics serve
a different role than actual packets. Statistics are intended to give you an indication of what is happening with your network. If the statistics indicate you may have an issue, then you can use the actual packets saved in your GigaStor to further analyze the traffic.

By default the GigaStor uses a dynamic sampling ratio for statistics. This can be changed in the GigaStor Control Panel > Settings > General tab to a fixed sampling ratio of 1, 100, or whatever you wish.

Using dynamic sampling allows the GigaStor to make decisions about how sampling for statistics should be accomplished. The GigaStor makes its decisions based on the amount of memory available in the statistics queue buffer and the amount of packets coming into the capture card. All statistical processing is handled in the statistics queue buffer (stored in RAM) and the size of this buffer is very significant for probe instances providing statistics information.

If you set GigaStor Packet Sampling to a fixed sampling ratio, the GigaStor collects its statistics based on your sampling ratio regardless of available system resources and traffic to the capture card. If, for example, you have the ratio set to 1, you are telling the GigaStor to sample every single packet that it sees. This has a potential negative side effect—especially in very high traffic conditions—because there could be a significant impact on the GigaStor’s processing resources (either write-to-disk or read-from-disk), thereby slowing other processes active at the same time. The potential advantage is that your statistics will more closely resemble what you see in actual packet analysis, but may not exactly match it.

There are millions and millions of packets traversing your network. Over a long enough time frame the statistics are going to be equally valid if you sample every 10 or 100 or 1000 packets rather than every single packet. Again, statistics sampling does not prevent you from clicking the Analyze button to view the actual packets the GigaStor captured with no sampling at all.

This explains why you might see more stations in Top Talkers within Decode and Analysis than in IP pairs on the GigaStor Control Panel. Usually, the risk of packet loss significantly outweighs any discrepancy between the statistics in the GigaStor Control Panel and the actual packets it captured.

**Understanding GigaStor indexing**

This section describes how the GigaStor captures packets and indexes them for statistics.

Indexing is an important part of how the GigaStor is able to be as efficient as it is. A brief synopsis of indexing in the GigaStor is this:

- All captured packets are written to disk. None of the settings in the GigaStor Control Panel control what is written to disk in any way.
- Indexing is not used for packet capture. It is only for statistics.
- GigaStor Control Panel > Settings > Capture and Analysis options tells the GigaStor which packets to index for statistics.
- GigaStor Control Panel > Settings > Collect and Show GigaStor Indexing Information by tells GigaStor how many entries it can use every 15 seconds. After the maximum number of entries for a 15 second period is reached, new data that was not already being indexed is not indexed for that 15 second period; however, packets that were already being indexed continue to be indexed during that 15 second period.
• Every 15 seconds the GigaStor writes all indexed data for 15 second interval that was just indexed. The indexed data is cleared from memory and indexing of the next 15 seconds begins.

• Previously indexed data has no effect on any other 15 second interval, except for the need to see the SYN-SYN/ACK-ACK to begin collecting “new” server data. This means that if in one 15 second period the maximum number of entries was reached and a new conversation is started that continues into the next 15 second interval, there is nothing that prevents the subsequent 15 second interval from beginning to index the new conversation that was not indexed in the previous 15 second interval.

• When GigaStor Control Panel > Settings > Enable Intelligent TCP protocol determination is enabled, a SYN-SYN/ACK-ACK is required. After the GigaStor sees a SYN-SYN/ACK-ACK for a server, it no longer needs to see the SYN-SYN/ACK-ACK to collect data from that server on the port that it saw the SYN-SYN/ACK-ACK. If for any reason the GigaStor probe is not running, it needs to see the SYN-SYN/ACK-ACK to index data. If GigaStor Control Panel > Settings > Enable Intelligent TCP protocol determination is unchecked, the GigaStor does not need to see the SYN-SYN/ACK-ACK to ever index data.

For more details about indexing in the GigaStor continue reading the rest of this section.

Every 15 seconds the GigaStor writes indexed, statistical data into a GigaStor.ometa file on the D: drive. It contains only statistical (indexed) information “collected” by the GigaStor. This file and the statistics it contains have no relationship to what packets are written to disk. When the capture card sees any packet, it is immediately timestamped and passed to the GigaStor buffer. The GigaStor writes all packet data to disk regardless of whether a packet is indexed.

Also on the D:\ drive are a number of .odat files. These files contain the actual packets that are written to disk and used for analyzing.

The GigaStor does not index every single packet. There are a number of factors that result in a packet not being indexed. Anything you see in the GigaStor Control Panel should be used for reference, not as absolute numbers. For absolute numbers, you must analyze the packets and view them in the Decode pane.

At the beginning of each 15 second period (the 15 seconds is not based on the system time clock period, but on timestamps from the captured packets) the GigaStor takes all of the indexed data that it has and writes it into the GigaStor.ometa file. The GigaStor then clears out the statistical memory that was used for indexing during the 15 second collection period and begins analyzing the next 15 seconds for statistical data. After a packet has been analyzed, it is written to disk. If for some reason a packet is skipped, it is written to disk before the next packet is analyzed.

Again, not every packet is indexed. This does not mean that if a packet is not indexed, that it is not written to disk. The GigaStor writes every packet to disk, even if it is not indexed. If there are 1,000,000 packets that come in during a 15 second period, and the GigaStor only analyzes 85,000, it will still writes 1,000,000 packets to the hard drive.
If the Screen Resolution in the GigaStor Control Panel is set to less than 15 seconds, the GigaStor does not use the index file (GigaStor.ometa) to see what was indexed because the time frame is smaller than 15 seconds. Instead it reads the data that is written to disk in the .odat file to produce the reports and not the indexed data.

The indexed, statistical information that comes from the indexed data is not 100% accurate when compared to packet capture. More importantly, it is not intended to be. It is, however, statistically accurate.

When the GigaStor attempts to analyze a packet to index, it does not analyze the packet if the packet is being analyzed by a different portion within Observer, such as Network Trending. Network Trending analyzes data for its own purpose. If a packet is being analyzed by Network Trending at the time the GigaStor wants to analyze the packet, the GigaStor skips the packet and goes to the next packet. The packet is written to disk, it is just not indexed.

After 15 seconds, the GigaStor starts over, so everything is cleared out and it all starts from zero entries per index data table, but the GigaStor does keep track of which devices it classified as servers. For instance, if in one 15 second period, the GigaStor sees a SYN-i-SYN/ACK-ACK and determines that port 8080 on 10.0.0.1 is a server, in the next 15 second period, the GigaStor does not require a SYN-SYN/ACK-ACK to know that port 8080 on 10.0.0.1 is a server. It already knows and continues indexing any 10.0.0.1 8080 as the server. The indexing of server 10.0.0.1 on port 8080 requires that either you establish 8080 as a known protocol or you have disabled the GigaStor Control Panel > Settings > Intelligent TCP Determination option. However, depending on which options are enabled and disabled, the GigaStor may completely ignore 10.0.0.1 on 8080 from being indexed.

Exporting GigaStor data for archiving

You can export your GigaStor-collected data on a scheduled basis. This can be done for archival or backup purposes.

Use the Export tab to configure when and to where your data is saved or to manually export your data. You can manually export your GigaStor data in several file formats or you can schedule Observer to export the data.

Part of what makes the GigaStor searches so quick is that the data is indexed. Any data that is exported to a file is saved, but unindexed. The data remains in the indexed GigaStor file until it is overwritten. The exported data is always available and means you will still have access to the saved packet data, but you must load the capture file into the analyzer before you can search it. Having a good naming convention can help you find your files later.

**Note:** This process should be completed on the GigaStor probe itself by having the software running in Observer mode rather than Expert Probe. See Switching between the probe and analyzer user interfaces (page 286). This may require that you use Remote Desktop to access the system.

1. Redirect the probe instance to the local analyzer if it is not already connected to it.
2. On the Home tab, in the Capture group, click **GigaStor**.
3. Click the **Settings** button to open **GigaStor Settings**.
4. Click the Export tab.
5. Choose how you want to export the data and in which format (BFR, PCAP, or CAP).
6. (Optional) Choose to schedule the export so that it can happen automatically.
7. If you want to export data from specific time ranges only, or just export the data on an “as needed” basis, click Manual Export.
8. (Optional) Choose if you want to have Observer write a progress status every 30 seconds to the Log window.
9. Click OK.

**Configuring your GigaStor**

Learn how to configure packet capture and buffer sizes, define subnets, and change the storage directory where packets and other data is stored.

**Defining your subnets in GigaStor**

You can specify subnet properties for the GigaStor to allow for statistical aggregation of devices within the Statistics tabs in GigaStor Control Panel.

1. On the Home tab, in the Capture group, click GigaStor.
2. Click the Settings button.
3. Click the Subnet tab.
4. Use the Add, Delete, Modify, Import, and Delete All buttons to configure the subnet settings for the GigaStor. When you define subnets in the GigaStor Control Panel, Observer adds that subnet information to its index files. All future data analyzed will have subnet filtering readily available as well as statistical data. On the IP Stations tab you see your subnets and you can perform statistical analysis based on subnets.

When you analyze data from captures with index files without any subnets defined, there will be no subnet available in the IP stations tab even if the analyzed data includes some index files with the new subnet information.

**Tip!** You can import subnet ranges using an ipsubnetrange file. See Structure of an .ipsubnetrange file (page 172).

**Tracking individual analysis ports**

When using the capture card in your GigaStor, you can track statistical information per physical port.

Data captured by the capture card is indexed to show on which port the data arrived. You can further choose to use physical ports to filter statistics. This means that information on the Statistics tab at the bottom of the GigaStor Control Panel is dependent on which physical ports are selected.

1. On the Home tab, in the Capture group, click GigaStor.
2. Click the Settings button.
3. Click the **General Options** tab.  
   See Setting the GigaStor general options for a description of each field of the GigaStor General Options tab.

4. Enable these two options:
   - Track statistics information per physical port
   - Use physical port selections to filter statistics

### Configuring the packet capture and GigaStor buffer size

Allows you to set the amount of RAM that Observer will dedicate to the capture buffer cache for this instance. This configuration value has been pre-set for optimum performance given a single active GigaStor monitoring instance. The default settings allows enough memory to set up a number of passive GigaStor instances.

If you wish to run multiple active monitoring instances to watch multiple links or networks, you can decrease the capture buffer size dedicated to GigaStor collection, which frees some memory for creating other probe collection instances. Inadequate memory allocation to GigaStor collection can affect performance and result in dropped packets during high load periods.

A GigaStor Instance can be as large as the physical memory installed on your system after subtracting the memory dedicated to Windows and other probe instances.

To change the allocation for this probe instance, click the **Configure** button, which will display the probe instance, Memory and Security Administration dialog.

In all cases, the actual buffer size (Max Buffer Size) is also reduced by 7% for memory management purposes. Should you try to exceed the Max Buffer Size an error dialog will be displayed indicating the minimum and maximum buffer size for your Observer (or probe) buffer.

### How to change the GigaStor storage directory or drive

You can change the directory where packets collected by your GigaStor are stored. However, if you are using a GigaStor hardware appliance, this should always remain set to **D:\DATA**.

This can also be performed on any Observer and is not limited to the GigaStor.

Some reasons for changing the GigaStor storage directory include:

- You are using the GigaStor Software Edition and need to store packets somewhere else than the C:\ drive.
- You regularly schedule packet captures, so you want those captures to be saved in a specific location.
- You need to store packet captures on a higher capacity hard disk.

To change the directory where collected packets are stored:

1. Click the File tab, and click **Options > General Options**.
2. Click the **Folders** tab.
3. Change the directory used for packet captures.
Caution: If you are using a GigaStor hardware appliance, this should always remain set to D:\DATA.

Configuring options for the GigaStor charts, graphs, and reports

When updating charts and reports, keep in mind that the GigaStor Control Panel uses statistics, not packets.

The indexing maximums and sampling ratio for statistics are configured in Setting the GigaStor general options and affect what appears on the charts and reports.

Statistics Lists tab

Observer tracks and makes many statistics available to you. You can control how those statistics are displayed for your GigaStor. This tab lets you customize how MAC address, IP address, IP Pair, and port information are displayed in the various constraint tab statistical listings.

1. On the Home tab, in the Capture group, click GigaStor.
2. Click the Settings button.
3. Click the Statistics Lists tab.
4. Choose how you want the statistics to be displayed.

Mining data from your GigaStor

Retrieving data from GigaStor and analyzing it is a primary function of the GigaStor Control Panel. You can use the information in the packet capture to identify numerous network conditions. By using filters and a specific analysis type, you can hone in on the exact information you want.

You have different options when you want to analyze captured data. You can analyze the data:

♦ Without any filters.
♦ With filters from the Observer filter editor.
♦ With filters from the GigaStor Control Panel.
♦ By combining filters from the GigaStor Control Panel and the Observer filter editor.

Note: All packets captured by the probe are time stamped immediately as it is seen by the capture card interface and then passed to the capture buffer. This ensures the most accurate timestamp.

Table 50 (page 322) describes the different options available on the GigaStor Analysis Options screen that appears when you click the Analyze button on the GigaStor Control Panel.
<table>
<thead>
<tr>
<th>This option:</th>
<th>Allow you to do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Analysis Time Range</strong></td>
<td>Shows the start and end time of the time range you selected in the Detail Chart. You can change the time here if you wish.</td>
</tr>
<tr>
<td><strong>Analysis Options</strong></td>
<td></td>
</tr>
<tr>
<td>Analyze all data (no filtering)</td>
<td>Takes all packets in the selected time frame on the Detail Chart and analyzes it using the analysis type chosen at the bottom of the screen, but without using any filter. See Analyzing data without any filters (page 326).</td>
</tr>
<tr>
<td>Select an existing filter</td>
<td>Takes all packets in the selected time frame on the Detail Chart and analyzes it using the analysis type chosen at the bottom of the screen and applies the filter you select (after clicking OK). See Analyzing data with filters from the Observer filter editor (page 326).</td>
</tr>
<tr>
<td>Filter using selected GigaStor entries</td>
<td>Takes all packets in the selected time frame on the Detail Chart and creates a one-time use filter for you using the options you chose from the Mac Stations, IP Stations, IP Pairs or any of the other tabs in the GigaStor Control Panel. See Analyzing data by combining GigaStor Control Panel and Observer filters (page 328).</td>
</tr>
<tr>
<td>VoIP and Videoconferencing calls by SIP tag</td>
<td>Takes all of the packets in the selected time frame on the Detail Chart and allows you to extract VoIP and videoconferencing calls based on a SIP tag. For further details about the Settings, see How to extract VoIP and video calls from your GigaStor (page 178).</td>
</tr>
<tr>
<td>Reorder and filter based on trailer timestamp</td>
<td>Some switch aggregators add their own timestamp to packets and can cause packets to have a different order than they were actually seen by the GigaStor. If selected, Observer reorders and filters packets based on the timestamp information from the switch aggregator you chose from the list instead of from the GigaStor. See How to reorder packets based on a trailer timestamp (page 324).</td>
</tr>
<tr>
<td>Include Expert information in analysis filter</td>
<td>Expert Information packets provide context of network conditions during the time that the traffic was captured. The expert frames may provide you insight into what was happening that may have influenced a condition within a packet capture you are analyzing.</td>
</tr>
<tr>
<td>Display selected filter before starting analysis</td>
<td>Allows you to view the filter before Observer begins analyzing the packet capture. For example, you might choose this option if you have already used the filter and the output is has excluded traffic you were expecting. By displaying the filter, you can inspect it to see why it may excluding the traffic.</td>
</tr>
<tr>
<td><strong>Analysis Type</strong></td>
<td></td>
</tr>
<tr>
<td>Expert analysis and decode</td>
<td>Along with the packet decode, this provides Observer’s advanced expert analysis, such as protocol analysis, top talkers, Internet Observer, Application Transaction Analysis, VLAN information, and Forensic Analysis using Snort. Use this option if you want to deep dive into the packets with ability to view common services and applications, response performance by severity, port-based protocols with slow response, network and application problems with local traffic and WAN/Internet traffic distinction, and more.</td>
</tr>
<tr>
<td>This option:</td>
<td>Allow you to do this:</td>
</tr>
<tr>
<td>------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Decode without expert analysis</td>
<td>Provides a packet decode without any of the insight of expert features listed above.</td>
</tr>
<tr>
<td>FIX analysis</td>
<td>Used in conjunction with a FIX analysis profile, the results are displayed on the FIX Analysis tab in the GigaStor Control Panel. See Analyzing FIX transactions (page 347). Use this option if you need to see the raw FIX protocol packets and headers, highlight just the FIX data, filter a trade by order ID for further analysis, or to validate a specific transaction.</td>
</tr>
<tr>
<td>Forensic analysis</td>
<td>Allows you to choose a profile where you have defined which Snort rules you want to use. The results are displayed on the Forensic Analysis tab in the GigaStor Control Panel. If you chose &quot;Expert analysis and decode&quot; and decided you also wanted to do forensic analysis, you could do that by clicking the Forensic Analysis tab, which prompts you for a profile. Use this option if you need to scan high-volume packet captures for intrusion signatures and other traffic patterns that can be specified using the familiar Snort rule syntax. You can enforce your &quot;acceptable use&quot; policies, fight industrial espionage, and assist with government regulations like Sarbanes Oxley or HIPPA requirements. Using network forensics you can provide pre-intrusion tracking and identification while delivering a paper trail after any intrusion. Or you can perform network troubleshooting using root-cause analysis and identify network problems that have been around awhile. See Examining your network traffic with forensic analysis (page 330).</td>
</tr>
<tr>
<td>Microburst analysis</td>
<td>Analyzes the selected time frame for any microbursts (as defined in the Microburst Analysis Settings dialog) and displays the results in the Microburst Analysis tab of the GigaStor Control Panel. This is an easier way to find microbursts across a much longer time frame than using the Detail Chart where the longest time frame that can be analyzed is 15 minutes. Use this option if you need to monitor applications that are sensitive to microbursts, such as financial, audio, video, or multicast applications. See Searching for microbursts (page 338).</td>
</tr>
<tr>
<td>Trading Multicast analysis</td>
<td>Analyzes the selected time frame for trading multicast streams issues on your network specifically related to stock exchanges. The streams can be analyzed for tracking UDP sequence numbers, multiple protocol data units (PDUs) within a UDP packet, and stream type or ID. Use this option if you want to analyze any of the Trading Multicast streams Observer supports.</td>
</tr>
<tr>
<td>IPTV analysis</td>
<td>Analyzes the selected time frame for IPTV traffic on your network. IPTV is configured by providing the multicast stream IP (or range of IPs) and, optionally, the UDP ports used to transport the content, along with the receive capabilities of the devices consuming the IPTV feeds. These settings allow Observer to identify IPTV traffic of interest (the IP and UDP ports) and to accurately calculate metrics about the quality of the feed for the endpoints, such as MDI, by providing the Delay Factor and Media Loss Rate information.</td>
</tr>
<tr>
<td>Multiple GigaStor analysis</td>
<td>Combines and analyzes data streams from two or more active probe instances. The active probe instances are typically from multiple GigaStor probes, but can also be from the same GigaStor probe. Use this option if your GigaStor probes captured the same data from two or more perspectives and you want to compare them using MultiHop Analysis. The MultiHop Analysis</td>
</tr>
<tr>
<td>This option:</td>
<td>Allow you to do this:</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------</td>
</tr>
<tr>
<td></td>
<td>can be based on IP, IP Pair, IP port, or a filter. Or use it when two or more perspectives are capturing different parts of the same communication (one send and the other receive; or 50% of the connections to an application on one and 50% on the other) and you want to combine the data to get a complete picture of the communication. This might be due to the way traffic was routed (and eventually captured) or part of an architectural decision to load balance the traffic across multiple physical capture appliances.</td>
</tr>
<tr>
<td>Third Party Decoder</td>
<td>Observer allows you to use other software to view packet decodes if you wish. You might do this because the other tool’s interface or workflow. This option is only available if the Third Party Decoder option has already been enabled in Options &gt; General Options and click the Third Party Decoder tab. By default the menu text is “Decode Capture File using Wireshark,” but is completely configurable. See Third Party Decoder tab (page 34) for details on how to change the menu text and what application is used.</td>
</tr>
<tr>
<td>Remember Analysis Options and Type</td>
<td>The selected the last analysis options are used for any subsequent analysis. This is useful if you typically use the same analysis options repeatedly.</td>
</tr>
</tbody>
</table>

**Selecting a time frame to analyze**

The GigaStor Control Panel has two graphs along the top: a Detail Chart and below it a Outline Chart. The Detail chart shows a shorter time frame. The Outline Chart shows a longer time frame with the Detail Chart being a portion of time from within Outline Chart.

You can configure the resolution of Detail Charts by clicking the “Screen resolution” option and using the slider to pick a time resolution. It can be anything from 8 hours/8 weeks so that you can see longer term trends to as short as 10 nanoseconds/500 nanoseconds to focus on specific issues. At the shorter time resolutions you can enable microburst analysis. The “Data type” list specifies what type of data appears in the Detail Chart.

You can configure the amount of time shown on the Outline Chart by right-clicking it and choosing “Outline Time Resolution.” It is measured in multiples of the Detail Chart. You may also choose to show packets or load in the chart.

**Tip!** If you know the time when something occurred that you want to investigate, you can jump to that time by right-clicking the Detail Chart and choosing Go to Specific Time.

**How to reorder packets based on a trailer timestamp**

You can change how Observer filters and sorts packets in the Decode pane based on a timestamp from your switch aggregator rather when GigaStor saw the packets.

Reordering packets is limited to post capture analysis only; it does not affect real-time analysis, triggers and alarms, or trending analysis. If you save a packet capture after it has been reordered using this option, the packets are saved in the...
reordered series. If you load a saved, reordered packet capture, then analysis is based on the reordered time frames and not the time stamps from the GigaStor.

1. In the GigaStor Control Panel, select the time range of traffic you want to decode and click **Analyze**.

   **GigaStor Analysis Options** opens with the start and end time selected.

2. Select a filter type.

3. Select **Reorder and filter based on trailer timestamp** and click Settings.

   **Trailer Timestamp Settings** opens.

   Figure 83: Trailer Timestamp Settings

4. In Timestamp type, choose your switch aggregator.

   **Timestamp types (page 325)**

5. Choose what filters to apply.

   **Trailer filters (page 326)**

   The Decode pane displays packets in the sorted (and filtered) order based on your chosen switch aggregator.

**Timestamp types**

The Timestamp types provides a list of the supported switch aggregators that can be used to reorder packets before they are shown in the Decode pane.

<table>
<thead>
<tr>
<th>Switch Aggregator</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arista</td>
<td>Keyframes are used to correlate packets to a physical port group. For instance, any keyframe seen on port 1 associates packets with that keyframe only with port 1. Likewise, a keyframe seen on port 2 associates the packets only to port 2, and so on. A keyframe is unique to a physical port group.</td>
</tr>
<tr>
<td>cPacket</td>
<td></td>
</tr>
<tr>
<td>Gigamon</td>
<td></td>
</tr>
<tr>
<td>GigaNova</td>
<td></td>
</tr>
<tr>
<td>Gigamon SMART</td>
<td></td>
</tr>
<tr>
<td>Gigamon H-Series</td>
<td></td>
</tr>
</tbody>
</table>

**Timestamping on the Arista 7150 Series**
**Switch Aggregator**

<table>
<thead>
<tr>
<th>Switch Aggregator</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>IXIA Anue</td>
<td></td>
</tr>
<tr>
<td>NetScaler</td>
<td></td>
</tr>
<tr>
<td>Network Instruments</td>
<td>Choose if you use Observer Matrix.</td>
</tr>
<tr>
<td>PacketPortal PDG</td>
<td></td>
</tr>
<tr>
<td>VSS Monitoring</td>
<td></td>
</tr>
<tr>
<td>VSS Monitoring w/ Port</td>
<td>VSS Monitoring with Port Stamping. VSS Monitoring’s Port and Time Stamping Feature</td>
</tr>
</tbody>
</table>

**Trailer filters**

Trailer filters allow you to exclude or include packets from your switch aggregator based on where the trailer occurs and other location-specific information.

<table>
<thead>
<tr>
<th>Trailer level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trailer level</td>
<td>Use when multiple timestamps are found in a packet to identify which timestamp to use. The levels are identified starting at the end of the packet.</td>
</tr>
<tr>
<td>Group ID</td>
<td>The port group ID from Matrix. You can find this ID on the Matrix in <strong>System &gt; General &gt; Trailer Configuration</strong>.</td>
</tr>
<tr>
<td>Box ID</td>
<td>The port box ID from Matrix. You can find this ID on the Matrix in <strong>System &gt; General &gt; Trailer Configuration</strong>.</td>
</tr>
<tr>
<td>Port</td>
<td>The ingress port on the switch aggregator where the packet was seen.</td>
</tr>
<tr>
<td>Probe ID(s)</td>
<td>A comma separated list of hexadecimal characters from a PacketPortal IV SFProbe or JMEP. Use PacketPortal System Manager (IV SFProbe) or the SFP Programmer GUI (JMEP) to view a list of probe IDs. A sample probe ID: 5e65eb52f633.</td>
</tr>
</tbody>
</table>

**Analyzing data without any filters**

1. Select a time frame you want to analyze. See Selecting a time frame to analyze (page 324).
2. Click the **Update Reports** button to get the latest data from the time frame selected. This is unnecessary if you have “Auto-update GigaStor chart on statistics tab or selection change” in the GigaStor Settings. See Setting the GigaStor general options.
3. Click the **Analyze** button. The GigaStor Analysis Options window opens.
4. Select “Analyze all traffic in the analysis interval” and click **OK**.

Your unfiltered data appears in a new “Decode and Analysis” tab.

**Analyzing data with filters from the Observer filter editor**

1. Select a time frame you want to analyze. See Selecting a time frame to analyze (page 324).
2. Click the **Update Reports** button to get the latest data from the time frame selected. This is unnecessary if you have “Auto-update GigaStor chart on statistics tab or selection change” in the GigaStor Settings. See Setting the GigaStor general options.
statistics tab or selection change” in the GigaStor Settings. See Setting the GigaStor general options.

3. Click the Analyze button. The GigaStor Analysis Options window opens.


5. Choose one or more filters that you want to use and click OK.

Your filtered data appears in a new “Decode and Analysis” tab.

**Analyzing data with filters from the GigaStor Control Panel**

You may want to filter the data that is shown on the Detail Graph. You can do so with the filters section of the GigaStor Control Panel. You can filter data from MAC Stations tab, IP Stations tab, IP Pairs tab, and more.

One example where you might use this is if you have strange traffic (perhaps a virus) on your network that you want to identify or isolate. By selecting a station from IP Stations tab and an application from the TCP Applications tab, you can select the “Combine tabs for detailed chart pre-filter” to generate a specific report. Using this report you can understand the general pattern of activity of the strange traffic so that you can conduct further analysis using packet decodes.

**Note:** If you are using the Ethernet Physical Port filter in conjunction with other filters, in the GigaStor Control Panel > Settings > General Options tab, you must enable the “Use physical port selections to filter statistics” option otherwise the combined filter will not work as you expect.

1. Select a time frame you want to analyze. See Selecting a time frame to analyze (page 324).

2. Click the Update Reports button to get the latest data from the time frame selected. This is unnecessary if you have “Auto-update GigaStor chart on statistics tab or selection change” in the GigaStor Settings. See Setting the GigaStor general options.

3. Click the IP Stations tab (or any statistics tab to the right of the Summary tab).

4. Select one or more stations. This creates and opens a GigaStor Control Panel filter.

**Figure 84: GigaStor Control Panel filter**
5. Click other tabs and choose what entries you want to add to your filter, such as an application from the TCP Applications tab. When selecting options from different tabs a filter is built, and it uses a logical AND to build it.

6. Click the **Update Chart** button. This refreshes the Detail Chart using the filter you built.

You have filtered data in the GigaStor Control Panel, which may suffice. You can also choose to further analyze the data. See Analyzing data by combining GigaStor Control Panel and Observer filters (page 328).

### Analyzing data by combining GigaStor Control Panel and Observer filters

**Tip!** If you chose “Create analysis filter using checked GigaStor entries” and do not have any data or do not have the data you expected, it may be because you applied too many filters. Try the “Analyze all traffic in the analysis interval” option instead.

1. Complete the procedure in Analyzing data with filters from the GigaStor Control Panel (page 327).

2. After you have a filtered chart, click the **Analyze** button. The GigaStor Analysis Options window opens.

3. Because you are analyzing data with checked GigaStor entries, you have two choices:
   - Analyze all traffic in the analysis interval—Uses the filtered data as-is and analyzes it.
   - Create analysis filter using checked GigaStor entries—Creates a second filter and applies it to the already filtered data.

4. Click **OK**.

Your filtered data appears in a new “Decode and Analysis” tab.

### Analyzing multiple GigaStor probe instances from one GigaStor Control Panel

Combining the data of multiple GigaStor probe instances into one GigaStor Control Panel allows for quick and easy isolation of information.

One example where you might use this is if you need to find information but are unsure which GigaStor probe instance to query. Instead, you can combine the data of any GigaStor probe instances you have access to and perform just one query.

**Note:** The GigaStor Control Panel must be open for every GigaStor probe instance you want to combine for analysis.

To analyze multiple GigaStor probe instances from one GigaStor Control Panel:

1. On the Home tab, in the Capture group, click **GigaStor**.

2. Click Tools.

3. Click Select GigaStors for Combined Indexing.
4. Choose two or more probe instances and click **Apply**.  
   If a particular GigaStor probe instance is not listed, ensure the GigaStor Control Panel for that instance is open and try again.

5. Click Update Reports to start combining index data.

6. After the process completes, the currently open GigaStor Control Panel is showing a real-time aggregate of multiple GigaStor probe instances.

After completing this task:
Simply use the combined GigaStor Control Panel the same way as a non-combined GigaStor Control Panel. See Using the GigaStor Control Panel (page 306) for details.

### Understanding GigaStor accelerated analysis

GigaStor accelerated analysis significantly increases the speed that analysis results are made available in the GigaStor Control Panel. Accelerated analysis first became available in 17.1.0.0, and starting in 17.2.0.0 it is now always enabled.

**Accelerated analysis improves speed by bypassing the data mining process for packets pre-determined to not match your criteria.** In non-accelerated analysis, every packet in the GigaStor during your selected time slice requires examination against your analysis query before processing can complete. With accelerated analysis this is no longer the case. If your analysis query can be accelerated, your query will be accelerated in-part or in-full without any extra steps to follow. Your returned results are always as accurate as the “normal” speed data mine.

**Note:** GigaStor accelerated analysis requires version 17.1.0.0 or later. Starting in 17.2.0.0, it remains enabled at all times.

No special or extra hardware is required for accelerated analysis to operate. This means both the GigaStor hardware appliances from VIAVI and GigaStor Software Edition on your own hardware can all use accelerated analysis. Likewise, the speed increase from accelerated analysis works on active instances and their passive instances. For example, redirected probe instances to a local Observer will benefit from accelerated analysis.

**Accelerated analysis cannot increase the data mining speed of traffic that was collected previous to 17.1.0.0.** To determine which incoming packets can be accelerated in future data mines and why, accelerated analysis must see the packets as they arrive. For example, if you are upgrading to 17.1.0.0 from a previous version, none of your existing GigaStor data can benefit from accelerated analysis because old versions did not have the feature. Anything new you collect is a candidate for accelerated analysis.

**If any portion of your analysis query cannot be accelerated, log entries are shown in the Observer log.** This means that if no log entries are recorded when you perform GigaStor analysis, the entire query was sped up with accelerated analysis. If you see log entries that state accelerated analysis could not be used for part or all of your data mine, it may lead to clues as to why that happened. Accelerated analysis attempts to speed up as much of your data extraction as possible.

**Accelerated analysis cannot accelerate any analysis that is specifically asked to include Expert Information Packets in the results.** Asking that
Expert Information Packets be in your GigaStor analysis results causes a condition where Expert Information Packets are meeting the criteria of your analysis query every 1-second (the frequency that expert packets are stored) and therefore negates any performance gains from accelerated analysis because no packets are bypassed. A warning message of longer extraction times is displayed in the GigaStor Control Panel if you attempt to include expert packets. Overall, you do not need to disable the collection of Expert Information Packets for accelerated analysis to operate correctly—simply do not ask for expert packets in your analysis results.

Filter elements that support accelerated analysis

GigaStor accelerated analysis supports single and multiple-element data extraction filters. If at least one of these listed element configurations is in your analysis filter, then accelerated analysis is possible.

Accelerated analysis occurs when your GigaStor extraction filter has at least one of these filter elements. You can join these with any other filter element using an AND statement and get the benefits of accelerated analysis. Conversely, your extraction cannot be accelerated if you use an OR statement in your extraction filter; in these cases, the GigaStor extracts data at normal speeds.

Note: IP addresses refer to either IPv4 and IPv6 unless otherwise noted.

| IP Address |
| IP Pair |
| IP Range |

Examining your network traffic with forensic analysis

Forensic Analysis is a powerful tool for scanning high-volume packet captures for intrusion signatures and other traffic patterns that can be specified using the familiar Snort rule syntax.

Network forensics is the idea of being able to resolve network problems through captured network traffic. Previous methods of network forensics required you to be able to recreate the problem. Using the GigaStor you do not have to recreate the problem — you already have the captured packets. Instead of reacting to a problem, you can use network forensics to proactively solve problems.

You might need network forensics because of company policy or because of governmentally-mandated compliance. You can enforce your “acceptable use” policies, fight industrial espionage, and assist with government regulations like Sarbanes Oxley or HIPPA requirements. Using network forensics you can provide pre-intrusion tracking and identification while delivering a paper trail after any intrusion. Or you can perform network troubleshooting using root-cause analysis and identify network problems that have been around awhile.

Snort is an open source network intrusion detection system (NIDS). Snort’s rule definition language is the standard way to specify packet filters aimed at sensing intrusion attempts. You can obtain the rules from http://www.snort.org.

Snort rules imported into Observer operate much like Observer’s expert conditions, telling Observer how to examine each packet to determine whether it matches specified criteria, triggering an alert when the criteria is met. They differ from expert conditions in that they only operate post-capture, and the rules themselves are text files imported into Observer.
Importing Snort rules

After getting the Snort rules from [http://www.snort.org](http://www.snort.org), follow these steps to import them into Observer.

1. On the Home tab, in the Capture group, click **GigaStor**.
2. Click the **Forensic Analysis** tab.
3. Right-click anywhere on the Forensic Analysis tab and choose Forensic Settings from the menu. The Select Forensic Analysis Profile window opens.
4. Choose your profile and click Edit. The Forensic Settings window opens.
5. At the bottom of the window, click the **Import Snort Files** button.
6. Locate your Snort rules file and click Open. Close all of the windows. After you import the rules into Observer you are able to enable and disable rules and groups of rules by their classification as needed.

Observer displays a progress bar and then an import summary showing the results of the import. Because Observer’s forensic analysis omits support for rule types and options not relevant to a post-capture system, the import summary will probably list a few unrecognized options and rule types. This is normal, and unless you are debugging rules that you wrote yourself, can be ignored.

7. To use the Snort rules you just imported, right-click anywhere on the Forensic Analysis tab and choose Analyze from the menu.

Analyzing packets using Snort rules

To analyze packets using Snort rules, you must first import the rules into Observer. See Importing Snort rules (page 331).

1. On the Home tab, in the Capture group, click **GigaStor**.
2. Right-click anywhere on the **Forensic Analysis** tab and choose **Analyze** from the menu.

applies the rules and filters to the capture data and displays the results in the Forensics Summary tab. A new tab is also opened that contains the decode.

### Forensic Analysis tab

It is important to examine the preprocessor results to ensure that time-outs and other maximum value exceeded conditions haven’t compromised the analysis. If you see that preprocessors have timed out on hundreds of flows and streams, you may want to adjust preprocessor settings to eliminate these conditions. Intruders often attempt to exceed the limitations of forensic analysis to hide malicious content.

The right-click menu lets you examine the rule that triggered the alert (if applicable). It also lets you jump to web-based threat references such as bugtraq for further information about the alert. These references must be coded into the Snort rule to be available from the right-click menu.

### Forensic Analysis Log tab

The Forensic Analysis Log comprehensively lists all rule alerts and preprocessor events in a table, letting you sort individual occurrences by priority, classification, rule ID, or any other column heading. Just click on the column heading to sort the alerts by the given criteria.
Creating a Forensic Settings profile

Forensics profiles provide a mechanism to define and load different pairings of settings and rules profiles. Settings profiles define pre-processor settings that let you tune performance; rules profiles define which forensic rules are to be processed during analysis to catch threats against particular target operating systems and web servers. Because Observer performs signature matching on existing captures rather than in real time, its preprocessor configuration differs from that of native Snort. When you import a set of Snort rules that includes configuration settings, Observer imports rules classifications, but uses its own defaults for the preprocessor settings.

**Note:** There is a difference between enabling the preprocessor and enabling logs for the preprocessor. For example, you can enable IP defragmentation with or without logging. Without logging, IP fragments are simply reassembled; only time-out or maximum limit reached messages are noted in the Forensics Log and in the Forensic Analysis Summary window. If logging is enabled, all reassembly activity is displayed in the Forensics Log (but not displayed in the Forensic Analysis Summary).

1. On the Home tab, in the Capture group, click GigaStor.
2. Click the Forensic Analysis tab.
3. Right-click anywhere on the Forensic Analysis tab and choose Forensic Settings from the menu. The Select Forensic Analysis Profile window opens.
4. Choose your profile and click Edit. The Forensic Settings window opens.
5. From the Forensic Settings window, complete the following:
   - Import Snort rules
   - Define Forensic Settings.
   - Define Rule Settings—Select the rules you want to enable.
6. Close all of the windows, then right-click anywhere on the Forensic Analysis tab and choose Analyze from the menu.

   applies the rules and filters to the capture data and displays the results in the Forensics Summary tab.

The top portion of the Rules window lists the rules that were imported, grouped in a tree with branches that correspond to the files that were imported.

Rule classifications offer another level of control. Check the “Rules must also match rule classifications” box to display a list of defined rule classifications. Classifications are defined at import time by parsing the Snort config classification statements encountered in the rule set. Rules are assigned a classification in the rule statement’s classtype option.

Select the rule classification(s) you want to enable. If classification matching is enabled, a rule and its classification must both be enabled for that rule to be
Examining your network traffic with forensic analysis
Chapter 18: GigaStor Control Panel

processed. For example, suppose you want to enable all policy violation rules: simply right-click on the rule list, choose Enable all rules, and then enable the policy violation classification.

Table 51. Forensic Settings options

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings Profile</td>
<td>Settings Profiles provide a mechanism to save and load different preprocessor settings, and share them with other Observer.</td>
</tr>
<tr>
<td>IP Flow</td>
<td>Packets belong to the same IP flow if they share the same layer 3 protocol, and also share the same source and destination addresses and ports. If this box is checked, forensic analysis identifies IP flows (also known as conversations), allowing Snort rules to isolate packets by direction and connection state via the flow option. If this pre-processor is disabled, flow keywords are ignored, but the rest of the rule is processed. The remaining settings allow you to throttle flow analysis by limiting the number of flows tracked, and by decreasing the time window within which a flow is considered active.</td>
</tr>
<tr>
<td>IP Defragmentation</td>
<td>Some types of attacks use packet fragmentation to escape detection. Enabling this preprocessor causes forensic analysis to identify and reconstruct fragmented packets based on the specified fragment reassembly policy. Rules are then run against the reconstructed packets during forensic analysis. The fragment reassembly policy mimics the behavior of various operating systems in what to do when ambiguous fragments are received. Choose the policy to match the OS of the server (or servers) being monitored. If the buffer contains traffic targeting hosts with different operating systems, use post-filtering to isolate the traffic before forensic analysis so that you can apply the correct policy. Defragmentation Policy is: BSD=AIX, FreeBSD, HP-UX B.10.20, IRIX, IRIX64, NCD Thin Clients, OpenVMS, OS/2, OSF1, SunOS 4.1.4, Tru64 Unix, VAX/VMS Last data in=Cisco IOS BSD-right=HP JetDirect (printer) First data in=HP-UX 11.00, MacOS, SunOS 5.5.1 through 5.8 Linux=Linux, OpenBSD Solaris=Solaris Windows=Windows (95/98/NT4/W2K/XP) Refer to <a href="http://www.snort.org">http://www.snort.org</a> for more detailed version-specific information. The remaining options allow you to enable logging of alerts and reconstruction progress, limit the number of active packet fragments to track, and change the length of fragment inactivity that causes the fragment to be dropped from analysis.</td>
</tr>
<tr>
<td>TCP Stream Reassembly</td>
<td>Another IDS evasion technique is to fragment the attack across multiple TCP segments. Because hackers know that IDS systems attempt to reconstruct TCP streams, they use a number of techniques to confuse the IDS so that it reconstructs an incorrect stream (in other words, the IDS processes the stream differently from that of the intended target). As with IP fragmentation, forensic analysis must be configured to mimic how the host processes ambiguous and overlapping TCP segments, and the topology between attacker and target to accurately reassemble</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td>TCP Stream Reassembly (Continued)</td>
<td>Log preprocessor events—Checking this box causes forensic analysis to display all activity generated by the TCP stream assembly preprocessor to the log. Maximum active TCP streams tracked—If this value is set too high given the size of the buffer being analyzed, performance can suffer because of memory consumption. If this value is set too low, forensic analysis can be susceptible to denial of service attacks upon the IDS itself (i.e., the attack on the target is carried out after the IDS has used up its simultaneous sessions allocation). Drop TCP streams inactive for this duration—A TCP session is dropped from analysis as soon as it has been closed by an RST message or FIN handshake, or after the time-out threshold for inactivity has been reached. Exercise caution when adjusting the time-out, because hackers can use TCP tear-down policies (and the differences between how analyzers handle inactivity vs. various operating systems) to evade detection. TTL delta alert limit—Some attackers depend on knowledge of the target system’s location relative to the IDS to send different streams of packets to each by manipulating TTL (Time To Live) values. Any large swing in Time To Live (TTL) values within a stream segment can be evidence of this kind of evasion attempt. Set the value too high, and analysis will miss these attempts. Setting the value too low can result in excessive false positives. Overlapping packet alert threshold—The reassembly preprocessor will generate an alert when more than this number of packets within a stream have overlapping sequence numbers. Process only established streams—Check this box if you want analysis to recognize streams established during the given packet capture. Reconstruct Client to Server streams—Check this box to have analysis actually reconstruct streams received by servers. Reconstruct Server to Client streams—Check this box to have analysis actually reconstruct streams received by clients. Overlap method—Different operating systems handle overlapping packets using one of these methods. Choose one to match the method of the systems being monitored. Reassembly error action—Discard and flush writes the reassembled stream for analysis, excluding the packet that caused the error. Insert and flush writes the reassembled stream, but includes the packet that caused the error. Insert no flush includes the error-causing packet and continues stream reassembly. Reassembled packet size threshold range—Some evasion strategies attempt to evade detection by fragmenting the TCP header across multiple packets. Reassembling the stream in packets of uniform size makes this easier for attackers to slip traffic past the rules, so forensic analysis reassembles the stream using random packet sizes. Here you can set the upper and lower limits on the size of these packets.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td>Reassembled packet size seed value</td>
<td>Changing the seed value will cause forensic analysis to use a different pattern of packet sizes for stream reassembly. Running the analysis with a different seed value can catch signature matches that would otherwise escape detection.</td>
</tr>
<tr>
<td>Port List</td>
<td>Enabling the Port List option limits analysis to (or excludes from analysis) the given port numbers.</td>
</tr>
</tbody>
</table>

**HTTP URI Normalization**

Many HTTP-based attacks attempt to evade detection by encoding URI strings in UTF-8 or Microsoft %u notation for specifying Unicode characters. This preprocessor includes options to circumvent the most common evasion techniques. To match patterns against the normalized URIs rather than the unconverted strings captured from the wire, the VRT Rules use the uricontent option, which depends on this preprocessor. Without normalization, you would have to include signatures for the pattern in all possible formats (using the content option), rather than in one canonical version.

Log preprocessor events—Checking this box causes forensic analysis to save any alerts generated by the HTTP preprocessor to the log, but not the Forensic Summary Window.

Maximum directory segment size—Specifies the maximum length of a directory segment (i.e., the number of characters allowed between slashes). If a URI directory is larger than this, an alert is generated. 200 characters is a reasonable cutoff point to start with. This should limit the alerts to IDS evasions.

Unicode Code Page—Specify the appropriate country code page for the traffic being monitored.

Normalize ASCII percent encodings—This option must be enabled for the rest of the options to work. The second check box allows you to enable logging when such encoding is encountered during preprocessing. Because such encoding is considered standard, logging occurrences of this is not recommended.

Normalize percent-U encodings—Convert Microsoft-style %u-encoded characters to standard format. The second check box allows you to enable logging when such encoding is encountered during preprocessing. Because such encoding is considered non-standard (and a common hacker trick), logging occurrences of this is recommended.

Normalize UTF-8 encodings—Convert UTF-8 encoded characters to standard format. The second check box allows you to enable logging when such encoding is encountered during preprocessing. Because Apache uses this standard, enable this option when monitoring Apache servers. Although you might be interested in logging UTF-8 encoded URIs, doing so can result in a lot of noise because this type of encoding is common.

Lookup Unicode in code page—Enables Unicode codepoint mapping during pre-processing to handle non-ASCII codepoints that the IIS server accepts.

Normalize double encodings—This option mimics IIS behavior that intruders can use to launch insertion attacks. Normalize bare binary non ASCII encodings—This an IIS feature that uses non-ASCII characters as valid values when decoding UTF-8
### Field

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>values. As this is non-standard, logging this type of encoding is recommended.</td>
</tr>
<tr>
<td>Normalize directory traversal—Directory traversal attacks attempt to access unauthorized directories and commands on a web server or application by using the <code>./</code> and <code>../</code> syntax. This preprocessor removes directory traversals and self-referential directories. You may want to disable logging for occurrences of this, as many web pages and applications use directory traversals to reference content.</td>
</tr>
<tr>
<td>Normalize multiple slashes to one—Another directory traversal strategy is to attempt to confuse the web server with excessive multiple slashes.</td>
</tr>
<tr>
<td>Normalize Backslash—This option emulates IIS treatment of backslashes (i.e., converts them to forward slashes).</td>
</tr>
<tr>
<td>Ethernet uses Address Resolution Protocol (ARP) to map IP addresses to a particular machine (MAC) addresses. Rather than continuously broadcasting the map to all devices on the segment, each device maintains its own copy, called the ARP cache, which is updated whenever the device receives an ARP Reply. Hackers use cache poisoning to launch man-in-the-middle and denial of service (DoS) attacks. The ARP inspection preprocessor examines ARP traffic for malicious forgeries (ARP spoofing) and the traffic resulting from these types of attacks.</td>
</tr>
<tr>
<td>Log preprocessor events—Checking this box causes forensic analysis to save any alerts generated by the ARP Inspection preprocessor to the log, but not the Forensic Summary Window.</td>
</tr>
<tr>
<td>Report non-broadcast requests—Non-broadcast ARP traffic can be evidence of malicious intent. Once scenario is the hacker attempting to convince a target computer that the hacker’s computer is a router, thus allowing the hacker to monitor all traffic from the target. However, some devices (such as printers) use non-broadcast ARP requests as part of normal operation. Start by checking the box to detect such traffic; disable the option only if analysis detects false positives.</td>
</tr>
<tr>
<td>Hackers may attempt to evade detection by inserting control characters into Telnet and FTP commands aimed at a target. This pre-processor strips these codes, thus normalizing all such traffic before subsequent forensic rules are applied.</td>
</tr>
<tr>
<td>Log preprocessor events—Checking this box causes forensic analysis to save any alerts generated by the Telnet Normalization preprocessor to the log, but not the Forensic Summary Window.</td>
</tr>
<tr>
<td>Port List—Lets you specify a list of ports to include or exclude from Telnet pre-processing. The default settings are appropriate for most networks.</td>
</tr>
<tr>
<td>A scrollable window located below the preprocessor settings lists the variables that were imported along with the Snort rules. Variables are referenced by the rules to specify local and remote network ranges, and common server IP addresses and ports. You can edit variable definitions by double-clicking on the variable you want to edit.</td>
</tr>
<tr>
<td>The VRT Rule Set variable settings (and those of most publicly-distributed rule sets) will work on any network without modification, but you can dramatically improve performance</td>
</tr>
</tbody>
</table>
### Field | Description
--- | ---
by customizing these variables to match the network being monitored. For example, the VRT rules define HTTP servers as any, which results in much unnecessary processing at runtime.
Address variables can reference another variable, or specify an IP address or class, or a series of either. Note that unlike native Snort, Observer can process IPv6 addresses.
Port variables can reference another variable, or specify a port or a range of ports. To change a variable, simply double-click the entry. The Edit Forensic Variable dialog shows a number of examples of each type of variable which you can use as a template when changing values of address and port variables.

---

### Using network forensics to track a security breach

It goes without saying that you have a firewall and other perimeter defenses in place to ward off intruders. But sometimes those can be defeated by unique attacks from the outside, and they do not fend off any internal attacks. Existing security deployments look for known threats or vulnerabilities and miss the new, unknown threats. Use the Forensic Analysis tab to find all of these and to research and identify sources of “zero-day attack.”

Imagine the following scenario: Over the weekend seemingly random security anomalies began to attack your DMZ. Your intrusion protection system (IPS) detected and repelled these attacks. During the same time frame and unknown to the IPS/IDS, a brute force attack occurred and was successful against the default “Admin” account on your VPN concentrator. After they were beyond your perimeter, which was accomplished using a created VPN account, Trojan applications installed remote control utilities and keystroke loggers. Subsequent malicious activity using these utilities occurred against other internal systems.

How do you identify what happened and when it happened? How do you identify who was affected?

1. Isolate the time frame over the weekend where you noticed the attacks against your DMZ. Collect all of the internal activity over the next few days. Select the time in the Detail Chart of the GigaStor Control Panel from where you noticed the attacks and the next few days. Change the time resolution, if necessary, to zoom out (or in) so that you have the data highlighted. See Selecting a time frame to analyze (page 324).

2. Using current Snort rules, click the **Analyze** button. See Importing Snort rules (page 331).

3. Search the decoded packets for possible exploits, internal denial-of-service attacks, and key logging.

4. If you find anything suspicious, navigate into the individual frames to isolate data that was transferred under false pretenses.

5. Use Connection Dynamics in Observer to track the path that the intruder took across your network. Identify all infrastructure systems that were affected and potentially compromised.
Using network forensics to track acceptable use or compliance

**Note:** Stream reconstruction (including VoIP) is illegal in some jurisdictions and may be disabled by VIAVI to comply with those laws.

Your company likely has an “acceptable use” policy for its network. As a network administrator, you may be asked to track a specific person’s internet use. The challenge of tracking web user activity is that it can provide domain names and URL information but cannot show what exact content was being displayed at the time. If those sites cease to exist or change their content, providing adequate documentation is nearly impossible.

The solution is to record the traffic in its entirety, which offers the ability to view the transactions, and also to reconstruct the original stream of data.

1. Isolate the time frame where you suspect the person was misusing the network. See Selecting a time frame to analyze (page 324).
2. Click the **IP Stations tab** and find the address of the user you are tracking. Select the address. This creates a filter.
3. Click Update Chart. This updates the Detail Chart and shows you all of the traffic from the address.
4. You can further filter the chart and reports by selecting specific traffic types (for example, HTTP, SMTP, Telnet, and so on).
5. Analyze the data using one of the options described in Mining data from your GigaStor (page 321). This opens your data in the Decode tab in Observer.
6. Assuming the data is HTTP, select a packet in the Decode tab and right-click. Choose TCP Dump (HTTP) from the menu. This analyzes the data and opens it in the Expert tab.
7. Scroll through the decoded packets. Click the “ReconstructedPage.html” files to see the web page as it looked when the user saw it.

This same process can be used for replaying VoIP calls or capturing e-mail and instant messaging to ensure your company’s “acceptable use” policy is being followed.

### Searching for microbursts

For a computer network, a microburst is an unusually large amount of data in a short time frame that saturates your network and adds to latency. These bursts are seen as a spike over normal traffic when viewed on a graph. They are usually less than one millisecond long (or even shorter), and they typically occur during high traffic volume, such as after a major news event or announcement when many people are using the network simultaneously.

**Note:** Microbursts occur in every network, but are also very environment-specific. What may be a microburst for one company may be considered acceptable traffic for another. Given that many applications have error checking and retransmission algorithms, and that microbursts are so short that connectivity for most applications is not affected, microbursts are not a concern for many network engineers. However, some applications are more sensitive to microbursts, such as financial, audio, video, or multicast.
You might have microburst issues if your latency is creeping into the tens of milliseconds (or doubling your previous baseline). Your brokers may know something is awry because revenue is dropping. Revenue is dropping because your broker's trades are executed just behind others beating them to the market, thereby getting a better price and more revenue. All of this will occur and neither your brokers nor you may even be aware the microbursts are occurring.

Almost half of all trades executed globally are initiated and completed by computers, not humans. Since computers are reacting to price fluctuations, when a microburst occurs, packets may be dropped, which causes them to be retransmitted and that takes several milliseconds—nearly doubling the time to complete the transaction. A 1-millisecond advantage in trading applications can be worth $100 million a year to a major brokerage firm.¹

To prevent data loss because of microbursts, design your network so that its capacity can withstand the highest possible burst of activity in whatever a time frame you deem important (perhaps millisecond). Adding additional switches or load-balancers to your network are a couple of possible solutions. This way the link will never be constantly busy for more than one millisecond at a time, and no data will be delayed on the link for more than one millisecond.

Another option is to smooth out any traffic or applications not sensitive to latency or jitter sharing the same link. Using these options, you can optimize your network for bandwidth efficiency, performance, or a combination of both depending on each application's requirements.

Even after identifying and correcting for all issues in your network, you may still have problems with your Internet Service Provider. A study performed by Microsoft Research indicates that microbursts are more likely to occur at edge or aggregation links.² Therefore, it may be necessary to also have your ISP optimize their flows to you.

Practically speaking, the capacity necessary to keep latency below one millisecond is normally much less than the peak one millisecond data rate. This is because many links use buffers to hold the traffic exceeding the link capacity until the buffer can be cleared. Assuming the system can clear the buffer queue quickly when the burst ends, microbursts are avoided because buffer capacity was created.

In the GigaStor Control Panel, a microburst occurs when 1) the maximum bits per duration interval based on the capture card speed and utilization threshold you define is reached, and 2) the interval contains at least two packets (full or partial).

There are a few different ways to search for microbursts using Observer.

- Using triggers and alarms to inform you when microbursts occur. Customize your triggers and actions and choose Microbursts from the Alarms list.

¹ Information Week, April 21, 2007.
² Microsoft Research, June 1, 2009.
Using the Microburst Analysis tab is the easiest way to analyze large chunks of time for microbursts and view the decoded packets.

Using Network Trending for microbursts. This option is different than the packet capture and decode option available through the Microburst Analysis tab. First, packet capture does not need to be running for Microburst trending to see any microbursts. Second, Microburst trending can also be pushed to Observer Reporting Server and aggregated with Microburst trending information from other probes in your network so that you have a fuller picture of where and when microbursts are occurring.

Using the Detail Chart. This method is limited to a 15 minute time frame on the Detail Chart.

Using the Microburst Analysis tab in the GigaStor Control Panel

To search for microbursts across a large time frame (greater than 15 minutes) you must use the Microburst Analysis tab.

The Microburst Analysis tab shows you the number of microbursts Observer found in the time frame you selected. You can see exactly when the microburst occurred, how many bytes where in the burst, and the network utilization when the burst occurred.

When you select a microburst, you can choose to see that slice of time on the Detail Chart or you can view the packet in the Decode pane.

You can select the Microburst Analysis Graph tab and see the found microbursts on a graph.

1. Select a probe instance.
2. On the Home tab, in the Capture group, click GigaStor.
3. Click the Microburst Analysis tab.
4. Highlight the data in the Detail Chart you want to analyze for microbursts and click Analyze. The GigaStor Analysis Options screen opens.
5. Choose whether you want any filters and select Microburst analysis in the Analysis Type section.
6. Define what a microburst is for your network and click OK. The results appear in the Microburst Analysis tab. For details, see Duration, Utilization threshold, and Full duplex. It may take a moment for the GigaStor Control Panel to process the data and display the results.

Using the Detail Chart only

The longest time frame that can be analyzed with the Detail Chart method is 15 minutes. You may be better off using the Microburst Analysis tab instead.

See Using the Microburst Analysis tab in the GigaStor Control Panel (page 340).

Tip! Microburst analysis is easier to comprehend using bars instead of lines on the Detail Chart. Choose Settings > Detailed Chart and change the appearance to 2D Columns. Depending on your preferences, at times you may also wish to change the Y-axis scale to 100 when you are viewing the chart as Percent of duration Intervals with Microbursts.
To enable microburst analysis and define what on your network qualifies as a microburst:

1. On the Home tab, in the Capture group, click **GigaStor**.
2. Click the Screen resolution box, which opens the Microburst Analysis options.
3. Select Enable Microburst Analysis and choose your settings. When you make changes to these options, the Detail Chart changes. Sometimes it is a very subtle change. All of these options are interrelated. By changing any one of these settings, you change what is determined to be a microburst. When that changes, the graphs change. Change only one option at a time, then view your changes.

**Screen resolution** (Interval/Total Time): The screen resolution is two numbers that define the length of time shown in the Detail Chart. The first number is the interval length, which when looking at a bar chart, is each bar. The second number is the total time of all of the intervals on the chart, although if an interval does not have any bursts the interval will not have a bar. The interval is used along with Duration to determine how many chunks of time are theoretically possible. See Table 52 (page 342) for examples of how changing the interval may affect the Detail Chart.

**Duration**: The duration is length of time over which the burst is calculated. It must contain two or more packets (or partial packets) to be counted as a microburst. A single packet filling an entire duration interval does not count as a microburst. The shorter the time frame, the more bursts you may have because the length of time necessary to meet the threshold is shorter. Conversely, as you increase the length of time required for traffic to be considered a burst, fewer bursts will meet the duration threshold. This is why counts may change as you increase or decrease the duration. More of less traffic meets the duration threshold to be considered a microburst. See Table 52 (page 342) for examples of how changing the duration may affect the Detail Chart.

**Utilization threshold**: The utilization threshold is the percent of your capture card speed that must be met before a microburst can be determined to have occurred. The lowest threshold allowed is 10%. The highest threshold is 100%, although it is extremely rare that 100% is ever achieved. Ninety-nine percent utilization is not uncommon though. See Table 52 (page 342) for examples of how changing the Utilization threshold may affect the Detail Chart.

**Full Duplex / DTE / DCE**: Determines how the utilization threshold is calculated and what information is shown in the Detail Chart. These options are only available when the probe instance you are using is attached to a capture card. We do not recommend attaching passive probe instances to the capture card, so these options may not be available to you. In this case, your settings are Full Duplex + DTE + DCE are not available and cannot be changed.

*Full Duplex + DTE + DCE*: Each port on the capture card is considered independently from all others. The traffic is never combined between ports...
to meet a threshold. If you have a 4-port 1 Gb capture card, you have four independent 1 Gb connections.

A microburst is counted when the utilization on any one of the ports exceeds the utilization threshold, but only on that port. The threshold does not need to be met on all ports — just on one or more of them.

**Full Duplex + DTE:** Calculates and displays microbursts only on DTE ports. The DTE ports on the capture card are the even numbered ports (2, 4, 6, 8).

**Full Duplex + DCE:** Same as Full Duplex + DTE, except for DCE links. The DCE ports are the odd numbered ports (1, 3, 5, 7).

**None selected:** When no options are selected, the ports are combined to create the maximum utilization threshold. If you have a 4-port 1 Gb capture card, you have one connection with a 4 Gb maximum utilization. (This is the opposite of Full Duplex + DTE + DCE where you have four independent 1 Gb connections.) For this reason, you will likely see fewer microbursts than when any of the Full Duplex options are selected because the utilization threshold is higher.

**Note:** The Data type option is unavailable when doing Microburst analysis because Microburst analysis shows the number of times or percentage of time when a microburst occurs within a duration and utilization threshold. Because the charts show only microbursts and no other type of information, you cannot choose to show bytes, bits or packets for data type.

**Percent of duration intervals with microbursts:** The Detail Chart shows bursts as a percentage. It uses four variables to determine the percentage. Each bar (assuming your chart is configured to show bars instead of lines) represents one interval. Within each slice are smaller chunks of time, which are the durations (although they are not visible on the Detail Chart). The percentage is calculated by:

1. \( \frac{\text{Screen resolution interval}}{\text{Duration}} \)  = Maximum number of intervals
2. \( \frac{\text{Number of duration intervals with microbursts}}{\text{Maximum number of intervals}} \) = Percent of interval durations with microbursts

**Number of duration intervals with microbursts:** The Detail Chart shows the count of microbursts that occurred in each duration interval. There can only be one microburst per duration interval. This number is also used to calculate the percent of duration intervals with microbursts.

**Table 52 (page 342)** shows how changing one variable changes the calculations and can affect what you see in your charts.

<table>
<thead>
<tr>
<th>Interval</th>
<th>Duration</th>
<th>MB Util</th>
<th>Bits/sec in Interval</th>
<th>Bytes/sec in Interval</th>
</tr>
</thead>
<tbody>
<tr>
<td>5 ms, 1 s, 200 ms</td>
<td>1, 2, 3</td>
<td>10%, 50%, 90%</td>
<td>2,500,000 to 100,000,000,000</td>
<td>309,672 to 12,338,304</td>
</tr>
<tr>
<td>1 ms</td>
<td>1, 3, 4</td>
<td>12,4</td>
<td>5,000,000 to 100,000,000,000</td>
<td>61,688,484 to 617,826</td>
</tr>
<tr>
<td>10 µs</td>
<td>1, 3, 4</td>
<td>12,4</td>
<td>5,000,000 to 100,000,000,000</td>
<td>61,688,484 to 617,826</td>
</tr>
<tr>
<td>100 µs</td>
<td>1, 3, 4</td>
<td>12,4</td>
<td>5,000,000 to 100,000,000,000</td>
<td>61,688,484 to 617,826</td>
</tr>
</tbody>
</table>
Reconstructing streams of HTTP, VoIP, and more

The process of capturing and reconstructing traffic is pretty much the same regardless of traffic type. Use these steps to reconstruct the stream.

**Note:** Stream reconstruction (including VoIP) is illegal in some jurisdictions and may be disabled by VIAVI to comply with those laws.

The process described here is for reconstructing HTTP, but the process is the same for other applications, except instep 6 you would choose the appropriate menu option.

1. Isolate the time frame in the Detail Chart you want to analyze. See Selecting a time frame to analyze (page 324).
2. (Optional) Using the various Statistics tabs, select IP Stations tab and choose the station(s) you want to isolate. This creates a filter.
3. Click Update Chart. This updates the Detail Chart and shows you all of the traffic from the address.
4. You can further filter the chart and reports by selecting specific traffic types (for example, HTTP, SMTP, Telnet, and so on).
5. Analyze the data using one of the options described in Mining data from your GigaStor (page 321). This opens your data in the Decode tab in Observer.
6. Assuming the data is HTTP, select a packet in the Decode tab and right-click. Choose TCP Dump (HTTP) from the menu. This analyzes the data and opens it in the Expert tab.

7. Scroll through the decoded packets. Click the "ReconstructedPage.html" files to see the web page as it looked when the user saw it.

Defining what can be recreated in Stream Reconstruction

Note: Stream reconstruction (including VoIP) is illegal in some jurisdictions and may be disabled by VIAVI to comply with those laws.

For security or privacy reasons or because of company policy, you may need to limit what the GigaStor probe can recreate through its stream reconstruction feature.

1. On the Home tab, in the Capture group, click GigaStor.
2. Click the Settings button.
3. Click the Stream Reconstruction tab.
4. Choose which content streams you would like to be able to reconstruct and have appear on the Stream Reconstruction tab of the GigaStor Control Panel.
5. Choose whether to limit stream reconstruction by specific subnets.

How to extract VoIP and video calls from your GigaStor

VoIP and videoconferencing calls can be extracted from a GigaStor if you know the approximate time the events occurred.

Prerequisite(s):

You must understand how to select a time frame from your GigaStor. See Selecting a time frame to analyze (page 324).

Note: This process is only compatible with SIP data.

Locating and extracting SIP-based voice and video data from your GigaStor is a straightforward task. All of the SIP setup and teardown packets are extracted along with any payload, such as audio and video, to ensure you retrieve complete sessions. This includes all person-to-person audio calls and videoconferencing as well as conference calls and conference video where multiple endpoints are present. An endpoint could be a person holding a handset, wearing a headset, or a line that is open for hold music or for recording.

To extract VoIP and videoconferencing calls from your GigaStor:

1. Select a time frame you want to analyze.
2. Click the Update Reports button to get the latest data from the time frame selected.
   
   This step is unnecessary if Auto-update GigaStor chart on statistics tab or selection change is enabled in the GigaStor settings. See Setting the GigaStor general options.

3. Click the Analyze button.

4. In the Analysis Options section, choose VoIP and Videoconferencing calls by SIP tag. Click the Settings option and choose your call search criteria.
Option | Description
--- | ---
A --> (ANY) | Extract call(s) where pattern A is in the SIP “From” field.
A <-- (ANY) | Extract call(s) where pattern A is in the SIP “To” field.
A <-> (ANY) | Extract call(s) where pattern A is in the SIP “From” or “To” field.
A <-> B | Extract call(s) where pattern A and pattern B is in either the SIP “From” or “To” field.
A --> B | Extract call(s) with pattern A in the SIP “From” field and pattern B is in a SIP “To” field.
Call-ID | Extract call(s) with the specified pattern in the SIP “Call-ID” field.

5. (Optional) Enable one or more search pattern modifiers:
   - Use regular expression(s)—Perl 5 regular expressions. For details and examples, see
   - Match case—case sensitive search

6. Type a string for the GigaStor to search for in the Call-ID Pattern.

7. Choose one of the result options:
   - Stop searching when one matching call is found. This provides you the results more quickly, but the tradeoff is that if the endpoints identified by search criteria had multiple separate calls within the timeframe selected, only the first call is extracted and any subsequent calls are excluded.
   - Search for all matching calls within the GigaStor analysis time range (up to the filtering limit).

8. Click **OK** to save your settings.

9. Choose your analysis type. The options are described in Mining data from your GigaStor (page 321).
   - Expert analysis and decode
   - Decode without expert analysis
   - Third party decoder

If your search pattern found results, the results are displayed in a new tab and can be further analyzed.

**Using Observer in financial firms**

In an environment where even nanoseconds matter, a GigaStor allows you to identify when an anomaly in your network occurs and alerts you to it so that you can resolve it quickly.

If you are a network administrator in a financial or trading firm, small amounts of time can mean the difference between making or losing money or making money versus making a lot of money. Your networks must be fast, and your trading algorithms must be running as efficiently as possible with no data loss on your network. In addition to the in-depth network troubleshooting features, the GigaStor has several components designed with your business in mind:

- **GigaStor probe**: The GigaStor probe is a high-performance capture-based network appliance that is extremely fault tolerant with redundant, high efficiency cooling. It captures both packet and flow-based traffic for long-term retention of raw, indexed data. Having this data allows you rapid...
event analysis of errors and anomalies. It can sustain full-duplex wire speed capture and write-to-disk.

♦ **Trading Multicast analytics**: Multicast is used in trading firms to deliver information on pricing, volume, and more. Getting this information as fast as possible is critical because it affects profits. Therefore, multicast streams use connectionless UDP rather than the connection-oriented TCP protocol to traverse the network. UDP has little overhead in comparison to TCP (like the three-way handshake). Hence, it is much faster and more efficient for traversing the network. However, UDP also has weaknesses that can have seriously negative implications for the trading network. Packets can be lost, arrive out of order, and/or be corrupted. Data is not retransmitted when this occurs with UDP, and even if it were, given the high speed of today’s trading, it would likely be too late. When any of these occur, it directly impacts trade execution. No data can mean that no trade or the wrong trade is placed. To partially overcome this weakness with UDP, multicast streams almost always use sequence numbers within their payload to allow detection of these events. As a network administrator in a trading firm, you likely monitor these sequence numbers quite closely looking for gaps in the numbers. In Observer, you are able to create custom feed definitions to monitor for missing sequence numbers if you are not using BATS, CME, Edge feed, JSE feed, LSE, Mold UDP 64, SIAC, FIX Fast. In addition to gap sequence detection and alarming, Observer can perform proximity analysis near anomalous events. What was occurring when the gap was detected? Proximity analysis shows you what was occurring on your network at or around the time the anomaly was detected. When a multicast gap is detected you want to quickly understand what may have caused it.

♦ **Microburst intelligence**: A microburst is an unusually large amount of data in a short time frame that saturates your network and adds to latency. Excessive microbursts, either in duration or utilization impact multicast streams and/or trading activity. You want to swiftly locate the time and cause of these microbursts, but given the enormous amount of data that crosses your network, this process can be difficult. With a GigaStor probe, the microburst analysis is fully automated after you define duration and utilization thresholds. You can sort through hours of collected data, alarm when thresholds are exceeded, and report on trends. You can rapidly correlate microbursts to degraded response time. Using the trending reports you can proactively address trends before they impact performance.

♦ **FIX capabilities**: FIX is a transport protocol used between trading companies. It contains what kind of trades are occurring (buy or sell), who is doing the trading, what the order ID is. Observer has full decode support for FIX (4.2, 4.4) along with support for all of the most significant FIX commands. If you need extended capabilities for monitoring FIX beyond what is available in Observer, you can create customized profiles. Using its FIX analytics, Observer can quantify execution times with transaction-by-transaction analysis and send alarms when specific conditions are met. You can use filters to parse vast amounts of traffic quickly by trading station, time, and many other parameters.
Analyzing FIX transactions

The Financial Information eXchange (FIX) protocol is an electronic communications protocol used for international real-time exchange of information related to the securities transactions and markets.

If you need visibility into the FIX protocol you must be able to see and use the raw packet data in the area above the header. The GigaStor probe provides you access to it.

Use the FIX Analysis tab in the GigaStor Control Panel to highlight only FIX data and to select of the timeframe in question. The capability to filter on a trade by order ID for further analysis or to validate a specific transaction can be accomplished from this point. Use the filtering available in the GigaStor Control Panel to identify specific issues with a FIX transaction. And, finally, graph a response time graph for those transactions.

Outside of the GigaStor Control Panel, these other areas may be valuable for you when you are analyzing FIX transactions:

♦ Decode and Analysis in Observer—Allows you to decode and analyze the raw FIX information and presents it in an easy to read format. In the Decode and Analysis tab you can use filters and do post-capture analysis on specific FIX transactions that have issues.

♦ Application Transaction Analysis in Observer—Examines all transactions related to FIX even those beyond layer 4 into the application layer. Information about the transactions of applications for each request and the type of request are tracked. View a graph of response time and application error conditions or request and response results. ATA performs in-depth application analysis of each request or type of request by examining important information within the payload. This information typically involves massive amounts of data often best viewed in graphical format to more easily spot trends or patterns.

♦ Baseline and trending reports in Observer or Observer Reporting Server—Using Application Transaction Analysis you can create reports on all FIX statistics for capacity planning. If you have numerous probes from which you want FIX transactions aggregated and analyzed, then use Observer Reporting Server (sold separately).

Configuring a FIX profile

Observer uses profiles to analyze FIX data. Default profiles are in three main categories: pre-trade, trade, and post-trade. Within each category, there are numerous variants that allow you to focus on a specific trade type, such as "Pre-trade: Quote Negotiation." You can use the settings described here to edit, create, import, or export a FIX profile.

Table 53. FIX Settings

<table>
<thead>
<tr>
<th>This option...</th>
<th>Allow you to do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>FIX Profile</td>
<td>Lists the name of the current profile. The current profile is the rest of the dialog window, including the General Settings and the Type/Message.</td>
</tr>
<tr>
<td>Edit</td>
<td>Use this button to rename, add a new, or delete a profile. If you have numerous GigaStor probes where you want to use the...</td>
</tr>
<tr>
<td><strong>This option...</strong></td>
<td><strong>Allow you to do this...</strong></td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>same FIX analysis options, modify or create the profiles on one system, export them, and import them into the other GigaStor probes.</td>
<td>Import</td>
</tr>
<tr>
<td>Use this button to import FIX profiles that was created and exported from another Observer.</td>
<td>Export</td>
</tr>
<tr>
<td>Use this button to export a FIX profile.</td>
<td></td>
</tr>
</tbody>
</table>

**General Settings**

| **Maximum tracked requests** | Lists the maximum number of requests to be tracked during the time frame selected in the Detail Chart. The default is 1000 requests. Typically, 1000 requests should be sufficient to provide the information you seek. If it is not, you may increase or decrease it. By increasing the amount of requests, the amount of system resources needed to analyze the requests is also increased, which means the analysis will take longer to complete. |
| **Ignore duplicate requests** | If selected, duplicate requests are ignored. This is the default setting. If unchecked, duplicate requests may be present in the analysis and reduces the number of unique requests in the tracked requests. |
| **Maximum displayed results** | Defines the maximum number of results to display in the GigaStor Control Panel for the fastest or slowest responses. |
| **Track not responded requests within** | Amount of time used as the threshold that the GigaStor should wait for a response to a request before discarding the request from its analysis data set. If you want only requests that have received a response, uncheck this option. |
| **Type and Message** | Type and Message are options defined in the FIX protocol specification. If Track is selected, the FIX transaction type will be part of this analysis profile. All untracked options are ignored for this profile. |

**Troubleshooting the GigaStor Control Panel**

Use the information in this section to assist you if you have a problem with the GigaStor Control Panel.

**GigaStor Control Panel option is grayed out**

If the Capture > GigaStor Control Panel option is grayed out and unavailable, one of two things has likely occurred.

- You are not looking at a probe instance (passive or active) from the GigaStor probe. Verify you are using a probe instance for the GigaStor probe. If you are, then consider the next option.
- You are viewing a Packet Capture instead of the GigaStor Control Panel. You can only view one or the other. You cannot view both simultaneously. Close the Packet Capture window, then choose Capture > GigaStor Control Panel.

Now that you are viewing the GigaStor Control Panel, you may want to change your packet capture scheduling and ensuring that you do a “GigaStor” capture rather than a packet capture.
GigaStor is full or does not have the history you expect

Your GigaStor has storage space to capture your network’s traffic. The GigaStor probe will save data until its hard drives are full (or you fill the storage capacity of a GigaStor Software Edition), then one of two things will happen.

The GigaStor will stop capturing packets and saving them to disk or it starts overwriting the oldest data first so that you have a rolling window of capture. The option that controls how the GigaStor behaves in the Settings—General Options tab.

If you do not have as much history as you think you should, then consider:

♦ Pre-filtering your captures. Although this will provide more space for your captures, by definition you are excluding some traffic. The traffic you exclude may be just the traffic you need to analyze at some point.

♦ Capturing only partial packets. If you do not need to analyze the payload of every packet, then consider capturing the headers of packets.

♦ Purchasing a larger capacity GigaStor hardware probe or software license.

TCP applications are not appearing in the GigaStor Control Panel

If the GigaStor Control Panel is not displaying all of the applications you expect to see, ensure the “Limit to ports defined in Protocol Definitions” in Settings >General is unchecked.

Loading decodes in Observer is slow

If your Observer is taking a long time to load a decode from a GigaStor probe, you may be attempting to mine too much data. Too improve performance, use filters to limit the packets you want to decode, shorten the time frame you are mining, or both.
Chapter 19: Backups and Restoring

Many of the tools in Observer have the ability to import and export settings. You can use this functionality to back up or restore certain parts of your software configuration.

Configuring a FIX profile

Observer uses profiles to analyze FIX data. Default profiles are in three main categories: pre-trade, trade, and post-trade. Within each category, there are numerous variants that allow you to focus on a specific trade type, such as "Pre-trade: Quote Negotiation." You can use the settings described here to edit, create, import, or export a FIX profile.

Table 54. FIX Settings

<table>
<thead>
<tr>
<th>This option...</th>
<th>Allow you to do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>FIX Profile</td>
<td>Lists the name of the current profile. The current profile is the rest of the dialog window, including the General Settings and the Type/Message.</td>
</tr>
<tr>
<td>Edit</td>
<td>Use this button to rename, add a new, or delete a profile. If you have numerous Observer GigaStor probes where you want to use the same FIX analysis options, modify or create the profiles on one system, export them, and import them into the other GigaStor probes.</td>
</tr>
<tr>
<td>Import</td>
<td>Use this button to import FIX profiles that was created and exported from another Observer.</td>
</tr>
<tr>
<td>Export</td>
<td>Use this button to export a FIX profile.</td>
</tr>
</tbody>
</table>

General Settings

| Maximum tracked requests | Lists the maximum number of requests to be tracked during the time frame selected in the Detail Chart. The default is 1000 requests. Typically, 1000 requests should be sufficient to provide the information you seek. If it is not, you may increase or decrease it. By increasing the amount of requests, |
Sharing alarms with others

Observer alarms can be shared using the included import and export functions. Sharing is useful for making your alarms uniform across multiple installations, and it can even be used as a backup tool.

How to import alarms

To import alarms, you need access to an exported *.ALM file. You must bring this file back into Observer using the import process described here:

1. Click the Alarms Settings button, near the bottommost portion of the Observer window. The Alarm Settings window appears.
2. Click a probe instance to highlight it.
3. Click the Selected Instance Alarm Settings button. The Probe Alarms Settings window appears.
4. Click the Import Alarms button.
5. Navigate to, and select, your file; click Open.

You successfully imported an alarm file. The alarms contained within are now part of your local collection, including the triggers and actions associated with each alarm.

How to export alarms

To share alarms, the alarms must first be saved to a file. Create your file by following this export process:

1. Click the Alarms Settings button, near the bottommost portion of the Observer window. The Alarm Settings window appears.
2. Click a probe instance to highlight it.
3. Click the Selected Instance Alarm Settings button. The Probe Alarms Settings window appears.
4. Select each alarm you want to export.
5. Click the Export Checked Alarms button.
6. Give your file a name, and click Save.

You successfully exported your alarms to an *.ALM file. You can now share this file with other Observer installations or keep it as a backup copy.

Sharing application definitions with others

Application definitions can be shared using the included import and export functions. Sharing is useful for making your application definitions uniform across multiple installations, and it can even be used as a backup tool.

How to export application definitions

To share application definitions with other users, you must first save them to a file.

Create your file by following this export process:

1. Click the File tab, and click Options > Protocol Definitions.
2. Click any one of the applications definitions tabs (not the Server Application Discovery tab itself) to ensure one of these tabs has focus.
3. Click Tools, and click Export Current Application Definitions.
   The Export Application Definitions dialog appears.
4. Select the groups of definitions you want to export, and click Export.
5. Type a name for your file, and click Save.

You successfully exported your application definitions to a *.protodefs file.

You can now share this file with other users and installations, or keep it as a backup copy.

How to import application definitions

Prerequisite(s):

To import application definitions, you need access to an exported *.protodefs file. See How to export application definitions (page 71) for details.

To import application definitions, follow the import process:

1. Click the File tab, and click Options > Protocol Definitions.
2. Click any one of the applications definitions tabs (not the Server Application Discovery tab itself) to ensure one of these tabs has focus.
3. Click Tools, and click Import Application Definitions.
   The Open file dialog appears.
4. Locate and select the *.protodefs file that you want to import, and click Open.
The Import Application Definitions dialog appears.

5. Select the protocols to import and the importing behavior.

You successfully imported application definitions. The definitions you import are now part of your local collection.

Private key locations per server

Private key locations differ from application to application.

Microsoft Lync Server

Microsoft Lync Server encrypts all of its VoIP traffic, including the call set up process. To decrypt a Microsoft Lync server conversation, you must have the security certificate and Observer must see the telephone’s power up.

By default, the Lync Server key is not exportable. You must create an exportable key for Observer to use. Getting the Lync Server key is similar to that for the IIS Web Server. See Windows IIS Web Server (page 105).

Apache Web Server

Perform a search for the file with the name “server.key”. Check the format of the server.key file to ensure it is not an encrypted private key file. See Encrypted private key file (page 106).

However, if the private key file is encrypted, the private key file must be decrypted using the openssl command line tool and the password that was used to encrypt it. This utility can be obtained by following an appropriate link as follows:

- [http://www.openssl.org](http://www.openssl.org)
- For Windows compatible versions, use a search engine to search for the terms “Download,” “Win32,” and “OpenSSL”.

After obtaining the openssl command line utility, the private key file can be decrypted using the following command (choose the appropriate locations for the input and output files):

```
openssl rsa -in server.key -out UnencryptedKey.key
```
You can now use the newly created output key, in Observer, to successfully decrypt and analyze encrypted network traffic.

**Windows IIS Web Server**

Windows does not contain a searchable private key file. The key file must be extracted from the website server certificate, and the server certificate must contain the private key file.

Use the following Microsoft Support document to export your server certificate and private key to a single .pfx file: [http://support.microsoft.com/kb/232136](http://support.microsoft.com/kb/232136) (How to back up a server certificate in Internet Information Services).

After you successfully export the .pfx file (PKCS #12), you must obtain the openssl utility. This utility can be obtained by following an appropriate link as follows:

- [http://www.openssl.org](http://www.openssl.org)
- For Windows compatible versions, use a search engine to search for the terms “Download,” “Win32,” and “OpenSSL”.

With a valid .pfx server certificate backup file and the openssl utility, the following command should be used (choose the appropriate locations for the input and output files):

```
openssl pkcs12 -nodes -in c:\mycertificate.pfx -out c:\server.key
```

You can now use the newly created output key, in Observer, to successfully decrypt and analyze encrypted network traffic.

**Non-encrypted private key file**

A normal, non-encrypted private key file should contain text of the following format. Notice the absence of a "Proc-Type: ENCRYPTED" header.

A file of this format is usable by Observer.

```
-----BEGIN RSA PRIVATE KEY-----
MIICXgIBAAKBgQD7uhNymd6WCo0rgH0rp5zs4FEwCX2Jrktn0dmTf44SVA6vFLF1
vake0YP/sFs4aa2uAnOFCbFaS2w3IZWum4asCgvtb82il+13VcdyR+2SRx9GMbu
SnoL/6FI86m+C0ghq6g0IliTAJYn+MYCE2bwbMykzlrjPVUOXE9IEG0A0QIDAQAB
AoGAFQOywegVEmQRp2WN6YXnJKxVGBGcZrPdWr3gCO/ITXhYULT12I47Qld+i
-----END RSA PRIVATE KEY-----
```

**Encrypted private key file**

An encrypted private key file may have the following format, which indicates that the private key file obtained contains an RSA Private Key, where the text for the key itself is encrypted.

A file in this format will generate an error dialog stating “Error Loading the Private Key File!” You must decrypt this key file before it will function.

```
-----BEGIN RSA PRIVATE KEY-----
Proc-Type: 4,ENCRYPTED
DEK-Info:
DES-EDE3-CBC,7BC....
JHq80U0pDbeFM9h2j2Smiegx0a2q/MiX43XA4Es6nKmzu9oI/ZfpIdAHl8gwtsD
mZ5bQR1X9Axi1ry+0tg21bUaphQEv1995PwUsh89N9dVumsykmM5xSwD7tkbHb
i0/VSAAAD9bV3db15nbMwMnP+YC39S0GAK4ZriqrHRQ94fd/ZAvP8kV91lWcmX6
-----END RSA PRIVATE KEY-----
```
Importing and exporting VoIP or video conferencing settings

Settings for VoIP can be imported or exported into the Network Trending tool. Doing either is very useful depending on what you are trying to accomplish. For example, if you want to backup your settings or share your VoIP settings with other Observer installations, you should export your VoIP settings.

To import and/or export your VoIP settings, complete the following steps:

1. On the Home tab, in the Capture group, click **Network Trending > Network Trending**.
2. Click the **Tools** button.
3. Click Import or Export Settings. A file dialog appears, which allows you to complete the process.

Restoring the default application list

Under certain circumstances, it may be beneficial for you to restore the default application list. Doing so removes all of your custom or modified application definitions and returns your applications to default—exactly how the default installation would behave.

How to restore TCP application definitions

To restore the default TCP applications, complete the following steps:

1. Click the File tab, and click **Options > Protocol Definitions**.
2. Click the **TCP Application Definitions tab** to ensure it has focus.
3. Click the **Tools** button, and click **Restore Predefined TCP Applications**. A confirmation prompt appears.
4. Click **OK** to confirm.
5. (Optional) Select **Apply Changes Across All Probe Instances** if you want to apply these changes to all probe instances.
   
   **Apply changes across all Probe Instances** only applies changes to currently connected probes instances. The changes cannot apply to disconnected probe instances.
6. Click **OK** to apply and save your changes.

Your TCP application definitions list is now restored.

How to restore UDP application definitions

To restore the default UDP applications, complete the following steps:

1. Click the File tab, and click **Options > Protocol Definitions**.
2. Click the **UDP Application Definitions tab** to ensure it has focus.
3. Click the **Tools** button, and click **Restore Predefined UDP Applications**. A confirmation prompt appears. Click **OK** to confirm.
4. (Optional) Select **Apply Changes Across All Probe Instances** if you want to apply these changes to all probe instances.

**Apply changes across all Probe Instances** only applies changes to currently connected probes instances. The changes cannot apply to disconnected probe instances.

5. Click **OK** to apply and save your changes.

Your list is restored.

### Importing or exporting a server profile

You can import or export servers that you monitor from one Observer to another. This can save time and reduce typing errors if you have several Observer which you want to have the same servers be analyzed for application transaction analysis.

**Tip!** You can also logically group server applications and switch between profiles quickly by choosing a profile from the Profiles list.

1. On the Home tab, in the Analysis group, click **Application Transactions**.
2. Click the **Settings** button to define any application servers you want to monitor.
3. Click the **Import** or **Export** button.

First you must define the server applications and then export the server to create the *.ata file that you can later import.

### Creating a Forensic Settings profile

Forensics profiles provide a mechanism to define and load different pairings of settings and rules profiles. **Settings profiles** define pre-processor settings that let you tune performance; **rules profiles** define which forensic rules are to be processed during analysis to catch threats against particular target operating systems and web servers. Because Observer performs signature matching on existing captures rather than in real time, its preprocessor configuration differs from that of native Snort. When you import a set of Snort rules that includes configuration settings, Observer imports rules classifications, but uses its own defaults for the preprocessor settings.

**Note:** There is a difference between enabling the preprocessor and enabling logs for the preprocessor. For example, you can enable IP defragmentation with or without logging. Without logging, IP fragments are simply reassembled; only time-out or maximum limit reached messages are noted in the Forensics Log and in the Forensic Analysis Summary window. If logging is enabled, all reassembly activity is displayed in the Forensics Log (but not displayed in the Forensic Analysis Summary).

1. On the Home tab, in the Capture group, click **GigaStor**.
2. Click the **Forensic Analysis** tab.
3. Right-click anywhere on the Forensic Analysis tab and choose **Forensic Settings** from the menu. The Select Forensic Analysis Profile window opens.
4. Choose your profile and click **Edit**. The Forensic Settings window opens.
5. From the Forensic Settings window, complete the following:
   - Import Snort rules
   - Define Forensic Settings.
   - Define Rule Settings—Select the rules you want to enable.

6. Close all of the windows, then right-click anywhere on the Forensic Analysis tab and choose Analyze from the menu.

   Applies the rules and filters to the capture data and displays the results in the Forensics Summary tab.

   The top portion of the Rules window lists the rules that were imported, grouped in a tree with branches that correspond to the files that were imported.

   Rule classifications offer another level of control. Check the “Rules must also match rule classifications” box to display a list of defined rule classifications. Classifications are defined at import time by parsing the Snort config classification statements encountered in the rule set. Rules are assigned a classification in the rule statement’s classtype option.

   Select the rule classification(s) you want to enable. If classification matching is enabled, a rule and its classification must both be enabled for that rule to be processed. For example, suppose you want to enable all policy violation rules: simply right-click on the rule list, choose Enable all rules, and then enable the policy violation classification.

Table 55. Forensic Settings options

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings Profile</td>
<td>Settings Profiles provide a mechanism to save and load different preprocessor settings, and share them with other Observer.</td>
</tr>
<tr>
<td>IP Flow</td>
<td>Packets belong to the same IP flow if they share the same layer 3 protocol, and also share the same source and destination addresses and ports. If this box is checked, forensic analysis identifies IP flows (also known as conversations), allowing Snort rules to isolate packets by direction and connection state via the flow option. If this pre-processor is disabled, flow keywords are ignored, but the rest of the rule is processed. The remaining settings allow you to throttle flow analysis by limiting the number of flows tracked, and by decreasing the time window within which a flow is considered active.</td>
</tr>
<tr>
<td>IP Defragmentation</td>
<td>Some types of attacks use packet fragmentation to escape detection. Enabling this preprocessor causes forensic analysis to identify and reconstruct fragmented packets based on the specified fragment reassembly policy. Rules are then run against the reconstructed packets during forensic analysis. The fragment reassembly policy mimics the behavior of various operating systems in what to do when ambiguous fragments are received. Choose the policy to match the OS of the server (or servers) being monitored. If the buffer contains traffic targeting hosts with different operating systems, use post-filtering to isolate the traffic before forensic analysis so that you can apply the correct policy. Defragmentation Policy is: BSD=AIX, FreeBSD, HP-UX B.10.20, IRIX, IRIX64, NCD Thin Clients, OpenVMS, OS/2, OSF1, SunOS 4.1.4, Tru64 Unix, VAX/VMS</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td>Last data in</td>
<td>Cisco IOS</td>
</tr>
<tr>
<td>BSD-right</td>
<td>HP JetDirect (printer)</td>
</tr>
<tr>
<td>First data in</td>
<td>HP-UX 11.00, MacOS, SunOS 5.5.1 through 5.8</td>
</tr>
<tr>
<td>Linux</td>
<td>Linux, OpenBSD</td>
</tr>
<tr>
<td>Solaris</td>
<td>Solaris</td>
</tr>
<tr>
<td>Windows</td>
<td>Windows (95/98/NT4/W2K/XP)</td>
</tr>
<tr>
<td><strong>Refer to</strong> <a href="http://www.snort.org">http://www.snort.org</a> <strong>for more detailed version-specific information.</strong> The remaining options allow you to enable logging of alerts and reconstruction progress, limit the number of active packet fragments to track, and change the length of fragment inactivity that causes the fragment to be dropped from analysis.</td>
<td></td>
</tr>
</tbody>
</table>

TCP Stream Reassembly

Another IDS evasion technique is to fragment the attack across multiple TCP segments. Because hackers know that IDS systems attempt to reconstruct TCP streams, they use a number of techniques to confuse the IDS so that it reconstructs an incorrect stream (in other words, the IDS processes the stream differently from that of the intended target). As with IP fragmentation, forensic analysis must be configured to mimic how the host processes ambiguous and overlapping TCP segments, and the topology between attacker and target to accurately reassemble the same stream that landed on the target. Re-assembly options are described below:

TCP Stream Reassembly (Continued)

Log preprocessor events—Checking this box causes forensic analysis to display all activity generated by the TCP stream assembly preprocessor to the log.

Maximum active TCP streams tracked—If this value is set too high given the size of the buffer being analyzed, performance can suffer because of memory consumption. If this value is set too low, forensic analysis can be susceptible to denial of service attacks upon the IDS itself (i.e., the attack on the target is carried out after the IDS has used up its simultaneous sessions allocation).

Drop TCP streams inactive for this duration—A TCP session is dropped from analysis as soon as it has been closed by an RST message or FIN handshake, or after the time-out threshold for inactivity has been reached. Exercise caution when adjusting the time-out, because hackers can use TCP tear-down policies (and the differences between how analyzers handle inactivity vs. various operating systems) to evade detection.

TTL delta alert limit—Some attackers depend on knowledge of the target system’s location relative to the IDS to send different streams of packets to each by manipulating TTL (Time To Live) values. Any large swing in Time To Live (TTL) values within a stream segment can be evidence of this kind of evasion attempt. Set the value too high, and analysis will miss these attempts. Setting the value too low can result in excessive false positives.

Overlapping packet alert threshold—The reassembly preprocessor will generate an alert when more than this number of packets within a stream have overlapping sequence numbers.
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TCP Stream Reassembly</td>
<td><strong>Continued</strong></td>
</tr>
<tr>
<td></td>
<td>Reassembly error action—Discard and flush writes the reassembled stream for analysis, excluding the packet that caused the error. Insert and flush writes the reassembled stream, but includes the packet that caused the error. Insert no flush includes the error-causing packet and continues stream reassembly.</td>
</tr>
<tr>
<td></td>
<td>Reassembled packet size threshold range—Some evasion strategies attempt to evade detection by fragmenting the TCP header across multiple packets. Reassembling the stream in packets of uniform size makes this easier for attackers to slip traffic past the rules, so forensic analysis reassembles the stream using random packet sizes. Here you can set the upper and lower limits on the size of these packets.</td>
</tr>
<tr>
<td></td>
<td>Reassembled packet size seed value—Changing the seed value will cause forensic analysis to use a different pattern of packet sizes for stream reassembly. Running the analysis with a different seed value can catch signature matches that would otherwise escape detection.</td>
</tr>
<tr>
<td></td>
<td>Port List—Enabling the Port List option limits analysis to (or excludes from analysis) the given port numbers.</td>
</tr>
<tr>
<td>HTTP URI Normalization</td>
<td>Many HTTP-based attacks attempt to evade detection by encoding URI strings in UTF-8 or Microsoft %u notation for specifying Unicode characters. This preprocessor includes options to circumvent the most common evasion techniques. To match patterns against the normalized URIs rather than the unconverted strings captured from the wire, the VRT Rules use the uricontent option, which depends on this preprocessor. Without normalization, you would have to include signatures for the pattern in all possible formats (using the content option), rather than in one canonical version.</td>
</tr>
<tr>
<td></td>
<td>Log preprocessor events—Checking this box causes forensic analysis to save any alerts generated by the HTTP preprocessor to the log, but not the Forensic Summary Window.</td>
</tr>
<tr>
<td></td>
<td>Maximum directory segment size—Specifies the maximum length of a directory segment (i.e., the number of characters allowed between slashes). If a URI directory is larger than this, an alert is generated. 200 characters is reasonable cutoff point to start with. This should limit the alerts to IDS evasions.</td>
</tr>
<tr>
<td></td>
<td>Unicode Code Page—Specify the appropriate country code page for the traffic being monitored.</td>
</tr>
<tr>
<td></td>
<td>Normalize ASCII percent encodings—This option must be enabled for the rest of the options to work. The second check box allows you to enable logging when such encoding is used.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>HTTP URI Normalization (Continued)</strong></td>
<td>Normalize percent-U encodings—Convert Microsoft-style %u-encoded characters to standard format. The second check box allows you to enable logging when such encoding is encountered during preprocessing. Because such encoding is considered non-standard (and a common hacker trick), logging occurrences of this is recommended. Normalize UTF-8 encodings—Convert UTF-8 encoded characters to standard format. The second check box allows you to enable logging when such encoding is encountered during preprocessing. Because Apache uses this standard, enable this option when monitoring Apache servers. Although you might be interested in logging UTF-8 encoded URIs, doing so can result in a lot of noise because this type of encoding is common. Lookup Unicode in code page—Enables Unicode codepoint mapping during pre-processing to handle non-ASCII codepoints that the IIS server accepts. Normalize double encodings—This option mimics IIS behavior that intruders can use to launch insertion attacks. Normalize bare binary non ASCII encodings—This an IIS feature that uses non-ASCII characters as valid values when decoding UTF-8 values. As this is non-standard, logging this type of encoding is recommended. Normalize directory traversal—Directory traversal attacks attempt to access unauthorized directories and commands on a web server or application by using the '/../' and '/../' syntax. This preprocessor removes directory traversals and self-referential directories. You may want to disable logging for occurrences of this, as many web pages and applications use directory traversals to reference content. Normalize multiple slashes to one—Another directory traversal strategy is to attempt to confuse the web server with excessive multiple slashes. Normalize Backslash—This option emulates IIS treatment of backslashes (i.e., converts them to forward slashes).</td>
</tr>
</tbody>
</table>
| **ARP Inspection** | Ethernet uses Address Resolution Protocol (ARP) to map IP addresses to a particular machine (MAC) addresses. Rather than continuously broadcasting the map to all devices on the segment, each device maintains its own copy, called the ARP cache, which is updated whenever the device receives an ARP Reply. Hackers use cache poisoning to launch man-in-the-middle and denial of service (DoS) attacks. The ARP inspection preprocessor examines ARP traffic for malicious forgeries (ARP spoofing) and the traffic resulting from these types of attacks. Log preprocessor events—Checking this box causes forensic analysis to save any alerts generated by the ARP Inspection preprocessor to the log, but not the Forensic Summary Window. Report non-broadcast requests—Non-broadcast ARP traffic can be evidence of malicious intent. Once scenario is the hacker attempting to convince a target computer that the hacker’s computer is a router, thus allowing the hacker to monitor all traffic from the target. However, some devices (such as printers)
## Field Description

- use non-broadcast ARP requests as part of normal operation. Start by checking the box to detect such traffic; disable the option only if analysis detects false positives.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Telnet Normalization</td>
<td>Hackers may attempt to evade detection by inserting control characters into Telnet and FTP commands aimed at a target. This pre-processor strips these codes, thus normalizing all such traffic before subsequent forensic rules are applied.</td>
</tr>
<tr>
<td></td>
<td>Log preprocessor events—Checking this box causes forensic analysis to save any alerts generated by the Telnet Normalization preprocessor to the log, but not the Forensic Summary Window.</td>
</tr>
<tr>
<td></td>
<td>Port List—Lets you specify a list of ports to include or exclude from Telnet pre-processing. The default settings are appropriate for most networks.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Variable Name</th>
<th>A scrollable window located below the preprocessor settings lists the variables that were imported along with the Snort rules. Variables are referenced by the rules to specify local and remote network ranges, and common server IP addresses and ports. You can edit variable definitions by double-clicking on the variable you want to edit.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The VRT Rule Set variable settings (and those of most publicly-distributed rule sets) will work on any network without modification, but you can dramatically improve performance by customizing these variables to match the network being monitored. For example, the VRT rules define HTTP servers as any, which results in much unnecessary processing at runtime.</td>
</tr>
<tr>
<td></td>
<td>Address variables can reference another variable, or specify an IP address or class, or a series of either. Note that unlike native Snort, Observer can process IPv6 addresses.</td>
</tr>
<tr>
<td></td>
<td>Port variables can reference another variable, or specify a port or a range of ports. To change a variable, simply double-click the entry. The Edit Forensic Variable dialog shows a number of examples of each type of variable which you can use as a template when changing values of address and port variables.</td>
</tr>
</tbody>
</table>

## Importing Snort rules

After getting the Snort rules from [http://www.snort.org](http://www.snort.org), follow these steps to import them into Observer.

1. On the Home tab, in the Capture group, click **GigaStor**.
2. Click the **Forensic Analysis** tab.
3. Right-click anywhere on the Forensic Analysis tab and choose Forensic Settings from the menu. The Select Forensic Analysis Profile window opens.
4. Choose your profile and click Edit. The Forensic Settings window opens.
5. At the bottom of the window, click the **Import Snort Files** button.
6. Locate your Snort rules file and click Open. Close all of the windows. After you import the rules into Observer you are able to enable and disable rules and groups of rules by their classification as needed.

Observer displays a progress bar and then an import summary showing the results of the import. Because Observer’s forensic analysis omits support for
rule types and options not relevant to a post-capture system, the import summary will probably list a few unrecognized options and rule types. This is normal, and unless you are debugging rules that you wrote yourself, can be ignored.

7. To use the Snort rules you just imported, right-click anywhere on the Forensic Analysis tab and choose Analyze from the menu.
Index

Numerics
10 Gb Probe  21, 258
25901 (port) 241
25903 (port) 241
32-bit 235
3-D Pie/Chart Display Properties 78
64-bit 235, 288
64-bit, RAM 235
802.11 225, 225, 228, 250, 272
802.1Q 243, 282
AES 152, 269, 269, 282
Agent Information Windows 205
Agent Information Windows, SNMP 205
agents  200, 204, 205
aggregator 325
Alarm Settings 142
alarms  147, 147, 147, 147, 147, 147, 147, 147, 148, 148, 148, 185, 185, 228, 240, 250, 351, 351, 351, 351, 351, 351, 351, 351, 351, 351
configuring 142, 142, 146
customizing 146, 146, 146, 146, 146, 146
enabling 142, 142, 143, 143
exporting 147, 147, 351, 351
filter-based, creating 144, 144
high latency 143
importing 148, 148, 351, 351
resetting 145, 145, 145
retransmissions, excessive 143
VoIP 185, 185
allocating 238
analyzer connection 241
analyzing 330
analyzing data  178, 178, 326, 327, 344, 344
Anue 325
Anyone account  241, 241
Apache Web Server 105, 353
Application Definitions and Server Application
Discovery Settings 62
Application Discovery, Server 68
Application Performance Analysis 286
about 159
collection intervals 159
configuring 160
response time calculation 159
Application Transaction Analysis 164, 286
about 163, 164
response time calculation 163
Application Transaction Analysis - Graph Properties
164
Application Transaction Analysis Trending Specific -
Servers 164
applications, analyzing 164, 172
applications, see server applications 68
applying 97, 97, 118
ArcaBook Multicast 68
archiving data 318
Arista 325
ARP inspection 332, 356
ARP inspection, network forensics preprocessor 332, 356
as probe or analyzer 286
Asset ID 156
Asset name 156
Asset type 156
ATA 167
ATM 264, 264, 272, 273
ATM Address Filter 89
autoupgrade 269
Autoupgrade tab 272
autoupgrading 269, 272

B
backup
  installation 21, 258
backups 260
bad TCP checksums 242
  troubleshooting 242
Bandwidth Utilization 44
Bandwidth Utilization - Full Duplex Display 44
Bandwidth Utilization tool 44, 44, 45
Bandwidth Utilization with Filter 45
best practices 226
BFR 34, 82, 104
BIOS memory hole 235
Box ID 235
broadcast and multicast storms 54
broadcast traffic 265
buffer 232
buffer size 226, 320
buffer statistics 232
buffer, see capture buffer and statistics buffer 232
buffers 226, 228, 228, 228, 235, 237, 250, 250, 250
  circular 80, 80
  configuring 75, 79
  replaying 111
bugtraq 331, 331
building 58, 58, 58, 59, 59, 59

C
Calculate Cumulative Bytes 112
calculating
  network delay 124
  response time 125
caller ID 184
CAP 82, 104
capacity 305
Capture Application Transaction Analysis 164
capture buffer
  64-bit Windows 232
  FIFO 308
  IP defragmentation 332, 356
  Max Buffer Size 232
  overwriting 308
  physical ports 308
  RAM limitations 232
  size 232
  TCP stream 332, 356
capture card 47, 77, 271
driver requirements 23, 255
  filter ports 308
  passive probe instance 226
  performance 226
  ports 308
  probe instance warning 226
  recommendations 239
  statistics 308
  time synchronization 271
capture card driver 23, 255
Capture Decode 114
capture decodes 272
Capture Graph 78
Capture Internet Observer 39
Capture Pairs (Matrix) 41
Capture Protocols 42
Capture Summary 48
Capture Top Talkers 46
Capture VLAN 56
captures
  see packet captures 85
see packet captures 85
capturing 84
capturing packets 313
CAPWAP Control 68
CAPWAP Data 68
CDU 272
Certificate ID 156
CIFS 163
CIR 142
circular 80, 80
Cisco 6xxx switches 246
  troubleshooting 246
Cisco EAP/LEAP 287
Classic Mode 35
clock synchronization 271
CME RLC 68
collecting data 271
Collecting Information in Charts, Lists, Forms, Tables and Traps 213
collection interval 247, 299
collection intervals 159
collision test 245, 245
color codes 132
command line 99, 99
command line, enabling 98, 98
Committed Information Rate 142
common issues 239
common problems with 240, 241
Configure IP Application List for Internet Observer Statistics Dialog 39
Configure IP Application Ports Dialog 41
configuring 44, 75, 78, 79, 79, 80, 81, 84, 123, 123, 134, 134, 134, 134, 134, 138, 138, 142, 142, 146, 146, 169, 172, 269, 272, 272, 272, 272, 272, 308, 319
  Expert Information 79
  network trending folder 269
  partial packets 81, 81, 81
  probe name 269
configuring statistics memory 270
connecting 266
connecting to analyzer 266, 266, 266, 266, 267, 271
Connection Dynamics 103
  about 131
  color codes 132
  packet types 132
  using 131
connections 39, 39, 39, 41, 41, 41, 46
content 277, 277
context 277, 278
contextual visibility 277, 278, 280
cPacket 325
CRC-16 273
CRC-32 273
creating 84, 96
CSU 272
capsulation 273, 273
custom decode DLLs 110
customizing  146, 146, 146, 146, 146, 146

customizing

D3 272
D3/E3/HSSI 272
DAAP 130
data rate  170, 306
data storage 320
data, collecting  168, 170
data, deleting  168
data, viewing 168
daylight savings time 245
Daylight Savings Time  245, 245

Decode and Analysis 114
decode API  223
decode DLLs, custom 110
Decode pane 325
decodes
  troubleshooting 349
decoding  103, 103, 106, 112, 117, 118, 118, 134, 177, 177, 177, 228, 228, 228, 228, 250, 250, 250, 313, 331
expert analysis  103, 131
  configuring 122, 123, 123
  summary view 125
  using 126
expert thresholds
  configuring 134, 134
geolocation 34
NetFlow  109, 118
packet captures  103, 103, 103, 103, 106, 117
  encrypted 105, 105, 106, 106, 353, 353
reconstruction 130
sFlow  109, 118
user interface 112, 112, 114, 114
using third party decoder  34, 34
VoIP  177, 177
defining its purpose 238
definition 225
definitions, restoring  73, 355
deleting
  network trending data 168
denial of service  332, 356
derived application definitions 71
derived applications 30
Device Configuration 109
devices 63, 183
  discovering 63, 63, 63, 65
DHCP 163
DHCPv6 163
Diameter 163
difference from packets 315
difference from statistics 315
directory 320
Discover Network Names 244, 244, 244
  VLANs 244

Discover Network Names (Address Book) 62
Discover Network Names Mode 62
Discover Network Names tool 58, 59
Discover SNMP Devices 63
discovering 62, 62, 62, 63, 63, 63, 65, 65
discovery method 58, 58
Display Protocols for Selected Station 42
Display Stations sending Selected IP 103
DLCl Address Filter 89

DLCI CIR Setup 142
DLLs 110
DLLs, custom decode 110
DMP  82, 104
DNS 59, 60, 163
DNS names
  resolving 60
DNS resolution 269
driver error support 49
driver requirements  23, 23, 23, 255, 255, 255
drivers, wireless 256
DS3
  fractionalized 273
DSU
  encapsulation 273, 273
duplicate, removing 84, 125
dynamic 72
dynamic traffic management 277, 277, 280

E1 272
  WAN relay type 273
E3 272
  fractionalized 273
EAP/LEAP 287
effect 151
effect 151
effects of packet capture 237
efficiency 151
e-mail, via 192
E-Model 181
enabling 142, 142, 143, 143
ENC  82, 104
capsulation  272, 273, 273, 273, 273, 273, 273, 273, 273, 273, 273
crypted 105, 105, 106, 106, 353, 353
crypted traffic 106
cryption 30, 30, 30, 30, 30, 269, 269
  AES  152, 282
  see also security 152, 282
cryption key 241, 258, 269, 287
cryption keys 258
End to End Server Analysis - MultiHop Analysis 127
End to End Server Analysis - Server Analysis 127
End to End Server Analysis Settings - Display - End to End Analysis 127
End to End Server Analysis Settings - Display - Response Time 127
End to End Server Analysis Settings - Display - Server Load 127
End to End Server Analysis Settings - Display - Utilization 127
using 127, 127, 127, 127
entries, adding 59, 59, 61
Error Filter 89
errors 49, 50, 50, 50, 52
Ethernet 52
Errors by Station 50
Errors by Station tool 50
ErrorTrak 17, 249
ESX/ESXi
troubleshooting 24, 25, 26
Ethernet 52, 225, 225, 228, 272
ARP inspection 332, 356
ers 52
full-duplex 228, 250
jumbo frames 272
Ethernet Physical Port 327
Ethernet Physical Port filter 327
Ethernet Physical Port Filter 89
Ethernet Vital Plot Properties 49
Ethernet Vital Signs 49
Ethernet Vital Signs and Collision Expert 49
expert analysis 103, 131
configuring 122, 123, 123
see decoding 125
summary view 125
using 126
Expert Connection Dynamics 103
Expert Fibre Events 103
Expert Global Settings 103
Expert Global Settings - Connection Dynamics 103
Expert Global Settings - General 103
Expert Global Settings - IP Range 103
Expert Global Settings - TCP IP 103
Expert Global Settings - Time Interval Analysis 103
Expert Global Settings - What-if Analysis 103
Expert ICMP Events 103
Expert Information 79, 79
Expert Information, excluding 79
Expert IPX Events 103
Expert NetBIOS Events 103
Expert Probe 228, 228, 228, 250, 250, 269, 285, 285
as probe or analyzer 286
changing NIC 265
configuring 272, 272
connecting to analyzer 266
data transfer 285
GigaStor 285
NetFlow 247, 299
port bonding 296
redirection 266
Expert Reconstruct Streams 103
Expert Server Analysis 103
expert summary 228, 250
Expert Summary 103
Expert TCP Dump 103
Expert TCP Events 103
expert thresholds
configuring 134, 134, 134, 134
Expert Thresholds (OSI Model) 134
Expert Time Interval Analysis 103
Expert UDP Events 103
Expert VoIP 103
Expert VoIP Analysis 103
Expert VoIP Events 103
Expert VoIP Settings - General 103
Expert VoIP Settings - MOS 103
Expert VoIP Settings - VoIP Summary Graph 180
Expert What-If Analysis 103
Expert Wireless Events 103
exporting 62, 62, 147, 147, 176, 351, 351, 355
alarms 147, 147, 147, 147, 176, 351, 351, 351, 351, 351
protocol definitions 62
server applications 70, 71, 352, 352
VoIP 176, 355
F
Fabric Manager 277, 277, 278, 279, 280
FDDI 103
FDDI Errors by Station 49
FDDI Vital Signs 49
feature suitability 81
Federal Information Processing Standards 149
Fibre Channel Vital Signs 49
FIFO 279, 308
FIFO buffer 280
files included 223
filter 326
Ethernet Physical Port 327
Filter Names 89
filter ports 308
filter-based, creating 144, 144
filtering 89, 330
post-filters
applying 97, 97, 118
command line 99
command line, enabling 98
pre-filters
"exclude" rules 89
creating 89, 89, 96
exporting 89
importing 89
scope 96
pre-filters, scope 96
VoIP 177
filtering telephone numbers 177
filtering, physical 327
filters 247, 247, 299, 299, 326, 326, 327, 328, 330
activate and deactivate 96, 96
clearly enabling 98
command line 99
command line, enabling 98
see also filtering 89
partial packets 84
Filters 89, 90
Find Packet 117
finding a specific time 324
FIPS 149, 149
firewall, ports 241
FIX 114, 163, 164, 347
FIX protocol 347
Folders tab 32
forensic analysis 330, 332, 337, 338, 356
format
PCAPNG 82, 104
XML 82, 104
formats 82, 104
BFR 82, 104
CAP 82, 104
DMP 82, 104
ENC 82, 104
PCAP 82, 104
fractionalized 272, 273, 273, 273, 273

frame check sequence 272
frame checksum 272
full-duplex Ethernet 228, 250
G
General tab 272
GeoIP Settings 34
geolocation 34, 34
getting started 301
Gigabit 228, 272
Gigabit Probe 21, 258
Gigabit tab 272
gigabytes 232, 232
Gigamon 277, 277, 278, 282, 325
Gigamon GigaSMART 325
Gigamon H-Series 325
GigaStor 238, 265, 279, 280, 285
about 303
AES 269
collision test 245
crypto 269
Expert Probe 285
getting started 301
indexing 316
RAM 238
recommendations 239
reserved memory 238
traffic generation 245
virtual machine with 288
GigaStor capture 226, 228, 250
GigaStor Control Panel 312
analyzing data 178, 178, 326, 327, 344, 344
archiving data 318
buffer size 320
capturing packets 313
configuring 308, 319
filters 326, 327, 328
finding a specific time 324
FIX 347
forensic analysis 330, 332, 337, 338, 356
getting started 301
importing 61, 61, 61, 62, 62, 70, 148, 148, 176, 351, 351, 352, 355
addresses 61
alarms 147, 147, 148, 148, 148, 351, 351, 351, 351, 351
protocol definitions 62
server applications 70, 352
VoIP 176, 355
in a switched environment 230
included, files 223
indexing 312, 316, 316
individual stations 41, 41, 41, 46
install 20, 254
installation 20, 20, 21, 21, 223, 254, 254, 254, 258
installer 20, 254
installing 20, 20, 21, 254, 254, 254
Interface Properties 103
interface switching 228, 250
Internet Observer 39
Internet Observer Internet Patrol 39
Internet Observer IP Subprotocols View 39
Internet Observer Settings 39
Internet Observer tool 39, 39, 39
Internet Patrol 39
Internet Patrol - Pair Circle 39
IP address
GigaStor 265
IPv6 332, 356
NAT 245
statistics 321
IP Calculator 62
IP defragmentation 332, 356
IP Discovery 62
IP flow 332, 356
IP Fragment Bits Filter 89
H
H.245 163
H.248 163, 163
H.323 103, 163
hardware 18, 234, 252, 304
hardware acceleration 239
hardware requirements 17, 249
hidden features
See Classic Mode
high latency 143
high-volume 330
HSSI 272, 273
HSSI, fractionalized 272
HTTP 130, 163
I
ICA 163
ICMP Expert 103
Ignore response times longer than 167
IIS Web Server, Windows 105, 353
IMAP 163
IMAP4 130
importing 61, 61, 61, 62, 62, 70, 148, 148, 176, 351, 351, 352, 355
address book 61
alarms 147, 147, 148, 148, 148, 351, 351, 351, 351, 351
protocol definitions 62
server applications 70, 352
VoIP 176, 355
in a switched environment 230
included, files 223
indexing 312, 316, 316
individual stations 41, 41, 41, 46
install 20, 254
installation 20, 20, 21, 21, 223, 254, 254, 254, 258
installer 20, 254
installing 20, 20, 21, 254, 254, 254
Interface Properties 103
interface switching 228, 250
Internet Observer 39
Internet Observer Internet Patrol 39
Internet Observer IP Subprotocols View 39
Internet Observer Settings 39
Internet Observer tool 39, 39, 39
Internet Patrol 39
Internet Patrol - Pair Circle 39
IP address
GigaStor 265
IPv6 332, 356
NAT 245
statistics 321
IP Calculator 62
IP defragmentation 332, 356
IP Discovery 62
IP flow 332, 356
IP Fragment Bits Filter 89
IP Fragment Offset Filter 89
IP mapping 140, 141, 141, 141
IP masquerading, see NAT 245
IP Pairs – Pair Circle 103
IP precedence 272, 272
IP Properties 103
IP range 184
IP Subnet Mask Calculator 62
IP Subprotocols 103
ipsubnetrange 172
IPTV 321
IPv4 264, 264
IPv4 Options Filter 89
IPv4 TOS Precedence 81
IPv6 33, 264, 264, 332, 332, 356, 356
IPv6 Address representation 103
IPv6 Flow Label 81
IPv6 Options Filter 89
IPv6 Traffic Class 81
Issuing time 156
IXIA 325
IXIA Anue 325
J
jitter
calculating 187
Jitter 103
jumbo frames 272, 272, 272
L
LAPB 272
laptop
   NICs 287
      using as probe 287
      wireless 287
Last seen IP 156
Last seen time 156
Layer 3 Switch 244
LDAP 96, 96, 163
license 260, 305
license update 22, 259
licenses
   redeeming 21, 258
   troubleshooting 21, 258
licensing 22, 259
limitations 159, 159, 164
limitations of 286
line frame 272
List Bar Display Properties 103
List Display Properties 103
load 43
   preprocess settings 332, 356
load, preprocessor 226
load, testing 47, 47, 128
loading 82, 104
local probe 27
Locator, Switch Station 62, 65
M
MAC address
   statistics 321
MAC addresses 244
Mac Header 264, 264
MAC Properties 103
macro graph, see Outline Chart 324
Management Console 201, 216, 216
Management Station 201
matching between probe and analyzer 241
Matrix 325, 326
Max Buffer Size 232
MDS Fingerprint 156
Mean Opinion Score (VoIP Expert) 103
megabytes 226
MEGACO 163
memory 234, 234
memory allocation 270
memory management 232
memory tuning 232
memory, see RAM 237
merging 83
MIB 198
   see SNMP 198, 210
see SNMP 198, 210
MIB Compiler 195
MIB Editor 195
   adding MIBS 213
   requests 207
   SNMP agents 206
   viewing MIBs 215
MIB Editor, using 202, 206, 208, 210, 211, 211, 212,
   212, 214
MIB Walker 195
MIB Walker, using 214, 216
MIBs 195
micro graph, see Detail Chart 324
microburst analysis 324
microbursts, about 338, 338
microbursts, searching for 338
Microsoft 24, 257
Microsoft Lync Server 105, 353
Microsoft Network Discovery 62
minimum specifications 18, 252, 304
minimum specs 18, 252, 304
mining data 321, 324
mirror port 230
mirror port, see also SPAN ports 230
missing 86, 241
missing features
   See Classic Mode
missing from Observer 265
Modify Observer Reserved Memory dialog 103
MOS 181
MOS Settings 103
moving through RAM 237
MPLS 228, 250, 262, 264, 264, 272, 272
   ATM 264
   IPv4 264
   IPv6 264
   Mac Header 264
   pseudowire word 264
MPLS Filter 89
Msft (Microsoft) Configuration 62
MSRPC 163
Multi Probe 228, 228, 250
   changing NIC 265
   configuring 272, 272
   connecting to analyzer 266
   data transfer 285
   limitations of 286
   redirection 266
multicast 260
Multicast Pitch 68
MultiHop Analysis 135
  configuring 138, 138
  IP mapping 140, 141, 141, 141
  synchronization method 138, 138
  user offset 138, 140
  using, quickly 137
Multiple Address Tables 62
Multiple Filters 89
multiple in a system 271

N
  name, changing 269
  naming 263
  NAT 245, 245, 245
  NetFlow 109, 109, 118, 228, 245, 247, 250, 272, 299
    decoding 118
    TAPs and 245
    versions supported 247, 299
  NetFlow collector 247, 299
  NetFlow Device Configuration 109
  NetFlow Trending collector 247, 299
  NetScaler 325
  network 49, 49, 49, 50, 50, 54
    errors 50
    load 43
    load, testing 47, 47, 128
    summary 48, 48
    troubleshooting 48, 49, 49, 49
    utilization 43, 44, 44, 45, 45, 48, 48
  Network 1 probe instance 263
  Network Activity Display Properties 54
  network adapter
    capture card 47, 77
    configuring 44
  network adapter, see also NIC 265
  Network Device Properties - Data Logging Tab 197
  Network Device Properties - Description Tab 195
  Network Device Properties - Notification Tab 197
  Network Errors Settings 50
  Network Intrusion Detection 330, 330
  network load 43, 47, 47
  viewing 324
  network masquerading, see NAT 245
  network packet broker 277, 277, 278
  Network Summary 48
  Network Summary tool 48
  network trending 171, 180, 181, 228, 240, 250, 287
    about 164
    Application Performance Analysis
      about 159
      collection intervals 159
      configuring 160
    Application Transaction Analysis 163
    applications, analyzing 164, 172
    configuring 169, 172
    data, collecting 168, 170
    data, deleting 168
    data, viewing 164, 168
    devices 183
    disk space requirements 171
    enabling 175
    filters 247, 299
    hard drive space 171
  IP range 184
    limitations 159, 159, 164
    MOS 181
    sampling divider 247, 299
    scheduling 170
    server profiles 165, 356
    settings 180, 181
    VoIP 175, 180, 181, 181, 183, 184
  Network Trending 158, 260
    network trending default location 171
    network trending disk space requirements 170, 306
    network trending folder 269
    Network Trending Folder 171
    network trending hard drive space 170, 306
    network trending limit 171
    network trending max 171
    network trending maximum 171
    Network Trending Schedule 170
    Network Trending Settings - MOS 103
    network trending space required 170, 306
    network trending storage limits 171
    Network Trending Viewer 168
    Network Vital Signs tool 49
  New MIB Object Dialog 214
  New Trap Dialog 195
  NFS 163
  NIC 228, 250, 256
    broadcast traffic 265
    changing 265
    missing 241, 265
    missing from Observer 265
    multiple in a system 271
  NICs 287
  NIDS 330
  NIProbe.exe 21, 258
  NNTP 130
  no network card 265
  not connecting 241
  notifications 192, 192, 192, 193, 193, 193, 194, 194
  Notify Probe User 81
  NPB 277, 277, 278
  Numeric Value Filter 89

O
  Observer
    encryption 30
    feature suitability 81
    no network card 265
    notifications 192, 192, 192, 193, 193, 193, 194, 194
    regulation compliance 149
    switching to probe 228, 250
    system requirements 17, 249
    user interface 27
  Observer Analyzer 21, 258
  Observer General Options - folders 103
  Observer General Options - IPv6 103
  Observer General Options - Security 103
  Observer General Options Tab 103
  Observer GigaStor 21, 258
  Observer Management Server 269
  Observer settings 308
  Observer Suite Custom Decode Kit
    decode API 223
    installation 223
    using 222
warranty 223
observer.exe 21, 258
OID
see SNMP 200
see SNMP 200
OMS 30, 30, 30, 30, 30, 228, 250, 269
SafeNet HSM 106
synchronizing protocol definitions 62
OpenView 143
operating system 19, 253
options 269
OR filter example 96
OID see SNMP 200
OSI Layer 7 286
other codecs 130
overwriting 308

P
packet 332, 356
analyzing 330
decoding 331
sampling 308
packet alert threshold 332, 356
packet broker 279, 280
packet broker integration 279
Packet Broker Integration tab 277
packet capture 237, 272, 272, 314, 314, 314, 320
active instance vs. passive instance 226
buffer 232
daylight savings time 245
decoding 228, 250, 313
GigaStor Portable 245
high-volume 330
memory 234
partial 324
RAM 237
reassembling 332, 356
packet capture directory 320
Packet Capture on Multiple Instances Settings 84
Packet Capture Options 78
Packet Capture Schedule 85
packet captures 78, 85, 85, 85, 103, 103, 103, 103, 103, 106, 117, 150, 151
configuring 75, 78, 79, 80, 81, 84
Expert Information 79
partial packets 81, 81, 81
creating 84
decoding 103, 103, 106, 112, 117, 134
efficiency 151
encrypted 105, 105, 106, 106, 353, 353
filtering 89
from multiple sources 84
from unknown sources 104, 104
loading 82, 104
merging 83
replaying 111
saving 82, 82, 104, 104, 116
scheduling 85, 85
security 151
sharing 150
synchronizing 138, 138, 140, 140
timestamps 78
transferring 85
wireless 17, 249, 287
packet filters 330
packet fragmentation 332, 356
packet headers, limiting captures to 308
Packet Length Filter 89
Packet Portal 325
packet storms 54
Packet Time Filter 89
packet types 132
Packet View Settings - Column Order 103
Packet View Settings - Configure SNMP MIBs 103
Packet View Settings - General 103
Packet View Settings - Protocol Forcing 103
Packet View Settings - Summary 103
PacketPortalPDG 325
packets 46, 84
capturing 84
difference from statistics 315
duplicate, removing 84, 125
Expert Information 79
Expert Information, excluding 79
missing 86
moving through RAM 237
RAM 237
saving 116
searching for 117
sizes 46
skipped 133
Paging Server Properties Dialog 193
paging service 193, 193
Pair Statistics (Matrix) 103
Pair Statistics Settings 103
Pair Statistics Settings - List 103
Pair Statistics Settings - Pair Circle 103
Pair Statistics Settings - Statistics Settings 103
Pair Statistics tool 41
partial 324
Partial Packet Capture for TCP/UDP Payload Filter 150
partial packets 81, 81, 81, 84
partial packets, saving 308
passive probe instance 226
Pattern Filter 89, 91
PCAP 34, 82, 104
PCAPNG 82, 104
performance 226
Phone Pager Schedule 103
physical port indexing, see virtual adapters 301
physical ports 308
Ping Trace Route 67
Ping/Trace Route 67, 67
POP3 130, 163
port 326
port bonding 228, 250, 296
Port Filter 89
port tag 282
ports 28, 69, 72, 72, 308, 312, 319
filtering, physical 327
Post Capture Filtering 97
post-filters
applying 97, 97, 118
command line 99
command line, enabling 98
pre-filters
creating 89, 96
scope 96, 96
preprocess settings 332, 356
privacy 314
Probe Alarms Settings - Actions 146
Probe Alarms Settings - Alarm List 143
Probe Alarms Settings - Triggers 146
probe connection 241
probe ID 326
probe instance 324
  active 226, 232
  active vs. passive 226
  best practices 226
configuring 272
configuring statistics memory 270
connecting 266
connecting to analyzer 271
defining its purpose 238
definition of 226
memory allocation 270
memory tuning 232
naming 263
passive 226
redirecting 265
reserving memory 232
specifying NIC 271
probe instance warning 226
probe instances
  redirecting 267
probe name 269
probe redirection 266
Probe redirection error 241
Probe Service Configuration Applet 286
probe, local 27
probes 84, 267
  Adapter Speed tab 272
  Autoupgrade tab 272
  autoupgrading 269, 272
  backing up 260
  clock synchronization 271
  collecting data 271
  common problems with 240, 241
  configuring 269
 connecting to analyzer 266, 267
  D3/E3/HSSI 272
  definition 225
  encryption keys 258
  General tab 272
  Gigabit tab 272
  hardware 234
  hardware acceleration 239
  in a switched environment 230
  IP precedence 272
  MPLS 264, 272
  name, changing 269
  not connecting 241
  options 269
  port bonding 296
  see probe instances 267
  protecting 24, 257
  running as Windows service 269
  security 267
  software, versions 228
  SPAN ports 228
  statistics sampling divider 272
  switching to analyzer 228, 250
  T1/E1 tab 272
  updating 24, 257
  upgrading 258, 258
  Virtual Adapters tab 272
  virtual TAPs 288
  VLAN access 241
  WAN 272
  wireless 272
  Wireless 802.11 tab 272
  see probe instances 267
  promiscuous mode 17, 230, 249, 287, 288
  protected memory 231, 234, 234, 234, 235, 237
  protecting 24, 257
  protocol 163
  Protocol
  Filters 90
  protocol definitions 62, 62
    exporting 62
    importing 62
  Protocol Definitions and Server Application Discovery 103
  Protocol Distribution 42
  Protocol Distribution Settings 42
  Protocol Distribution Statistics 42
  Protocol Distribution Statistics Switched 42
  Protocol Distribution tool 42
  Protocol Filter 89
  protocols 41, 41, 42, 42, 42, 312
    statistics 42
  pseudowire word 264, 264
Q
  QoS 272
  Quality of Service (QoS) 103
R
  RADIUS 163
  RAID 226, 226, 264
  RAM 18, 237, 237, 237, 238, 252, 304
    allocating 238
    buffer size 226
    effects of packet capture 237
    formula 232
    GigaStor 238
    limitations 232
    packet capture 226, 232
    probe instance 324
    see also buffer 232
    see also protected memory, user memory, and
    reserved memory 231
    recommendations 235
    reserving for Observer 272
    resizing 231
    statistics 232
    TCP stream reassembly 332, 356
    tuning 232
    used in Observer 231
    Windows 232
  RAM limitations 232
  RAM needed for busy networks 238
  Random Access Memory, see also RAM 231
  Real Time Protocol 187
  Real-time Transport Control Protocol 103
  Real-time Transport Protocol 103
  reassembling 332, 356
  recommendations 235
  recommended specifications 18, 252, 304
  recommended specs 18, 252, 304
  reconstruction 130
    see stream reconstruction 130
see stream reconstruction 130
reconstruction, stream 103, 130, 130
redirecting 265, 267
redirecting, see probes 267
redirection 266, 266, 266, 266
registry 260
regulation compliance 149, 149
  see security 149
Remote Probe Expert Analysis and Decode 103
Reorder and filter based on trailer timestamp 324
reorder packets 325
Replay Packet Buffer 103
replaying 111
reports
  email, via 192
requests 207
requirements, hardware/software 17, 249
Reserve Observer Memory 103
reserved memory 228, 234, 234, 235, 237, 238, 250
  see also RAM 231
reserved memory from 228, 250
reserved memory in Observer 272
reserving for Observer 272
resetting 145, 145, 145
resizing 231
Resolve IP 62
resolving DNS names 60
response time 125, 167
response time calculation 163
restoring 73, 73, 74, 355, 355, 355
retransmissions, excessive 143
RFC1213
  see SNMP 63, 63
see SNMP 63, 63
RMON 230
RMON Extension Configuration 81
RMON Tables 103
Router Observer 43
Router Observer Settings 43
Router Observer tool 43
routers 43, 43, 43, 43
  statistics 43
RTCP 103
RTF Report Options 103
RTP 103
RTP RTCP Graph 103, 180
RTSP 130
rules profiles 332, 356
running as Windows service 269
running Observer or Probe 286
  packet captures 85, 85, 85
scope 96, 96
scripts 260
searching for 117
security 151, 228, 250, 267
  encryption 152, 282
  encryption key 241
  matching between probe and analyzer 241
  packet captures 150, 151
  personal information 21, 258
  Probe redirection error 241
  probes 84, 267
  regulation compliance 149
  user accounts 150
security breach 337
Select WEP Profile 116
self-optimizing management 277, 277
Server Analysis
  using 103, 103, 127
Server Application Discovery 62, 62, 68
  adding derived definitions 71
  definitions, restoring 73, 355
server applications
  adding 68, 71
  discovering 62, 62, 62
  editing 72
  exporting 62, 70, 71, 352, 352
  importing 62, 70, 70, 352, 352
  ports 69, 72, 72, 72
  restoring 73, 73, 74, 355, 355, 355
  see also applications 68
server profiles 165, 356
Server, Apache Web 105, 353
Server, Windows IIS Web 105, 353
service 269
services 286
Set Local Probe Name 103
settings 181, 230
settings profiles 332, 356
sFlow 109, 109, 118, 228, 250, 272
  decoding 118
  Device Configuration 109
sFlow, versions supported 247, 299
SHA1 Fingerprint 156
sharing 150
Shoutcast 68, 130
signal strength 51
signal strength conversion 51
simultaneous 228, 250
Single Probe 228, 228, 250
  Anyone account 241
  changing NIC 241
  configuring 272, 272
  data transfer 285
  redirection 266
  VoIP 286
Single Probe memory limit 234
SIP 163, 183, 183
site survey 50
Size Distribution Settings 46
Size Distribution Statistics 46
Size Distribution Statistics tool 46
sizes 46
skipped 133
skipped packets 133
slow 262

S
SafeNet HSM 106, 106
sampling 308
sampling divider 240, 247, 247, 299, 299
sampling ratio 312
Save Packet Capture 116
saving 58, 61, 61, 82, 82, 104, 104, 116, 116
saving packet captures 82, 104
saving, formats 82, 104
SCCP 163
scheduled capture 314
scheduling 85, 85, 170

372 | Index (21 Jan 2021) — Archive/Non-authoritative version
slow probe system 240
SMB 163
SMTP 130, 163, 192, 192
Sniffer 82, 104
SNMP 230, 260
about 195, 216, 216
devices 63
discovering 63, 63, 63, 65
Management Console 201, 216, 216
Management Station 201
MIB 198
MIB Editor
adding MIBs 213
requests 207
SNMP agents 206
viewing MIBs 215
MIB Editor, using 202, 206, 208, 210, 211, 211, 212, 212, 214
MIB Walker, using 214, 216
traps 209, 213, 214, 214
SNMP Agent Information Windows 205
SNMP agents 206
SNMP General Options Tab 103
SNMP traps 143
SNMP Trending Data Manager 195, 195
SNMP Walker 214
Snort 330, 331, 332, 332, 356, 356
IP flow 332, 356
IPv6 332, 356
variable name 332, 356
SNORT 260
Snort rules 331, 331, 331, 361
software probes 228, 258
software requirements 17, 249
software, versions 228
SPAN
VLANs 243
SPAN port 243
see also mirror port 230
SPAN ports 228
broadcast traffic 265
settings 230
software probes 228
see also mirror port 230
virtual machine 288
specifications 18, 252, 304
specifying NIC 271
specs 18, 252, 304
SSL, decrypting 106
SSL/TLS Decryption Parameters 103
State 156
Stations - Pair Circle 103
statistics 42, 42, 42, 43, 45, 45, 50, 232, 272, 287, 308, 321, 321
collection interval 247, 299
collections 39, 39, 39, 41, 41, 41, 46
difference from packets 315
errors 49, 50, 50
individual stations 41, 41, 41, 46
memory 234
network load 43
packet capture 272
packets 46
protocols 41, 42, 42, 42
RAM needed for busy networks 238
routers 43, 43, 43, 43
sampling divider 240, 247, 299
top talkers 46, 46, 46, 46
utilization 44, 45, 48, 48
VLAN 56, 56, 56
wireless 42, 50, 50
statistics buffer 232, 232
Statistics Memory Alloction Page 103
storage 18, 252, 304
storage size 305
stream reconstruction 103, 130, 130, 343, 344
other codecs 130
Stream Reconstruction 103
Subnet mask 81
Subnet Mask Calculator 67, 67
subnets 319
summary 48, 48
summary view 125
supported 330
switch 325
switch aggregator 324, 325, 326
Switch Station Locator 65
Switch Station Locator tool 62, 65, 65, 65
switches
discovering 65
switching to analyzer 228, 250
switching to probe 228, 250
synchronization 140, 245, 271
synchronization method 138, 138
synchronizing 138, 138, 140, 140
synchronizing protocol definitions 62
system load 308
system requirements 17, 249
system specification 18, 252, 304

T
T1 272
WAN relay type 273
T1/E1 tab 272
TAP
NetFlow 245
TAPs and 245
collection interval 247, 299
collections 39, 39, 39, 41, 41, 41, 46
difference from packets 315
errors 49, 50, 50
individual stations 41, 41, 41, 46
memory 234
network load 43
packet capture 272
packets 46
protocols 41, 42, 42, 42
ram needed for busy networks 238
routers 43, 43, 43, 43
sampling divider 240, 247, 299
top talkers 46, 46, 46, 46
utilization 44, 45, 48, 48
VLAN 56, 56, 56
wireless 42, 50, 50
statistics buffer 232, 232
Statistics Memory Alloction Page 103
statistics queue buffer 231, 234, 235, 237, 237, 238, 239
statistics sampling divider 272
storage 18, 252, 304
storage size 305
stream reconstruction 103, 130, 130, 343, 344
other codecs 130
Stream Reconstruction 103
Subnet mask 81
Subnet Mask Calculator 67, 67
subnets 319
summary 48, 48
summary view 125
supported 330
switch 325
switch aggregator 324, 325, 326
Switch Station Locator 65
Switch Station Locator tool 62, 65, 65, 65
switches
discovering 65
switching to analyzer 228, 250
switching to probe 228, 250
synchronization 140, 245, 271
synchronization method 138, 138
synchronizing 138, 138, 140, 140
synchronizing protocol definitions 62
system load 308
system requirements 17, 249
system specification 18, 252, 304
timestamp 324
timestamps 78, 326
packet captures 78
Tivoli 143
TNS 163
Token Ring Errors by Station 50
Token Ring Vital Signs 49
top talker 312
top talkers 46, 46, 46, 46
Top Talkers 55, 232
Top Talkers Statistics 46
Top Talkers tool 46, 46
top talkers, defined 46
topologies 225, 228, 250
802.11 225
Ethernet 225
ToS 272
traffic generation 245, 245
Traffic Generator 47
Traffic Generator Settings 47
trailers 326
trailers 326
trailers, transferring 85
traffic generation 245, 245
see SNMP 214
traps 209, 213, 214, 214
see SNMP 214
trending
see network trending 164
triggers 228, 240, 250
trimming data 314
troubleshooting 48, 49, 49, 49, 242, 246, 328, 348
  analyzer connection 241
  bad TCP checksums 242
  broadcast and multicast storms 54
  Cisco 6xxx switches 246
  common issues 239
  network 47, 49, 49, 49, 50, 50, 54
  packet storms 54
  probe connection 241
  slow decode 349
  slow probe system 240
  SSL, decrypting 106
  synchronization 140
  virtual machines 24
  VLAN Statistics tool 242, 243
  VLAN visibility 244
TTL Hop Limit 81

U

UDP Expert 103
Update Chart button 308
updating 24, 257
  Observer 21, 258
upgrading virus protection 24, 257
upgrade 20, 21, 254, 254
upgrading 20, 21, 254, 254, 258, 258, 258
upgrading version 16 21, 254
upgrading version 17 20, 254
upgrading, encryption keys 258
user accounts

security 150
user interface 27, 112, 112, 114
  see Observer 27
user memory 231
user offset 138, 140
users 228, 241, 250
  simultaneous 228, 250
Agent Information Windows 205
using as probe 287
using third party decoder 34, 34
using 65
using, quickly 137
utilization 43, 44, 44, 44, 45, 45, 48, 48, 48, 48, 48
Utilization History 48
Utilization History tool 48
Utilization Thermometer Mode 48

V

v16 21, 254
v17 20, 254
variable name 332, 356
version 16 21, 254
version 17 20, 254
version numbering 38
versions supported 247, 299
viewing 324
viewing MIBs 215
virtual adapter 226, 272, 288, 296
virtual adapters 301
Virtual Adapters tab 272
virtual machine 17, 18, 249, 252, 288, 288, 288, 304
  vSphere 24, 25, 25, 26
virtual machine with 288
virtual NIC 288
virtual TAP 288
Virtual Tap 103
Virtual Tap Settings Dialog 103
virtual TAPs 288
virus protection 24, 257
VLAN 56, 56, 56, 243, 243, 282
  "No VLAN" 242, 243
VLAN access 241
VLAN Filter 89
VLAN ISL Filter 89
VLAN Properties 56
VLAN Statistics 56, 243
VLAN Statistics tool 56, 242, 243
VLAN visibility 244
VLANs 243, 243, 244
  Discover Network Names 244
SPAN port 243
VM specs 18, 252, 304
VMONI 241
VMONI Protocol Analyzer 241
VMware 18, 252, 304
VoIP 103, 176, 176, 177, 177, 177, 181, 181, 181, 183, 184, 185, 185, 185, 228, 250, 272, 286, 286, 355, 355
  alarms 185, 185
caller ID 184
decoding 177, 177
exporting 176, 355
filtering telephone numbers 177
importing 176, 355
<table>
<thead>
<tr>
<th>Network Trending</th>
<th>175, 180, 181</th>
</tr>
</thead>
<tbody>
<tr>
<td>Devices</td>
<td>183</td>
</tr>
<tr>
<td>IP Range</td>
<td>184</td>
</tr>
<tr>
<td>MOS</td>
<td>181</td>
</tr>
<tr>
<td>Settings</td>
<td>181</td>
</tr>
<tr>
<td>Terminology</td>
<td>189</td>
</tr>
<tr>
<td>VoIP RTP RTCP Graph</td>
<td>103</td>
</tr>
<tr>
<td>VoIP Settings - Caller ID</td>
<td>184</td>
</tr>
<tr>
<td>VoIP Settings - Device IP Address</td>
<td>183</td>
</tr>
<tr>
<td>VoIP Settings - General</td>
<td>181</td>
</tr>
<tr>
<td>VoIP Settings - IP Range Filters</td>
<td>184</td>
</tr>
<tr>
<td>VoIP Settings - MOS Score</td>
<td>181</td>
</tr>
<tr>
<td>VPN</td>
<td>245</td>
</tr>
<tr>
<td>vSphere</td>
<td>18, 252, 304</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>24, 25, 25, 26</td>
</tr>
<tr>
<td>VSS</td>
<td>325</td>
</tr>
<tr>
<td>VSS Monitoring</td>
<td>325</td>
</tr>
<tr>
<td>VSS Monitoring w/Port</td>
<td>325</td>
</tr>
</tbody>
</table>

**W**

<table>
<thead>
<tr>
<th>WAN</th>
<th>138, 272, 272, 272</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fractionalized</td>
<td>272</td>
</tr>
<tr>
<td>WAN Alarms</td>
<td>142</td>
</tr>
<tr>
<td>WAN Conditions Filter</td>
<td>89</td>
</tr>
<tr>
<td>WAN Load</td>
<td>55</td>
</tr>
<tr>
<td>WAN Port Filter</td>
<td>89</td>
</tr>
<tr>
<td>WAN Relay Type</td>
<td>273, 273</td>
</tr>
<tr>
<td>WAN Switch</td>
<td>62</td>
</tr>
<tr>
<td>WAN Type</td>
<td>273, 273</td>
</tr>
<tr>
<td>WAN Vital Plot Properties</td>
<td>49</td>
</tr>
<tr>
<td>WAN Vital Signs</td>
<td>55</td>
</tr>
<tr>
<td>WAN Vital Signs by DLCI</td>
<td>49</td>
</tr>
<tr>
<td>Warranty</td>
<td>223</td>
</tr>
<tr>
<td>Web Observer</td>
<td>41</td>
</tr>
<tr>
<td>WEB Observer Settings</td>
<td>41</td>
</tr>
<tr>
<td>Web Observer Tool</td>
<td>41</td>
</tr>
<tr>
<td>Web Server, Apache</td>
<td>105, 353</td>
</tr>
<tr>
<td>Web Server, Windows IIS</td>
<td>105, 353</td>
</tr>
<tr>
<td>WebSphere</td>
<td>163</td>
</tr>
<tr>
<td>What-if Modeling</td>
<td>128, 128</td>
</tr>
<tr>
<td>Windows</td>
<td>256</td>
</tr>
<tr>
<td>32-bit</td>
<td>235, 260</td>
</tr>
<tr>
<td>64-bit</td>
<td>232, 235, 260, 288</td>
</tr>
<tr>
<td>Registry</td>
<td>260</td>
</tr>
<tr>
<td>Reserved Memory from</td>
<td>228, 250</td>
</tr>
<tr>
<td>Reserved Memory in Observer</td>
<td>272</td>
</tr>
<tr>
<td>Service</td>
<td>269</td>
</tr>
<tr>
<td>Services</td>
<td>286</td>
</tr>
<tr>
<td>Windows 10</td>
<td>19, 253</td>
</tr>
<tr>
<td>Windows 2003</td>
<td>19, 253</td>
</tr>
<tr>
<td>Windows 2008</td>
<td>19, 253</td>
</tr>
<tr>
<td>Windows 2012</td>
<td>19, 253</td>
</tr>
<tr>
<td>Windows 2016</td>
<td>19, 253</td>
</tr>
<tr>
<td>Windows 7</td>
<td>19, 253</td>
</tr>
<tr>
<td>Windows 8</td>
<td>19, 253</td>
</tr>
<tr>
<td>Windows IIS Web Server</td>
<td>105, 353</td>
</tr>
<tr>
<td>Windows Memory Pool</td>
<td>234, 234</td>
</tr>
<tr>
<td>Windows Protected Memory</td>
<td>231</td>
</tr>
<tr>
<td>Windows Updates</td>
<td>24, 257</td>
</tr>
<tr>
<td>Windows Vista</td>
<td>19, 253</td>
</tr>
<tr>
<td>Windows, SNMP Agent Information</td>
<td>205</td>
</tr>
<tr>
<td>Wireless</td>
<td>17, 42, 42, 42, 42, 45, 45, 50, 50, 50, 225, 228, 228, 249, 250, 272, 272, 287, 287</td>
</tr>
<tr>
<td></td>
<td>access point statistics 42, 42, 45, 45</td>
</tr>
</tbody>
</table>

**X**

| XML              | 82, 82, 104, 104 |

**Y**

| YouTube         | 277, 277         |

**Symbols**

"No VLAN" 242, 243